Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Matériel » HP SmartTank Plus 559 » 19-05-2020 21:25:20

Plus de problème !!!

Plus besoin de unplug/replug : il suffisait de redémarrer le PC.

Affaire résolue, donc !

Merci Croutons !!!

#2 Re : Matériel » HP SmartTank Plus 559 » 17-05-2020 15:59:07

J'ai effectivement, suite au message de Croutons, essayé avec la version 3.19.6 et y suis parvenu mais seulement au travers du parcours du combattant :
le faire en user et ne passer à root qu'à la demande de l'installer, refuser les options d'installation par défaut (aucun "enter", du moins sur les options générales de départ) et ne pas accepter l'installation en PyQt4 ni PyQt4-dbus : seulement en Qt5.
À noter que l'installer, pour y parvenir, reprend des dépendances de Debian 9.8 !!!!

Enfin, nous y voilà +-, merci pour la contrib.

Reste : à chaque changement de user, il faut unplug/replug le câble USB pour imprimer ou scanner, ....

Les versions ultérieures se bloquent car elles ne contiennent pas l'option de ne pas choisir Qt4 : l'installer ne trouve pas les PyQt4 et PyQt4-dbus correspondant et finit avec un brillant "exit", .....

#3 Re : Matériel » HP SmartTank Plus 559 » 16-05-2020 12:24:02

La pûûûûgne !!!!!
Maintenant Buster 10.3 est supporté (théoriquement) mais avec mes apt-get update et apt-upgrade régulers, je me retrouve avec Buster 10.4 sans le savoir !
Et, .... le 10.4 n'est pas supporté !!!! La Joie !!!!
Je pourrais essayer de passer en Bullseye qui supporte hplip 3.20 mais alors, il faut renoncer à d'autres logiciels, ...

#4 Re : Matériel » HP SmartTank Plus 559 » 02-05-2020 15:07:44

C'est exact : la distro Buster en est à la version 3.18.

C'est pour cela que j'ai déchargé la version 3.20 sur https://developers.hp.com/hp-linux-imag … -printing/ .

C'est  lors de cette installation qu'apparaît qu'elle ne vaut encore que pour Buster 10.2 alors que je suis déjà en 10.3 .

D'ailleurs si on regarde sur la page developpers.hp.com, ils écrivent que c'est bien jusque 10.2 que la version est adaptée.

D'où : problème ! Ce, alors que j'ai acquis cette imprimante convaincu par la réputation de compatibilté de HP avec linux.

Là, je suis le bec dans l'eau.

Le second problème est que dans les références aux nouvelles inclusions dans la version 3.19, ils indiquent HP Smart Tank Plus 550 comme nouvellement incluse.

Je présuppose que cela vaut pour la 559 aussi, encore que .....

#5 Matériel » HP SmartTank Plus 559 » 02-05-2020 08:51:12

hussaile
Réponses : 9
Bjr,

KWiFiManager (sous Trinity Desktop TDE) repère le bidule.

Malheureusement hplib présent sur la distro Buster 10.3 ne m'aide pas à le connecter.

Après download sur la page https://developers.hp.com/hp-linux-imaging-and-printing ,
donc la dernière version, j'essaie d'installer le run.

En cours d'installation, il me dit qu'il ne vaut que pour debian 10.2 et finit pas se bloquer sur des dépendances manquantes.

Or, pratiquant la mise à jour régulière, je suis sous 10.3.

Quelqu'un a-t-il réussi à installer ce modèle sous 10.3 ?

#6 Re : Gestion des paquets Debian » pulseaudio pas installable sur Buster backported » 24-03-2020 16:04:49

root@PC:/home/xyz#

apt-get install pulseaudio



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 pulseaudio : Dépend: libpulse0 (= 12.2-4+deb10u1) mais 13.0-3~bpo10+1 devra être installé
              Recommande: rtkit mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 


Avec "aptitude install pulseaudio", c'est un plus long avec des choix, mais on retombe sur le même problème.

C'est que libpulse0 et ses dépendances ne sont pas encore backportés et donc entrent en conflit avec pulseauido qui a déjà été backporté.

D'où l'intérêt de pouvoir installer la version non-backportée de pulseaudio.

Edit : ajout des balises codes, voir le tuto : https://debian-facile.org/atelier:bbcode?s

#7 Re : Matériel » lenteur extrême du desktop après mise à jour. » 24-03-2020 14:16:53

C'était pulseaudio rémanant avec un problème de dépendance de buster backporté (avec libpulse0). une fois désinstallé, tous les problèmes ont disparu.

#8 Re : Gestion des paquets Debian » pulseaudio pas installable sur Buster backported » 24-03-2020 14:10:07

Pardon, oubli : buster backporté.

aptitude install ramène vers le même problème : libpusle0 n'est pas de la bonne version ( celle du backport de pulseaudio) et donc pulseaudio n'est pas installé.

Ce que je veux pouvoir faire est installer la version buster simple de pulseaudio, mais le backportage de tout mon système m'en empêche.

Comment le forcer ?

#9 Gestion des paquets Debian » pulseaudio pas installable sur Buster backported » 24-03-2020 12:16:53

hussaile
Réponses : 7
Bjr,

Comment forcer l'installation d'une version non-backported de pulseaudio sur une système backported ?

Le problème est, en effet, qu'avec ma version backported, pulseaudio n'est pas installable comme backported parce qu'une partie des fichiers nécessaires en termes de dépendances n'ont pas encore été backportés et cela crée des problèmes de dépendance ?

Et, sans pulsaudio mais seulement avec alsa, pas de son dans le programme "solfège" ni en navigant avec le brower "Tor", ....

Si je veux installer pulsaudio et es dépendances à partir de "sid", il me faut des heures d'installations en cascade pour les paquets nécessaires, ...;

Plus simple si je pouvais forcer l'installation non-backportée de pulseaudio, ....

#11 Re : Contribution à Debian, packaging, traductions, bugs, etc. » Installer le paquet fahcontrol du site foldingathome.org sur Buster » 22-03-2020 13:08:58

D'après ce que je vois python-gnome2 est considéré deprecated, unmaintained et unsecure et, donc, n'a pas été inclus pour debian buster.

J'ai avisé le webmaster de https://foldingathome.org/ et il ne reste qu'à attendre une modification de leur software, je suppose, à moins qu'il ne soit disponible en source et modifiable par l'un des membres de ce forum.

Personnellement, j'en suis incapable : cela fait 45 ans que je n'ai plus programmé et c'était en Fortran IV-G

#12 Re : Contribution à Debian, packaging, traductions, bugs, etc. » Installer le paquet fahcontrol du site foldingathome.org sur Buster » 22-03-2020 12:34:04

Ok, cela change effectivement.

Nonobstant, maintenant je me retrouve avec l'output suivant :

root@PC:~# dpkg -i '/home/xyz/Téléchargements/fahcontrol_7.5.1-1_all.deb'
Sélection du paquet fahcontrol précédemment désélectionné.
(Lecture de la base de données... 336036 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../fahcontrol_7.5.1-1_all.deb ...
Dépaquetage de fahcontrol (7.5.1-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de fahcontrol :
fahcontrol dépend de python-gnome2 ; cependant :
  Le paquet python-gnome2 n'est pas installé.

dpkg: erreur de traitement du paquet fahcontrol (--install) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Des erreurs ont été rencontrées pendant l'exécution :
fahcontrol


Avec synaptics, je cherche python-gnome2 mais ne le trouve pas.

Avec apt-get, j'obtiens le message suivant :

root@PC:~# apt-get install python-gnome2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet python-gnome2 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « python-gnome2 » n'a pas de version susceptible d'être installée

Voilà : où est-ce que je peux trouver python-gnome2 ?

#13 Re : Contribution à Debian, packaging, traductions, bugs, etc. » Installer le paquet fahcontrol du site foldingathome.org sur Buster » 22-03-2020 12:07:33

je me mets en console, puis fais "su" et donne le mot de passe root, ce qui me met en mode superutilisateur, administrateur du système.

#14 Contribution à Debian, packaging, traductions, bugs, etc. » Installer le paquet fahcontrol du site foldingathome.org sur Buster » 22-03-2020 11:09:46

hussaile
Réponses : 13
Bonjour,

Des scientifiques du monde entiers demandent que tous les ordinateurs disponibles mettent de la mémoire en ligne pour aider à la recherche.

C'est sur :

https://foldingathome.org/

que l'on peur trouver un programme fahcontrol_7.5.1-1_all.deb à installer.

Malheureusement, l'instruction dpkg comme root donne le message suivant (debian buster backported, 32bits):


dpkg -i '/home/xyz/Téléchargements/fahcontrol_7.5.1-1_all.deb'
dpkg: avertissement: « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg: avertissement: « start-stop-daemon » introuvable dans la variable PATH ou non exécutable
dpkg: erreur: 2 programmes attendus non trouvés dans la variable PATH ou non exécutables
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
 


et impossible d'installer.

Synaptic donne ldconfig comme installé et start-stop-daemon absent au bataillon.

Quelqu'un pourrait-il arranger ce programme  fahcontrol pour qu'il puisse être installé depuis Synaptic ?

De cette manière, toute la communauté Debian pourra aider la recherche contre ce satané virus !

Edit modération : modification du titre pour que la demande d’aide et l’objet du fil soient plus clairs wink

#15 Gestion des paquets Debian » solfege » 08-03-2020 14:46:04

hussaile
Réponses : 0
hello,

solfege_c_midi is not present in the actual debian compilation of solfege so that there is no sound available.

Brgds

JB

#16 Re : Matériel » lenteur extrême du desktop après mise à jour. » 28-01-2020 12:03:14

C'était peut-être le backport le problème. Sans rien faire d'autre que des apt-get update/uprade réguliers, cela s'est résolu.
Merci pour l'attention au problème

#17 Re : Matériel » lenteur extrême du desktop après mise à jour. » 24-01-2020 13:53:38

Voici :

x@PC:~$

apt-cache policy firmware-amd-graphics xserver-xorg-video-radeon linux-image-686-pae



firmware-amd-graphics:
  Installé : 20190114-2
  Candidat : 20190114-2
 Table de version :
     20190717-2~bpo10+1 100
        100 http://ftp.be.debian.org/debian buster-backports/non-free i386 Packages
 *** 20190114-2 500
        500 http://deb.debian.org/debian buster/non-free i386 Packages
        100 /var/lib/dpkg/status
xserver-xorg-video-radeon:
  Installé : 1:19.0.1-1
  Candidat : 1:19.0.1-1
 Table de version :
 *** 1:19.0.1-1 500
        500 http://deb.debian.org/debian buster/main i386 Packages
        100 /var/lib/dpkg/status
linux-image-686-pae:
  Installé : 5.4.8-1~bpo10+1
  Candidat : 5.4.8-1~bpo10+1
 Table de version :
 *** 5.4.8-1~bpo10+1 100
        100 http://ftp.be.debian.org/debian buster-backports/main i386 Packages
        100 /var/lib/dpkg/status
     4.19+105+deb10u1 500
        500 http://deb.debian.org/debian buster/main i386 Packages



Édit modération : ajout des balises codes, voir le tuto : https://debian-facile.org/atelier:bbcode?s

#18 Re : Matériel » lenteur extrême du desktop après mise à jour. » 24-01-2020 09:24:01

une fois firmware-amd-graphics installé, que dois-je désinstaller pour que ce driver prenne le dessus pendant le démarrage ?
Manifestement, il ne le fait pas.

#19 Re : Matériel » lenteur extrême du desktop après mise à jour. » 24-01-2020 08:14:50

Je vais essayer en installant firmware-amd-graphics qui ne l'était pas.
xserver-xorg-video-radeon était déjà installé et à jour.

Voici :

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV370 [Radeon X300]
        Subsystem: ASUSTeK Computer Inc. RV370 [Radeon X300]
        Kernel driver in use: radeon
        Kernel modules: radeonfb, radeon

#20 Matériel » lenteur extrême du desktop après mise à jour. » 23-01-2020 22:50:28

hussaile
Réponses : 8
Bjr,

Après mise à jour il y a de cela un peu plus d'une semaine, le desktop est devenu super-lent.

Démarrer sous kernel 5.4 ou l'ancien 4.19 ne fait pas de différence.

Debian- Buster, carte graphique ATI Radeon RV370

Dans /var/log/Xorg.0.log je trouve les lignes suivantes :

[    68.233] (==) RADEON(0): DRI3 disabled
[    68.233] (==) RADEON(0): Backing store enabled
[    68.233] (WW) RADEON(0): Direct rendering disabled
[    68.233] (II) RADEON(0): Acceleration disabled

ce qui expliquerait la chose.

Comment changer cela ?

#21 Matériel » parport_pci » 16-10-2019 13:01:19

hussaile
Réponses : 0
Bonjour,

Où trouvez une liste de cartes PCI compatibles pour ajouter un port parallèle aux machines récentes qui en sont dépourvues ?

Pour kernel série 5 sous Debian Buster.

#22 Re : Autres WM » de xdm vers tdm » 16-10-2019 12:56:13

tdm est le display manager de TDE (trinity desktop environment, le successeur de KDE3.5) https:///www.trinitydesktop.org

J'ai résolu cela de la manière brute : désinstaller sddm puis réinstaller tdm.

#23 Autres WM » de xdm vers tdm » 01-10-2019 08:00:35

hussaile
Réponses : 2
Bonjour,

Quel fichier modifier pour passer de l'interface login xdm à l'interface tdm ?
Debian Buster avec Trinity Display Environment.
(pas de fichier inittab)

#24 Re : Autres WM » XWIndows avec environnement debian se plante » 31-01-2019 09:27:54

Voilà, me revoilà. J'avais cramé par un faux contact électrique le disque dur sur lequel j'avais installé debian.
Heureusement, c'était un disque reçu gratos.
Je viens enfin de refaire une installation avec CD de démarrage d'installation puis installation en ligne.
Toujours le même problème de stabilité sous XWindows.
Ci-après la fin de Xorg.0.log (je suppose que c'est là que l'on trouve le pourquoi XWindows crashe) :

[  2026.051] (II) Device 'ImPS/2 Logitech Wheel Mouse' set to 400 DPI
[  2026.051] (II) input device 'ImPS/2 Logitech Wheel Mouse', /dev/input/event2 is a pointer caps
[  2026.051] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input2/event2"
[  2026.051] (II) XINPUT: Adding extended input device "ImPS/2 Logitech Wheel Mouse" (type: MOUSE, id 10)
[  2026.052] (**) Option "AccelerationScheme" "none"
[  2026.052] (**) ImPS/2 Logitech Wheel Mouse: (accel) selected scheme none/0
[  2026.052] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration factor: 2.000
[  2026.052] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration threshold: 4
[  2026.052] (II) input device 'ImPS/2 Logitech Wheel Mouse', /dev/input/event2 is tagged by udev as: Mouse
[  2026.053] (II) Device 'ImPS/2 Logitech Wheel Mouse' set to 400 DPI
[  2026.053] (II) input device 'ImPS/2 Logitech Wheel Mouse', /dev/input/event2 is a pointer caps
[  2026.053] (II) config/udev: Adding input device ImPS/2 Logitech Wheel Mouse (/dev/input/mouse0)
[  2026.053] (II) No input driver specified, ignoring this device.
[  2026.053] (II) This device may have been added with another device file.
[  2026.054] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[  2026.054] (II) No input driver specified, ignoring this device.
[  2026.054] (II) This device may have been added with another device file.
[  2026.068] (II) UnloadModule: "libinput"
[  2026.068] (II) UnloadModule: "libinput"
[  2026.068] (II) UnloadModule: "libinput"
[  2026.068] (II) UnloadModule: "libinput"
[  2026.069] (II) UnloadModule: "libinput"
[  2026.071] (II) NOUVEAU(0): NVLeaveVT is called.
[  2026.104] (II) Server terminated successfully (0). Closing log file.

#25 Re : Autres WM » XWIndows avec environnement debian se plante » 16-12-2018 17:40:34

Effectivement, j'ai coché l'environnement de bureau Debian. J'aurais pu cocher KDE, Gnome ou un autre.

Quand on installe sur base de debian pur, l'option "debian desktop" existe, ce que j'ai choisi puisque le plus simple.

Le problème ne semble pas dépendre du type d'environnement mais du système xwindows même (Xorg).

Ce qui m'intéresse est de savoir, sous, debian, comment s'appelle le fichier *.log qui reprend ce qu'a fait xwindows et aussi savoir dans quel dossier aller le chercher pour pouvoir l'éditer.

Pied de page des forums

Propulsé par FluxBB