Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#2 Améliorations et Suggestions » [résolu] Indiquer combien de fois mes messages ont été lu sur le forum » 26-10-2019 06:27:01

cdarsac
Réponses : 2
Bonjour,

Après le post d'une discussion, le nombre de réponse apparaît.

Par contre, je n'ai pas trouvé où ou comment faire apparaître le nombre de fois où mon message a été lu ?

Cette information est-elle disponible ?

Merci de vos réponses.        smile

#3 Système » Pb hibernation: pas de conservation des fenêtres ouvertes (firefox ... » 26-10-2019 06:20:04

cdarsac
Réponses : 0
Bonjour,

Lorsque je lance l'hibernation après avoir affecté cette fonction à la touche "arrêt/marche" (seule méthode que j'ai trouvée), mon PC portable (Acer) s'arrête bien.

Par contre au redémarrage, si je vois bien passer "resuming for hibernation" à l'écran, aucun des programmes ouverts et tournant avant l’hibernation n'apparaissent (firefox, monitor system ...).

La sortie d'hibernation semble s'apparenter à un redémarrage classique, sans conservation du contexte avant l'arrêt-machine.

Dois-je installer des paquets supplémentaires spécifiques ?         smile

Merci de vos réponses.

#4 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 20-09-2019 07:35:37

A force de chercher, j'ai fini par trouver une solution à mon pb dans le BIOS             smile

   

Après l'installation de Debian, rebooter et ouvrir le BIOS au redémarrage du PC ([F2] dans mon cas), puis:

    1/ Onglet 'Boot':
    Boot mode:        UEFI
    Secure Boot:     Enable

    2/ Onglet 'Security'
    Select en UEFI file as trusted for executing     Enter
    HDD0
    EFI
    debian
    grubx64.efi
    Boot Description: Grubx64
    Add an new file:     Yes

    3/ Onglet Boot
    Boot priority order:     1. EFI File Boot 0: grubx64






Merci à tous de votre aide, qui avaient fini par me mettre sur la bonne voie.           smile

Dernière modification par cdarsac (Hier 07:29:38)

#5 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 19-09-2019 06:23:37

A force de chercher, j'ai fini par trouver une solution à mon pb dans le BIOS             smile

Après l'installation de Debian, rebooter et ouvrir le BIOS au redémarrage du PC ([F2] dans mon cas), puis:

1/ Onglet 'Boot':
Boot mode:        UEFI
Secure Boot:     Enable

2/ Onglet 'Security'
Select en UEFI file as trusted for executing     Enter
HDD0
EFI
debian
grubx64.efi
Boot Description: Grubx64
Add an new file:     Yes

3/ Onglet Boot
Boot priority order:     1. EFI File Boot 0: grubx64




Merci à tous de votre aide, qui avaient fini par me mettre sur la bonne voie.           cool

#6 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 19-09-2019 05:50:43

cdarsac a écrit :

Pfff, rien n'y fait:     sad

J'ai beau avoir un 'mot-de-passe superviseur', je ne vois pas d'option ne permettant de supprimer le mot-de-passe bios.



En fait, pas d'option pour supprimer le mot-de-passe, mais il suffit de le modifier en entrant un nouveau mot-de-passe 'vide' pour le supprimer ...       tongue

#7 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 18-09-2019 13:42:21

raleur a écrit :


cdarsac a écrit :


    Assistée - utiliser un disque entier

    Disque à partitionner: SCSI1 (0,0,0) (sda) - 1.0 TB ATA WDC WD10JPVX-22J

    Schéma de partitionnement: Tout dans une seule partition (recommandé pour les
débutants)
    - SCSI1 (0,0,0) (sda) - 1TB ATA WDC
         -n°1     536 MB ESP
         -n°2     991 GB ext4   /
         -n°3         8 GB swap swap


Si tu as amorcé l'installateur en mode legacy, le partitionnement assisté sur tout le disque n'aurait pas dû créer une partition système EFI (ESP).



C'est bien ce qui m'inquiète, j'ai l'impression que mes disques ne sont pas complètement reformatés et que je récupère d'anciennes choses, sources de mes pb.     sad

Y-aurait-il un moyen de faire cela en 'rescue mode' pour être tranquille ?

#8 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 18-09-2019 13:39:40

raleur a écrit :


cdarsac a écrit :

- SCSI3 (0,0,0) (sdb) - 128 GB ATA LITEON
     -n°1     536 MB fat32
     -n°2     255 GB ext2
     -n°3     127 GB swap swap



Une partition de 255 Go sur un disque de 128 Go ?
Un swap de 127 Go ???



Désolé, c'est moi qui ai mal recopié:      ops.gif

- SCSI3 (0,0,0) (sdb) - 128 GB ATA LITEON
                  1.0 MB     espace libre
     -n°1     536 MB B fat32
     -n°2     255 MB    ext2
     -n°3     127 GB
                 335 KB espace libre

#9 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 18-09-2019 11:28:34

J'ai mis à jour le post, au fur et à mesure de mon installation:

https://debian-facile.org/viewtopic.php … 28#p311428


Malheureusement, même punition:               sad
Après reboot:
   

Default Boot Device Missing or Boot Failed.
    Insert Recovery Media and Hit any key
    Then select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media

#10 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 18-09-2019 09:52:47

Pfff, rien n'y fait:     sad

J'ai beau avoir un 'mot-de-passe superviseur', je ne vois pas d'option ne permettant de supprimer le mot-de-passe bios.

#11 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 18-09-2019 09:35:42

Debian Alain a écrit :

bonjour cdarsac ,  https://debian-facile.org/img/smilies/xtras/woohoo.gif
tu le sais , je ne suis qu'un amateur , mais , à ta place ,

je commencerai par supprimer le mdp bios .

çà te fera des soucis en moins .

et tes problèmes seront plus simples à résoudre .

https://debian-facile.org/img/smilies/xtras/coyotus.png



Ok, mais je fais comment ?       smile

#12 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 18-09-2019 09:08:28

naguam a écrit :

Tu as deux disques dans ton laptop ? tu le fait comment le partitionnement ? (par default ? si oui sur quel disque)
En legacy, il te demande si il n'y a pas d'autre os de choisir le disque pour le chargeur d'amorçage, as-tu bien choisis celui sur lequel tu as fait l'installation ?
Sinon ce genre de soucis, c'est difficile à régler sans avoir la machine sous les yeux hmm

Aussi j'avais pas fait le lien avec le l'url que tu as mis (après modif?) dans le premier post, tu avait déjà accès au grub (en efi donc techniquement ça devrait pas être au niveau du bios que ça coince).
Et j'avais pas vu plus que ça cette discussion, ça change des choses sur ma compréhension du problème.

D'après ce que je vois de l'autre discussion, comme tu est prêt a faire d'autres installations je te conseillerais de refaire une installation mais sans lvm car utiliser deux disques en un seul grâce à lvm c'est bien quand on a pas de soucis, mais dès qu'on en as et qu'on ne maitrise pas lvm, ça devient vite compliqué.
Juste pour tester je ferais des partitions simples du genre la partition efi sur un disque et la partition / et swap sur ce même disque, et utiliser l'autre disque entièrement pour le /home.

Cela posera moins de problème pour une éventuelle utilisation du mode rescue d'un installeur pour monter le /



OK, merci pour cette analyse.               smile

Je refais donc une installation pour te donner la réponse à tes questions:

BIOS:

Mon PC: portable de marque ACER, modèle TravelMate P278-MG

[F2] au boot: accès au Bios via un password

Boot:
- Boot mode: Legacy

Security:
- Supervisor Password is: Set
- User password is: Clear
-HDD0 password is: Frozen
-HDD1 password is: Frozen

Main:
D2D Recovery: enable
GPT Partition recovery: none
GPT partition Record: no record



CD-ROM utilisé:

firmware-10.1.0-amd64-netinst



Méthode de partitionnement:

Assistée - utiliser un disque entier
Disque à partitionner: SCSI1 (0,0,0) (sda) - 1.0 TB ATA WDC WD10JPVX-22J
Schéma de partitionnement: Tout dans une seule partition (recommandé pour les débutants)

Table des partitions et points de montage configurés:

- SCSI1 (0,0,0) (sda) - 1TB ATA WDC
                  1.0 MB        espace libre
     -n°1     536 MB B F ESP
     -n°2     991 GB     F ext4      /
     -n°3         8 GB     F swap    swap
                 728 KB espace libre


- SCSI3 (0,0,0) (sdb) - 128 GB ATA LITEON
                  1.0 MB     espace libre
     -n°1     536 MB B fat32
     -n°2     255 MB    ext2
     -n°3     127 GB
                 335 KB espace libre



Boot Mode:

Boot priority order:
1.  HDD1: WDC WD10JPVX-22JC3T0
2.  HDD0: LITEON CV1-8B128
3. USB CDROM
...



Après reboot:

Default Boot Device Missing or Boot Failed.
Insert Recovery Media and Hit any key
Then select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media

#13 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 17-09-2019 11:41:42

Voici le résultat de l'installation en legacy:              sad

Default Boot Device Missing or Boot Failed
Insert Recovery Media and Hit any key
Then Select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media



Le 'Boot manager' me propose ensuite 4 choix:
1/ HDD0
2/ HDD1
3/ CDROM
4/ Network Boot: Realtek PXE B02 D00

Malheureusement, chacun d'entre eux reboucle sur le message de départ ...

#14 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 17-09-2019 11:04:16

naguam a écrit :

Ne possédant pas de acer ni d'aucune machine ne possédant le même bios, je ne peux pas te dire.
Malheureusement au niveau des interfaces de configuration de bios, il n'y a rien de très standard.
Sinon tu peux peut-être prendre des photos du bios au niveau des options de boot (boot-order, etc)
et les poster sur un hébergeur d'image (toile-libre, imgur, etc) et mettre le lien ici pour pouvor voir de quoi il retourne smile.

Sinon tu peux aussi passer ton bios en legacy bios et faire une installation en legacy.



Allez, je tente une installation en Legacy, ca me semble plus simple dans un 1er temps !       smile

#15 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 17-09-2019 09:57:21

naguam a écrit :

Avec certains bios, la création d'entrée de boot efi n'est pas faite bien que les fichiers sont biens placés dans la partition efi au bon endroit.
Du coup si ton bios est plutôt complet, ce qui n'est pas toujours le cas il y a peut être moyen d'entrer manuellement \EFI\debian\shimx64.efi (ça m'est arrivé avec un hp au bios... disons pas terrible)
Après si il y a aucune possibilité de ce type, essaye de passer ton bios en legacy bios et fait une install en legacy bios.



Merci de ta réponse.       smile

Mais comment entrer manuellement \EFI\debian\shimx64.efi comme tu le suggères ?            scratchhead.gif

Je viens de parcourir les différents menus déroulants de mon Bios (lnsydeH20 Setup Utility Rev 5.0) et je ne vois rien qui semble correspondre.      sad

#16 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 17-09-2019 08:06:15

Après une réinstallation en "mode expert", j'obtiens un reboot en boucle avec le message suivant:

System BootOrder not found. Initializing defaults
Creating boot entry "Boot003D" with label "debian" for file "\EFI\debian\shimx64.efi"

Reset System



Quelqu'un a-t-il une idée qui puisse me permettre d’installer debian sur mon PC Portable ?                 smile

#17 Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): AVEC réinstallation » 17-09-2019 05:57:38

cdarsac
Réponses : 21
Bonjour à tous,

J'ai ouvert la discussion "no bootable"device" (Debian10 Buster): sans réinstallation" ( https://debian-facile.org/viewtopic.php?id=25177 ) suite à un pb d'installation de Debian10-buster sur mon portable.
Le but était de résoudre le pb SANS réinstallation.

Je suis maintenant ouvert à une deuxième solution, à savoir la résolution de mon pb AVEC réinstallation.
C'est l'objet de cette deuxième discussion.        smile


Mon PC: portable de marque ACER, modèle TravelMate P278-MG
Mon boot mode: UEFI
Mon Secure Boot: Disable
Mon boot device install: CD-ROM (debian-10.1.0-amd64-netinst, télécharger sur https://cdimage.debian.org/debian-cd/cu … 64/iso-cd/)

#18 Re : Suivi du Wiki et des Projets Git » cherrytree - installation sur buster » 16-09-2019 10:29:07

enicar a écrit :


Edit : J'ai vu que tu avais lancé l'application en étant root
ce qu'il ne faut jamais faire. Ça ne peut pas fonctionner. Essaye
de relancer l'application en utilisateur.



Bingo, c'était bien cela la source du pb !
En lançant l’application en "user", cela fonctionne parfaitement !                  woohoo.gif

Je crois que je vais m'en souvenir longtemps !

merci.gifmerci.gifmerci.gif

#19 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 16-09-2019 07:27:08

raleur a écrit :

La commande fdisk ne doit pas être exécutée dans GRUB mais dans Linux.
Relance l'installateur en mode "rescue", monte la racine, lance un shell sur la racine et tu pourras exécuter les commandes :

fdisk -l
efibootmgr -v
blkid



Voici:
file-Rfc489fe2939f7f4c6039c8b3fb040bf4

#20 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 16-09-2019 06:12:47

raleur a écrit :

Regarde les messages dans la console des logs (tty4). Ou va dans une console avec un shell (tty2 ou tty3) et regarde la fin de /var/log/syslog.



Bonjour,

Voilà les logs de la console tty4:
file-R814120a471d429be057acb5bb0d0150d

#21 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 11-09-2019 20:06:08

raleur a écrit :

Regarde les messages dans la console des logs (tty4). Ou va dans une console avec un shell (tty2 ou tty3) et regarde la fin de /var/log/syslog.



En tty4, voilà ce que donne "

tail  /var/log/syslog

":


main-menu[259]: INFO: Menu item 'rescue-mode' succeded but requested to be left unconfigured.
main-menu[259]: INFO: Falling back to the package description for brltty-udeb
init: starting pid 240,tty 'dev/tty2' : '-/bin/sh'
 



Edit à toto : Mis le retour de la commande en utilisant le GROS bouton Commande user du forum afin que tous puisse lire lisiblement le contenu de cette intervention.

#22 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 11-09-2019 18:27:51

raleur a écrit :

Ctrl+Alt+F4 pour basculer sur tty4 par exemple.



Eh oui, ça marche mieux comme cela !         woohoo.gif

merci.gif

#23 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 11-09-2019 18:17:40

Ok, mais comment faire ?       scratchhead.gif

Voici les choix que me propose le 'rescue mode':


Choose language
Access software for a blind person using a braille display
Configure the keyboard
Detect and mount CD-ROM
Load installer components from CD
Detect network hardware
Configure the network
Configure the clock
Detect disks
Enter rescue mode
Partition disks
Install the base system
Configure the package manager
Select and install software
Install the GRUB boot loader on a hard disk
Continue without boot loader
Finish the installation
Change debconf priority
Check the CD-ROM(s) integrity
Save debug logs
Execute a shell
Eject a CD from the drive
Abort the installation
 



Edit à toto : Mis le retour de la commande en utilisant le GROS bouton Autre code du forum afin que tous puisse lire lisiblement le contenu de cette intervention.

#24 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 11-09-2019 17:56:36

raleur a écrit :

Bien, tu as utilisé LVM donc ça simplifie l'identification de la racine : /dev/PC-Portable-ACER-Christophe-vg/root
(Curieux que les volumes logiques soient mentionnés en double)



Oui, j'ai bien utilisé LVM.        smile

Après le choix de 'Device to use as root file system', j'ai l'erreur suivante:

An error occured while mounting the device you entered for your file system ( /dev/PC-Portable-ACER-Christophe-vg/root ) on /target.
Please check the syslog for more information

<Go Back>             <Continue>
 

#25 Re : Installation de Debian » [résolu] "no bootable"device" (Debian10 Buster): SANS réinstallation » 11-09-2019 17:50:06

raleur a écrit :

Ça ne dit pas dans quelle partition est la racine. D'autre part un disque sd* peut changer de nom d'un démarrage à l'autre.



Je comprends bien, mais comment puis-je répondre à la question ?      smile

Pied de page des forums

Propulsé par FluxBB