Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-07-2020 20:32:44

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Debian testing : panne de clipman [résolu]

Bonjour à tous,

Je vivais heureux avec mon Debian testing (xfce) tout frais, et soudain, la petite icône de clipman m'affiche "le presse-papier est vide" en permanence...
Le copier/coller fonctionne (entre application, pour un presse-papier) mais j'avais pris l'habitude d'entasser dans clipman une paire de copies puis de les recoller dans le bon ordre, et je suis très frustré...
J'ai les paquets suivants, qu'il ne me semble pas avoir mis à jour récemment:
DzHueq0.png
J'avais aussi xfce4-goodies, que j'ai enlevé comme ça pour voir (et sans effet)...
Je considérais que ce xfce4-clipman était le bon choix "par défaut" sur xfce...

Tout conseil est le bienvenu!
Merci!
Hervé

Dernière modification par Herve5 (27-07-2020 15:54:23)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#2 07-07-2020 13:06:26

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-9-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Debian testing : panne de clipman [résolu]

Hello
D’après mes essaies les copies sont stocké dans un fichier texte dans le répertoire .cache
On peut facilement essayer de créer un historique de copies voir ce que cela donne

on tue clipman hmm

pkill xfce4-clipman



puis on teste en créant le fichier texte qui doit contenir les copies enregistré (si déjà existant il sera recréé)

echo -e "[texts]\ntexts=hello;Debian;test;">~/.cache/xfce4/clipman/textsrc



puis relance clipman

xfce4-clipman


tu devrais avoir 3 copies enregistré?


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 07-07-2020 14:17:53

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : Debian testing : panne de clipman [résolu]

Merci Croutons!

En procédant comme tu as dit, je note que

- clipman semble se relancer immédiatement en fait. Par exemple, lorsque je veux la relancer à la fin, j'obtiens

~$ xfce4-clipman
** Message: 15:10:12.720: Primary instance org.xfce.clipman already running

(xfce4-clipman:204036): GLib-GIO-WARNING **: 15:10:27.726: Your application did not unregister from D-Bus before destruction. Consider using g_application_run().


et, également, la petite icône de presse-papier ne disparaît pas dans mon menu

- le fichier où sont enregistré les presse-papiers successifs n'existait pas

- maintenant que je l'ai créé, après avoir re-tué le process, je vois effectivement les trois presse-papiers que je viens d'y mettre

- mais clipman n'écrit toujours pas dans ce fichier lorsque je copie un mot de plus. Il doit y avoir la partie qui récupère le presse-papiers qui rate son tour quelque part...

[edit] Clipman par contre ramène bien l'un des anciens mots dans le presse papier par contre si je le lui demande

Dernière modification par Herve5 (07-07-2020 14:19:41)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#4 18-07-2020 14:52:25

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : Debian testing : panne de clipman [résolu]

Bon, j'ai carrément désinstallé xfce4-clipman et xfce4-clipman-plugin, relancé ma session, vérifié qu'il semblait ne pas rester de préférences louches dans $HOME (mais, ça, je ne sais pas si c'est exhaustif) puis réinstallé les deux packages : toujours rien. Je me demande si je n'ai pas installé autre chose qui interfère avec le presse-papier, mais je ne sais pas quoi...
J'ai même réinstallé un xfce4-goodies que j'avais viré depuis quelque temps, au motif que dans la liste des trucs (souvent inutiles) offerts l'on reparlait de clipman : en vain...

Dernière modification par Herve5 (18-07-2020 14:55:55)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#5 27-07-2020 15:53:58

Herve5
Membre
Lieu : région de Cannes, France
Distrib. : Debian 10
Noyau : Linux 5.7.0-3-amd64
(G)UI : Mate 1.20.4
Inscription : 02-03-2019

Re : Debian testing : panne de clipman [résolu]

Finalement!
C'était un réglage "inhibit" dans Clipman qu'il fallait repasser à zéro. Je l'avais bien vu, et modifié (incorrectement) à la main. Il fallait passer par l'éditeur de paramètres xfce, et depuis ça marche!
2KLYVVd.png

(et je n'ai pas trouvé ce qui m'avant changé ce bit au départ...)

Merci à tous, je n'aurais pas continué aussi longtemps seul!

--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

Pied de page des forums