Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
doc:environnements:mate:paquets-optionnels [26/01/2016 04:37]
smolski
doc:environnements:mate:paquets-optionnels [21/10/2019 13:14] (Version actuelle)
èfpé correction mineure, cosmétique, appel à contrib.
Ligne 8: Ligne 8:
     * Création par [[user>​nifseg]] et [[user>​laguespa]] le 02/01/2014     * Création par [[user>​nifseg]] et [[user>​laguespa]] le 02/01/2014
     * Testé par <...> le <​...> ​     * Testé par <...> le <​...> ​
-  * Commentaires sur le forum : [[https://​debian-facile.org/​viewtopic.php?​pid=147488#​p147488 | Lien vers le forum concernant ce tuto]] ((N'​hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !)) +  * Commentaires sur le forum : [[https://​debian-facile.org/​viewtopic.php?​pid=147488#​p147488|C'est ici]]((N'​hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !))
- +
- +
-===== Quelques suggestions de logiciels à installer avec Mate  ===== +
- +
- +
-Voilà de quoi modifier de l'​image,​ lire du flash, faire de la suite bureautique,​ scanner des documents, naviguer sur Internet avec un truc un peu lourd quand même, écouter de la musique et même du mp3, ouvrir des huîtres... +
- +
-<code root>​apt-get install gstreamer0.10-plugins-ugly gstreamer0.10-fluendo-mp3 libreoffice libreoffice-l10n-fr \ +
-  gimp simple-scan iceweasel iceweasel-l10n-fr vlc flashplugin-nonfree debian-keyring</​code>​ +
- +
-Voilà, c'est une suggestion, à vous d'​adapter selon ce que vous préférez. +
  
 =====Installation d'​applications supplémentaires ===== =====Installation d'​applications supplémentaires =====
Ligne 26: Ligne 14:
 ==== Installation d'​applications spécifiques à MATE ==== ==== Installation d'​applications spécifiques à MATE ====
  
-<​note ​important>(si vous avez choisi de ne pas installer le paquet "​mate-desktop-environment-extra"​)</​note>​ +<​note>​Cette section ​informative ​est utile pour ceux qui ont opté pour une [[doc:​environnements:​mate:​installation|installation]] standard via le paquet ''mate-desktop-environment''​. Il est toujours intéressant de partir d'​un ​environnement de bureau ​dépouillé pour n'installer ​que les paquets dont vous avez réellement besoinsans superflu. ​Il s'agit d'une sélection subjective et bien entendu vous n'​êtes pas obligé ​d'installer ces programmes !</​note>​ 
- +FIXME
-<​note>​Bien entendu, vous n'​êtes pas forcé d'​installer tous ces programmes! \\ +
-Il s'agit d'un choix subjectif, cette section est informative et utile pour ceux qui ont choisi d'installer "mate-core"​(ça vous évite de vous casser la tête à chercher le nom de chaque paquet que vous souhaiteriez installer). Il est toujours intéressant de partir d'​un ​EB dépouillé pour installer ​seulement ​les paquets dont vous avez réellement besoin sans superflu. ​De plus c'est un bon apprentissage !</​note>​ +
- +
-Si vous souhaitez connaître le nom de tous les paquets commençant par "​mate"​ tapez: +
-<code user>​apt-cache search mate | grep -E ^mate*</​code>​ +
-Ou : +
-<code user>​apt-cache --names-only search "​^mate-*"</​code>​ +
- +
-Installation ​d'outils ​d'administration système pour MATE : +
-<code root>​apt-get install mate-system-tools</​code>​ +
- +
-<​note>​Ajoute le menu Administration au menu "​Système"​ du tableau de bord supérieur.</​note>​  +
- +
-Installation du bluetooth [erreur] : +
-<code root>​apt-get install mate-bluetooth</​code>​ +
- +
-Installation d'une table de caractères [erreur] : +
-<code root>​apt-get install mate-character-map</​code>​+
  
-Installation des bulles ​de notifications provenant du panel +Pour afficher la liste de tous les paquets dont le nom commence par ''​mate-'',​ exécutez ​
-<​code ​root>apt-get install mate-indicator-applet mate-notification-daemon</​code>​+<​code ​user>apt-cache --names-only search ^mate-</​code>​
  
-Installation ​du gestionnaire ​de fenêtres de MATE [erreur] ​+<del>Installation ​des bulles ​de notifications provenant du panel :</​del>​ 
-<code root>​apt-get install mate-window-manager</​code>​+<code root>​apt-get install mate-indicator-applet</​code>​
  
-Installation d'applications diverses et utiles ​pour MATE+Installation d'un outil partage de fichiers public ​pour MATE :
 <code root>​apt-get install mate-user-share</​code>​ <code root>​apt-get install mate-user-share</​code>​
- 
  
 ==== Installation d'​applications diverses issues du projet GNOME ==== ==== Installation d'​applications diverses issues du projet GNOME ====
  
-<​note>​Pour installer ​certains programmes issus de GNOME je vous conseille ​d'utiliser le paramètre "--no-install-recommends" ​de apt-get ​pour ne pas installer ​des dépendances recommandées qui ne sont pas strictements necessaires,​ ce qui pourrait induire des conflits et créer des doublons entre les applications de MATE et de GNOME ! \\ +<​note>​Lors de l'​installation de certains programmes issus du projet ​GNOME, il est conseillé ​d'employer l'​option ''​%%--no-install-recommends%%'' ​de ''​[[doc:​systeme:​apt:​apt-get|apt-get]]''​ afin de ne pas installer ​les dépendances ​//recommandées// qui ne sont pas indispensables ou qui pourraient ​créer des doublons ​voire induire des conflits ​entre les applications de MATE et celles ​de GNOME.</​note>​
-Pour les applications concernées je vais spécifier ce paramètre !</​note>​+
  
 === Outils d'​administration === === Outils d'​administration ===
 +
 +Installation d'un outil de notification et d'​installation des mises à jour :
 +<code root># Debian 9 Stretch
 +apt-get install --no-install-recommends pk-update-icon apt-config-auto-update</​code>​
 +<code root># Debian 10 Buster
 +apt-get install --no-install-recommends pk-update-icon gnome-packagekit</​code>​
 +
 +<note important>​Sous Debian 10 Buster, il faut terminer la configuration à la main (bah oui, c'est moche :-(), en renseignant le champ "​Command for installing updates:"​ avec ''/​usr/​bin/​gpk-update-viewer''​ : \\ \\ {{/​file-Re70b8297dd18ef483cbb9cb1136badc1.png?​150|Package Update Indicator Preferences (avant)}} {{/​file-R69d7413faaa1b533980fd44a06267cf3.png?​150|Package Update Indicator Preferences (après)}} \\ \\ Vous pourrez alors déclencher l'//​Outil de mise à jour de paquets// en cliquant sur "​Install updates"​ lorsque des mises à jour disponibles seront notifiées (ce que la vie peut être belle parfois ^_^).</​note>​
  
 Installation d'un éditeur de configuration : Installation d'un éditeur de configuration :
-<code root>​apt-get install dconf-service dconf-tools</​code>​+<code root>​apt-get install dconf-editor</​code>​
  
 Installation d'un outil de partitionnement : Installation d'un outil de partitionnement :
 <code root>​apt-get install gparted</​code>​ <code root>​apt-get install gparted</​code>​
  
-Installation de l'​utilitaire de disque ​Gnome :+Installation de l'​utilitaire de disque ​GNOME :
 <code root>​apt-get --no-install-recommends install gnome-disk-utility</​code>​ <code root>​apt-get --no-install-recommends install gnome-disk-utility</​code>​
  
-Installation du gestionnaire de paquets Synaptic, de la logithèque et de Gdebi +Installation du gestionnaire de paquets ​[[doc:​systeme:​apt:​synaptic|Synaptic]], de la logithèque et de [[doc:​systeme:​apt:​gdebi|GDebi]] ​
-<code root>​apt-get --no-install-recommends install synaptic ​software-center ​gdebi</​code>​+<code root>​apt-get --no-install-recommends install synaptic ​gnome-software ​gdebi</​code>​
  
-Installation d'​un ​gestionnaire et d'un notificateur de mise à jour : +Installation d'​un ​outil permettant ​de configurer ​les sources de mise à jour :
-<code root>​apt-get --no-install-recommends install update-manager-gnome update-notifier</​code>​ +
- +
-Installation du paquet qui permet ​de configurer ​ses sources de mise à jour :+
 <code root>​apt-get --no-install-recommends install software-properties-gtk</​code>​ <code root>​apt-get --no-install-recommends install software-properties-gtk</​code>​
  
Ligne 85: Ligne 58:
 <code root>​apt-get --no-install-recommends install seahorse</​code>​ <code root>​apt-get --no-install-recommends install seahorse</​code>​
  
-Installation d'un serveur d'​affichage à distance et d'un client VNC:+Installation d'un serveur d'​affichage à distance et d'un client VNC :
 <code root>​apt-get install vino remmina</​code>​ <code root>​apt-get install vino remmina</​code>​
  
-Installation du manuel ​d'aide pour les applications+Installation du navigateur ​d'aide pour les applications ​:
 <code root>​apt-get --no-install-recommends install yelp</​code>​ <code root>​apt-get --no-install-recommends install yelp</​code>​
  
 === Applications toutes catégories confondues === === Applications toutes catégories confondues ===
- 
-Vous pouvez configurer la connexion depuis le centre de contrôle, mais pour un portable c'est plus pratique d'​installer un gestionnaire de connexions automatique pour le Wifi : 
-<code root>​apt-get --no-install-recommends install network-manager-gnome</​code>​ 
-<​note>​Si vous souhaitez un gestionnaire de connexions plus léger, vous pouvez également utiliser Wicd qui fonctionne très bien avec Mate. A noter que Wicd ne prévoit qu'une seule interface Wifi : Il ne faut pas oublier de l'​inscrire dans la configuration (wlan0, wlan1...) sinon aucun réseau ne sera détecté, forcément.</​note>​ 
-<note important>​N'​installez qu'un seul gestionnaire de connexion Wifi !</​note>​ 
  
 Installation d'un logiciel de retouche photo : Installation d'un logiciel de retouche photo :
 <code root>​apt-get install gimp gimp-data-extras gimp-help-fr</​code>​ <code root>​apt-get install gimp gimp-data-extras gimp-help-fr</​code>​
-Et/ou:+Et/ou :
 <code root>​apt-get install imagemagick</​code>​ <code root>​apt-get install imagemagick</​code>​
  
Ligne 109: Ligne 77:
 <code root>​apt-get --no-install-recommends install pidgin</​code>​ <code root>​apt-get --no-install-recommends install pidgin</​code>​
  
-Installation du numérisateur de Gnome :+Installation du numérisateur de GNOME :
 <code root>​apt-get --no-install-recommends install simple-scan</​code>​ <code root>​apt-get --no-install-recommends install simple-scan</​code>​
  
Ligne 118: Ligne 86:
 <code root>​apt-get --no-install-recommends install cheese totem brasero</​code>​ <code root>​apt-get --no-install-recommends install cheese totem brasero</​code>​
  
-==== Installation d'​applications hors projet ​MATE et GNOME ====+Installation de la table de caractères GNOME : 
 +<code root>​apt-get --no-install-recommends install gucharmap</​code>​ 
 + 
 +==== Installation d'​applications hors projets ​MATE et GNOME ====
  
 Installation d'une suite bureautique : Installation d'une suite bureautique :
Ligne 124: Ligne 95:
  
 Installation d'un naviguateur internet : Installation d'un naviguateur internet :
-<code root>​apt-get install ​iceweasel iceweasel-l10n-fr</​code>​ +<code root>​apt-get install ​firefox-esr firefox-esr-l10n-fr</​code>​ 
-Ou/et +Et/ou 
-<code root>​apt-get install chromium-browser ​chromium-browser-l10n</​code>​+<code root>​apt-get install chromium chromium-l10n</​code>​
  
 Applications multimédia : Applications multimédia :
 <code root>​apt-get install audacious audacious-plugins audacity soundconverter easytag vlc mplayer mencoder asunder</​code>​ <code root>​apt-get install audacious audacious-plugins audacity soundconverter easytag vlc mplayer mencoder asunder</​code>​
  
-==== Pour lire du HTML5 avec Mate et avec Debian en général ====+Gestionnaire graphique du Bluetooth : 
 +<code root>​apt-get install blueman</​code>​ 
 + 
 +==== Pour lire du HTML5 avec MATE (et Debian en général====
  
 Il nous faudra installer quelques paquets :  Il nous faudra installer quelques paquets : 
-<code root>​apt-get install ​gstreamer0.10-alsa gstreamer0.10-gconf gstreamer0.10-plugins-bad gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly ​ gstreamer0.10-pulseaudio ​gstreamer1.0-alsa ​ gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly ​ gstreamer1.0-pulseaudio</​code>​+<code root>​apt-get install gstreamer1.0-alsa gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio</​code>​
  
-Et aussi installer l'​extension YouTube ALL HTML5 pour iceweasel (ou firefox c'est pareil) ​depuis les modules complémentaires du navigateur. +Et aussi installer l'​extension YouTube ALL HTML5 pour Firefox ​depuis les modules complémentaires du navigateur.
-===== Liens utiles =====+
  
-Sur le forum là : 
-  * [[http://​debian-facile.org/​topic-8242-wiki-mate-l-environnement-de-bureau-page-3.html#​p84329]] :) 
doc/environnements/mate/paquets-optionnels.1453779470.txt.gz · Dernière modification: 26/01/2016 04:37 par smolski

Pied de page des forums

Propulsé par FluxBB