Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-11-2014 15:46:49

Gargamel
Membre
Distrib. : SID64 - Jessie
Noyau : 3.11 amd64
(G)UI : XFCE 4.10
Inscription : 02-09-2008

Mises à jour bloquées cause conflits (--full-resolver)

Bonsoir à tous,

Voilà quelques jours, un wagon de màj est arrivé, seul bémol, beaucoup de paquets sont en conflits voir cassés. Reste que dans cette liste, se trouvent des paquets qui peuvent mis à jour mais cela est rendu impossible à cause de tous ces conflits.
A moins de sélectionner les paquets non concernés et les mettre à jour un à un, c'est un vrai casse-tête chinois roll

Voici ce que j'ai en attente en ce moment:

Unable to safely resolve dependencies, try running with --full-resolver.
root@debian:/home/belette# aptitude safe-upgrade --full-resolver
The following NEW packages will be installed:
  cups-core-drivers{a} cups-filters-core-drivers{a} dconf-cli{a} evolution{a} evolution-common{a}
  evolution-plugins{a} gdm3{a} gir1.2-atspi-2.0{a} gir1.2-gdm3{a} gir1.2-gnomedesktop-3.0{a}
  gir1.2-ibus-1.0{a} gnome-backgrounds{a} gnome-flashback{a} gnome-flashback-common{a} gnome-screensaver{a}
  gnome-session-flashback{a} gnome-user-share{a} gstreamer1.0-libav{a} libapache2-mod-dnssd{a}
  libboost-thread1.55.0{a} libcamel-1.2-49{a} libchamplain-0.12-0{a} libchamplain-gtk-0.12-0{a}
  libcogl-pango20{a} libcogl-path20{a} libcogl20{ab} libcolord-gtk1{a} libebackend-1.2-7{a} libecal-1.2-16{a}
  libedata-book-1.2-20{a} libedata-cal-1.2-23{a} libedataserver-1.2-18{a} libevolution{a}
  libfreerdp-cache1.1{a} libfreerdp-client1.1{a} libfreerdp-codec1.1{a} libfreerdp-common1.1.0{a}
  libfreerdp-core1.1{a} libfreerdp-crypto1.1{a} libfreerdp-gdi1.1{a} libfreerdp-locale1.1{a}
  libfreerdp-primitives1.1{a} libfreerdp-utils1.1{a} libgdata19{a} libgdm1{a} libgjs0e{ab}
  libgnome-desktop-3-10{a} libgoa-1.0-0b{ab} libgoa-backend-1.0-1{a} libgrilo-0.2-1{a} libgroupsock4{ab}
  libgtkhtml-4.0-0{a} libgtkhtml-4.0-common{a} libgtkhtml-editor-4.0-0{a} libgtkspell3-3-0{a}
  libibus-1.0-5{a} libinput5{a} liblivemedia38{a} libmozjs-24-0{a} libmutter0e{ab} libnss-myhostname{a}
  libphonenumber6{a} libprotobuf9{a} libpst4{a} libpwquality-common{a} libpwquality1{a}
  librygel-core-2.4-2{a} librygel-renderer-2.4-2{a} librygel-server-2.4-2{a} libwinpr-crt0.1{a}
  libwinpr-crypto0.1{a} libwinpr-dsparse0.1{a} libwinpr-environment0.1{a} libwinpr-file0.1{a}
  libwinpr-handle0.1{a} libwinpr-heap0.1{a} libwinpr-input0.1{a} libwinpr-interlocked0.1{a}
  libwinpr-library0.1{a} libwinpr-path0.1{a} libwinpr-pool0.1{a} libwinpr-registry0.1{a} libwinpr-rpc0.1{a}
  libwinpr-sspi0.1{a} libwinpr-synch0.1{a} libwinpr-sysinfo0.1{a} libwinpr-thread0.1{a} libwinpr-utils0.1{a}
  libxcb-xkb1{a} libxkbcommon-x11-0{a} libytnef0{a} realmd{a} rygel{a} xwayland{a}
The following packages will be REMOVED:
  liblivemedia36{u} ttf-dejavu{u} ttf-dejavu-core{u} ttf-dejavu-extra{u}
The following packages will be upgraded:
  avahi-daemon base-passwd binutils cheese-common cinelerra-cv coinor-libcoinutils3 cpp cpp-4.9 cups cups-bsd
  cups-client cups-daemon cups-filters{b} db5.1-util{b} dictionaries-common evolution-data-server
  evolution-data-server-common firebird2.5-common firebird2.5-common-doc firebird2.5-server-common
  folks-common g++ g++-4.9 gcc gcc-4.9 gcc-4.9-base gir1.2-clutter-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gir1.2-mutter-3.0 gjs gnome-bluetooth
  gnome-contacts gnome-control-center gnome-control-center-data gnome-online-accounts gnome-panel
  gnome-panel-data gnome-session gnome-session-bin gnome-session-common gnome-session-fallback
  gnome-settings-daemon gnome-shell gnome-shell-common gnome-sushi groff-base gsettings-desktop-schemas
  gstreamer1.0-clutter gstreamer1.0-plugins-base gstreamer1.0-x gvfs gvfs-backends gvfs-common gvfs-daemons
  gvfs-libs libappindicator1 libappindicator3-1 libasan1 libatomic1 libaudiofile1 libavahi-client3
  libavahi-common-data libavahi-common3 libavahi-core7 libavahi-glib1 libc-bin libc-dev-bin libc6 libc6-dev
  libcgi-pm-perl libcheese-gtk23 libcheese7 libchromaprint0 libcilkrts5 libclutter-1.0-0{b}
  libclutter-gst-2.0-0 libclutter-gtk-1.0-0 libcogl-common libcups2 libcupscgi1 libcupsimage2 libcupsmime1
  libcupsppdc1 libcurl3 libcurl3-gnutls libebook-1.2-14 libebook-contacts-1.2-0 libefivar0 libexpat1
  libfbclient2 libfbembed2.5 libfolks-eds25 libfolks-telepathy25 libfolks25 libgail-3-0 libgcc-4.9-dev
  libgcc1 libgegl-0.2-0 libgfortran3 libgoa-1.0-common libgomp1 libgssapi-krb5-2
  libgstreamer-plugins-base1.0-0 libgstreamer0.10-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libhyphen0 libio-socket-ssl-perl libitm1 libjpeg-progs libjpeg-turbo-progs{b} libjpeg62-turbo{b}
  libk5crypto3 libkpathsea6 libkrb5-3 libkrb5support0 liblightdm-gobject-1-0 liblsan0 libmlt6 libpaper-utils
  libpaper1 libpcsclite1 libquadmath0 libquicktime2 libquicktimehv-1.6.0-1 libsqlite3-0 libstdc++-4.9-dev
  libstdc++6 libtbb2 libtevent0 libtracker-sparql-1.0-0 libtsan0 libubsan0 libvlc5 libvlccore8 libvorbis0a
  libvorbisenc2 libvorbisfile3 libx264-142 lightdm linux-compiler-gcc-4.8-x86 multiarch-support mutter-common
  nautilus nautilus-data nfacct openssh-client printer-driver-splix systemd-shim torsocks vlc vlc-data
  vlc-nox vlc-plugin-notify wget
The following packages are RECOMMENDED but will NOT be installed:
  libcgi-fast-perl vlc-plugin-pulse
161 packages upgraded, 94 newly installed, 4 to remove and 0 not upgraded.
Need to get 170 MB/171 MB of archives. After unpacking 163 MB will be used.
The following packages have unmet dependencies:
 libgoa-1.0-0b : Conflicts: libgoa-1.0-0 but 3.8.3-2 is installed.
 libcogl20 : Breaks: libcogl12 but 1.14.0-3 is installed.
 db5.1-util : Breaks: libdb5.1 (< 5.1.29-8~) but 5.1.29-7 is installed.
 libgroupsock4 : Conflicts: libgroupsock1 but 2:2014.10.07-dmo1 is installed.
 libgjs0e : Conflicts: libgjs0c but 1.36.1-2 is installed.
 libclutter-1.0-0 : Breaks: libcogl12 but 1.14.0-3 is installed.
 libgoa-1.0-0 : Depends: libgoa-1.0-common (= 3.8.3-2) but 3.14.1-1 is to be installed.
 cups-filters : Conflicts: foomatic-filters but 4.0.17-5 is installed.
                Conflicts: ghostscript-cups but 9.05~dfsg-9.1 is installed.
 libjpeg-turbo-progs : Conflicts: libjpeg-progs but 1:9a-2 is to be installed.
 libmutter0 : Depends: mutter-common (= 3.4.1-7) but 3.14.1-2 is to be installed.
 libjpeg62-turbo : Conflicts: libjpeg62 but 1:1.3.1-8 is installed.
 libjpeg62 : Depends: libjpeg62-turbo (= 1:1.3.1-8) but 1:1.3.1-10 is to be installed.
 libmutter0e : Conflicts: libmutter0 but 3.4.1-7+b1 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                      
1)      db5.1-util                                        
2)      foomatic-filters                                  
3)      ghostscript-cups                                  
4)      gjs                                                
5)      gnome-session                                      
6)      gnome-shell                                        
7)      gnome-sushi                                        
8)      libcogl-pango12                                    
9)      libcogl12                                          
10)     libgdata13                                        
11)     libgoa-1.0-0                                      
12)     libjpeg-turbo-progs                                
13)     libjpeg62                                          
14)     libmutter0                                        
15)     vlc                                                
16)     vlc-nox                                            
17)     vlc-plugin-notify                                  

      Keep the following packages at their current version:
18)     gdm3 [Not Installed]                              
19)     libgjs0e [Not Installed]                          
20)     libgroupsock4 [Not Installed]                      

      Leave the following dependencies unresolved:        
21)     nautilus recommends gnome-sushi                    
22)     task-xfce-desktop recommends vlc                  


Accept this solution? [Y/n/q/?]
 



Je veux bien attendre que les paquets soient débloqués par les devs, mais là, il y en a beaucoup trop.
Certains retraits de paquets importants pour permettre que ça passe me font craindre de me retrouver devant une console au prochain démarrage....
Un exercice bien enrichissant à travailler, mais comment? Que faire en pareil cas?



En vous remerciant d'avance de votre aide

smile

Dernière modification par Gargamel (08-11-2014 15:49:55)


Debian SID XFCE: Asus P8Z68 + I5, ATI 5850
Mageia 3 KDE: Asus P5B deluxe + Q6600

Hors ligne

#2 08-11-2014 20:07:52

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Mises à jour bloquées cause conflits (--full-resolver)

j'ai également eu ce genre de problèmes et de souvenir j'ai attendu que les paquets soient débloqués et quand je voulais mettre à jour un logiciel j'utilisais simplement apt-get qui ne cherche pas à résoudre des conflits et m'installait la ou les mise(s) à jour sans problème wink

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#3 08-11-2014 21:20:54

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : Mises à jour bloquées cause conflits (--full-resolver)

Commence par mettre à jour les paquets "à problèmes" (vlc, gnome-session, gnome-shell), et vois ensuite si ça te débloque un peu ce foutoir…

Jouer sous Debian ? Facile !

Hors ligne

#4 08-11-2014 21:34:58

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Mises à jour bloquées cause conflits (--full-resolver)

la syntaxe c'est aptitude safe-upgrade. Ensuite ça t'apprendra a mettre une SID lol

Je plussoie pour mettre à jour un par un les paquets principaux  qui coincent avec aptitude full-upgrade  ET en lisant bien ce qu'il s'affiche.

Dans Sid et même Jessie, les dépendances sont parfois un peu remaniées de manière ... non linéaires. le safe-upgrade n'est pas toujours suffisant en sachant que le full-upgrade est toujours dangereux, surtout lorsqu'il y a beaucoup de paquets en jeu. C'est là où un peu de jugeotte et la lecture attentive des messages sont bienvenue.

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#5 09-11-2014 04:34:22

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mises à jour bloquées cause conflits (--full-resolver)

Salut

Pour ma part les mises à jour récente de ma sid on toutes bien passées. J'utilise toujours en premier un aptitude safe-upgrade. Quand il y a des paquets qui ne peuvent être mis à jour je regarde alors avec aptitude full-upgrade -s si aptitude trouve une solution dans les premiers choix (des fois c'est seulement le deuxième ou le troisième choix qui est le bon). Sinon, j'attends les prochaines mises à jour et tout finit toujours par passer. Des fois il faut juste un peu de patience et ne pas chercher à tout mettre à jour tout de suite.

Sinon regarde ça tranquillement pour voir ce que tu peux faire et bonne chance smile

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

En ligne

#6 09-11-2014 06:13:20

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Mises à jour bloquées cause conflits (--full-resolver)

État actuel : 112 mises à jour restantes [+112], 25926 nouveaux paquets [-6].
root@madebian:~# aptitude safe-upgrade


112 paquets mis à jour sans problème smile


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

En ligne

#7 09-11-2014 18:28:35

Gargamel
Membre
Distrib. : SID64 - Jessie
Noyau : 3.11 amd64
(G)UI : XFCE 4.10
Inscription : 02-09-2008

Re : Mises à jour bloquées cause conflits (--full-resolver)

Bonjour à  tous,


Merci pour vos retours, des petites avancées, mais rien de flagrant. J'ai réussi à mettre certains paquets à jour et diminuer un peu la liste, mais le gros provient de gnome, rien ne peut se faire sans le contourner.


vv222 a écrit :

Commence par mettre à jour les paquets "à problèmes" (vlc, gnome-session, gnome-shell), et vois ensuite si ça te débloque un peu ce foutoir…


Ca a marché pour quelques paquets, mais trop d'implications avec gnome hmm



martinux_qc a écrit :

Salut

Pour ma part les mises à jour récente de ma sid on toutes bien passées. J'utilise toujours en premier un aptitude safe-upgrade. Quand il y a des paquets qui ne peuvent être mis à jour je regarde alors avec aptitude full-upgrade -s si aptitude trouve une solution dans les premiers choix (des fois c'est seulement le deuxième ou le troisième choix qui est le bon). Sinon, j'attends les prochaines mises à jour et tout finit toujours par passer. Des fois il faut juste un peu de patience et ne pas chercher à tout mettre à jour tout de suite.
Sinon regarde ça tranquillement pour voir ce que tu peux faire et bonne chance smile



Leçon que j'ai bien retenu venant de toi de part le passé wink Là où c'est quand pas évident, c'est de déterminer si le paquet qui va être supprimé ne va pas manquer plus tard pour autre chose ou rendre instable le système


martinux_qc a écrit :

État actuel : 112 mises à jour restantes [+112], 25926 nouveaux paquets [-6].
root@madebian:~# aptitude safe-upgrade


112 paquets mis à jour sans problème smile



Aujourd'hui, 212 packages upgraded, 56 newly installed, 3 to remove and 0 not upgraded. argh......


C'est la liste la moins lourde trouvé avec full-upgrade, j'ai regardé sur le net ce que je pouvais trouver sur ces paquets, je vais tenter la màj, je croise les doigts .....

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Remove the following packages:
1)      db5.1-util                  
2)      foomatic-filters            
3)      ghostscript-cups            
4)      libcogl-pango12            
5)      libcogl12                  
6)      libgdata13                  
7)      libgjs0c                    
8)      libgoa-1.0-0                
9)      libjpeg-turbo-progs        
10)     libjpeg62                  
11)     libmutter0                  

 

Dernière modification par Gargamel (09-11-2014 18:33:45)


Debian SID XFCE: Asus P8Z68 + I5, ATI 5850
Mageia 3 KDE: Asus P5B deluxe + Q6600

Hors ligne

#8 09-11-2014 19:10:23

Gargamel
Membre
Distrib. : SID64 - Jessie
Noyau : 3.11 amd64
(G)UI : XFCE 4.10
Inscription : 02-09-2008

Re : Mises à jour bloquées cause conflits (--full-resolver)

Bon la suite...

Etant satisfait du peu de paquets à virer, je suis allé faire mon full-upgrade. Au moment de faire cette màj, je me retrouve avec 5 bugs critiques (gnome........pour pas changer....) que je me suis empressé de les pinned.
Je relance mon full-upgrade, et là, ben, c'était plus pareil, impossible de retomber sur cette petite proposition faite auparavant.
Dépiter, je tente par curiosité un safe-upgrade et là, 70 paquets mis à jour big_smile  j'en ai autant en souffrance mais ceux-là, je suis pas pressé.........

smile

Debian SID XFCE: Asus P8Z68 + I5, ATI 5850
Mageia 3 KDE: Asus P5B deluxe + Q6600

Hors ligne

Pied de page des forums