Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-01-2015 17:49:03

Erlen
Membre
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : openbox
Inscription : 16-04-2014

[Résolu] VLC erreur de segmentation

Bonjour,

J'ai installé avidemux sur mon ordi et depuis je ne plus lire les fichiers flv avec vlc.
Quand je clique sur ouvrir un fichier video quelque soit le format rien ne se passe.
Si j'utilise la console, vlc se ferme des le lancement de la vidéo avec ce message dans la console : erreur de segmentation.
Il en va de même avec totem.
J'ai supprimé avidemux ainsi que le dépot, j'ai réinstallé vlc mais sans que cela ne résolve mon problème.
merci

Dernière modification par Erlen (21-01-2015 16:03:23)

Hors ligne

#2 17-01-2015 09:19:45

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] VLC erreur de segmentation

Salut,


Tu avais ajouter les dépôt deb-multimedia ?


Les avais tu épinglé pour ne pas qu'ils prennent le dessus sur les dépôts officiels ? -> Les fichiers apt_preferences


J'ai une partition sid avec les dépôts deb-multimedia ( pour entre autre avidemux : le couteau suisse de l'édition multimedia ), et j'ai de nombreux paquets non mis à jour, sans doute les dépôts deb-multimedia qui ont mis le " bronx " dans les versions de paquets . Sur ma partition sid principal, avec que les dépôts officiels, ben, tous les paquets sont à jour !


Alors, pour gérer les dépôts deb-multimedia, je fais mes mises à jour à coup de

aptitude safe-upgrade

aptitude est verbeux ( ne sera pas installé car la version x.y.z a été installé .. mad ) et il peut proposer plusieurs choix . ( édition : deb-multimedia préconise apt-get )


Pour ton soucis, tu devrais regarder si aptitude trouve des dépendances cassées avec :

aptitude search ~b




note : une discussion intéressante sur les dépôts multimedia -> Attention au dépôt debian-multimedia.org ! ( sur linuxfr, les commentaires sont instructifs ) .


smile

Dernière modification par nono47 (17-01-2015 09:41:29)

Hors ligne

#3 21-01-2015 16:02:50

Erlen
Membre
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : openbox
Inscription : 16-04-2014

Re : [Résolu] VLC erreur de segmentation

Merci pour l'info pour que le dépôt soit considéré comme secondaire.
En fait j'ai été voir dans les logs ce qui avait été modifié et de là j'ai purgé et réinstallé les lib.
Tout est revenu dans l'ordre, sauf que je n'ai plus avidemux, avec ta solution pour hiérarchiser les dépot ça devrait passer merci

Hors ligne

Pied de page des forums