Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-01-2015 10:42:41

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

[Résolu] Paquets et Mod

Bonjour à tous,

Comme je le disais dans mon premier poste, (celui-ci étant le deuxième), je débute, alors soyer indulgent..

Je voudrais simplement savoir si les Mod dépendaient des paquets installés sur la machine.

En effet, j'ai une page qui affiche un phpinfo() chez mon hébergeur habituel avec dans la section "Loaded Modules" les mod activés, et j'essai (tant bien que mal) de reproduire sur mon serveur la même config, mais certains mod ne sont pas connus par mon serveur.

exemple : a2enmod mod_php5 => Module mod_php5 does not exist

mod_php5 étant un des modules activé chez mon hébergeur habituel.

Si les Mod dépendent effectivement des paquets installés sur le serveur, y-a-t il une façon de savoir quels paquets je dois installer sur le mien ?

Merci à tous,

Orsam

Dernière modification par Orsam999 (18-01-2015 13:11:18)


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#2 18-01-2015 11:05:01

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [Résolu] Paquets et Mod

Salut Orsam999, 
Je dirais qu'il faut que tu compares la liste des paquets php installer sur le serveur hébergé avec ceux en local:

dpkg --get-selections | sed 's:install$::' | grep -i php

Hors ligne

#3 18-01-2015 11:08:12

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Paquets et Mod

Bonjour smile

Oui, les mod dépendent des paquets installés. Si tu souhaites installer un serveur lamp (Linux Apache Mysql Php), c'est cette command. Comme tu semble déjà avoir Apache2 installé, tu peux vérifier la presence de chaque paquet comme ceci

apt-cache policy mysql-server libapache2-mod-php5 php5-mysql


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#4 18-01-2015 11:09:26

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Paquets et Mod

Bonjour Kao et merci pour ta réponse super rapide !!

Sur mon serveur, j'ai déjà fait dpkg --get-selections pour la liste des paquets installé, mais comment faire chez mon hébergeur habituel ?? (je n'ai pas de console, c'est un hébergement "Site Web").

Merci.

Orsam

Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#5 18-01-2015 11:20:57

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Paquets et Mod

Bonjour Bendia,

Désolé nos réponse ce sont croisés.

Suite à la commande que tu me donne, tout semble installé :


mysql-server:
  Installé : 5.5.40-0+wheezy1
  Candidat : 5.5.40-0+wheezy1
 Table de version :
 *** 5.5.40-0+wheezy1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        500 http://security.debian.org/ wheezy/updates/main i386 Packages
        100 /var/lib/dpkg/status
libapache2-mod-php5:
  Installé : 5.4.36-0+deb7u3
  Candidat : 5.4.36-0+deb7u3
 Table de version :
 *** 5.4.36-0+deb7u3 0
        500 http://security.debian.org/ wheezy/updates/main i386 Packages
        100 /var/lib/dpkg/status
     5.4.36-0+deb7u1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
php5-mysql:
  Installé : 5.4.36-0+deb7u3
  Candidat : 5.4.36-0+deb7u3
 Table de version :
 *** 5.4.36-0+deb7u3 0
        500 http://security.debian.org/ wheezy/updates/main i386 Packages
        100 /var/lib/dpkg/status
     5.4.36-0+deb7u1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages

 



Y a t'il un site où je peux trouver mod "machin" dépend du paquets "un tel" ??

Dernière modification par Orsam999 (18-01-2015 11:24:31)


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#6 18-01-2015 11:42:30

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Paquets et Mod

Petit complément de réponse suite au message de Kao :


dpkg --get-selections | sed 's:install$::' | grep -i php
 


me donne


php5
php5-cli
php5-common
php5-dev
php5-gd
php5-mcrypt
php5-mysql
 


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#7 18-01-2015 11:46:17

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [Résolu] Paquets et Mod

Tu cherches quel mod exactement?
Tu peux trouver les descriptions ici et éventuellement le contenu:
https://packages.debian.org/fr/source/wheezy/php5

Hors ligne

#8 18-01-2015 11:56:08

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Paquets et Mod

Et bien en fait, je cherche à trouver tous les mod installés chez mon hébergeur habituel, qui ne sont pas installés sur mon serveur.

Voici les mod installés chez mon hébergeur (trouvé dans le phpinfo()):


core
mod_authn_file
mod_authn_default
mod_authz_host
mod_authz_groupfile
mod_authz_user
mod_authz_default
mod_auth_basic
mod_auth_digest
mod_reqtimeout
mod_include
mod_filter
mod_deflate
mod_log_config
mod_logio
mod_env
mod_expires
mod_headers
mod_unique_id
mod_setenvif
mod_version
mod_proxy
mod_proxy_connect
mod_proxy_http
mod_ssl
prefork
http_core
mod_mime
mod_status
mod_autoindex
mod_asis
mod_info
mod_cgi
mod_negotiation
mod_dir
mod_actions
mod_userdir
mod_alias
mod_rewrite
mod_so
mod_authnz_external
mod_authz_unixgroup
mod_extract_forwarded
mod_fpcgid
mod_limitipconn
mod_security2
mod_php5
 



et voici les miens, aussi dans phpinfo() :

core
mod_log_config
mod_logio
mod_version
prefork
http_core
mod_so
mod_alias
mod_auth_basic
mod_authn_file
mod_authz_default
mod_authz_groupfile
mod_authz_host
mod_authz_user
mod_autoindex
mod_cgi
mod_deflate
mod_dir
mod_env
mod_mime
mod_negotiation
mod_php5
mod_reqtimeout
mod_rewrite
mod_setenvif
mod_status





Je cherche à reproduire la même config. pour pouvoir travailler sur mon serveur en dev et une fois que c'est bon, mettre en prod chez mon hébergeur.


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#9 18-01-2015 12:19:48

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [Résolu] Paquets et Mod

Tapes ceci pour chaque extension qui te manques dans une moteur de recherche type google:

debian package  mod_security2


Tu devrais tomber sur une page de ce type:
https://packages.debian.org/wheezy/modsecurity-crs
Indiquant le nom du paquet à installer.
Il faut y aller par déduction...

Hors ligne

#10 18-01-2015 12:45:40

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Paquets et Mod

Ok, En installant le paquets "modsecurity-crs", j'ai effectivement récupéré deux mod supplémentaires.

Mais tout ça me semble un peu hasardeux big_smile car si je fait comme tu me le conseil :

taper :

debian package  mod_security2

  dans google, ce dernier me propose trois paquets differents.

C'est un peu à la grace de dieu, non ?? lol


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#11 18-01-2015 13:03:45

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [Résolu] Paquets et Mod

C'est parce qu'ils affichent aussi les dépendances.
Si tu en installes un l'autre s'installera aussi:
On peut voir les dépendances avec:

apt-cache depends modsecurity-crs



et les dépendances inverses avec

apt-cache rdepends modsecurity-crs

Hors ligne

#12 18-01-2015 13:10:57

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Paquets et Mod

Ok, je comprends maintenant...

J'ai trouvé encore un mod...

C'est un travail de longue haleine...

En tout cas, merci beaucoup pour ton aide.

Orsam

Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#13 18-01-2015 13:34:14

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Paquets et Mod

En fait, il y a beaucoup de mod déjà présent dans le repertoire mod-available.

Il faut juste savoir que :

pour activer mod_include, il faut mettre a2enmod include,
pour activer mod_info, il faut mettre a2enmod info, etc...

Orsam

Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#14 18-01-2015 15:03:56

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : [Résolu] Paquets et Mod

Sans avoir accès à la liste des paquets installés par l'hébergeur, c'est plus dur, il faut y aller à taton.

Hors ligne

Pied de page des forums