Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-02-2015 18:11:34

Debeee
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Lxde / Openbox
Inscription : 11-02-2015

Programmer le bouton on/off ssur eeepc 701

Bonjour tout le monde,
Voilà mon pb : sur mon eeepc 701 flambant neuf avec sa Jessie / Lxde, quand j'appuie sur le bouton on/off, ça quitte sans crier gare.
J'avais le même comportement sous Lubuntu, mais pas sous eeebuntu : sur ce dernier, ça amenait à la fenêtre de déconnexion.
Je voudrais retrouver ce comportement en programmant le bouton on/off dans le fichier ~/.config/openbox/lxde-rc.xml.
J'ai donc rajouté ça dans ce fichier :

<keybind key="XF86PowerOff">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>Arrêt</name>
        </startupnotify>
        <command>lxsession-logout</command>
      </action>
    </keybind>


Ben ça marche pô... (après avoir relancé la session pour que la modife soit prise en compte bien entendu...)
J'ai aussi essayé avec XF86PowerDown, XF86Logoff, XF86Stop, XF86Sleep, XF86Go, et j'ai du aussi essayer avec XF86Power et XF86PowerOn
Que d'alle...
Je fais fausse route ?

Hors ligne

#2 15-02-2015 18:26:52

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Programmer le bouton on/off ssur eeepc 701

Salut,
Je ne sais pas si c'est possible avec ce fichier lxde mais peut-être que tu peux utiliser l'utilitaire xev pour obtenir le code du bouton puis l'utiliser comme tu le veux.
Sinon voir du côté de l'acpi: http://unix.stackexchange.com/questions … own-action

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 15-02-2015 19:08:17

Debeee
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Lxde / Openbox
Inscription : 11-02-2015

Re : Programmer le bouton on/off ssur eeepc 701

Merci sogalpunx, en fait, j'ai trouvé la solution (sans trop la piger, si tu peux éclairer ma bidouille d'un peu de science, c'est bienvenu)
D'abord, mes sources :
http://wiki.linuxquestions.org/wiki/XF8 … rd_symbols
https://help.ubuntu.com/community/Lubun … tall_Login
http://ubuntuforums.org/showthread.php?t=2139865
et le dernier pour la route, décisif :
http://unix.stackexchange.com/questions … -to-delete

Alors en fait, j'ai fait la manip avec xev, le pb, c'est qu'en réponse, ta machine s'éteint (désolé, pas eu le temps de lire le message !)
J'ai trouvé (dernier lien) de quoi désactiver cette touche. Dans le fichier /etc/systemd/logind.conf (ouvert en root), on remplace la ligne (commentée) :

#HandlePowerKey=poweroff


par la ligne (décommentée) :

HandlePowerKey=ignore



Et bien sûr, il faut mettre le code de mon post #1 dans le fichier  ~/.config/openbox/lxde-rc.xml.
Reboot
Ben là, j'ai pas compris, j'ai direct le comportement attendu : je tombe sur la mire de déconnexion en appuyant sur on/off.

Nota : par défaut, le programme de logout est lxde-logout. Si on le remplace par lxsession-logout, y'a pas le gros logo lxde qui bouffe une place folle en haut de fenêtre et qui empêche d'avoir toutes les options sur mon écran de 480 px de haut : on a alors toutes les options, dont "se déconnecter" et "annuler"

Carton plein !

Dernière modification par Debeee (15-02-2015 19:09:38)

Hors ligne

Pied de page des forums