Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-02-2015 14:50:36

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Lissage police Libreoffice

Salut,

J'utilise depuis peu une Debian virtualisée sous Windows 7 (ordi du boulot… pas le choix). J'ai reproduit dans Libreoffice le look des textes Word utilisé par les collègues (c'est le look par défaut en fait, la police utilisée étant Calibri).

Ce qui me chagrine c'est l'affichage à l'écran : en haut, sous Debian/LibreOffice, en bas sous Windows/Word

1424172640.png

1424177231.png

Je trouve le premier texte plus désagréable à lire et j'imagine que c'est un problème de lissage de police. Pourtant, le lissage est bien coché dans les options de LibreOffice.

Je suis sous iw3m ; je n'ai pas d'outils particuliers (comme ceux qu'on trouve sous Gnome, je crois) pour gérer l'affichage de la police.

Des suggestions ?

Merci smile

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#2 19-02-2015 17:35:46

Debeee
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Lxde / Openbox
Inscription : 11-02-2015

Re : Lissage police Libreoffice

Salut Lunatic,
tout d'abord, est-tu sûr d'avoir la police calibri dans ta debian ? Car si tu ouvres ton doc word dans LO, il va te mettre "calibri" dans la fenêtre police, mais faire l'affichage du texte avec une police de sustitution => pas pareil !
Ensuite, j'ai LO sur une Jessie toute neuve, sur une Lubuntu 14.04 et sur un mac => y'a pas photo, le mac affiche beaucoup plus propre (c'est encore plus flagrant sur un doc pdf). Jessie serait plutôt meilleure que Lubuntu, mais ça reste moyen, et dans tous les cas, LO affiche comme un cochon (tu enregistres le même doc en pdf et tu regardes la différence…)
Le lissage n'est pas très bon et ne change donc pas grand chose hélas.

Hors ligne

#3 19-02-2015 17:52:25

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : Lissage police Libreoffice

Salut Debeee et merci pour ta réponse.

Oui, j'ai bien installé la police Calibri.

J'ai installé XFCE et là, le lissage est actif. Ou, pour être plus précis, l'anti-crénelage est coché dans la partie « Apparence » des paramètres de XFCE (lissage, lui, étant sur « Aucune ».)
Le résultat sous Libre Office est plus beau que sous i3wm. Paradoxalement, si j'active le « lissage » avec l'outil de XFCE, la police ne paraît plus lissée du tout sous Libre Office et elle apparaît comme elle apparaît sous i3wm.

En résumé : sous XFCE, anti-crénelage actif, lissage inactif. Ensuite, dans Libre Office, je ne vois alors pas la différence entre l'option lissage (option de LibreOffice, donc…) active ou pas.

Mais dans aucun cas je ne parviens à atteindre ce résultat sous i3wm. Faut sans doute intervenir sur le serveur X directement…

Pas simple tout ça !

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#4 19-02-2015 19:14:54

Debeee
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Lxde / Openbox
Inscription : 11-02-2015

Re : Lissage police Libreoffice

Tu as raison, c'est très bizarre...
Je suis sous Lxde, et dans le panneau de réglages, j'ai l'option "activer anticrénelage" cochée. Si je décoche, c'est la cata (ça ressemble à ton exemple du haut).
Ensuite, j'ai une case "activer l'amélioration" avec un menu déroulant. Si je mets sur "léger", c'est nickel, police bien propre (j'ai de la Liberation serif). Si je mets sur "moyen" ou "complet", c'est tout moche (mais moins qu'avec l'anticrénelage off) => c'est aussi naze que sous Xfce !
J'ai aussi une option "géométrie des sous-pixels", c'est en RGB que c'est le plus lisible.
Sous LO, que je mette ou non le lissage des polices (à partir de 8 et j'ai du texte en 12), ça ne change strictement rien de visible.
Sinon, j'ai été dur : avec ma Jessie Lxde, le rendu est propre sous LO, et ça semble en progrès par rapport à Lubuntu 14.04 => je tâcherai de prendre des photos pour voir.
Sinon, i3wm, c'est quand même du spartiate, non, de ce que j'ai vu ? P'têt pas optimisé pour de l'affichage de doc LO ou autre...

Hors ligne

#5 19-02-2015 19:35:20

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : Lissage police Libreoffice

Comme libre office utilise les lib gtk+, je me demande si ce ne serait pas une bonne
idée d'activer l'anti-crénelage dans un utilitaire comme lxappearance (gestionnaire de
thème gtk).

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#6 19-02-2015 21:45:43

Debeee
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Lxde / Openbox
Inscription : 11-02-2015

Re : Lissage police Libreoffice

J'ai expérimenté un truc encore plus bizarre : j'ai testé sur mon eeepc 701 (la même Jessie Lxde que sur l'ordi de bureau sus-testé), les réglages ont un impact sur la fenêtre de réglages (les modifes des polices sont visibles quand je modifie les réglages), par contre, strictement aucun changement sur la fenêtre de LO (qui est très moche quel que soit le réglage) !! Sur l'ordi de bureau, il y avait une différence très nette. On parle de la même distrib sortie du même CD d'install.
Il y a aussi sûrement un impact carte graphique et driver, par ex, si on a un driver Nvidia, il rajoute sa surcouche de réglages de netteté, anti aliasing et tout le bla bla…
Pas gagné tout ça.

Hors ligne

Pied de page des forums