Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-02-2015 02:13:43

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Appareil photo ne se monte plus

Salut à tous !

Nouveau problème sous Wheezy 7.8 : impossible d'accéder à mon Canon EOS 350D. Il apparaît bien dans un lsusb :

lsusb


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 015: ID 04a9:30ef Canon, Inc. EOS 350D (ptp)
Bus 004 Device 002: ID 046d:0870 Logitech, Inc. QuickCam Express
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 005 Device 003: ID 1d57:0005 Xenta Wireless Receiver (Keyboard and Mouse)
Bus 005 Device 004: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader



Mais il ne se monte pas, et n’apparaît même pas en tant que périphérique montable, dans Gparted par exemple.

(même situation avec Jessie en MV, soit dit en passant)

Pourtant, il fut un temps où tout ça fonctionnait, (ça fait un petit moment que j'avais pas branché mon apn, je devais en être à la 7.4, par là), l'appareil était reconnu comme n'importe quel périphérique de stockage, sans rien installer de particulier. Qu'a-t-il donc bien pu se passer entre temps ? Et que puis-je essayer pour que ça marche ?

Merci d'avance pour vos réponses !


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#2 20-02-2015 12:12:26

sv0t
Membre
Distrib. : Debian
Noyau : Linux deb 3.16.0-4-amd64
(G)UI : oui
Inscription : 16-01-2015

Re : Appareil photo ne se monte plus

Je te renvoie à la commande https://debian-facile.org/doc:systeme:mount et tu as http://lea-linux.org/documentations/Har … _image-apn ce tuto qui reprend bien les choses.

Hors ligne

#3 20-02-2015 14:50:21

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : Appareil photo ne se monte plus

Merci pour les liens.

Donc, dans le deuxième, ils parlent à un moment d'installer gtkam, et effectivement, gtkam arrive à accéder au contenu de l'appareil photo. Mais c'est pas ce que je veux. Moi je veux accéder au contenu de l'appareil via Thunar.

La commande mount, c'est bien, mais faut que j'aie quelque chose qui corresponde à mon appareil photo. Aucune partition pouvant y correspondre ne semble exister dans /dev :

antoine@Ordinosaurus-Rex:~$ cat /proc/partitions
major minor  #blocks  name

   2        0          4 fd0
   8       16   78150744 sdb
   8       17   78149632 sdb1
   8       32   39062500 sdc
   8       33   35156250 sdc1
   8       34    3903488 sdc2
   8       48 1953514584 sdd
   8       49 1953513472 sdd1
  11        0     663556 sr0



(sdb, sdc et sdd sont les trois disques durs de ma tour)

Du coup je sais toujours pas quoi faire...


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#4 20-02-2015 15:58:12

AigletoN
Membre
Distrib. : Debian Jessie
(G)UI : KDE
Inscription : 14-12-2014

Re : Appareil photo ne se monte plus

brancher et allumer le canon puis

fdisk -l

Hors ligne

#5 20-02-2015 16:03:46

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : Appareil photo ne se monte plus

antoine@Ordinosaurus-Rex:~$ sudo fdisk -l

Disque /dev/sdb : 80.0 Go, 80026361856 octets
255 têtes, 63 secteurs/piste, 9729 cylindres, total 156301488 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x0009240f

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1   *        2048   156301311    78149632   83  Linux

Disque /dev/sdc : 40.0 Go, 40000000000 octets
255 têtes, 63 secteurs/piste, 4863 cylindres, total 78125000 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x00034eb9

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdc1   *        2048    70314547    35156250   83  Linux
/dev/sdc2        70316032    78123007     3903488   82  partition d'échange Linux / Solaris

Disque /dev/sdd : 2000.4 Go, 2000398934016 octets
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Identifiant de disque : 0x000bde25

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdd1   *        2048  3907028991  1953513472   83  Linux



Ça nous apprend rien de plus, y'a que mes disques durs.


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#6 20-02-2015 16:36:41

sv0t
Membre
Distrib. : Debian
Noyau : Linux deb 3.16.0-4-amd64
(G)UI : oui
Inscription : 16-01-2015

Re : Appareil photo ne se monte plus

Normal que mount ne renvoie rien, il faut modifier le fichier fstab, plus simple plour utiliser le protocole PTP


Paquet : gphoto2                              
État: non installé
Version : 2.4.14-1
Priorité : supplémentaire
Section : utils
Responsable : Debian PhotoTools Maintainers <pkg-phototools-devel@lists.alioth.debian.org>
Architecture : amd64
Taille décompressée : 1 061 k
Dépend: libc6 (>= 2.3.3), libcdk5, libexif12, libgphoto2-2 (>= 2.4.10.1), libgphoto2-port0 (>= 2.4.10.1), libncurses5 (>= 5.5-5~), libpopt0 (>= 1.14), libreadline6 (>= 6.0)
Suggère: gtkam, gthumb
Description : The gphoto2 digital camera command-line client
 The gphoto2 library can be used by applications to access various digital camera models, via standard protocols such as USB Mass Storage and PTP, or vendor-specific protocols.
 
 This package provide the gphoto2 command-line frontend.
Site : http://www.gphoto.org/proj/gphoto2/
 

Hors ligne

#7 20-02-2015 16:53:32

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : Appareil photo ne se monte plus

OK, mais faut que j'ajoute quoi dans fstab ?

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#8 20-02-2015 17:32:01

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Appareil photo ne se monte plus


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 20-02-2015 19:00:43

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : Appareil photo ne se monte plus

Merci pour le lien, mais c'est encore une méthode différente de récupération des photos, qui n'est pas celle que je cherche. Ce que je veux, c'est détecter la partition sur la carte mémoire de l'appareil pour pouvoir la monter et y accéder dans un gestionnaire de fichiers, comme je le faisais avant (sans aucune installation ni aucun paramétrage, soit dit en passant).

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#10 21-02-2015 07:01:25

AigletoN
Membre
Distrib. : Debian Jessie
(G)UI : KDE
Inscription : 14-12-2014

Re : Appareil photo ne se monte plus

fdisk aurait du montrer la carte :
j'ai brancher ma clé usb 32 go et ma carte de mon appareil de 8go

root@flycomputer:/home/laurent# fdisk -l

Disque /dev/sda : 465,8 GiB, 500107862016 octets, 976773168 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0xe0c5913d

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048  39198719  39196672  18,7G 83 Linux
/dev/sda2        40965750 285153245 244187496 116,4G  7 HPFS/NTFS/exFAT
/dev/sda3       285155326 976771071 691615746 329,8G  f W95 Ext'd (LBA)
/dev/sda4        39198720  40964095   1765376   862M 82 Linux swap / Solaris
/dev/sda5       285155328 976771071 691615744 329,8G  7 HPFS/NTFS/exFAT

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.
Disque /dev/sdb : 29,7 GiB, 31876710400 octets, 62259200 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0xe5d565a8

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdb1          63 62251874 62251812 29,7G  7 HPFS/NTFS/exFAT

Disque /dev/sdc : 7,5 GiB, 8069677056 octets, 15761088 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x00000000

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdc1  *     8064 15761087 15753024  7,5G  c W95 FAT32 (LBA)

root@flycomputer:/home/laurent#
 



tester avec une autre carte ?
pour la monter il faut la voir big_smile

Dernière modification par AigletoN (21-02-2015 07:02:54)

Hors ligne

#11 21-02-2015 09:25:06

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Appareil photo ne se monte plus

Le protocole de communication entre l'ordinateur et l'appareil photo varie d'un appareil à l'autre. Pour faire simple il y a 3 catégories :

    UMS (USB Mass Storage) : l'appareil se comporte comme une simple clé USB ou un disque dur externe et utilise en général un système de fichier FAT32 (parfois FAT16) ;
    PTP (Picture Transfert Protocol) : est le protocole standard de communication et de pilotage des appareils photo. Malheureusement certains fabriquants ont une interprétation bien à eux de ce protocole ;
    Protocole spécifique : ce n'est presque plus le cas aujourd'hui mais par le passé certains appareils utilisaient des protocoles spécifiques.

Dans les 2 derniers cas il faut passer par GPhoto pour extraire les photos de l'appareil. Il existe un modèle générique USB PTP pour les appareils supportant le protocole PTP standard et des variantes spécifiques.


http://doc.kubuntu-fr.org/photo

Il est possible d'installer une version antérieure de la libgphoto2 pour te dépanner et d'empêcher ensuite la mise à jour tant que le problème sur la nouvelle perdure, mais là, j'sais pas faire. smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 21-02-2015 10:54:35

AigletoN
Membre
Distrib. : Debian Jessie
(G)UI : KDE
Inscription : 14-12-2014

Re : Appareil photo ne se monte plus

http://sourceforge.net/projects/gphoto/files/  surement sa ?
mais je pense que ça ne changera rien puisque materiel non vue
ni par gparted et ni avec fdisk

Dernière modification par AigletoN (21-02-2015 10:55:04)

Hors ligne

#13 21-02-2015 11:05:37

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Appareil photo ne se monte plus

je suis votre discution de loin (avec mon café) , l usb n a besoin de rien pour fonctionner , il y aurait peut etre autre chose qu un probleme logiciel.
tu a testé sous win ou un autre linux.
la carte memoire est bien installé , la batterie correcte ?

j ai testé mon petit futji 10.2 c est bon j ai mon dossier photo avec mes photos (c est comme une clé usb )

Dernière modification par robert2a (21-02-2015 11:09:31)

Hors ligne

#14 22-02-2015 10:31:22

AigletoN
Membre
Distrib. : Debian Jessie
(G)UI : KDE
Inscription : 14-12-2014

Re : Appareil photo ne se monte plus

meme si le materiel se monte pas il devrai être visible ,pour ça aussi que je pense à un soucis materiel .
j'ai une carte mmc comme sa HS et non visible ^^

Dernière modification par AigletoN (22-02-2015 10:32:37)

Hors ligne

#15 23-02-2015 20:10:04

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : Appareil photo ne se monte plus

Ah oui, j'ai oublié de le préciser, mais l'appareil a été reconnu sans problème par Windows et le lecteur DVD de mes grands parents (mais pas par la télé, l'appareil doit être trop vieux pour être compatible), et la carte CF a également parfaitement fonctionné avec le lecteur de carte intégré à ma tour. Par contre sous Debian, j'ai testé avec Wheezy sur la tour et un des laptops et avec Jessie sur une MV sur la tour, rien à faire. La batterie est assez chargée (j'ai fait le test avec une batterie pleine au cas où, ça change rien). Et l'appareil est au moins en partie reconnu par le système puis qu'il apparait dans lsusb et que j'arrive à accéder à son contenu via gtkam.

Dernière modification par Ralph W. Llama (23-02-2015 20:12:05)


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

Pied de page des forums