Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-02-2015 15:05:24

humpf
Membre
Distrib. : debian 7.8
Noyau : 3.2.0-4-amd64
(G)UI : lxde sur inspiron, kde sur aspire
Inscription : 19-10-2013

configuration graphique et économie d'énergie

bonjour

je suis en train de réaliser, après avoir installé wheezy 7.8 version kde, que la gestion de l'énergie et l'éclairage de l'écran fonctionnent très mal. Je suis donc parti en quète dinfos car j'imagine qu'il doit y avoir des réglages spécifiques à effectuer, selon la configuration, et vu la complexité du sujet je préfère prendre un avis "éclairé".

ma configuration : un portable acer aspire 5750G équipé d'un intel core i7 QM, et 8 G de ram.

ce processeur est apparemment équipé d'une puce graphique intel et le portable est aussi équipé d'une carte graphique nvidia. J' ignore totalement comment le choix d'utiliser l'une ou l'autre est fait.

ci dessous résultat de la commande lspci | grep VGA :


tenek@debian:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)

 



lorsque j'utilise le module de configuration / économies d'énergie, si je diminue l'éclairage, il n'y a pas d'effet (après avoir "appliqué". Idem avec les touches de fonction du clavier permettant de régler l'éclairage, elles ne fonctionnent pas. (les touches de fonction du volume fonctionnent).

j'aimerais savoir si il s'agit d'un soucis lié à la configuration, ou si il y a quelque chose à installer. Il me semble me souvenir que "nouveau", le driver libre des cartes nvidia, devrait pouvoir fonctionner, mais j'ai l'impression que le graphique passe par la partie graphique intel... (selon kinfocenter)

voir ceci :

tenek@debian:~$ grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log
[    22.774] (II) Module intel: vendor="X.Org Foundation"
[    22.774]    compiled for 1.12.3.902, module version = 2.19.0
[    22.774]    Module class: X.Org Video Driver
--
[    22.790] (II) Module vesa: vendor="X.Org Foundation"
[    22.790]    compiled for 1.12.1, module version = 2.3.1
[    22.790]    Module class: X.Org Video Driver
 



le fait est que le portable utilise la technologie "otpimus", j'ai cherché et trouvé une piste, et suivi les indications d'installation de bumblebee ici : http://debian-facile.org/doc:materiel:c … ia:optimus (et donc également installé mesa-utils, bumblebee-nvidia et firmware-linux-nonfree) (il m'a fallu éditer /etc/apt/sources.list pour y ajouter les backports comme ceci :

## backports
deb http://ftp.fr.debian.org/debian/ stable-backports main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stable-backports main contrib non-free
 



je vais de ce pas redémarrer la machine et vérifier si un effet positif se fait sentir je croise les doigts !

bon, redémarrage sans soucis, un panneau de contrôle nvidia apparait dans le menu système et configuration, il m'indique que le driver nvidia n'est pas utilisée et qu'il faut configurer xorg.conf... via la commande (en root) "nvidia-xsettings"

ok je croyais que ce serait automatique... hélas, un essai de faire tourner le driver nvidia ne donne rien si ce n'est 'commande introuvable' :

root@debian:/home/tenek# nvidia-xconfig
bash: nvidia-xconfig : commande introuvable
 



Du coup j'essaie de vérifier la carte intel avec glxgears :


tenek@debian:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
302 frames in 5.0 seconds = 60.274 FPS
301 frames in 5.0 seconds = 60.160 FPS
301 frames in 5.0 seconds = 60.153 FPS
301 frames in 5.0 seconds = 60.164 FPS
301 frames in 5.0 seconds = 60.163 FPS
?
 



au moins là ça donne une réponse... bon... Pour le moment j'utilise toujours le driver intel et je n'ai toujours pas de réglages de luminosité...  ça devient... Quelqu'un pourrait-il m'aider ?

merci de vos avis

Dernière modification par humpf (25-02-2015 01:03:30)


debian wheezy kde sur acer aspire 5750G / DD 640G / 8G de ram - debian wheezy lxde sur dell inspiron 6400 /DD 128G / 2G de ram.
kubuntu 14.04 sur dell vostro 3555 / DD500G / 4 G de ram - xubuntu 14.04 sur dell optiplex gx260 / DD 500G / 1G de ram
sidux  xfce sur machine maison pour le multimedia (sert à lire des films sur une tv cathodique via péritel)

Hors ligne

#2 25-02-2015 01:02:58

humpf
Membre
Distrib. : debian 7.8
Noyau : 3.2.0-4-amd64
(G)UI : lxde sur inspiron, kde sur aspire
Inscription : 19-10-2013

Re : configuration graphique et économie d'énergie

hello !

je vois que tout le monde a des problèmes de réglage graphique et d'économie d'énergie non résolus !!!

debian wheezy kde sur acer aspire 5750G / DD 640G / 8G de ram - debian wheezy lxde sur dell inspiron 6400 /DD 128G / 2G de ram.
kubuntu 14.04 sur dell vostro 3555 / DD500G / 4 G de ram - xubuntu 14.04 sur dell optiplex gx260 / DD 500G / 1G de ram
sidux  xfce sur machine maison pour le multimedia (sert à lire des films sur une tv cathodique via péritel)

Hors ligne

#3 25-02-2015 06:30:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : configuration graphique et économie d'énergie

Il y a certainement un rapport entre le fait que Wheezy est en fin de carrière et que les nouveaux matos sont moins bien pris en charge de ce fait ? smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 16-03-2015 19:28:32

humpf
Membre
Distrib. : debian 7.8
Noyau : 3.2.0-4-amd64
(G)UI : lxde sur inspiron, kde sur aspire
Inscription : 19-10-2013

Re : configuration graphique et économie d'énergie

smolski a écrit :

Il y a certainement un rapport entre le fait que Wheezy est en fin de carrière et que les nouveaux matos sont moins bien pris en charge de ce fait ? smile



je ne sais pas, ma machine est pas récente, (2011 ?) c'est tout de même bizarre que le système d'économie d'énergie ne fonctionne pas. Je ne vois pas où chercher... Et puis c'est vrai que j'ai pas beaucoup de temps à consacrer à la recherche de solutions...


debian wheezy kde sur acer aspire 5750G / DD 640G / 8G de ram - debian wheezy lxde sur dell inspiron 6400 /DD 128G / 2G de ram.
kubuntu 14.04 sur dell vostro 3555 / DD500G / 4 G de ram - xubuntu 14.04 sur dell optiplex gx260 / DD 500G / 1G de ram
sidux  xfce sur machine maison pour le multimedia (sert à lire des films sur une tv cathodique via péritel)

Hors ligne

Pied de page des forums