Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-03-2015 01:52:42

Wheezy01500
Membre
Inscription : 02-03-2015

Probléme freeze / perte evenement clique souris

Bonjour à tous,

Je viens vers vous car là je suis totalement désespéré.
Depuis peu j'en ai eu marre de windows et je suis passé sous linux.

J'ai préféré une Debian wheezy 7.8 amd64. Je formate mon PC et go pour l'installation.
Une fois installé, je redémarre et me voilà sur Debian. Je commence à tester et à vouloir installer la carte graphique pour être en 1920x1080 et utiliser pleinement gnome 3.

C'est là que les ennuis commencent.

Je lance Iceweasel pour aller chercher les pilotes proprio ATI (crossfire 6870HD ^^) et je remarque que je ne peux plus aller dans le menu "activité" pour lancer un terminal par exemple.
Ou alors si j'y arrive je reste bloqué sur le terminal ou autre mais je ne peux cliquer nulle part... je ne peux plus déplacer aucune fenêtre ou fermer la fenêtre. Par miracle j'arrive à fermer au moins une fenêtre et hop j'ai à nouveau accés au menu principal, aux bouton des fenêtres...

Je me dit ce n'est rien c'est le probléme des pilotes qui ne sont pas installés (xorg qui plante avec ATI/AMD)... IDEM o_O
Je ferme ma session et je me logue à nouveau... Plus de probléme O_o

Pour faire court je rencontre ce genre de probléme avec:
Ubuntu (ouai j'ai essayé au cas ou) : freeze menu Unity
Debian 32 ou 64bit
Debian en minimalist avec Openbox : J'ouvre thunar et le terminal puis freeze... la souris bouge mais je ne peux rien faire d'autre. Alt+F4 pour fermer au moins une fenêtre... cela re-fonctionne O_o
Debian "Jessie" : Bah ouai le kernel et plus recent, je me suis dit le probléme vient de là... nada... idem... freeze -> je ferme la session -> plus de freeze

Et tout cela avec ou sans pilote graphique... donc pour moi cela ne vient pas des pilotes.

Mes pistes:

Xorg imcompatible avec ATI?
Pilote ?
mon crossfire ATI?
GTK2 GTK3?

Ma config:
AMD Phenom X4 3.4Ghz
8Go RAM
ASUS Formula 4
Crossfire 6870HD ATI
SSD 64Go Crucial

Demain je tente avec une seule carte? Des fois que... Ou alors je vais me chercher une Nvidia GT720 juste pour dépanner... si cela vient de ATI?

Je fournis tous les logs que vous voulez, il faut juste me dire lesquels.

J'ai essayé avec flgrx et driver libre c'est pareil...

Merci à vous de votre aide, je ne sais plus quoi faire...

Wheezy01500

Hors ligne

#2 02-03-2015 12:35:45

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Probléme freeze / perte evenement clique souris

bonjour

le seul pilote correct pour moi est le radeon avec une seule carte (en 2D uniquement ) , le flgrx impossible de le faire fonctionner avec une R9 270. (depot debian ou proprio ATI )
le pilote radeon des depots debian devrait te depanner , sinon personnellement j ai installé une nvidia a la place.

Hors ligne

#3 10-03-2015 05:28:10

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : Probléme freeze / perte evenement clique souris

Salut

Wheezy01500 a écrit :

Et tout cela avec ou sans pilote graphique... donc pour moi cela ne vient pas des pilotes.


Comment a-tu installé ce pilote? c'est celui que tu as été chercher sur le site d'ATI?

Hors ligne

#4 10-03-2015 08:45:08

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Probléme freeze / perte evenement clique souris

Salut,


Pour installer le pilote libre pour ta carte ati/radeon, il te faut ajouter les dépôts non-free dans ton sources.list pour pouvoir installer le paquet firmware-linux-nonfree
De la lecture pour comprendre cette histoire de dépôt -> APT : fichiers sources.list ou ici dans la documentation officielle : sources.list


Le chemin du fichier sources.list est /etc/apt/sources.list


Pour le modifier, il faut le faire en root ( = administrateur ), tu peux passer en mode administrateur avec la commande su ( ensuite tu tapes exit pour sortir du mode root quand tu as fini tes commandes d' administration dans le terminal )
Donc dans un terminal ou la console :

su


Il va te demander le mot de passe root qui n’apparaît pas quand tu le tapes


Puis avec nano, un éditeur de texte simple, tu modifies le fichier sources.list :

nano /etc/apt/sources.list


Tu fais tes modifications, puis tu enregistres Ctrl +o ( la touche contrôle et la touche o ( la lettre o ) en même temps ) et Ctrl +x pour quitter .


Tu recharges la liste des paquets ( paquet, c'est le nom des programmes/logiciel sous debian )

apt-get update




Et tu installes le paquet qui contient le pilote graphique :

apt-get install firmware-linux-nonfree




Et tu reboote .


note : pour installer un logiciel sous debian, il faut passer par le gestionnaire de paquets apt, c'est pas comme sous windows où tu allais chercher des programmes sur divers sites internet .


Je ne suis pas très pédagogue, donc n'hésite pas à poser des questions ou peut être un barbu va passer faire une explication de cette histoire de paquets .

Dernière modification par nono47 (10-03-2015 09:07:20)

Hors ligne

#5 10-03-2015 21:39:43

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Probléme freeze / perte evenement clique souris

le Crossfire 6870HD ATI n est reconnu qu avec le pilote propriétaire ATI de chez AMD , je te deconseille .
suis le tuto ci dessus , avec juste le firmware ça doit fonctionner (demonte le Crossfire ) et garde qu une carte (en 2D de toute maniere pas tres utile )

ps: je viens de finir l installation d un amd64 4200 X2 en 939 de 2004 tongue avec une R300 (gt 9600 ati en agp 8X  refroidissement passif ) , sur jessie.

aucun soucis apres avoir fait la manip ci dessus (firmware-linux-nonfree) et mit le cool quiet sur "on" dans le bios wink

a priori ta carte fait parti des gpu reconnu (serie 6800 HD ) apres avoir vérifié dans mon Xorg.0.log

@++

Dernière modification par robert2a (10-03-2015 22:22:48)

Hors ligne

Pied de page des forums