Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-04-2015 15:58:00

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

Bonjour,

je viens de là :

http://debian-facile.org/viewtopic.php? … 94#p115694

et viens ici pour prolonger "l'expérience" smile

à partir de cette liste :

[276M]  100-chansons-fr_2002_100-ch-francaises_1
[ 11M]  100-chansons-fr_1_01_la-romance-de-paris_charles-trenet_1942.flac
[ 13M]  100-chansons-fr_1_02_seule-ce-soir_leo-marjane_1941.flac
[ 10M]  100-chansons-fr_1_03_mon-amant-de-saint-jean_lucienne-delyle_1942.flac
[9.4M]  100-chansons-fr_1_04_j-ai-pleure-sur-tes-pas_andre-claveau_1943.flac



je fais un copier collage spécial dans librecalc, avec les options :
1428932498.png

la cellule < 9.4 > apparaît comme du 'texte'

1428933037.png

second essai en ajoutant l'option : "détecter les nombres spéciaux", ce qui donne le second tableau : format 'date'

pour modifier le format 'texte' en format 'nombre' :

1/ format / effacer 'le formatage direct' : la cellule devient < '9.4 >

1428933284.png

2/ formatage de cellule : 'nombre' en choisissant effectivement '1234,12'

ça n'a pas d'influence : le contenu de la cellule est toujours considéré comme du texte avec l'apostrophe devant.

3/ en faisant, dans librecalc,sur toute la colonne, un "rechercher-remplacer" le < ' > par < rien > : il ne trouve pas d'occurence de  < ' >


s'il n'y avait qu'une cellule concernée, ce serait vite réglé, "à la main", mais c'est loin d'être le cas smile

une idée ?

merci d'avance.
cordialement.
debianux

Dernière modification par debianux (13-04-2015 21:06:57)

Hors ligne

#2 13-04-2015 19:47:11

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

Passer la colonne chiffre par vim et supprimer l'apostrophe. Par exemple :

:%s/'//


puis par gedit pour le copier puis retour à librecalc en le collant.


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 13-04-2015 20:19:17

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

une idée,

dans les option de ton collé, tu sélectionne ta colonne avec les chiffres et tu la passe en "anglais US"

ça vient à mon avis du fait  qu'en "français" c'est une virgule pour le séparateur décimale


autre idée

tu fais un collage normal (sans l'option  "détecter les nombres spéciaux")
une fois réalisé, tu sélectionne ta colonne et tu fait un "rechercher et remplacer" (ctrl h) et tu change les "." et ","

Dernière modification par Severian (13-04-2015 20:40:13)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#4 13-04-2015 20:49:46

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

smolski a écrit :

Passer la colonne chiffre par vim et supprimer l'apostrophe. Par exemple :

:%s/'//


puis par gedit pour le copier puis retour à librecalc en le collant.



je pense que cette solution n'apporterait rien, tu reviens toujours avec 9.4 (9point4)
ça vient de libreoffice, quand tu tape une valeur avec décimale sur ton pavé numérique, le "point" deviens automatiquement une virgule et est reconnu comme un nombre, mais si tu utilise le "point" du "clavier", ça reste un "point" et la cellule et formaté en texte


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#5 13-04-2015 20:57:59

phreg
Membre
Distrib. : Antix MX-15
Noyau : 4.3-0-liquorix-686
(G)UI : Xfce 4.12
Inscription : 02-04-2011

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

Après l'import, Libreoffice permet de remplacer tous les "." par des "," dans la zone sélectionnée.
Edition, chercher et remplacer.
Pourquoi se compliquer la vie ?

Hors ligne

#6 13-04-2015 21:05:21

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

merci !
alors effectivement il faut faire la modification avant le collage :
dans mousepad (ou autre éditeur) : remplacer < . > par < , >
pour obtenir

[276M]  100-chansons-fr_2002_100-ch-francaises_1
[ 11M]  100-chansons-fr_1_01_la-romance-de-paris_charles-trenet_1942,flac
[ 13M]  100-chansons-fr_1_02_seule-ce-soir_leo-marjane_1941,flac
[ 10M]  100-chansons-fr_1_03_mon-amant-de-saint-jean_lucienne-delyle_1942,flac
[9,4M]  100-chansons-fr_1_04_j-ai-pleure-sur-tes-pas_andre-claveau_1943,flac



le ".flac" en profite pour passer en ",flac" mais ce sera facile de le remettre "à sa place" quand il sera en colonne smile

sélectionner le tout, copier,

dans libreoffice-calc, avec les mêmes réglages de séparateur que vu plus haut :

1428951802.png

youpie smile

merci à tous !

Hors ligne

#7 13-04-2015 23:00:42

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

Sinon dans options -> Paramètres linguistiques -> Langues,
touche séparateur de décimales (identiques au paramètre de la locale).

C'est là qu'est l'option de la virgule.

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#8 14-04-2015 08:43:28

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

Bonjour !

wiki mis à jour smile

@phreg
...parce que, dans ce cas précis, cela ne marche pas smile

@Papadakis
oui mais si tu veux garder la 'norme' française avec la virgule ?

@Severian

ça vient de libreoffice, quand tu tape une valeur avec décimale sur ton pavé numérique, le "point" deviens automatiquement une virgule et est reconnu comme un nombre, mais si tu utilise le "point" du "clavier", ça reste un "point" et la cellule et formaté en texte


sur mon portable, il n'y a pas de pavé numérique et il n'y a qu'une seule touche 'point' ( < shift > + <.;> ).

@Severian

une idée,


brillante !

dans les option de ton collé, tu sélectionne ta colonne avec les chiffres et tu la passe en "anglais US"


ça marche super, donc encore plus simple smile

wiki à remettre à jour smile

Hors ligne

#9 14-04-2015 08:50:57

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

wiki remis à jour !

Hors ligne

#10 14-04-2015 11:06:00

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [resolu] libreoffice-calc: formater: série de type < '9.4 > en < 9,4 >

Voilà par sed smile

sed -r 's/(\[[^]]*)\./\1,/' le_listing

Merci à pingouinux
http://forum.ubuntu-fr.org/viewtopic.php?id=1820661

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums