Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-04-2015 09:52:05

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Appareil photo Fujifilm Finepix SL 240

Salut !

J'ai fait l'acquisition d'un APN et bien sûr quand je le branche sur ma Debian, il ne se monte pas automatiquement (saloperie de Debian big_smile).

Mon syslog me renvoie ça au branchement :

Apr 24 09:42:32 Winston kernel: [46204.137237] usb 1-1: new high-speed USB device number 7 using ehci-pci
Apr 24 09:42:32 Winston kernel: [46204.272507] usb 1-1: New USB device found, idVendor=04cb, idProduct=0268
Apr 24 09:42:32 Winston kernel: [46204.272519] usb 1-1: New USB device strings: Mfr=0, Product=2, SerialNumber=3
Apr 24 09:42:32 Winston kernel: [46204.272526] usb 1-1: Product: USB PTP
Apr 24 09:42:32 Winston kernel: [46204.272532] usb 1-1: SerialNumber: 592D31343832311210300E052WJ56642
Apr 24 09:42:32 Winston mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:02.1/usb1/1-1"
Apr 24 09:42:32 Winston mtp-probe: bus: 1, device: 7 was not an MTP device



et l'appareil est même reconnu :

#lsusb
Bus 001 Device 007: ID 04cb:0268 Fuji Photo Film Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 046d:c315 Logitech, Inc. Classic Keyboard 200
Bus 002 Device 002: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub



Je vois plein de trucs sur internet mais ce que je voudrais avant de faire quoi que ce soit, c'est avoir la bonne méthode !


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#2 24-04-2015 10:47:58

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Appareil photo Fujifilm Finepix SL 240

Pour ma part, j'utilise un lecteur de carte externe connecté par usb dans lequel je mets mes cartes.  cool

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 24-04-2015 12:17:24

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

Mais ... mais ... cette réponse ne me convient pas ! smile

(je n'ai pas de lecteur de cartes).

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#4 24-04-2015 13:07:05

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

donne nous le résultat de:

cat /etc/fstab

Hors ligne

#5 24-04-2015 13:32:53

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

Je comprends pas bien ce que vient faire mon fstab ici.

# / was on /dev/sdc2 during installation
UUID=cbbcf8da-1abe-41fa-b83c-7fb8ab4862a4 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sdc6 during installation
UUID=317da15b-7556-44d7-add3-39f2e942492b /home   ext4  defaults  0 2

# /usr was on /dev/sdc3 during installation
UUID=74a9521a-a588-48be-86cd-0a35536251ac /usr    ext4  defaults  0 2
# /var was on /dev/sdc5 during installation
UUID=dd117d8a-1d50-4d60-ae65-68f054499355 /var    ext4  defaults  0 2

# swap was on /dev/sdc1 during installation
UUID=bba87bbf-9ce4-4e13-b765-4155e9f322e3 none    swap  sw    0 0

/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
 



Après, il y a 4 volumes en ext4 (mes disques durs) et 2 en nfs (un serveur de partage), voilà.


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#6 24-04-2015 14:17:24

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

pour le poursuivi, je t'invite à regarder la doc sur fstab.
Un pb assez similaire est revenu plusieurs fois sur le forum.

Dans ton cas, il ne semble pas  avoir de pb de ce coté.

Hors ligne

#7 24-04-2015 16:19:19

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

De ce que je comprends de la littérature que je trouve, mon appareil ne fonctionne pas comme un mass storage mais avec le protocole PTP.
C'est écrit ici :

Apr 24 09:42:32 Winston kernel: [46204.272526] usb 1-1: Product: USB PTP



Donc, toujours d'après ce que j'ai lu, il faut installer le paquet gphoto2, ce que j'ai fait.

Je suis allé configurer thunar comme indiqué ici http://debian-facile.org/viewtopic.php?pid=93187#p93187
Comme ligne de commande, j'ai tout simplement écrit /usr/bin/gphoto2

J'ai ensuite branché mon APN et miracle, j'ai 4 fenêtres qui apparaissent en haut à droite de mon écran pour me dire qu'un appareil photo a été détecté (4 fois la même chose).

Disons que j'ai progressé, je me plonge dans le man de gphoto2.

Si quelqu'un a de l'expérience sur ce paquet, je suis encore preneur. smile


Edit : j'ai installé une interface graphique (prévue pour ça), gtkam.
C'est pas aussi bien que si le bouzin était monté mais je m'en contenterai pour aujourd'hui.

Dernière modification par Papadakis (24-04-2015 16:44:54)


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#8 25-04-2015 19:52:20

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

Donc, j'ai configuré Thunar pour qu'il ouvre gtkam à la connexion d'une caméra :
Préférences -> Avancées -> Gestionnaire de volumes -> Configurez -> Caméras -> Importer les photos à la connexion, Commande :

/usr/bin/gtkam



Et bien thunar m'en ouvre 4 (comme le nombre de fenêtres pour gphoto2, bizarre hein!).

Quelqu'un pour gphoto2 ?


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#9 26-04-2015 15:28:27

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

Salut !

Je ne sais comment, les fenêtres ne sont plus que deux.
Toujours envahissantes.
Merci.

Capturedecran-26042015-152318.png

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#10 26-04-2015 15:58:51

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Appareil photo Fujifilm Finepix SL 240

Une fenêtre titrée gtkam et une normale, enlève gtkam peut-être ? smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 26-04-2015 17:28:01

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Appareil photo Fujifilm Finepix SL 240

smolski a écrit :

Une fenêtre titrée gtkam et une normale, enlève gtkam peut-être ? smile



Qu'est-ce que je fais, je signale ce spam ? tongue

Je résume pour ceux du fond :

-Avant, il n'y avait rien, j'ai installé gphoto2.
-Miracles, 4 fenêtres apparaissent (comme celles en haut à droite sur le copécran).
-J'installe Gtkam qui paraît être l'outil graphique de gphoto2.
Gtkam ouvre 4 autres fenêtres (plein écran) au branchement de l'appareil

Je bidouille je ne sais quoi (me souviens pas ce que j'ai fait, préférences thunar, qqchose dans xfce ?), il n'y a plus que deux fenêtres qui apparaissent (2+2 pour ceux du fond).

Edit: Je me rappelle le bidouillage, j'ai retiré le préréglage pour choisir l'appareil dans Gtkam.

Edit2: ce que j'aimerai moi, c'est pouvoir monter l'appareil normalement, comme une clé usb

Dernière modification par Papadakis (26-04-2015 20:05:33)


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#12 30-08-2015 11:19:29

fwong13
Membre
Inscription : 30-08-2015

Re : Appareil photo Fujifilm Finepix SL 240

Il me semble que tu n'as pas parlé de ton APN lui-même :

- Sur certains APN, 2 modes de connection USB sont possibles :

  - Mass Storage ---> le système détecte une sorte de "cle USB"

  - APN ---> Le système détecte une "webcam"

Tu devrais farfouiller dans la config de ton APN lui-même en personne !
pour dénicher une, ou des, option(s),  qui te permettrons peut-etre de
choisir le mode approprié à ton intention d'utilisation ..

quand 1000 fourmis attaquent ensemble un lion, c'est le lion qui perd ...

Hors ligne

Pied de page des forums