Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-05-2015 06:20:41

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

[RÉSOLU] écran noir après installation jessie xfce

bonjour,
sur un portable dell precision M90, avec un intel duo core et une carte graphique nvidia quadro fx-1500, cela fait deux fois que j'installe jessie avec xfce sur une partition. au début tout fonctionne bien. puis, sans raison évidente, au redémarrage, je me retrouve avec un écran noir, aussi bien lors du démarrage normal, que du démarrage de secours. donc aucun moyen d'accéder à une ligne de commande. à la première panne, j'avais décommenté les mauvaises lignes de lightdm.conf. à la seconde fois, j'ai fait bien attention. la connexion automatique a bien fonctionné pendant 24 heures. puis à nouveau écran noir. j'ai remis le fichier lightdm.conf d'origine, que j'avais cette fois conservé, à partir d'un wheezy sur une seconde partition, mais cela ne change rien. cela vient probablement de la gestion de nvidia, je suppose. mais sans accès à une ligne de commande, comment corriger le tir ??

Dernière modification par jeanmarc1 (06-05-2015 05:38:25)


"Being is not doing"

Hors ligne

#2 01-05-2015 06:23:49

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

Ctrl+ALt+F1 tu aura accès a un shell en principe  ?

Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#3 01-05-2015 06:51:56

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

merci pour ton conseil. je ne sais pas exactement ce que fait la commande ctrl+alt+f1. en la faisant dans l'écran noir du recovery, rien ne se passe. par contre, en redémarrant, j'ai pu rentrer dans le système. j'ai relancé puis à nouveau écran noir. même manip, et je suis à nouveau dans le système. je pense qu'il faudrait que j'installe les drivers nvidia. pas encore trouvé la manip dans jessie.

"Being is not doing"

Hors ligne

#4 01-05-2015 07:40:30

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : Jessie bureaux : mate et Handylinux basé sur Jessi
Noyau : linux 3.2.0-4-686-pae
(G)UI : mate
Inscription : 11-02-2012

Re : [RÉSOLU] écran noir après installation jessie xfce

Bonjour

Mes notes; si ça peut servir.

http://debian-facile.org/utilisateurs:n … os:accueil

N'achetez pas Windaube !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#5 01-05-2015 07:46:22

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

merci, nounours, pour tes notes.
j'ai essayé d'installer les drivers nvidia en suivant ces indications. hormis le dépôt non-free qui n'a pas l'air de répondre. j'ai pris ce dépôt à la place :

deb http://ftp.fr.debian.org/debian/ jessie main non-free


j'ai tenté d'installer cela :

apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)


la carte nvidia était notifiée comme trop ancienne. j'ai tout de même tenté l'installation.
maintenant au démarrage, j'arrive sur une série sans fin de lignes, indiquant : could not read microcode : -12
??


"Being is not doing"

Hors ligne

#6 01-05-2015 09:09:58

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

je crois que je vais devoir réinstaller, une gnome cette fois. possible que cela vienne de xfce... aussi j'ai utilisé une image amd64 pour la première fois, car j'ai vu que ces vieux portable dell supportent en fait le 64 bits. je ne sais pas si cela change quelque chose de réutiliser une 32 bits, si l'installation en 64 se fait sans problème.

"Being is not doing"

Hors ligne

#7 01-05-2015 09:40:35

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [RÉSOLU] écran noir après installation jessie xfce

Pour ta carte Nvidia Quadro fx 1500: mieux vaut aller voir sur le site de Nvidia quel version du pilote la prend en charge.

Je viens d'aller voir: c'est le 304.125 le plus récent, un pilote dit "LTS".

Dernière modification par yoshi (01-05-2015 09:44:27)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#8 01-05-2015 10:19:49

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

yoshi a écrit :

Pour ta carte Nvidia Quadro fx 1500: mieux vaut aller voir sur le site de Nvidia quel version du pilote la prend en charge.

Je viens d'aller voir: c'est le 304.125 le plus récent, un pilote dit "LTS".



je vais regarder merci. j'ai réinstallé avec gnome, pensant que peut être le problème venait de lightdm de xfce, mais non. la panne se reproduit.


"Being is not doing"

Hors ligne

#9 01-05-2015 10:39:01

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

yoshi a écrit :

Pour ta carte Nvidia Quadro fx 1500: mieux vaut aller voir sur le site de Nvidia quel version du pilote la prend en charge.
Je viens d'aller voir: c'est le 304.125 le plus récent, un pilote dit "LTS".



sur le site nvidia, j'ai trouvé le pilote pour une FX 1500, mais non FX 1500M (apparemment c'est une version notebook).
peut être sur cette page ?
une fois qu'on trouve le driver, je ne sais pas comment l'installer.


"Being is not doing"

Hors ligne

#10 01-05-2015 12:19:09

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [RÉSOLU] écran noir après installation jessie xfce

Je viens de chercher à nouveau. Ta quadro est dérivée de la GeForce 7900 GS, c'est pas tout récent. Je confirme la version du driver: 304.125
Donc c'est spécifique.

*** Tu as de la chance, il est dans les dépôts Debian, donc méthode classique préconisée par Debian pour l'install. (il est en "legacy").

Dernière modification par yoshi (01-05-2015 12:24:13)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#11 01-05-2015 12:26:07

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [RÉSOLU] écran noir après installation jessie xfce

Je pense que les paquets qui correspondent à ta carte sont:

nvidia-legacy-304xx-kernel-dkms
nvidia-legacy-304xx-driver

https://packages.debian.org/jessie/nvid … 4xx-driver

Hors ligne

#12 01-05-2015 12:30:15

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [RÉSOLU] écran noir après installation jessie xfce

Oui, c'est exactement ça.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#13 01-05-2015 14:10:35

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

merci pour vos aides. ces drivers sont-ils aussi valables pour la version 32 bits ?
pour l'instant, pas moyen d'avoir accès au système, ni même à la console de démarrage. écran noir systématique, et ctrl+alt+F1 inefficace. une idée ? si jamais je dois réinstaller une 4ème fois, peut-être devrais je prendre une version 32 bits pour cet ordi, qui date de 2007 et donc n'est pas tout jeune (pour un ordi).

"Being is not doing"

Hors ligne

#14 01-05-2015 16:43:09

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [RÉSOLU] écran noir après installation jessie xfce

Si c'est dispo en 64 bits, ça l'est en 32 bits également.

Pour le problème de l'écran noir, j'ai connu ça il y a quelques années. (ma GeForce 6600 GT de l'époque ne fonctionnait pas avec le pilote nv il fallait repasser au pilote vesa,
nouveau n'existait pas).
Le problème, c'est que maintenant il n'y a plus de /etc/X11/xorg.conf d'origine, donc je ne sais pas quel parametre changer. Peut être d'autres pourront te l'indiquer sur ce forum.
Enfin, le but, c'est de démarrer en donnant l'ordre au système d'utiliser le pilote vesa. Ce dernier est générique, pas bon du tout, mais au moins il fait fonctionner une interface graphique sommairement.

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#15 01-05-2015 16:46:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RÉSOLU] écran noir après installation jessie xfce

Je crois qu'on peut le fabriquer cet xorg pour ne configurer que l'écran :
http://debian-facile.org/doc:environnem … -xorg:conf smile

Ah non : obsolète !

Dernière modification par smolski (01-05-2015 16:47:31)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#16 01-05-2015 17:04:49

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : [RÉSOLU] écran noir après installation jessie xfce

Oui, et de toute façon, le pilote libre nv, je pense qu'on ne l'a même plus sous Linux depuis que nouveau est arrivé.
Il n'y a plus que les BSD qui l'utilise.
Le soucis, c'est que quand on est en écran noir sur un ordi avec un seul système d'installé, on est un peu dans la m....
La seule chose possible, c'est de passer une commande avec Grub, du style nouveau.modeset=0 vesa.modeset=1. Mais je suis loin d'être bon
avec ce genre de commandes ......

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#17 01-05-2015 17:27:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [RÉSOLU] écran noir après installation jessie xfce

Bonjour

si debian ne trouve pas de driver video , le bureau sera en vesa (pas de "nouveau" , ni de non-free nvidia installé , ni de proprio nvidia).
le graphisme  pas terrible certainement wink

si ça peut vous aider

Hors ligne

#18 01-05-2015 17:41:25

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

yoshi a écrit :

Oui, et de toute façon, le pilote libre nv, je pense qu'on ne l'a même plus sous Linux depuis que nouveau est arrivé.
Il n'y a plus que les BSD qui l'utilise.
Le soucis, c'est que quand on est en écran noir sur un ordi avec un seul système d'installé, on est un peu dans la m....
La seule chose possible, c'est de passer une commande avec Grub, du style nouveau.modeset=0 vesa.modeset=1. Mais je suis loin d'être bon
avec ce genre de commandes ......



oui, je me demandais justement si en jouant dans le grub avec la commande "e", on ne pouvait pas avoir tout de même accès à une console rudimentaire.


"Being is not doing"

Hors ligne

#19 01-05-2015 17:45:09

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

deuchdeb a écrit :

Je pense que les paquets qui correspondent à ta carte sont:

nvidia-legacy-304xx-kernel-dkms
nvidia-legacy-304xx-driver

https://packages.debian.org/jessie/nvid … 4xx-driver



après avoir ajouté une ligne "contrib non-free" dans sources.list, pourrait-on tenter d'installer cela :

apt-get install nvidia-legacy-304xx-kernel-dkms nvidia-settings nvidia-legacy-304xx-driver linux-headers-$(uname -r)



et doit-on ensuite modifier le fichier /etc/X11/xorg.conf ??


"Being is not doing"

Hors ligne

#20 01-05-2015 18:10:41

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [RÉSOLU] écran noir après installation jessie xfce

Oui c'est bien cela qu'il faut faire. Mais d'abord il faudra enlever les autres paquets nvidia que tu as installé et ceux qui se sont installés automatiquement.

Il faut aussi si tu veux une création automatique du fichier xorg.conf installer le paquet : nvidia-xconfig
https://packages.debian.org/stable/x11/nvidia-xconfig

Ensuite dans une console en root on lance la commande qui suit et cela crée automatiquement le fichier xorg.conf qui va bien.

nvidia-xconfig



Ensuite redémarrer l'ordinateur.

Hors ligne

#21 02-05-2015 07:09:42

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

merci, deuchdeb pour les précisions. j'ai réinstallé une xfce en 32 bits. pour l'instant, curieusement, elle fonctionne. je n'ai pas encore osé modifié le fichier /lightdm/lightdm.conf pour mettre la connexion automatique de l'utilisateur principal. à chaque fois que je l'ai fait dans les précédentes installations, cela a bugué l'entrée dans le système. je ne sais pas si cela a un lien, mais on met 0 secondes de temps de connexion. possible que le système fragile ne supporte pas....

"Being is not doing"

Hors ligne

#22 02-05-2015 09:09:28

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

j'ai une nouvelle piste. il ne s'agirait pas d'un problème de pilote de carte graphique, mais cela concernerait le fichier fstab. explications :
quand j'installe une distrib, premiers gestes : connexion automatique, et modifier le fstab pour accéder aux données de mon nas synology.
après avoir installé xfce de nouveau..., je mets en place la connexion auto. ok, on redémarre bien. j'ajoute les lignes d'accès nfs au nas dans etc/fstab. impossible de rentrer dans le système. je supprime les lignes via la wheezy d'une autre partition. cela redémarre bien.
voici les deux lignes que j'utilise pour fstab, en principe les deux fonctionnent dans wheezy, mais j'utilise plutôt la première :

#NFS MOUNTS
192.168.0.36:/volume1/username /home/jm/share/username nfs rw,sync,hard,intr 0 0


ou bien :

192.168.0.36:/volume1/username /home/jm/share/username nfs user,auto,exec 0 0



ce ne serait donc pas un pb de pilote vidéo. pour éviter de réinstaller le système x fois, la prochaine fois, je regarderai mieux "dr house".

si vous avez une piste pour se connecter au nas dans ces conditions, elle est bienvenue.
bien sûr, j'ai vérifié que "nfs-common" est bien installé d'office dans la jessie xfce, c'est bien le cas.

vos pistes pour les pilotes nvidia ne seront peut être pas inutiles toutefois. merci encore pour cela.


"Being is not doing"

Hors ligne

#23 03-05-2015 07:11:02

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

tout de même bizarre que toute ligne contenant "nfs" ajoutée au fstab, contrairement à wheezy, bug l'entrée dans le système. je ne sais pas si c'est un bug de jessie 8, concernant nfs, ou bien si cela a à voir avec le pilote "nouveau" de carte graphique qui ne peut gérer cette information. peut-être devrais je fermer ce post, et formuler cette nouvelle question dans la rubrique "réseau" du forum.

Dernière modification par jeanmarc1 (03-05-2015 07:11:55)


"Being is not doing"

Hors ligne

#24 05-05-2015 16:22:07

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

finalement, grâce à un ami, en modifiant la ligne ajoutée à fstab, en mentionnant "noauto", le système démarre bien, et les dossiers du nas sont montés. voici la fin de ligne utilisée :

nfs noauto,user,users,exec 0 0


logiquement, noauto ne devrait pas monter automatiquement les dossiers du nas, et pourtant si, ils sont montés. mystère ?
et idem sur une seconde jessie installée sur un autre ordi. la ligne dans fstab ne perturbe pas le démarrage uniquement si on met "noauto"....

Dernière modification par jeanmarc1 (05-05-2015 16:27:17)


"Being is not doing"

Hors ligne

#25 06-05-2015 05:14:01

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [RÉSOLU] écran noir après installation jessie xfce

en tâtonnant, j'ai compris plusieurs choses :
- quand on met la commande "noauto" dans le fstab, ce n'est pas un montage automatique qu'on obtient, mais semi-automatique. en effet, les dossiers du nas sont visibles dans le gestionnaire de fichiers, mais non montés. un simple clic dessus, dans le panneau latéral, suffit à les monter.
- finalement, dans mon cas, c'est l'absence du firmware de la carte wifi, qui bloquait l'entrée dans le système, dès lors qu'on utilisait la commande "auto" dans le fstab. après avoir installé le firmware adéquat (merci à michel pour le lien), la commande "auto" dans le fstab ne bloque plus le redémarrage du système.
je crois donc qu'on peut mettre "résolu" à ce fil de discussion. merci à tous et à toutes pour votre aide et soutien.

"Being is not doing"

Hors ligne

Pied de page des forums