Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-05-2015 23:59:11

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

(Résolu) Probleme avec 2 carte reseau

Un petit problème de plus pour vous
Voila mon trouble... ici j’ai 2 carte Ethernet installé sur ma machine, j'utilise seulement la eth1 pci,

sudo ifconfig
[sudo] password for ir0n:
eth0      Link encap:Ethernet  HWaddr 94:0c:6d:81:e8:25  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43748 errors:0 dropped:7879 overruns:0 frame:0
          TX packets:26143 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:3491946 (3.3 MiB)  TX bytes:1754591 (1.6 MiB)

eth1      Link encap:Ethernet  HWaddr 00:18:71:73:3f:d3  
          inet adr:192.168.2.185  Bcast:192.168.2.255  Masque:255.255.255.0
          adr inet6: fe80::218:71ff:fe73:3fd3/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:60774 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43329 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:78135541 (74.5 MiB)  TX bytes:12809763 (12.2 MiB)
          Interruption:17

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:269 errors:0 dropped:0 overruns:0 frame:0
          TX packets:269 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:29097 (28.4 KiB)  TX bytes:29097 (28.4 KiB)
 


Mon routeur  DDWRT (192.168.4.1) est configurez en Pont Client wifi a mon router Bell (192.168.2.1).

Modèle du Routeur Linksys WRT160N v3 Micrologiciel: DD-WRT v24-sp2 (03/25/13) mini
Heure: 13:47:57 up 49 days, 13:48, load average: 0.05, 0.04, 0.00
WAN: Désactivé



J'ai seulement 1 fils Ethernet entre mon P4 Debian et mon DDWRT, mais le router DDWRT n'est pas visible car mon adresse est attribué par le routeur Bell 192.168.2.xxx ...
Donc pour rejoindre mon DDWRT je dois activer eth0 (via l'applet NetworkManager)  lui attribuer une adresse manuel: 192.168.4.1xx Masque de réseau:  255.255.255.0 Passerelle: 192.168.4.1.

Aussitôt terminé les modification ou autre sur mon routeur je dois désactivé eth0 sinon au reboot je n'ai plus accès car il y'a un conflit et je ne sais pas comment le réglé.

Merci pour vos suggestion.

Dernière modification par Ir0nsh007er (06-05-2015 21:14:10)


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#2 02-05-2015 00:56:38

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : (Résolu) Probleme avec 2 carte reseau

J'ai un peu de mal à comprendre comment tu as configuré tes routeurs.

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#3 02-05-2015 02:04:41

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Router Bell (192.168.2.1) serveur DHCP, c'est lui qu'il reçoit le net, un peut comme vous freebox et autres FAI, il envoi le signal a mon DDWRT (192.168.4.1) en wifi qui lui me donne accès via fils Ethernet a mon pc. Le router DDWRT est juste PONT WIFI Bridge 0 et les port lan sur le routeur sont router  dynamique. Plus ou moins ca.
Si tu comprends l'anglais voici comment est configurez le Wireless Access point sur mon routeur:


Open the Setup -> Basic Setup tab

    WAN Connection Type : Disabled
    Local IP Address: 192.168.1.2 (i.e. different from primary router and out of primary router's DHCP pool)
    Subnet Mask: 255.255.255.0 (i.e. same as primary router)
    DHCP Server: Disable (also uncheck DNSmasq options)
    (Recommended) Gateway/Local DNS: IP address of primary router (many things will fail without this as your router will not be able to access the internet or another network without it)
    (Optional) Assign WAN Port to Switch (visible only with WAN Connection Type set to disabled): Enable this if you want to use WAN port as a switch port
    (Optional) NTP Client: Enable/Disable (if Enabled, specify Gateway/Local DNS above) Help
    Save

Open the Setup -> Advanced Routing tab

    (Optional) Change operating mode to: Router
    Save

Open the Wireless -> Basic Settings tab

    Wireless Network Name (SSID): YourNetworkNameHere
    (Optional) Sensitivity Range: The max distance (in meters) to clients x2
    Save

Open the Wireless -> Wireless Security tab

    Note: Security is optional, but recommended! Clients must support whatever mode you select here.
    (Recommended) Security Mode: WPA2
    (Recommended) WPA Algorithm: AES
    (Recommended) WPA Shared Key: >8 characters
    Save

Open the Services -> Services tab

    (Optional) DNSMasq: Disable (enable if you use additional DNSMasq settings)
    (Optional) ttraff Daemon: Disable
    Save

Open the Security -> Firewall tab

    Uncheck all boxes except Filter Multicast
    Save
    Disable SPI firewall
    Save

Open the Administration -> Management tab

    (Recommended) Info Site Password Protection: Enable
    (Recommended) Routing: Disabled (enable if you need to route between interfaces)
    Apply Settings and connect Ethernet cable to main router via LAN-to-LAN uplink*
    Reboot router to be sure all settings have been applied.
    You may have to reboot your own PC or do "ipconfig /release" + "ipconfig /renew" from the Windows command line.

 


Liens complet pour nourrir d'avantage votre envie d'apprendre.:D
http://www.dd-wrt.com/wiki/index.php/Wi … cess_Point

Bon .. lol .. La n'est pas la question ... big_smile  Pkoi ma 2e carte eth1 si je  l'active et je reboot je perds la connections via le net, pourtant l’accès a mon DDWRT 192.168.4.1 reste actif ?


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#4 02-05-2015 03:08:54

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Avant reboot

sudo ifconfig
[sudo] password for ir0n:
eth0      Link encap:Ethernet  HWaddr 94:0c:6d:81:e8:25  
          inet adr:192.168.4.169  Bcast:192.168.4.255  Masque:255.255.255.0
          adr inet6: fe80::960c:6dff:fe81:e825/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:66 errors:0 dropped:14 overruns:0 frame:0
          TX packets:135 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:8486 (8.2 KiB)  TX bytes:13717 (13.3 KiB)

eth1      Link encap:Ethernet  HWaddr 00:18:71:73:3f:d3  
          inet adr:192.168.2.185  Bcast:192.168.2.255  Masque:255.255.255.0
          adr inet6: fe80::218:71ff:fe73:3fd3/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:81 errors:0 dropped:0 overruns:0 frame:0
          TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:8915 (8.7 KiB)  TX bytes:9702 (9.4 KiB)
          Interruption:17

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:480 (480.0 B)  TX bytes:480 (480.0 B)
 




Suite au reboot plus d’accès au net... KLIK Onglet NetworkManager supprime connexion eth0 et réactive le net boom tout refonctionne ?


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#5 02-05-2015 03:33:13

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : (Résolu) Probleme avec 2 carte reseau

Salut

Il arrive souvent que network-manager foute la merde au lieu d'aider. Perso, je n'ai pas installé ce paquet et tout roule pour le mieux. À voir donc.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#6 02-05-2015 03:40:52

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Haricophile a écrit :

J'ai un peu de mal à comprendre comment tu as configuré tes routeurs.


Dégooglisons Internet.. wink
J'aime bien la parenthèse avec Asterix.


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#7 02-05-2015 03:44:44

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

martinux_qc a écrit :

Salut

Il arrive souvent que network-manager foute la merde au lieu d'aider. Perso, je n'ai pas installé ce paquet et tout roule pour le mieux. À voir donc.




Merci pour l'idée a suivre donc je devrais en console commenter eth0 ? ou dans les fichier config?


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#8 02-05-2015 03:47:35

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Eh cé mon localhost est devenu http://192.168.4.1/ Apache2 Debian Default Page ?? cé pas le DDWRT lol cé ma page web test

Dernière modification par Ir0nsh007er (02-05-2015 03:49:25)


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#9 02-05-2015 03:49:13

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : (Résolu) Probleme avec 2 carte reseau

Je ne suis pas expert en la matière, d'autres seront mieux te répondre que moi, mais dans mon cas donc je passe par la config du fichier /etc/network/interfaces

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#10 02-05-2015 03:55:40

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

mauvaise commande j'ai faite j'imagine

 sudo ifconfig eth0 192.168.4.169



Je vais redésactivez temporairement en attendant une aide 

sudo ifconfig eth0 down


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#11 02-05-2015 04:02:39

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Mon fichier /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback


 



Dossier /etc/network/interfaces.d/* est vide !


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#12 02-05-2015 06:46:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : (Résolu) Probleme avec 2 carte reseau

Sans networkmanager, mon fichier /etc/network/interfaces :


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface (c'est la connexion interne du pc)
auto lo
iface lo inet loopback

# The primary network interface (ma connexion internet filaire - câble RJ45)
# auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

# The secondary network interface static (c'est le reseau filaire privé local à mes pc)
# auto eth1
allow-hotplug eth1
iface eth1 inet static
address 192.168.x.x
broadcast 192.168.x.255
netmask 255.255.255.0

#wifi-0 Le wifi (chez moi sans pass)
#auto wlan0=wifi-maison
#iface wifi-maison inet dhcp
#  wireless-mode managed
#  wireless-essid xxxxxxx (nom de la box
#  wireless-key off

# wifi-elgg Le wifi (chez un client qui me donne un accès privilégié)
# auto wlan0=wifi-elgg
# iface wifi-elgg inet dhcp
# wireless-mode managed
# wpa-ssid xxxxxxxx (nom de la box)
# wpa-psk xxxxxxxx (pass de la box)

# wifi-sfr (wifi avec mon portable pour modem)
#auto wlan0=wifi-sfr
#iface wifi-sfr inet dhcp
#wireless-mode managed
#wpa-ssid xxxxxxxxxx (nom du modem)
#wpa-psk xxxxxxxxx (pass du modem)
 


Si tu supprimes networkmanager, il te faut configurer manuellement les interfaces de tes cartes dans le fichier interfaces en l'adaptant à ta situation.

Tu peux lire l'attribution des connexion de tes cartes réseaux ici :

cat /etc/udev/rules.d/70-persistent-net.rules


Le modifier avec root si tu en as le besoin.


Pour modifier le fichier interfaces, tu stoppes le service network :

service networking stop


Tu rédiges ou, si tu as déjà rédigé, tu décommentes pour activer une des configurations et tu relances le service network :

service networking start



Les wifi s'attribuent tout seuls

Sans redémarrage du pc, il te faut relancer chaque connexion filaire que tu veux utiliser avec la commande ifup :

ifup eth0


ifup eth1



Sinon, avec networkmanager, tu gardes le fichier comme il est et surtout tu t'occupes de rien dans le fichier interfaces. smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 02-05-2015 13:37:02

raleur
Membre
Inscription : 03-10-2014

Re : (Résolu) Probleme avec 2 carte reseau

La configuration de ton réseau n'est pas très claire.
- A quoi l'interface eth0 est-elle connectée ?
- Tu écris que le pont wifi a pour adresse 192.168.4.1 mais plus bas on lit "Local IP Address: 192.168.1.2". Qu'en est-il exactement ?
- Pourquoi ne configures-tu pas sur le pont wifi une adresse IP dans le sous-réseau 192.168.2.0/24 du routeur principal (mais en dehors de sa plage DHCP) ?
- Il ne faut définir qu'une seule passerelle par défaut sur ton PC. Ici elle est configurée en DHCP par le routeur principal, il ne faut pas en configurer une autre sur une autre interface. Pas besoin de passerelle pour atteindre une machine connectée directement au même réseau local.

Hors ligne

#14 05-05-2015 02:28:36

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

smolski a écrit :

Sans networkmanager, mon fichier /etc/network/interfaces :


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface (c'est la connexion interne du pc)
auto lo
iface lo inet loopback

# The primary network interface (ma connexion internet filaire - câble RJ45)
# auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

# The secondary network interface static (c'est le reseau filaire privé local à mes pc)
# auto eth1
allow-hotplug eth1
iface eth1 inet static
address 192.168.x.x
broadcast 192.168.x.255
netmask 255.255.255.0

#wifi-0 Le wifi (chez moi sans pass)
#auto wlan0=wifi-maison
#iface wifi-maison inet dhcp
#  wireless-mode managed
#  wireless-essid xxxxxxx (nom de la box
#  wireless-key off

# wifi-elgg Le wifi (chez un client qui me donne un accès privilégié)
# auto wlan0=wifi-elgg
# iface wifi-elgg inet dhcp
# wireless-mode managed
# wpa-ssid xxxxxxxx (nom de la box)
# wpa-psk xxxxxxxx (pass de la box)

# wifi-sfr (wifi avec mon portable pour modem)
#auto wlan0=wifi-sfr
#iface wifi-sfr inet dhcp
#wireless-mode managed
#wpa-ssid xxxxxxxxxx (nom du modem)
#wpa-psk xxxxxxxxx (pass du modem)
 


Si tu supprimes networkmanager, il te faut configurer manuellement les interfaces de tes cartes dans le fichier interfaces en l'adaptant à ta situation.

Tu peux lire l'attribution des connexion de tes cartes réseaux ici :

cat /etc/udev/rules.d/70-persistent-net.rules


Le modifier avec root si tu en as le besoin.


Pour modifier le fichier interfaces, tu stoppes le service network :

service networking stop


Tu rédiges ou, si tu as déjà rédigé, tu décommentes pour activer une des configurations et tu relances le service network :

service networking start



Les wifi s'attribuent tout seuls

Sans redémarrage du pc, il te faut relancer chaque connexion filaire que tu veux utiliser avec la commande ifup :

ifup eth0


ifup eth1



Sinon, avec networkmanager, tu gardes le fichier comme il est et surtout tu t'occupes de rien dans le fichier interfaces. smile



Merci de vos réponse, j'ai testé pis c'est pire soit je suis trop nul....
Mon fichier /etc/network/interfaces (testé. enlevé) :


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

allow-hotplug eth1
iface eth1 inet dhcp

# auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.4.1
broadcast 192.168.4.255
netmask 255.255.255.0
 


La tout merde ..
Je n'ai pas de wifi sur ma box P4 Debian
J’utilise l'applet networkmanager mais ca merde ma connection chaque fois
Voici un plan dessinée de ma main ... Il est aussi laid que la configuration de ma  box tongue

planwifi.jpg
D’ailleurs je ne peux avoir accès a DDWRT 192.168.3.1 Anyway cé pas la question .. big_smile Un prochain Post big_smile tongue

raleur a écrit :

La configuration de ton réseau n'est pas très claire.
- A quoi l'interface eth0 est-elle connectée ?
- Tu écris que le pont wifi a pour adresse 192.168.4.1 mais plus bas on lit "Local IP Address: 192.168.1.2". Qu'en est-il exactement ?
- Pourquoi ne configures-tu pas sur le pont wifi une adresse IP dans le sous-réseau 192.168.2.0/24 du routeur principal (mais en dehors de sa plage DHCP) ?
- Il ne faut définir qu'une seule passerelle par défaut sur ton PC. Ici elle est configurée en DHCP par le routeur principal, il ne faut pas en configurer une autre sur une autre interface. Pas besoin de passerelle pour atteindre une machine connectée directement au même réseau local.



- Le plan peut t'éclairé. Eth0 est intégré  donc je m'en sers comme eth virtuel !
-

 WAN Connection Type : Disabled
    Local IP Address: 192.168.1.2 (i.e. different from primary router and out of primary router's DHCP pool)

Effectivement j'ai pas suivi exactement ce tuto mais il lui ressemble en quelque point.

-Je veux avoir accès a l'appareil via une page web en tout temps pour cette raison j’ai configurez ainsi .. Je ne sait pas comment faire pour (mais en dehors de sa plage DHCP)

-IL n'ya  que bell SERVEUR DHCP

Merci de votre aide.

Dernière modification par Ir0nsh007er (05-05-2015 03:47:14)


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#15 05-05-2015 02:53:38

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Capture_d_cran_2015_05_04_21_01_46.png

Capture_d_cran_2015_05_04_21_40_43.png

Reserved for screenshot
How to screenshot debian?

xfce4-screenshooter -f
and if the command works, then you can add that to the keyboard shortcuts. Go to Setting Manager -> Keyboard -> Application Shortcuts and add the command. You can bind the command to any key that you want.

Go to Setting Manager -> Keyboard -> Application Shortcuts and add the command. You can bind the command to any key that you want.

Thx, I've add and it works well now.

Dernière modification par Ir0nsh007er (05-05-2015 03:43:06)


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#16 05-05-2015 03:48:49

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : (Résolu) Probleme avec 2 carte reseau

Salut Ir0nsh007er,

Pour faire des images d'écran partielles, tu as scrot :
http://debian-facile.org/doc:media:scrot smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#17 05-05-2015 05:58:59

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Je pense qu'il y a un problème de masque sous-réseau.
Quel est le masque sous-réseau de ta passerelle ? (192.168.2.1)

Un masque 255.255.255.0 signifie que ton réseau a 256 adresses IP (de 192.168.2.0 ->adresse réservée du réseau à 192.168.2.255 -> adresse réservée du broadcast).

Tu mets justement un masque 255.255.255.0 branché sur ton pont 192.168.4.1 avec une adresse dans la plage précédente.
Il est donc normal que ton pont ne soit pas reconnnu.

Le problème n'est peut-être pas tel quel mais m'est avis que ça vient de là.

Il faudrait le schéma que tu a fait mais avec les masques sous-réseau pour éclairer tout ça.

Une solution (plus simple?) serait de changer l'adresse du pont pour l'intégrer à la plage.
192.168.2.250 par exemple.

Dernière modification par Papadakis (05-05-2015 06:07:31)


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#18 05-05-2015 16:42:34

raleur
Membre
Inscription : 03-10-2014

Re : (Résolu) Probleme avec 2 carte reseau

Ir0nsh007er a écrit :

Effectivement j'ai pas suivi exactement ce tuto mais il lui ressemble en quelque point.


Ah, tu aurais pu préciser que c'était un "tuto" et non la configuration exacte du WRT.

Tu pourrais faire des bidouilles toutes plus sales les unes que les autres sur le PC, que ce soit avec Network Manager ou le fichier interfaces, pour communiquer avec les WRT ayant des adresses dans d'autres sous-réseaux. Mais la seule vraie solution propre, c'est de configurer les WRT avec des adresses dans le même sous-réseau que les autres machines (PC, routeur Bell). Hors de la plage DHCP du routeur Bell afin d'éviter un conflit d'adresse avec une machine à qui le routeur aurait attribué la même adresse. Tu peux voir la plage DHCP dans la configuration LAN du routeur Bell. A priori les adresses DHCP ont l'air d'être plutôt à la fin du sous-réseau, donc les adresse du début après celle du routeur Bell (192.168.2.2, 192.168.2.3...) devraient être disponibles.

En tout cas configurer une interface pour communiquer avec un appareil qui n'est pas connecté à cette interface est une aberration.

Hors ligne

#19 05-05-2015 22:41:03

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Merci Smolski pour les explications de scrot big_smile


Papadakis a écrit :

Je pense qu'il y a un problème de masque sous-réseau.
Quel est le masque sous-réseau de ta passerelle ? (192.168.2.1)

Un masque 255.255.255.0 signifie que ton réseau a 256 adresses IP (de 192.168.2.0 ->adresse réservée du réseau à 192.168.2.255 -> adresse réservée du broadcast).

Tu mets justement un masque 255.255.255.0 branché sur ton pont 192.168.4.1 avec une adresse dans la plage précédente.
Il est donc normal que ton pont ne soit pas reconnnu.

Le problème n'est peut-être pas tel quel mais m'est avis que ça vient de là.

Il faudrait le schéma que tu a fait mais avec les masques sous-réseau pour éclairer tout ça.

Une solution (plus simple?) serait de changer l'adresse du pont pour l'intégrer à la plage.
192.168.2.250 par exemple.



Merci de ton aide pour répondre a ta question oui ils ont tous 255.255.255.0 comme adresse.
Raleur: si je donne une add 192.168.2.x je n'ai pas accès a la page admin du router ! Il devient transparent ..il étais comme ça avant !


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#20 06-05-2015 00:07:53

raleur
Membre
Inscription : 03-10-2014

Re : (Résolu) Probleme avec 2 carte reseau

Comment ça, il devient transparent ? Il l'est déjà, c'est un pont ethernet-wifi. Je ne vois pas ce qu'une adresse IP différente peut y changer. Le fait qu'un pont soit transparent n'a jamais empêché d'y accéder via son adresse IP, quelle qu'elle soit.

Hors ligne

#21 06-05-2015 16:49:26

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

Comment ça t'as pas accès à la page admin du routeur ?
Tu y vas comment sur la page admin ?

Si ton adresse routeur est 192.168.4.1, mets ça dans /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

allow-hotplug eth1
iface eth1 inet dhcp

# auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.4.5
broadcast 192.168.4.255
netmask 255.255.255.0



192.168.4.5 (ou autre chose que 5, une IP dispo) et pas 192.168.4.1 (j'avais pas vu que t'avais fait ça) puisque c'est l'adresse du routeur, là tu configures ta carte eth0


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#22 06-05-2015 21:13:03

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Probleme avec 2 carte reseau

YAHOO ! MERCI A TOUS

Papadakis a écrit :

Comment ça t'as pas accès à la page admin du routeur ?
Tu y vas comment sur la page admin ?

Si ton adresse routeur est 192.168.4.1, mets ça dans /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

allow-hotplug eth1
iface eth1 inet dhcp

# auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.4.5
broadcast 192.168.4.255
netmask 255.255.255.0



192.168.4.5 (ou autre chose que 5, une IP dispo) et pas 192.168.4.1 (j'avais pas vu que t'avais fait ça) puisque c'est l'adresse du routeur, là tu configures ta carte eth0



raleur : Transparent (inaccessible)du a ma mauvaise config .. Mais la tout semble résolu.
Merci !! Problème réglé du a mauvaise adresses ip que j’avais mal configurez dans mon fichier interfaces

# auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.4.5


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

Pied de page des forums