Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-05-2015 10:05:05

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[abandon] owncloud et pam_mount

Bonjour,


le chiffrement d'un répertoire à synchroniser avec owncloud-client peut se faire avec "encfs".
j'essaye d'automatiser le montage/démontage, à l'ouverture de session, avec "pam_mount", en suivant les indications d'ici :

http://doc.ubuntu-fr.org/encfs


j'ai donc modifié le fichier de configuration pour inclure la ligne sur le volume :

cat /etc/security/pam_mount.conf.xml




<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE pam_mount SYSTEM "pam_mount.conf.xml.dtd">
<!--
  See pam_mount.conf(5) for a description.
-->

<pam_mount>

    <!-- debug should come before everything else,
    since this file is still processed in a single pass
    from top-to-bottom -->

<debug enable="0" />

    <!-- Volume definitions -->

<volume user="jlg" fstype="fuse" path="encfs#/home/jlg/owncloud/zaclys_f/" mountpoint="/home/jlg/zaclys_o/">

    <!-- pam_mount parameters: General tunables -->

<!--
<luserconf name=".pam_mount.conf.xml" />
-->

<!-- Note that commenting out mntoptions will give you the defaults.
     You will need to explicitly initialize it with the empty string
     to reset the defaults to nothing. -->
<mntoptions allow="nosuid,nodev,loop,encryption,fsck,nonempty,allow_root,allow_other" />
<!--
<mntoptions deny="suid,dev" />
<mntoptions allow="*" />
<mntoptions deny="*" />
-->
<mntoptions require="nosuid,nodev" />

<logout wait="0" hup="0" term="0" kill="0" />


    <!-- pam_mount parameters: Volume-related -->


<mkmountpoint enable="1" remove="true" />


</pam_mount>




après le redémarrage, le lancement d'un terminal en root donne :

su -


/etc/security/pam_mount.conf.xml:45: parser error : Opening and ending tag mismatch: volume line 17 and pam_mount
</pam_mount>
            ^
/etc/security/pam_mount.conf.xml:46: parser error : Premature end of data in tag pam_mount line 7

^
(rdconf1.c:387): libxml detected a syntax error in /etc/security/pam_mount.conf.xml
/etc/security/pam_mount.conf.xml:45: parser error : Opening and ending tag mismatch: volume line 17 and pam_mount
</pam_mount>
            ^
/etc/security/pam_mount.conf.xml:46: parser error : Premature end of data in tag pam_mount line 7

^
(rdconf1.c:387): libxml detected a syntax error in /etc/security/pam_mount.conf.xml
 




Opening and ending tag mismatch: volume line 17


la ligne 17 est celle ajoutée :

<volume user="jlg" fstype="fuse" path="encfs#/home/jlg/owncloud/zaclys_f/" mountpoint="/home/jlg/zaclys_o/">



je ne vois pas ce qui déplaît.


Premature end of data in tag pam_mount line 7


la ligne 7 était déjà là :

<pam_mount>




je ne vois pas plus.


à moins que ce ne soit le décalage de début de ligne (tabulation) ?
faudrait-il aligner sur

<!-- Volume definitions -->

?



merci d'avance.
cordialement.
debianux

Dernière modification par debianux (14-05-2015 19:13:16)

Hors ligne

#2 10-05-2015 10:12:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [abandon] owncloud et pam_mount

Bonjour,


d'après

<volume user="<<utilisateur>>" fstype="fuse" path="encfs#/home/<<utilisateur>>/.Encrypted" mountpoint="/home/<<utilisateur>>/Encrypted" />


essaye :

<volume user="jlg" fstype="fuse" path="encfs#/home/jlg/owncloud/zaclys_f/" mountpoint="/home/jlg/zaclys_o" />

mais sans garantie, hein.  hmm


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 10-05-2015 10:26:54

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

tout simplement : élégance et simplicité : merci paskal !

et regarde comme c'est beau, un montage automatique smile

cat /proc/mounts


fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
encfs /home/jlg/zaclys_o fuse.encfs rw,nosuid,nodev,relatime,user_id=1027,group_id=1001,default_permissions 0 0
 



ps: le décalage ou l'alignement n'a pas d'influence dans ce cas.

Dernière modification par debianux (10-05-2015 19:38:03)

Hors ligne

#4 10-05-2015 10:52:31

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [abandon] owncloud et pam_mount

de rien  smile

debianux a écrit :

et regarde comme c'est beau, un montage automatique smile

cool


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 10-05-2015 10:53:27

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

une autre question :
http://doc.ubuntu-fr.org/davfs2#astucen … vie_privee

Renforcer la sécurité du chiffrement


Utilisez une fonction non-documentée (!) de encfs, pour lui indiquer où se trouve désormais ce fichier. Le montage se fait alors ainsi




ENCFS6_CONFIG=/home/$USER/Secret/.encfs6.xml encfs /home/$USER/Box.net/Crypt /home/$USER/En_Clair





je n'ai pas compris comment on entre ces valeurs : on saisit ça directement dans un terminal ?

Hors ligne

#6 10-05-2015 11:13:02

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [abandon] owncloud et pam_mount

debianux a écrit :

je n'ai pas compris comment on entre ces valeurs : on saisit ça directement dans un terminal ?

Plus probablement dans le fichier de configuration de encfs.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#7 10-05-2015 12:05:01

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

je vais essayer de m'inspirer de :
https://wiki.archlinux.org/index.php/EncFS

Backup encrypted directory


mv ~/.name/encfs6.xml ~/.
ENCFS6_CONFIG=~/encfs6.xml encfs ~/.name /name

Hors ligne

#8 10-05-2015 12:42:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [abandon] owncloud et pam_mount

Ok, une directive en terminal, finalement.  smile
Merci pour le lien.  cool

edit: j'ai modifié ton message pour que ce soit en code et non en citation.  wink

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 10-05-2015 17:11:39

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

ok
interpellation smile
quand je cherche le "encfs6.xml" dans thunar, après un démontage

fusermount -u /home/jlg/zaclys_o

: y-est :
1431269735.png

quand je le cherche via le terminal : y-est-plus sad
~/owncloud/zaclys_f :

$ find . -iname "encfs6.xml"

zéro réponse

~/owncloud/zaclys_f

 ls
c0t3HiuYVoDy,CDtWyX8x1TkzzdFzMz6NCXL4-595tnmxG6s6QgsT25VwBYvCZsjB-Pg-5iHcGvQnmHvodmubedg
g1,jW1s16lljHkTpylFqqT-vej-UTQGHWoJbUVPe7HPdYPvW1rCMoK0lU1-yFHc9T1RAkaPfGDugqctiINM-NIWY
Sm5IJjPX3EXyBvu2tc5foXeNu3UjZFyAUVAZd1tIdgVts,
 



a-y-est : faut faire :
~/owncloud/zaclys_f

ls -a
.
..
c0t3HiuYVoDy,CDtWyX8x1TkzzdFzMz6NCXL4-595tnmxG6s6QgsT25VwBYvCZsjB-Pg-5iHcGvQnmHvodmubedg
.encfs6.xml
g1,jW1s16lljHkTpylFqqT-vej-UTQGHWoJbUVPe7HPdYPvW1rCMoK0lU1-yFHc9T1RAkaPfGDugqctiINM-NIWY
Sm5IJjPX3EXyBvu2tc5foXeNu3UjZFyAUVAZd1tIdgVts,
 



bon, là je raisonne à voix haute (j'espère que je ne dérange pas...), en temps réel (je sais, c'est très lent) smile

Hors ligne

#10 10-05-2015 17:22:39

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

donc reprise :
~

mv ~/owncloud/zaclys_f/.encfs6.xml  ~/.



suivi de "l'aventure" :

~$ ENCFS6_CONFIG=~/encfs6.xml encfs ~/owncloud/zaclys_f ~/zaclys_o
17:18:43 (FileUtils.cpp:360) Trouvé le fichier de configuration /home/jlg/encfs6.xml, mais chargement impossible
Création du nouveau volume encrypté.
Veuillez choisir l'une des options suivantes :
 entrez "x" pour le mode de configuration expert,
 entrez "p" pour le mode paranoïaque préconfiguré,
 toute autre entrée ou une ligne vide sélectionnera le mode normal.
?> p

Configuration paranoïaque sélectionnée.

Configuration terminée. Le système de fichier à créer a les propriétés suivantes :
Cryptage du système de fichiers : "ssl/aes" version 3:0:2
Encodage de fichier "nameio/block", version 3:0:1
Taille de clé : 256 bits
Taille de bloc : 1024 octets, y compris 8 octets d'
en-tête MAC.
Chaque fichier contient un en-tête de 8 octets avec des données IV uniques.
Noms de fichier encodés à l'aide du mode de chaînage IV.
Les données IV du fichier sont chaînées à celles du nom de fichier
File holes passed through to ciphertext.

-------------------------- AVERTISSEMENT --------------------------
Le vecteur d'
initialisation externe a été activé.
Cette option n'autorise pas l'usage de liens durs dans le système de fichiers.
Sans liens durs, quelques programmes peuvent ne pas fonctionner.
Les programmes «mutt» et «procmail» sont connus pour échouer.
Pour plus d'information, reportez-vous à la liste de discussion d'encfs.
Pour choisir une autre configuration, pressez CTRL-C et recommencez.

Vous devez entrer un mot de passe pour votre système de fichiers.
Vous devez vous en souvenir, car il n'existe aucun mécanisme de récupération.
Toutefois, le mot de passe peut être changé plus tard à l'
aide d'encfsctl.

Nouveau mot de passe :
Vérifier le mot de passe :



que va-t-il se passer ensuite ?
je n'en sais rien... smile
"et je recroise les doigts" smile

Hors ligne

#11 10-05-2015 19:36:41

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

bon, au redémarrage, ça monte comme prévu, pas de question sur "encfs6.xml" smile
on continue le jeu smile
création d'une copie de sécurité chiffrée :

cp ~/.encfs6.xml  /tmp



chiffrage :

ccrypt -e .encfs6.xml



mise dans un "abri" :

mv .encfs6.xml.cpt  /media/ds411/coffre/



si on a besoin de déchiffrer :

ccrypt -d .encfs6.xml.cpt

Hors ligne

#12 11-05-2015 10:09:39

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

Bonjour,

quelques perturbations ce matin... le montage ne s'est pas fait sad

essai en manuel "simple" (sans option "-o nonempty") :

encfs /home/jlg/owncloud/zaclys_f/ /home/jlg/zaclys_o/


Le répertoire "/home/jlg/zaclys_o/" n'existe pas. Faut-il le créer ? (y/n)



pour l'instant je ne vois pas comment et pourquoi "zaclys_o" a disparu.

depuis ~/owncloud/zaclys_f

ls -a


c0t3HiuYVoDy,CDtWyX8x1TkzzdFzMz6NCXL4-595tnmxG6s6QgsT25VwBYvCZsjB-Pg-5iHcGvQnmHvodmubedg
.encfs6.xml
g1,jW1s16lljHkTpylFqqT-vej-UTQGHWoJbUVPe7HPdYPvW1rCMoK0lU1-yFHc9T1RAkaPfGDugqctiINM-NIWY
Sm5IJjPX3EXyBvu2tc5foXeNu3UjZFyAUVAZd1tIdgVts,



les trois fichiers chiffrés sont toujours là, mais ".encfs6.xml" aussi alors que je pensais l'avoir déplacé. il date du

1076 mai   10 17:25 .encfs6.xml

et n'a donc pas été créé ce matin, à l'ouverture.

Hors ligne

#13 11-05-2015 10:40:59

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

bon, déjà repéré un truc raté au #10

ENCFS6_CONFIG=~/encfs6.xml encfs ~/owncloud/zaclys_f ~/zaclys_o



qui aurait dû comporter un point devant encfs6... (c'est pénible : tu regardes, plusieurs fois en plus, "enter", avec le sentiment du devoir accompli ; "l'autre" - "celui" qui est censé exécuter - "dort" aussi et ne te dit rien de plus que t'arriverais à comprendre, et paf, sortie de route pour somnolence...) smile

ENCFS6_CONFIG=~/.encfs6.xml encfs ~/owncloud/zaclys_f ~/zaclys_o



maintenant que le pare-choc est un peu redressé, j'espère qu'on va pouvoir rouler un peu... smile

Hors ligne

#14 11-05-2015 11:00:33

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

ici :
https://wiki.archlinux.org/index.php/Pam_mount

je lis:

<volume user="USERNAME" fstype="auto" path="/dev/sdaX" mountpoint="/home" options="fsck,noatime" />




original :

<volume user="jlg" fstype="fuse" path="encfs#/home/jlg/owncloud/zaclys_f/" mountpoint="/home/jlg/zaclys_o" />



avec l'option :

<volume user="jlg" fstype="fuse" path="encfs#/home/jlg/owncloud/zaclys_f/" mountpoint="/home/jlg/zaclys_o" options="nonempty" />

Hors ligne

#15 11-05-2015 11:41:14

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

re-démarrage, le montage se fait smile

indication de là où ce que se trouve ".encfs6.xml" :

ENCFS6_CONFIG=~/.encfs6.xml encfs ~/owncloud/zaclys_f ~/zaclys_o


Mot de passe :
fusermount: failed to access mountpoint /home/jlg/zaclys_o: Permission denied
Erreur de fuse. Problèmes courants :
 - module noyau fuse non installé (faites "modprobe fuse")
 - options invalides -- voir le message d'utilisation
 



pourtant il appartient au même user :

ls -al | grep za*


drwxr-xr-x   2 jlg  jlg       4096 mai   11 11:21 zaclys_o




qui appartient au groupe fuse :

groups


jlg dialout audio fuse vboxusers



sad

Hors ligne

#16 11-05-2015 16:50:13

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

remise à zéro et 'recommençage' : idem


j'essaye en root à partir du home:

ENCFS6_CONFIG=/home/jlg/coffre/.encfs6.xml encfs /home/jlg/owncloud/zaclys_f/ /home/jlg/zaclys_o/


Le répertoire "/home/jlg/zaclys_o/" n'existe pas. Faut-il le créer ? (y/n) n
Répertoire non créé.
16:38:32 (main.cpp:422) Impossible de trouver le point de montage, abandon.
Build : encfs version 1.7.4

Utilisation :  encfs [options] repRacine pointDeMontage [--[Options de montage FUSE]]

Options communes :
  -H\t\t\tafficher les options de montage FUSE
  -s\t\t\tdésactiver le fonctionnement multithreadé
  -f\t\t\tfonctionner devant (ne pas lancer de démon)
\t\t\tLes messages d'erreur sont envoyés sur stderr
\t\t\tau lieu du log système (syslog).
  -v, --verbose\t\tmode verbeux : afficher les messages de déboguage
  -i, --idle=MINUTES\tDémonter automatiquement après une période d'inactivité
  --anykey\t\tNe pas vérifier que la bonne clé est utilisée
  --forcedecode\t\tDécoder les données même si une erreur est détectée
\t\t\t(pour les systèmes de fichier utilisant des en-têtes de blocs MAC)
  --public    agit comme un système de fichiers multi-utilisateurs classique
      (encfs doit être lancé en root)
  --reverse    chiffrement inversé
  --extpass=programme\tUtiliser un programme externe pour la demande de mot de passe

Par exemple, pour monter sur ~/crypt, avec le stockage brut dans ~/.crypt :
    encfs ~/.crypt ~/crypt

Pour plus d'information, voir la page de manuel d'encfs(1)




je vérifie l'accès

cd /home/jlg/zaclys_o


-su: cd: /home/jlg/zaclys_o: Permission non accordée




je vérifie en user sur un autre onglet de terminal :
depuis ~/zaclys_o

ls -al


total 16
drwxr-xr-x   2 jlg jlg  4096 mai   11 16:00 .
drwxr-xr-x 133 jlg jlg 12288 mai   11 15:13 ..
 




comment peut-il se faire que le root n'ait pas la permission d'accès ?

Hors ligne

#17 11-05-2015 17:14:24

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

nouveau démarrage, après avoir copié un fichier dans "zaclys_o", qui est bien présent, chiffré, dans "zaclys_f", redémarrage, pour voir smile
devinez quoi : "zaclys_o" a (encore) disparu...

y aurait un truc pas net dans le "pam_mount" ?

Hors ligne

#18 12-05-2015 12:40:49

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

Bonjour,

une piste (enfin) : dans pam_mount.conf.xml :

<mkmountpoint enable="1" remove="true" />


ici:
http://manpages.ubuntu.com/manpages/kar … onf.5.html

Volume-related
       <mkmountpoint enable="1" remove="true" />
              Controls automatic creation and removal  of  mountpoints.  If  a
              mountpoint  does  not  exist  when  the  volume  is  about to be
              mounted, pam_mount can be instructed to  create  one  using  the
              enable  attribute.  Normally,  directories  created this way are
              retained after logout, but remove may be set to true  to  remove
              the  mountpoint  again, but only if it was automatically created
              by pam_mount in the same session before.



je vais essayer de remplacer "true" par "false"

Hors ligne

#19 12-05-2015 18:21:18

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

alors effectivement la modif empêche la suppression du répertoire à la fermeture smile

mais après avoir tout refait, ça re-coince à l'étape du ENCFS6_CONFIG du post #15 sad

une idée ? smile

Hors ligne

#20 12-05-2015 19:43:13

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

dans pam_mount.conf, j'ai mis le debug à 1 et je suppose que c'est la raison pour laquelle, lorsque j'ouvre un terminal en root :

su -


Password:
(pam_mount.c:365): pam_mount 2.13: entering auth stage
(pam_mount.c:554): pam_mount 2.13: entering session stage
(misc.c:39): Session open: (ruid/rgid=1027/0, e=0/0)
(pam_mount.c:615): no volumes to mount
command: 'pmvarrun' '-u' 'root' '-o' '1'
(misc.c:39): set_myuid<pre>: (ruid/rgid=1027/0, e=0/0)
(misc.c:39): set_myuid<post>: (ruid/rgid=0/0, e=0/0)
(pmvarrun.c:258): parsed count value 1
(pam_mount.c:441): pmvarrun says login count is 2
(pam_mount.c:646): done opening session (ret=0)



et quand je le referme :

exit



déconnexion
(pam_mount.c:692): received order to close things
(pam_mount.c:694): No volumes to umount
command: 'pmvarrun' '-u' 'root' '-o' '-1'
(misc.c:39): set_myuid<pre>: (ruid/rgid=1027/0, e=0/0)
(misc.c:39): set_myuid<post>: (ruid/rgid=0/0, e=0/0)
(pmvarrun.c:258): parsed count value 2
(pam_mount.c:441): pmvarrun says login count is 1
(pam_mount.c:721): root seems to have other remaining open sessions
(pam_mount.c:729): pam_mount execution complete
(pam_mount.c:116): Clean global config (0)
(pam_mount.c:133): clean system authtok=0x17e8c20 (0)
 



mais heureusement, les "zac" sont toujours montés :

fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
encfs /home/jlg/zaclys_o fuse.encfs rw,nosuid,nodev,relatime,user_id=1027,group_id=1001,default_permissions 0 0



j'ignore s'il y a une piste à en tirer...

Hors ligne

#21 14-05-2015 19:14:13

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [abandon] owncloud et pam_mount

il faut se rendre à l'évidence, la côte est trop difficile pour moi. abandon par ko...

Hors ligne

Pied de page des forums