Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-05-2015 07:15:08

epokz
Membre
Inscription : 11-04-2015

Complilation APACHE + PHP

Bonjour A tous

Je cherche un reproduire un serveur web afin de migrer un site web dans l’état (apache 2.2.3 / php 5.1.5) je ne peux pas passer par apt-install (si vous avez un moyen je suis preneur) donc il faut que je compile a la main si j'ai bien compris .... smile(autant vous le dire de suite c'est la première fois que je fais ça et je suis un débutant sur debian)
J'ai donc suivi cette procédure :
http://php.net/manual/fr/install.unix.apache2.php

J'ai déjà eu un certain nombre de dépendance a installer a coté de cette procédure mais la je bloque sur ce message d'erreur:

checking for specified location of the MySQL UNIX socket... no
checking for MySQL UNIX socket location... /var/run/mysqld/mysqld.sock
configure: error: Cannot find libmysqlclient under /usr.
Note that the MySQL client library is not bundled anymore!
 



ce message ce produit lorsque je lance la commande au point numéro 5

cd ../php-NN
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql



Merci pour votre aide!

Hors ligne

#2 18-05-2015 12:05:28

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Complilation APACHE + PHP

Hello,

Euh, pourquoi ne peux-tu pas passer par apt-get ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 18-05-2015 14:22:12

epokz
Membre
Inscription : 11-04-2015

Re : Complilation APACHE + PHP

captnfab a écrit :

Hello,

Euh, pourquoi ne peux-tu pas passer par apt-get ?



Il va m'installer la dernière version de php??? moi il me faut la version php 5.1.5

Hors ligne

#4 18-05-2015 17:42:01

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Complilation APACHE + PHP

Mon conseil: utilise apt-get pour installer Apache2, PHP et MySQL. Les versions ne seront pas celles que tu attends, mais ça donnera les bases.
Ensuite, si tu as besoin d'une version spécifique de PHP, tu peux la compiler à part mais là aussi, ce n'est pas une méthode recommandée.

Pourquoi as-tu besoin de versions spécifiques (vieilles et probablement pleines de failles de sécurité) ? Ton code PHP ne fonctionne pas sur les versions plus récentes ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 18-05-2015 18:54:27

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Complilation APACHE + PHP

Entièrement d'accord avec cptnfab.
J'essaierai d'abord avec les dernières versions pour voir où ça bloque.

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#6 19-05-2015 06:41:39

epokz
Membre
Inscription : 11-04-2015

Re : Complilation APACHE + PHP

captnfab a écrit :

Mon conseil: utilise apt-get pour installer Apache2, PHP et MySQL. Les versions ne seront pas celles que tu attends, mais ça donnera les bases.
Ensuite, si tu as besoin d'une version spécifique de PHP, tu peux la compiler à part mais là aussi, ce n'est pas une méthode recommandée.

Pourquoi as-tu besoin de versions spécifiques (vieilles et probablement pleines de failles de sécurité) ? Ton code PHP ne fonctionne pas sur les versions plus récentes ?



Merci pour vos réponses!

Donc si j'installe Apache2, PHP et MySQL via apt-get, je pourrai installer la version de PHP 5.1.6? En supprimant la version récente ou bien en faisant cohabiter les deux versions?

Je sais bien que ce n'est pas recommandé mais je viens de récupérer un site OSCOMMENCE d'un hébergeur qui est en cessation d'activité (ou rien n'est a jour... )  et comme il est très compliqué de mettre a jour ce site (de la bricole de partout) j'essaie divers options... Car ce site doit être refait intégralement très prochainement...

Quand je restaure mon site avec des versions récentes il n'y a rien qui fonctionne ...

Encore merci pour votre aide!

Hors ligne

Pied de page des forums