Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-05-2015 08:15:06

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

(Résolu) Activer https dans apache pour owncloud

Voila j'ai installé owncloud via les dépôts. Trop facile l’installation, configuration ..rien a faire que remplir le formulaire..
Mais le petit problème mineure que je rencontre est ce message dans le module admin:

Avertissement de sécurité
Vous accédez à ownCloud via HTTP. Nous vous recommandons fortement de configurer votre serveur pour forcer l'utilisation de HTTPS à la place.



Pourtant j'ai webmin installez et qui fonctionne bien en https ..

J’ai crée une nouvelle clé:

openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/apache2/ssl/apache.key -out /etc/apache2/ssl/apache.crt


Ensuite je modifie le fichier (qui en passant n'existe pas):

pico /etc/apache2/sites-available/default

 <VirtualHost *:80>
        Redirect / https://localhost/
</VirtualHost>
 
<VirtualHost *:443>
        ServerAdmin webmaster@localhost
        ServerName xx.xx.xx.xx
 
        DocumentRoot /var/www/
SSLEngine on
        SSLCertificateFile /etc/apache2/ssl/apache.crt
        SSLCertificateKeyFile /etc/apache2/ssl/apache.key



a2ensite default

ERROR: Site default does not exist!



Alors j'utilise le default-ssl.conf

a2ensite default-ssl.conf

Site default-ssl already enabled


ls -lh /etc/apache2/mods-enabled/ssl*

lrwxrwxrwx 1 root root 26 mai 21 00:45 /etc/apache2/mods-enabled/ssl.conf -> ../mods-available/ssl.conf
lrwxrwxrwx 1 root root 26 mai 21 00:45 /etc/apache2/mods-enabled/ssl.load -> ../mods-available/ssl.load



Une indice pour m'enligner?

Dernière modification par Ir0nsh007er (21-05-2015 09:49:31)


Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

#2 21-05-2015 09:45:11

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : (Résolu) Activer https dans apache pour owncloud

Salut,
Si tu utilises Apache2.4 (Jessie), le fichier ne doit pas s'appeler
/etc/apache2/sites-available/default
mais
/etc/apache2/sites-available/default.conf

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 21-05-2015 09:49:00

Ir0nsh007er
Membre
Lieu : Montréal, PQ, Canada
Distrib. : Debian GNU/Linux 9.0 Stretch/Sid
Noyau : 4.7.0-1-amd64 #1 SMP Debian 4.7.5-1 (2016-09-26) x
(G)UI : Xfce 4.12.3
Inscription : 30-04-2015
Site Web

Re : (Résolu) Activer https dans apache pour owncloud

Ahh Merci

Moé avec mon P4: Intel(R) Pentium(R) 4 CPU 3.40GHz, Mémoire: 6G DDR2, Carte Graphique: NVIDIA Corp GT216 [GeForce GT 220] (rev a2)
Ir0nsh007er (49 72 30 6E 73 68 30 30 37 65 72).  Mon CV
Noob un jour, noob toujours cool
01001001 01110010 00110000 01101110 01110011 01101000 00110000 00110000 00110111 01100101 01110010

Hors ligne

Pied de page des forums