Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-05-2015 20:58:50

sardon
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 08-03-2011

[résolu] Certains sites sont tout moches

en naviguant sur allo-cine ou même sur github, je m'aperçois que le rendu du contenu est bcp plus moche que sous Gnome..

Pourtant la version de iceweasel est la même, les polices sont les mêmes.. La seul explication que je perçois c'est ce que fais le navigateur par défaut quand la police n'est pas connue, une idée ?

Dernière modification par sardon (25-05-2015 10:14:06)

Hors ligne

#2 23-05-2015 22:07:09

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [résolu] Certains sites sont tout moches

Salut

Deux possibilités selon moi. 1) Dans les paramètres de Iceweasel (Contenu), la case pour permettre aux pages web d'utiliser leurs propres polices est bien cochée ? 2) Le paquet ttf-mscorefonts-installer qui installe les polices Microsoft True Type pour le Web peut améliorer les choses.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 23-05-2015 22:22:45

sardon
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 08-03-2011

Re : [résolu] Certains sites sont tout moches

martinux_qc a écrit :


la case pour permettre aux pages web d'utiliser leurs propres polices est bien cochée ?



Oui

martinux_qc a écrit :


Le paquet ttf-mscorefonts-installer qui installe les polices Microsoft True Type pour le Web peut améliorer les choses.



déjà installé en effet

Hors ligne

#4 23-05-2015 22:39:44

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [résolu] Certains sites sont tout moches

c'est pas très explicite. Donne des exemples concrets ou à défaut fait des captures d'écran.

En ligne

#5 24-05-2015 11:02:39

sardon
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 08-03-2011

Re : [résolu] Certains sites sont tout moches

Voici une capture d'écran

allo-cine.png

réalisée après avoir supprimé le paquet ttf-mscorefonts-installer, vu que sur mon portable, chargé de la même config, l'affichage est meilleur sans ce paquet..

Dans tous les cas, après vidage du cache, cela n'a rien changé

Hors ligne

#6 24-05-2015 11:50:05

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Jessie 8.x & Backports
Noyau : Noyau Linux 3.16.0-4-686-pae
(G)UI : Xfce 4.10 & Mate 1.8.1
Inscription : 30-06-2008

Re : [résolu] Certains sites sont tout moches

salut,

ce n'est pas un problème de lissage de police?

à voir dans paramètres>apparence>polices>activer activer l'anti-crénelage

Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#7 24-05-2015 12:57:32

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [résolu] Certains sites sont tout moches

j'ai le même pb et pour moi c'est activé.

En ligne

#8 24-05-2015 13:06:53

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Jessie 8.x & Backports
Noyau : Noyau Linux 3.16.0-4-686-pae
(G)UI : Xfce 4.10 & Mate 1.8.1
Inscription : 30-06-2008

Re : [résolu] Certains sites sont tout moches

salut,

effectivement, j'ai pu comparer et je n'ai pas ce problème, iceweasel 38.0.1, pas de configuration spéciale pour celui-ci.

Bon courage

Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#9 24-05-2015 13:52:51

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [résolu] Certains sites sont tout moches

j'ai pas de pb avec chroumium.

je sais pas si sardon peut confirmer

En ligne

#10 24-05-2015 14:08:45

sardon
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 08-03-2011

Re : [résolu] Certains sites sont tout moches

mksmn a écrit :

salut,

ce n'est pas un problème de lissage de police?

à voir dans paramètres>apparence>polices>activer activer l'anti-crénelage



non non c'est pas ça et je confirme que pour la version de chromium des dépôts de Jessie, on a pas ce pb de police..

Je précise aussi que sur le portable, j'ai la version 31.7.0 d'installé, alors que c'est la 38.0 sur l'ordi de bureau.. Mais il me semble que j'ai essayé hier avec la version 38.0 avec un bureau Gnome et que je n'ai rien remarqué de spécial dans l'affichage des polices..

Hors ligne

#11 24-05-2015 22:26:02

sardon
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 08-03-2011

Re : [résolu] Certains sites sont tout moches

Je ne sais pas si nIQnutn confirmera, mais en examinant les éléments HTML interprétés par les navigateurs, je m'aperçois pour le site d'AlloCiné que :

Firefox fait le malin en se disant qu'il peut interpréter la police Lucida, bien qu'elle ne soit pas installé sur mon système

Chromium part sur Arial qui elle est installé

Quand on joue avec l'anti-crénelage de XFCE, je m'aperçois que cela n'a un effet que sur les polices installés sur le système..

Bref, pour ce site (et pour d'autres) Firefox semble mal interprété la liste du CSS :
Tahoma, Lucida, Arial, sans-serif

Tahoma et Lucida n'étant pas installé, il devrait utiliser Arial comme chromium, alors est-ce un bug, un problème de configuration ??

Hors ligne

#12 24-05-2015 22:51:00

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [résolu] Certains sites sont tout moches

Effectivement c'est bien ça.

Il suffit de désactiver dans le CSS pour retrouver une police avec un rendu normal.


J'ai essayé avec un nouveau profil et sans extensions et le pb persiste.

En ligne

#13 25-05-2015 10:13:43

sardon
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 08-03-2011

Re : [résolu] Certains sites sont tout moches

J'ai trouvé une solution en partie là : https://wiki.archlinux.org/index.php/Font_configuration

En fait Firefox ne fait que suivre une erreur de configuration du système :


$ fc-match Lucida
luRS12.pcf.gz: "Lucida" "Sans"



Certaines polices de caractères comme Helvetica, Lucida, n'étant pas définies sur le système, sont bizarrement substituées par des polices bitmap!

Une solution est de désactiver cette substitution (voir le wiki cité ci-dessus), sur mon système le lien existe déjà :


# ll /etc/fonts/conf.d/70-no-bitmaps.conf
lrwxrwxrwx 1 root root 40 mai   18  2013 /etc/fonts/conf.d/70-no-bitmaps.conf -> /etc/fonts/conf.avail/70-no-bitmaps.conf



Par contre le fichier /etc/fonts/conf.avail/70-no-bitmaps.conf est vide ? J'ai donc ajouté les lignes trouvés sur une distribution Wheezy (Gnome) :

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Reject bitmap fonts -->
 <selectfont>
  <rejectfont>
   <pattern>
     <patelt name="scalable"><bool>false</bool></patelt>
   </pattern>
  </rejectfont>
 </selectfont>
</fontconfig>



Code xml permettant de rejeter les polices bitmap ! Et là, ça marche mieux :


$ fc-match Lucida
DejaVuSans.ttf: "DejaVu Sans" "Book"



... en fait juste comme avant ma migration vers Jessie et mon passage sous XFCE..


Je ne sais pas quelle étape à endommage ce fichier, par contre, ce que je sais c'est que la situation est la même sur un portable qui a suivi les mêmes migrations, donc il y doit y avoir un léger bug qq part...

Dernière modification par sardon (25-05-2015 10:16:06)

Hors ligne

#14 25-05-2015 11:11:08

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [résolu] Certains sites sont tout moches

Cette solution marche bien.

Je n'avais pas de fchier /etc/fonts/conf.avail/70-no-bitmaps.conf
Je suis dans le même cas, pas de pb avant le passage à Jessie.

En ligne

Pied de page des forums