Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-06-2015 08:19:43

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

[Résolu] Serveur DNS local

Salut !

J'essaye de me configurer un serveur DNS local, principalement pour l'utiliser sur mon réseau qui commence à grossir.
J'ai suivi ce wiki sur une machine virtuelle pour voir comment ça marche et tout va bien.
J'aimerais le faire sur la machine qui autohéberge mon serveur web.
Le problème est que je ne sais pas trop comment gérer le hostname, le /etc/host et le db.mondomaine.fr, etc.
Voilà les erreurs que j'obtiens :

nslookup


>mondomaine.fr



;; Got SERVFAIL reply from 192.168.1.5, trying next server
Server:   80.67.169.40
Address:  80.67.169.40#53

Non-authoritative answer:
Name: mondomaine.fr
Address: 2.0.131.88



2.0.131.88 étant mon IP publique (même pas vrai) au lieu du 192.168.1.5 comme je devrais avoir d'après le tuto.

named-checkzone mondomaine.fr db.mondomaine.fr

zone mondomaine.fr/IN: NS 'mondomaine.fr' has no address records (A or AAAA)
zone mondomaine.fr/IN: not loaded due to errors.



comme hostname, j'ai

mondomaine


mon /etc/hosts :

127.0.0.1       localhost.localdomain   localhost
192.168.1.5   mondomaine.fr   mondomaine

# The following lines are desirable for IPv6 capable hosts
#::1     localhost ip6-localhost ip6-loopback
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters



Y'a un petit queqchose qui fait foirer ma config, c'est le fait que mon serveur DNS est aussi mon serveur apache.
Je peux changer le /etc/hosts et le hostname en dns.mondomaine.fr sans que ça impacte mon serveur apache ? (je suis en prod avec un owncloud partagé, évidemment).

Dernière modification par Papadakis (06-06-2015 11:57:34)


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#2 06-06-2015 08:25:22

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Serveur DNS local

Salut,

Tu peux poster ton fichier de zone ? (le db.mondomaine.fr)

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 06-06-2015 08:28:17

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Serveur DNS local

;
; BIND data file for local loopback interface
;
$TTL    604800
@       IN      SOA     mondomaine.fr. root.mondomaine.fr. (
                              2         ; Serial
                         604800         ; Refresh
                          86400         ; Retry
                        2419200         ; Expire
                         604800 )       ; Negative Cache TTL
;
@       IN      NS      mondomaine.fr.
mondomaine.fr      IN      A       192.168.1.5


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#4 06-06-2015 10:19:04

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Serveur DNS local

Sur la dernière ligne, tu peux essayer de remplacer mondomaine.fr par @

tu inclus bien ton fichier de zone depuis externalzones.conf ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 06-06-2015 11:57:06

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Serveur DNS local

captnfab a écrit :

Sur la dernière ligne, tu peux essayer de remplacer mondomaine.fr par @


YEAH !

named-checkzone mondomaine.fr db.mondomaine.fr



zone mondomaine.fr/IN: loaded serial 2
OK



ou

nslookup


> mondomaine.fr



Server:   192.168.1.5
Address:  192.168.1.5#53

Name: mondomaine.fr
Address: 192.168.1.5




mais

captnfab a écrit :

tu inclus bien ton fichier de zone depuis externalzones.conf ?



J'ignore totalement de quoi tu parles.
C'est pas dans le tuto ça !
J'ai pas de externalzones.conf, alors "depuis externalzones.conf", non vraiment je comprends pas ta phrase.
Pour rappel, c'est juste un serveur local pour gérer mes machines, et il ne me manquait que ça (@) comme info. Je passe en résolu.

Dernière modification par Papadakis (06-06-2015 12:01:24)


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#6 06-06-2015 14:48:12

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Serveur DNS local

Super smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 07-06-2015 00:54:36

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Serveur DNS local

captnfab a écrit :

Sur la dernière ligne, tu peux essayer de remplacer mondomaine.fr par @


En plus de donner un contournement, il aurait été utile d'indiquer la cause de l'erreur : l'absence d'un point à la fin de mondomaine.fr. Sans ce point final, tout nom de domaine dans un fichier de zone est considéré comme non qualifié et complété avec l'origine courante (la valeur de @), ici mondomaine.fr. Le nom de domaine complet résultant était donc mondomaine.fr.mondomaine.fr.

Hors ligne

#8 07-06-2015 01:16:13

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Serveur DNS local

Merci pour les précisions smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 07-06-2015 04:43:31

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Serveur DNS local

une alternative avec $origine  qui remplace @ , ce fichier de bind9 est mit a jour par dhcp , dans cet exemple les clients sont éteints wink


$ORIGIN .
$TTL 172800     ; 2 days
mondomaine.com       IN SOA  debian10.mondomaine.com. root.mondomaine.com. (
                                2014112191 ; serial
                                172800     ; refresh (2 days)
                                86400      ; retry (1 day)
                                345600     ; expire (4 days)
                                86400      ; minimum (1 day)
                                )
                        NS      debian10.mondomaine.com.
                        MX      1 debian10.mondomaine.com.
$ORIGIN mondomaine.com.
apt                     CNAME   debian10
debian1                 A       192.168.10.10
debian10                A       192.168.10.1
mail                    CNAME   debian10
ntp                     A       192.168.10.1
$TTL 3600       ; 1 hour
opteronSM               A       192.168.10.21
                        TXT     "31f9081ee82c093aeec913407f7d630d03"
$TTL 172800     ; 2 days
www                     A       192.168.10.10
 



tout ce qui est en dessous de $ORIGIN mondomain.com.  ne comprend que le nom de la machine .
exemple: debian1 A 192.168.10.10     => sous entend debian1.mondomaine.com
avec "@" c'est le meme principe
le tuto de D_F pour bind9 n'est pas le mieux pour un débutant , je te conseille de lire le wiki debian du site officiel pour bind9 , pour la sécurité et la configuration des .conf de bind9
si tu a dhcp installé et configuré sur le serveur il n y a rien a faire coté client.
pour le serveur il est préférable de désactivé tout ce qui est automatique , personnellement il est sans bureau (donc pas de network manager ou autre )
j'ai un post qui traine sur D_F pour bind9

coté reseau eth1 rien de spécial


auto eth1
iface eth1 inet static
address 192.168.10.1
network 192.168.10.0
netmask 255.255.255.0
 



le fichier hosts du serveur


127.0.0.1       localhost
127.0.1.1       debian10

192.168.10.1    debian10.mondomaine.com

# The following lines are desirable for IPv6 capable hosts
#::1     localhost ip6-localhost ip6-loopback
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters
 


le hostname


debian10
 



le resolv.conf


 nameserver 192.168.10.1
 nameserver 80.10.246.130
 search mondomaine.com
 



si tu n a pas de dhcp il te suffit de renseigner en dessous $ORIGIN (ou @ ) tous tes clients , ton serveur de temps , ton www ,ton serveur mail  etc ......
pour les fichiers de configuration de bind9 j'ai suivi le wiki officiel de debian (sauf le chroot pas encore assez bon wink  ) , aprés plusieurs tentative j'ai abandonné tongue pour l'instant.

le fichier named.conf


// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

acl internals { 127.0.0.0/8; 192.168.10.0/24; };
include "/etc/bind/ns-mondomaine-com_rndc-key";
include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
 


tu ignore la ligne 2 , c est pour la mise a jour par dhcp de bind9

le fichier named.conf.local


// Do any local configuration here


 include "/etc/bind/named.conf.log";


zone "mondomaine.com" {
        type master;
        file "/etc/bind/db.mondomaine.com";
        forwarders {};
        allow-update { key ns-mondomaine-com_rndc-key; };
};

zone "10.168.192.in-addr.arpa" {
        type master;
        file "/etc/bind/db.mondomaine.com.inv";
        forwarders {};
        allow-update { key ns-mondomaine-com_rndc-key; };
};


// Consider adding the 1918 zones here, if they are not used in your
// organization

 include "/etc/bind/zones.rfc1918";
 


ici aussi tu ignore le allow-update si tu n a pas dhcp avec mise a jour des clients

le fichier named.conf.options


 options {
         directory "/var/cache/bind";

        // If there is a firewall between you and nameservers you want
        // to talk to, you may need to fix the firewall to allow multiple
        // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

        // If your ISP provided one or more IP addresses for stable
        // nameservers, you probably want to use them as forwarders.
        // Uncomment the following block, and insert the addresses replacing
        // the all-0's placeholder.

        forward only;
        forwarders { 80.10.246.130; };

        //========================================================================
        // If BIND logs error messages about the root key being expired,
        // you will need to update your keys.  See https://www.isc.org/bind-keys
        //========================================================================
        dnssec-validation auto;
        //dnssec-enable no;
        //dnssec-validation no;
        //dnssec-lookaside auto;
        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { none; };
        listen-on { 127.0.0.1; 192.168.10.1; };
        allow-transfer { none; };
        allow-query { internals; };
        allow-recursion { internals; };
        version none;

};
 



ici dnssec-validation no;  pas de mise a jour de dhcp , mon forwarders c est le dns de mon FAI  (dans le cas ou bind9 n arrive pas a résoudre )

le fichier named.conf.log


logging {

 channel update_debug {

 file "/var/log/update_debug.log" versions 3 size 100k;

 severity debug;

 print-severity yes;

 print-time yes;

 };

 channel security_info {

 file "/var/log/security_info.log"  versions 1  size 100k;

 severity info;

 print-severity yes;

 print-time yes;

 };

 channel bind_log {

 file "/var/log/bind.log" versions 3 size 1m;

 severity info;

 print-category yes;

 print-severity yes;

 print-time yes;

 };

 category default { bind_log; };

 category lame-servers { null; };

 category update { update_debug; };

 category update-security { update_debug; };
 



tu aura des logs séparés dans /var/log

coté client pas grand chose a faire , si tu est en ip fixe  dans le resolv.conf tu met :


# Generated by NetworkManager
search mondomaine.com
nameserver 192.168.10.1  (l ip de ton serveur dns )
 


le fichier hosts coté client


127.0.0.1 localhost
192.168.10.10 debian1.mondomaine.com

# The following lines are desirable for IPv6 capable hosts
#::1     localhost ip6-localhost ip6-loopback
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters
 



pour le host.conf j'ai la valeur multi on (par défaut)

pour ipv6 , il n est pas géré par le dns , le dhcp , desactivé dans le noyau .

enfin voila si ça peut aider  smile

Dernière modification par robert2a (07-06-2015 06:02:45)

Hors ligne

#10 07-06-2015 07:05:23

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : [Résolu] Serveur DNS local

Merci pour toutes les précisions (raleur et robert2a).
Effectivement, ça peut aider.

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#11 07-06-2015 08:21:47

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Serveur DNS local

par contre j'ai une petite question , peut etre que raleur à la réponse .
sur une installation nouvelle , quelque soit l emplacement de la machine (dans un domaine ou sans domaine ) j'ai ceci dans mon hosts.


127.0.0.1       localhost
127.0.1.1       debianx  (nom de la machine)
 


dans un premier temps j'ai effacé la seconde ligne j'ai pensé a une erreur de ma part hmm

pour mon serveur la troisieme ligne c'est moi qui l ai crée avec le nom de domaine complettement qualifié , les 2 premieres c'est debian smile


127.0.0.1       localhost
127.0.1.1       debian10

192.168.10.1    debian10.mondomaine.com

# The following lines are desirable for IPv6 capable hosts
#::1     localhost ip6-localhost ip6-loopback
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters
 

Dernière modification par robert2a (07-06-2015 08:25:34)

Hors ligne

#12 07-06-2015 11:14:54

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Serveur DNS local

robert2a a écrit :

une alternative avec $origine  qui remplace @ , ce fichier de bind9


La réaction que m'inspire ce fichier, c'est "pourquoi faire simple quand on peut faire compliqué". Avec le domaine racine (".") pour origine, on peut se permettre de manquer de rigueur et d'oublier de mettre le point final, ce n'est pas un service à rendre.

robert2a a écrit :

par contre j'ai une petite question , peut etre que raleur à la réponse .


Je ne vois aucune question.

Hors ligne

#13 07-06-2015 14:53:41

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Serveur DNS local

personne ne sait pourquoi 127.0.1.1 + "nomdelamachine"  en dessous de (localhost en 127.0.0.1)  c'etait la question.
et son utilité sur le réseau (comme jai dit plus haut je l'ai supprimé sans remarquer de problemes mais je la mettrai de nouveau dans la configuration de mes cartes ).

pour $origin ce n est pas un choix , c est dhcp qui me remet en forme le fichier , il a été crée avec "@" et avec la rigueur qu il faut .

il est bon de connaitre les 2 manieres d'écrire ce fichier , bind9 et dhcp sont maintenu par la meme équipe , j y suis pour rien wink

@++  smile

wiki debian :  https://wiki.debian.org/fr/Bind9

Dernière modification par robert2a (07-06-2015 14:56:53)

Hors ligne

#14 07-06-2015 15:02:20

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Serveur DNS local

voila une explication officielle de debian avec la réponse a ma question wink

http://www.debian.org/doc/manuals/debia … resolution

cité:

Chaque ligne commence par une adresse IP et est suivie du nom d’hôte associé.

L’adresse IP 127.0.1.1 en deuxième ligne de cet exemple pourrait ne pas être présente sur d’autres systèmes de type UNIX. L’installateur Debian ajoute cette entrée pour les systèmes sans adresse IP permanente en tant que contournement pour certains programmes (par exemple GNOME) comme expliqué dans le bogue nº 719621.

Le <nom_hote> correspond au nom d’hôte défini dans « /etc/hostname ».

Pour un système avec une adresse IP permanente, cette adresse IP devrait être utilisée à la place de 127.0.1.1.

Pour un système avec une adresse IP permanente et un nom de domaine complètement qualifié (FQDN) fourni par le système de noms de domaine (DNS), les <nom_hote> et <nom_domaine> canoniques devraient être utilisés ici, plutôt que le simple <nom_hote>.

donc sur mes 2 machines en IP fixe cette valeur est inutile et remplacé par l IP fixe + nom de domaine qualifié

pour tous les clients en dhcp sur le reseau "127.0.1.1  +  nom de machine" sera utilisé

voila un grand pas vers  la connaissance tongue

Dernière modification par robert2a (07-06-2015 15:09:36)

Hors ligne

Pied de page des forums