Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-06-2015 22:58:19

TheDarkShrek
Membre
Distrib. : Debian 7.8
Noyau : Linux 3.2.0-4-amd64
Inscription : 14-06-2015
Site Web

Installation openDMARC et ImageMagick

Bonjour à tous,

Venant du monde Windows, j'ai décidé de me lancer dans le monde linux.
Je viens de réinstaller mon serveur sous Debian 7.8.
J'héberge sur celui-ci un serveur web et un serveur de messagerie. Pour cela, je me suis basé sur des tutoriaux trouvés sur Internet (heureusement qu'internet est là d'ailleurs tongue)

Pour les paquets de base pour ce que je veux faire pas de soucis, tout s'est installé et configuré sans le moindre problème.
Par contre, je rencontre présentement des soucis pour 2 paquets.

Le premier est pour mon serveur de messagerie, le paquet openDMARC.
Lorsque je lance son installation, j'obtiens le message suivant :

apt-get install opendmarc


Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 opendmarc : Depends: libopendmarc2 (>= 1.1.0~beta2) but it is not going to be installed
             Depends: libspf2-2 but it is not installable
             Recommends: libopendbx1 but it is not going to be installed
             Recommends: libopendbx1-mysql but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Le deuxième est le paquet ImageMagick, j'obtiens le message suivant :

apt-get install imagemagick


Reading package lists... Done
Building dependency tree
Reading state information... Done
Package imagemagick is a virtual package provided by:
  graphicsmagick-imagemagick-compat 1.3.16-1.1 [Not candidate version]

E: Package 'imagemagick' has no installation candidate



En continuant mes recherches sur internet, j'ai fait quelques modifition sur mon fichier /etc/apt/sources.list dont voici le contenu

# deb http://mirrors.online.net/debian wheezy main

deb http://mirrors.online.net/debian wheezy main non-free contrib
# Line commented out by installer because it failed to verify:
#deb-src http://mirrors.online.net/debian wheezy main non-free contrib

#deb http://security.debian.org/ wheezy/updates main cotrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# squeeze update repository
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free

# wheezy security
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# Wheezy backports
deb http://ftp.debian.org/debian/ wheezy-backports main contrib non-free

deb http://ftp.fr.debian.org/debian/ wheezy-proposed-updates main contrib non-free

deb http://debian.proxad.net/debian/ wheezy main contrib non-free
deb http://debian.proxad.net/debian/ wheezy-updates main contrib non-free



j'ai aussi créé un fichier /etc/apt/preferences.d/pining

Package: *
Pin: release a=stable
Pin-Priority: 900

Package: *
Pin: release a=wheezy-backports
Pin-Priority: 1

Package: *
Pin: release a=testing
Pin-Priority: -10

Package: *
Pin: release a=experimental
Pin-Priority: -10

Package: *
Pin: release a=oldstable
Pin-Priority: -10



Je me doute que j'ai du oublié quelques choses mais j'ai beau chercher, je ne vois pas quoi.

Quelqu'un peut-il m'aider à résoudre mon problème ?

Merci par avance à tous ceux qui pourront me d'aider

Hors ligne

#2 14-06-2015 23:15:40

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Installation openDMARC et ImageMagick

Bonjour et bienvenue smile

Le problème ne viendrait-il pas du fait que la stable de ton fichier preferences fait référence à Jessie, alors que il semble que tu ais Wheezy installé (à ce sujet  : Voir le tuto : Trop cool d'indiquer son installation dans son profil ! wink ), soit oldstable, qui a une priorité négative dans ton fichier hmm

Dans le cas d'un fichier sources.list ne contenant qu'une branche (Wheezy dans ton cas), le fichier preferences me semble inutile.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 15-06-2015 07:01:30

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Jessie 8.x & Backports
Noyau : Noyau Linux 3.16.0-4-686-pae
(G)UI : Xfce 4.10 & Mate 1.8.1
Inscription : 30-06-2008

Re : Installation openDMARC et ImageMagick

salut,

as tu une raison particuilère de prendre une oldstable, soit wheezy, pour configurer ton serveur, de plus ton sources.list que tu as dû copier sur un site internet n'est pas d'une clarté absolue, tu devrais prendre celui-ci que tu pourras modifier selon tes besoins;

###DEBIAN STABLE & BACKPORTS

#Debian-jessie
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie main non-free contrib

#Debian-jessie-security
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free

#Debian-jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

#Debian-jessie-backports
deb http://ftp.fr.debian.org/debian jessie-backports main contrib non-free
#deb-src http://ftp.fr.debian.org/debian jessie-backports main contrib non-free

#Debian-jessie-iceweasel-release
deb http://mozilla.debian.net/ jessie-backports iceweasel-release
 



Sur une debain stable, qui plus est pour installer un serveur, tu n'as pas a mélanger les branches debian et tu n'as pas a utiliser un fichier préférence, surtout si tu découvre debian, c'est mon simple avis,
bon courage

Dernière modification par mksmn (15-06-2015 07:04:04)


Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#4 15-06-2015 08:00:45

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation openDMARC et ImageMagick

Bonjour et bienvenue  smile


Comme bendia, ton fichier preferences me semble peu indiqué en tout Wheezy.

Tu fais bien la mise-à-jour de la liste des paquets :

apt-get update


Et que donne :

dpkg --get-selections | grep 'hold$'


Ainsi que :

apt-cache policy imagemagick


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 15-06-2015 19:32:49

TheDarkShrek
Membre
Distrib. : Debian 7.8
Noyau : Linux 3.2.0-4-amd64
Inscription : 14-06-2015
Site Web

Re : Installation openDMARC et ImageMagick

Bonsoir.

Tout d'abord merci à tout ceux qui ont répondu à mon post. ça m'a beaucoup aidé.
Alors j'ai commencé par supprimer mon fichier preferences.
Ensuite, j'ai modifié mon sources.list.

Grâce à ces deux modifications, j'ai pu installé les paquets qu'il me manquait.

suite à cela, j'ai pu testé les commandes indiquées :

dpkg --get-selections | grep imagemagick


imagemagick                                     install
imagemagick-common                        install



apt-cache policy imagemagick


imagemagick:
  Installed: 8:6.7.7.10-5+deb7u3
  Candidate: 8:6.7.7.10-5+deb7u3
  Version table:
 *** 8:6.7.7.10-5+deb7u3 0
        500 http://mirrors.online.net/debian/ wheezy/main amd64 Packages
        500 http://security.debian.org/ wheezy/updates/main amd64 Packages
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status



dpkg --get-selections | grep opendmarc


libopendmarc2                               install
opendmarc                                    install



apt-cache policy opendmarc


opendmarc:
  Installed: 1.3.0+dfsg-1~bpo70+1
  Candidate: 1.3.0+dfsg-1~bpo70+1
  Version table:
 *** 1.3.0+dfsg-1~bpo70+1 0
        100 http://ftp.fr.debian.org/debian/ wheezy-backports/main amd64 Packages
        100 /var/lib/dpkg/status



A priori mes problèmes venaient surtout de la présence de mon fichier Preference.

Encore merci pour votre aide. big_smile:D:D

Hors ligne

#6 15-06-2015 20:05:55

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation openDMARC et ImageMagick


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#7 16-06-2015 06:46:22

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Jessie 8.x & Backports
Noyau : Noyau Linux 3.16.0-4-686-pae
(G)UI : Xfce 4.10 & Mate 1.8.1
Inscription : 30-06-2008

Re : Installation openDMARC et ImageMagick

salut,

tu es donc rester sous wheezy ?

Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#8 22-06-2015 19:48:29

TheDarkShrek
Membre
Distrib. : Debian 7.8
Noyau : Linux 3.2.0-4-amd64
Inscription : 14-06-2015
Site Web

Re : Installation openDMARC et ImageMagick

mksmn a écrit :

salut,

tu es donc rester sous wheezy ?



Oui. Pour le moment, cette version répond totalement à mes besoins ... et maintenant que j'ai réussit à l'installer wink

Hors ligne

#9 23-06-2015 06:45:54

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Jessie 8.x & Backports
Noyau : Noyau Linux 3.16.0-4-686-pae
(G)UI : Xfce 4.10 & Mate 1.8.1
Inscription : 30-06-2008

Re : Installation openDMARC et ImageMagick

salut,

ok c'est ton choix,

bonne continuation, et tu pourras migrer vers jessie quand tu le voudras.:)

Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

Pied de page des forums