Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-06-2015 13:42:15

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

montage automatique nfs

bonjour,
sur une machine installé avec jessie xfce, j'ai créé un montage automatique nfs dans le fstab pour accéder à un nas synology. pas de problème à ce niveau. ensuite, j'ai créé un second utilisateur. je lui ai donné le statut d'administrateur dans gnome-system-tools. malgré cela, aucun moyen d'automatiser le montage pour ce second utilisateur, bien que le mount -a monte bien les dossiers du nas. quelles que soient les formulations de la ligne de commande dans fstab, le montage n'est pas automatisé. il faut le lancer manuellement. avez-vous une idée de ce qu'il se passe ? un problème de permissions ?? merci par avance.

"Being is not doing"

Hors ligne

#2 19-06-2015 14:01:36

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : montage automatique nfs

donnes le résultat de

cat /etc/fstab

Hors ligne

#3 19-06-2015 14:43:41

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : montage automatique nfs

voici (user remplace le nom du second utilisateur créé) :

cat /etc/fstab


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=52134665-4e4f-480e-9280-3b1e095246e4 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda2 during installation
UUID=25ef4923-2a48-4fe7-9b9e-66b0f4278b7f none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0


192.168.0.36:/volume1/user /home/user/share/user nfs defaults,user,auto,noatime,intr 0 0
 


"Being is not doing"

Hors ligne

#4 19-06-2015 15:29:57

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : montage automatique nfs

jeanmarc1 a écrit :

user remplace le nom du second utilisateur créé


Même dans les options, après defaults ?


Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#5 19-06-2015 17:11:17

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : montage automatique nfs

Papadakis a écrit :

jeanmarc1 a écrit :

user remplace le nom du second utilisateur créé


Même dans les options, après defaults ?



ah non, bien sûr, en effet. dans la ligne de commande nfs, le mot user est respecté pour donner les droits à tous les utilisateurs.
sur d'autres jessie, j'utilise cette ligne qui marche bien, mais dans celle ci, elle bloque le démarrage :

nfs noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14 0 0


"Being is not doing"

Hors ligne

Pied de page des forums