Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-08-2015 16:20:47

jcv
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : KDE 4.14.2
Inscription : 16-06-2013

[Résolu] Perte du mode graphique

Bonjour à toutes et à tous,

J'ai installé Jessie (8.1) Et tout fonctionnait parfaitement jusqu'à aujourd'hui.

Mais aujourd'hui, j'ai bêtement suivi les conseils d'une revue, et j'ai installé nvidia en ligne de commande (apt-get install nvidia-driver nvidia-settings nvidia-xconfig).

J'ai fait redémarrer la machine, et désormais Debian passe en mode texte. Je n'ai plus le mode graphique. La commande startx donne :

  xinit : unable to connect to xserver : connection refused.

J'ai cherché sur Google, mais je n'ai  rien trouvé qui me satisfasse réellement.

Existe-t-il une solution simple à mon problème, ou dois-je tout réinstaller?

Merci d'avance à qui pourra me répondre.

JCV

Dernière modification par jcv (22-08-2015 18:59:10)

Hors ligne

#2 22-08-2015 16:30:47

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Perte du mode graphique

Bonjour

il faut nous donner des infos sur ta machine , surtout le type de carte graphique.
que donne cet commande en console


lspci
 


a priori tu a installé le driver non-free de debian et cela c est mal passé
tu peus revenir en arriere avec la commande


apt-get remove --purge nvidia*
 


je pense qu au depart tu avait le driver "nouveau" installé
tu peut aussi voir ton log du serveur X


nano /var/log/xorg.0.log
 


et le poster ici smile

ps: je pense que tu a jessie (avec systemd) , la commande pour demarrer le serveur x serait du genre


service gdm3 start
 


si je ne me trompe pas hmm
tu utilise KDE (comme bureau) et je ne connais pas son lanceur tongue ce n est peut etre pas gdm3 neutral

Dernière modification par robert2a (22-08-2015 16:38:49)

Hors ligne

#3 22-08-2015 17:56:41

jcv
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : KDE 4.14.2
Inscription : 16-06-2013

Re : [Résolu] Perte du mode graphique

Merci robert2a pour ta réponse rapide.

J'ai purgé nvidia comme tu me l'as conseillé. Mais il m'a fallu également supprimer et purger le paquet xserver-xorg, puis, bien sûr le réinstaller. J'ai maintenant retrouvé le mode graphique.

Merci pour ton aide efficace, et bonne journée.

JCV

Hors ligne

#4 22-08-2015 18:37:06

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Perte du mode graphique

jcv a écrit :

J'ai maintenant retrouvé le mode graphique.



\o/ smile Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 22-08-2015 19:00:45

jcv
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : KDE 4.14.2
Inscription : 16-06-2013

Re : [Résolu] Perte du mode graphique

C'est fait. Merci.

Hors ligne

#6 22-08-2015 19:49:02

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Perte du mode graphique

ce qui me dérange c est ton manque de curiosité jcv wink

tu ne veut pas savoir quel carte tu a et quel driver debian tu peut utiliser ?

je veut pas contrarier bendia tongue mais pour moi rien de résolu wink

si tu a installé ce driver tu devais bien avoir une raison , alors si tu veut retenter l aventure il y a des gens ici qui peuvent te guider dans le choix et la méthode pour installer un driver vidéo (et plein de tutos )

bien que le driver "nouveau" 100% libre et "mesa" 100% libre aussi pour la 3D fonctionne trés bien.

je pense que tu a une petite config comme machine ?

Hors ligne

#7 22-08-2015 19:50:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Perte du mode graphique

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 22-08-2015 23:07:27

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Perte du mode graphique

robert2a a écrit :

ce qui me dérange c est ton manque de curiosité jcv

Je ne vois pas ce qui est dérangeant wink Si tu ne veux pas passer des heures à bricoler un truc pas capital alors que tu as d'autres choses à faire, si ton ordi est ton outils de travail, si ce n'est pas ton Personal Computer mais celui de la famille ...

Mais ce qui est certain, c'est que le problème posé est résolu (l'interface graphique est revenue), et que si tu veux effectivement retenter l'aventure, d'une part, tu connais la solution si ça se passe mal, et que d'autre part, tu peux ouvrir une nouvelle discussion avec un titre indiquant clairement Problème d'installation du Driver Nvidia. Comme dit robert2a tu trouveras ici quelqu'un pour t'aider smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#9 23-08-2015 21:06:06

jcv
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : KDE 4.14.2
Inscription : 16-06-2013

Re : [Résolu] Perte du mode graphique

Je ne voudrais pas être à l'origine d'une dispute sur ce forum, surtout pas entre gens qui m'ont aidé, ou qui cherchent à m'aider.

J'avais acheté une revue où il était question de Debian-Jessie. Un article proposait d'installer le pilote nvidia, et j'ai voulu essayer. J'aime bien en effet, de temps en temps, explorer ma machine, et les possibilités de Linux.

Cependant l'installation de nvidia a mal tourné, et j'ai perdu le mode graphique, d'où mon appel à l'aide ; et je remercie encore rober2a de sa réponse.

Ceci dit je n'ai pas vraiment besoin de nvidia. Le paquet installé par défaut « nouveau » me satisfait. J'avais seulement agi par curiosité.

Je recommencerai la tentative plus tard. Peut-être qu'une fois  nvidia installé il faut, immédiatement après,  purger xserver-xorg, pour le réinstaller. C'est ce que j’ai fait pour résoudre mon problème, mais après avoir enlevé nvidia.

Conclusion : il ne faut pas suivre bêtement tout ce qui est écrit dans certaines revues.

Voilà ! Je souhaite que la sérénité revienne dans cette discussion.

Hors ligne

#10 23-08-2015 21:10:36

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Perte du mode graphique

cool

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#11 23-08-2015 21:26:06

jcv
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : KDE 4.14.2
Inscription : 16-06-2013

Re : [Résolu] Perte du mode graphique

paskal nous a chanté:

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...



I wanted to change my PC
But I failed ... snif!

Hors ligne

#12 23-08-2015 21:30:31

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Perte du mode graphique

lol

Je compatis ...  wink

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#13 23-08-2015 21:50:12

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Perte du mode graphique

jvc a écrit :

Je souhaite que la sérénité revienne


Il ne faut pas confondre l'energie que mettent les membres df à résoudre les problèmes posés et ainsi faire évoluer la connaissance de tous avec une confrontation.
Ici, la prise de parole est libre tant qu'elle n'atteinte pas aux règles basiques et fraternelles du forum df.

Et c'est pas triste comme ça ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#14 25-08-2015 16:39:43

jcv
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : KDE 4.14.2
Inscription : 16-06-2013

Re : [Résolu] Perte du mode graphique

D'accord.

Certains échanges ont été vigoureux; et il y a eu des messages pleins d'humour, d'autres avec de la poésie et des chansons. smile

Je crois qu'on peut désormais considérer la discussion comme étant définitivement close. wink

Merci encore à tout le monde, et spécialement à robert2a. cool

Hors ligne

Pied de page des forums