Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-08-2015 12:34:25

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

[abandonné] plus de connexion wifi après installation de gnome 3.14

Bonjour

J'avais réussi à faire fonctionner ma clef wifi en me servant de /etc/network/interfaces, après une netinstall de jessie amd64.

Ensuite j'ai installé le pilote proprio nvidia car en live gnome me disait ne pas pouvoir se lancer car ma carte ne supportait pas le 3D, alors qu'elle est récente. Bref, voici les lignes de commandes tapées (de mémoire, je vérifierai ça en rentrant du boulot)

apt-get install nvidia-driver nvidia-settings nvidia-xconfig



Tout c'est bien passé. (ensuite un petit coup de nvidia-setting pour créer le finchier x11

Ensuite j'installe gnome par

apt-get install gnome-shell



encore une fois tout semble bien se passer sauf que ... gnome ne se lance pas, peut importe comment on lui demande.

Je fini par trouver, le fichier xorg porte en fait un nom bizarre, en x86 ...

Je le renomme, le déplace, et ... Magie ! j'ai gnoome.

Sauf que impossible d'avoir un accès réseau.

Il semble qu'un conflit soit possible avec l'outil networking manager, j'essaie de jouer sur son fichier de configuration, et comme ça ne marche pas je le désinstalle ...


Maintenant, j'ai accès à mon routeur wifi, je peux le pinger mais je ne peux pinger aucun site (donc pas d'apt-get install ou autre évidemment...)

Je suis comme qui dirait bloqué, une idée ? Merci d'avance !

Dernière modification par araneus (13-09-2015 13:55:13)

Hors ligne

#2 25-08-2015 13:23:12

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

Salut

Si je résume, tu as complètement supprimé Network-manager et ton wifi est configuré par le fichier /etc/network/interfaces.

Et la, tu peux pinger le routeur (donc ton wifi fonctionne) mais pas vers internet.

Peux-tu mettre ici ton fichier interfaces ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 26-08-2015 11:48:37

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

tu résumes très bien, je vous copie le fichier /etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp
wpa-ssid BTHOTSPOT-DEF4
wpa-psk s:R9LEANEF

au fait j'oubliais une chose, au démarrage de l'ordi y'a une pause avec des astérisques rouges où il est écrit

a start job is running for LSB raise network interfaces ....

C'est l'ordi qui cherche le routeur c'est ça ?

edit : ce matin je n'arrive plus a pinguer le routeur ... j'ai dû changer un truc avant de me coucher l'autre soir ... mais je ne vois pas quoi

Une autre info, il y a plusieurs dossiers et fichiers dans /etc/network/ :

if-down.d   if-post-down.d   if-pre-up.d   if-up.d   interfaces   interfaces.d   run

Dernière modification par araneus (28-08-2015 12:22:51)

Hors ligne

#4 28-08-2015 12:24:46

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

bon il semblerait que même DF soit démuni face à cette situation wink

ce que je ne comprends pas c'est pourquoi ça fonctionnnait avant gnome et que sont installation (par le reseau) a tout planté ... je suppose que c'est dû à l'installation de Network-manager mais ... le désinstaller n'a rien résolu .....

pour info j'ai un portable qui utilise ce reseau wifi, voici le retour de

ifconfig


wlan0     Link encap:Ethernet  HWaddr 74:e5:43:17:c1:bc  
          inet adr:192.168.8.100  Bcast:192.168.8.255  Masque:255.255.255.0
          adr inet6: fe80::76e5:43ff:fe17:c1bc/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20584 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13721 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:20267806 (19.3 MiB)  TX bytes:2303244 (2.1 MiB)

Dernière modification par araneus (28-08-2015 12:29:29)

Hors ligne

#5 28-08-2015 13:34:24

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

Tu pourrais peut-être vérifier ce qui a été désinstallé en regardant les logs de apt ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#6 28-08-2015 13:51:40

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

et voici mon cher bendia (enfin je ne mets que les quelques lignes qui me semblent utiles)

cat /var/log/dpkg.log



2015-08-24 22:58:56 remove network-manager-gnome:amd64 0.9.10.0-2 <aucune>
2015-08-24 22:58:56 statut half-configured network-manager-gnome:amd64 0.9.10.0-2
2015-08-24 22:58:56 statut half-installed network-manager-gnome:amd64 0.9.10.0-2
 



cette dernière ligne apparait plusieurs fois dans la trentaine de lignes qui suivent.

Hors ligne

#7 28-08-2015 13:56:46

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

Il n'y a rien qui commence par wpa

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#8 28-08-2015 14:44:43

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

non je ne vois rien commençant par wpa, pourquoi ?

Hors ligne

#9 28-08-2015 15:25:53

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

Je n'ai configuré mon wifi qu'une seule fois sans network-manager, mais il me semble qu'il fallait le paquet wpa-supplicant pour gérer l'authentification par clé. Je me demandais si ce n'était pas une dépendance de NM desinstallée automatiquement lors de sa suppression. Cela expliquerait le pourquoi ça fonctionnait avant et plus maintenant.

Cependant, je n'ai pas ma machine sous la main pour  vérifier hmm

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#10 28-08-2015 16:31:14

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

ah si je comprends bien tu pensais que j'avais wpa-supplicant, que network-manager etait en conflit avec /etc/network/interfaces, et que le soucis c'est qu'en enlevant network-manager j'ai enlevé wpa-supplicant ... je vais vérifier

pour info j'ai essayé de paramétrer en static avec les données du portable ... Toujours la même chose, je ping le routeur mais aucun site internet

Destination Host Unreachable



sad

Dernière modification par araneus (28-08-2015 16:39:56)

Hors ligne

#11 28-08-2015 18:51:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

araneus a écrit :

Bonjour

J'avais réussi à faire fonctionner ma clef wifi en me servant de /etc/network/interfaces, après une netinstall de jessie amd64.

Ensuite j'ai installé le pilote proprio nvidia car en live gnome me disait ne pas pouvoir se lancer car ma carte ne supportait pas le 3D, alors qu'elle est récente. Bref, voici les lignes de commandes tapées (de mémoire, je vérifierai ça en rentrant du boulot)

apt-get install nvidia-driver nvidia-settings nvidia-xconfig



Tout c'est bien passé. (ensuite un petit coup de nvidia-setting pour créer le finchier x11

Ensuite j'installe gnome par

apt-get install gnome-shell



encore une fois tout semble bien se passer sauf que ... gnome ne se lance pas, peut importe comment on lui demande.

Je fini par trouver, le fichier xorg porte en fait un nom bizarre, en x86 ...

Je le renomme, le déplace, et ... Magie ! j'ai gnoome.

Sauf que impossible d'avoir un accès réseau.

Il semble qu'un conflit soit possible avec l'outil networking manager, j'essaie de jouer sur son fichier de configuration, et comme ça ne marche pas je le désinstalle ...


Maintenant, j'ai accès à mon routeur wifi, je peux le pinger mais je ne peux pinger aucun site (donc pas d'apt-get install ou autre évidemment...)

Je suis comme qui dirait bloqué, une idée ? Merci d'avance !



bonjour

je peus pas t aider pour le wifi (pas mon truc)

mais la creation du fichier de conf de nvidia s appelle xorg.conf
et il se trouve dans


nano /etc/X11/xorg.conf
 


la deja je comprend pas comment tu a fait pour que ce soit autrement
deuxieme remarque avec mes faibles connaissances si tu ping ton routeur c est que tu le voit et lui aussi.
sur un routeur cablé , soit tu est en dhcp et le dhcp du routeur te donne la route , soit tu est en ip fixe et tu a declaré une passerelle internet
a mon avis c est de ce cote la , dans ta configuration ou il y a soucis
pour ce qui est de network manager (on est pour ou on est contre ) mais il fonctionne extremement bien sur un client (pour un serveur il vaut mieux eviter )
pour que network manager fonctionne bien il faut que ton fichier de tes cartes reseau soit vide (juste lo )
@++
ps: un petit exemple (pour un reseau filaire)


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

 

Hors ligne

#12 29-08-2015 09:21:52

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

salut et merci de te joindre à nous smile

pour le fichier de configuration je n'ai rien fait, j'ai lancer la configuration automatique nvidia et ne trouvant le xorg j'ai chercher sur DF, où j'ai lu l'emplacement en x86, depuis ça marche...

pour network manager je ne suis ni pour ni contre (la politique ce n'est pas mon truc wink ) je l'avais enlevé car j'ai essayer de commenter toutes les lignes de /etc/network/interfaces et ça n'a rien changé ... mais maintenant que tu le dis je me demande si j'avais laissé les deux lignes lo ... je vais essayer et vous tenir au courant.

Sinon pour ce qui est du static je viens d'essayer de le faire à partir des infos du portable (donc passerelle spécifiée) et ça ne donne rien de plus comme je le disais dans mon post pécédent ...

je me demande si je ne vais pas abandonner et passer en ubuntu tongue:P

Hors ligne

#13 29-08-2015 09:43:00

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

bon effectivement les lignes lo étaient commentées. j'ai essayé de les remettre, en vain.

du coup j'ai commenté toutes les lignes sauf les deux lo puis :

J'ai essayé de commenter tout sauf ces deux lignes et de réinstaller network-manage avec apt, en vain (lorsque je veux aller dans les reglages de mon wifi, de ce reseau que je vois, l'ecran de reseau se ferme de lui meme ...)

j'ai essayé de réinstaller network-manager avec aptitude, qui a enlever des trucs au passages (la simulation me l'indiquant je me suis dit qu'il y avait peut etre des conflits que je ne comprenais aps) en vain ...

je précise qu'après chaque changement j'ai fait un reboot systeme ...

aller dernière information, au début du fichier /etc/network/interfaces il y a une ligne que je ne comprends pas (et que j'ai donc essayé diverses fois de commenter ou dé-commenter) :

source /etc/network/interfaces.d/*

Hors ligne

#14 01-09-2015 22:22:06

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

bonsoir

personne n'ayant d'idée savez vous comment connecter d'habitude un ordi au net via wifi avec debian ? car là c'est à se demander non ? debian n'est pas adaptée a cela ?

Hors ligne

#15 01-09-2015 22:52:21

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

Si ça à fonctionné, c'est que ça doit encore pouvoir le faire.

Il faut voir si ta clé wifi est encore bien reconnue avec lsusb par exemple.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#16 02-09-2015 17:16:01

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

salut bendia et merci de m'aider.

elle est reconnue mais je m'en doutais car je ping sans problème le routeur ...

Hors ligne

#17 02-09-2015 17:25:28

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

Les choses changent dans le bon sens. Peux tu donner le retour de

/sbin/ifconfig


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#18 02-09-2015 17:37:44

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

j'yvais ! au fait quand  je tache de pinguer un site (8.8.8.8) j'obtiens toujours ce fameux destination host unreachable, ça ne t'aide pas ? bon je vais taper ta jolie commande wink

oula y'a 8 ignes juste pour wlan0 ! tu veux des infos en particulier ?

edit : je compare au retour de la commande sur le portable et c'est très semblable ... sauf les inet adress

Dernière modification par araneus (02-09-2015 17:47:44)

Hors ligne

#19 13-09-2015 13:54:37

araneus
Membre
Distrib. : debian wheezy et raspbian
Noyau : 3.2.0-4-amd64
(G)UI : gnome 3
Inscription : 05-02-2014

Re : [abandonné] plus de connexion wifi après installation de gnome 3.14

bonjour

Alors je viens de réinstaller jessie, toujours avec gnome. J'ai internet cette fois ...

J'édite en ... résolu ? hmm

Hors ligne

Pied de page des forums