Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-03-2009 04:16:25

Einucent
Membre
Lieu : Tolosa
Distrib. : 6.0.4
Noyau : 2.6.32-trunk-686
(G)UI : Gnome 2.28.2
Inscription : 09-02-2009
Site Web

Disque interne non-reconnu

Bonjour,
J'ai installé aujourd'hui un disque suplémentaire S-ATA de 500 Go pour y stocker des données qui commençent à s'accumuler sur les autres. Mais il n'apparaît nulle-part, je comptait le formater et m'attaquer aux points de montage mais je le trouve pas physiquement. Je pense l'avoir branché correctement il y a quelque chose à quoi j'aurais du faire gaffe entre la nappe et l'alim ?

Déjà depuis le BIOS j'en ai pas trace.

Pour l'instant (vu depuis Debian) mes disques ressemblent à ça :

<-- ////////////////////////////// ST 340014 A ////////////////////////////!-->
hda1 | ntfs    |                     |                      |    9.77 Go (Windows)
hda2 | fat 32 | /Documents   | DOCUMENTS |   27.50 Go
<-- ////////////////////////////// ATA ST 380013 AS /////////////////////!-->
sda1     | ext3  |                       | root1              |     9.32 Go (Mandriva)
sda2     | ext3  | /                     | Debian_root    |     9.32 Go
sda3     |
   sda5 | swap |                       |                       | 956.97 Mo
   sda6 | ext3  |                       |home1             |     2.80 Go (Mandriva)
   sda7 | ext3  | /home            | Debian_home   |     2.80 Go
   sda8 | fat32 | /documents2   | DOCUMENTS2   |   49.37 Go
____________________________________________________________

hda2 et sda8 sont accessibles depuis Mandriva (qui va pas rester) et Windows, c'est ce que je veux et c'est la raison pour laquelle elles sont en fat 32. Je comptais bien trouver un hdb.

Dernière modification par Einucent (18-03-2009 04:32:34)


Led Zepplin didn't write tunes that everyone liked, they left that to the Bee Gees !
mxl87-br-buton.png

Hors ligne

#2 18-03-2009 04:45:10

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Disque interne non-reconnu

Salut

Ton problème semble venir du contrôleur sata qui n'est pas reconnu. Pourtant, tu es sous lenny, ton kernel devrait donc être assez récent.

Que donne un :

# fdisk -l


Sinon le problème peut aussi venir de la carte PCI. Elle accepte bien les SATA. Une personne ayant un problème semblable au tien (carte PCI supposée OK, mais disque pas reconnu par fdisk) a résolu le sien en changeant sa carte PCI.

Si tu ne trouves rien, donne-nous plus d'infos sur le matériel.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 18-03-2009 08:08:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Disque interne non-reconnu

Bonjour Einucent;

Si tu ne trouves rien, donne-nous plus d'infos sur le matériel.


Faire une copie de :

$ lspci


dans un terminal par exemple... wink

Tsop, amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 18-03-2009 09:51:34

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Disque interne non-reconnu

Salut Einucent !

Le problème ne vient pas de Debian, je mettrais même ma main à couper que Windows ne le voit pas non plus, puisqu'il n'est pas reconnu dans le bios.

Donc déjà, re-vérifie bien tes branchements. Normalement, tu ne peux pas te planter sur un disque Sata, il n'y a qu'un seul sens et les deux connecteurs ne sont pas de la même taille. Si tu es sûr que tout est bien connecté et que ça ne fonctionne toujours pas, débranche tes autres disques pour ne garder que celui-là (et attention à bien tout reconnecter à la même place plus tard !).

Si le bios ne le détecte toujours pas à ce stade, ça se complique vraiment. Donne-nous ces informations si tu les connais :
- marque et modèle de carte mère
- lecteurs (CD, DVD, graveur...), disques durs, leur type (IDE ou Sata) et l'ordre de branchement

C'est peut-être une incompatibilité matérielle, si tu as un autre ordinateur sous la main, essaye-le dessus.

Dans le pire des cas, ton disque est défectueux, ça m'est arrivé en décembre avec un 500Go de chez Seagate, et pourtant c'est le constructeur le plus fiable : le disque n'a jamais voulu démarrer !

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#5 18-03-2009 20:39:21

Einucent
Membre
Lieu : Tolosa
Distrib. : 6.0.4
Noyau : 2.6.32-trunk-686
(G)UI : Gnome 2.28.2
Inscription : 09-02-2009
Site Web

Re : Disque interne non-reconnu

Merci à tous.
Le disque est branché à même la carte mère. Je n'ai pas de carte PCI spécifique, en 2004, je l'ai fait assembler avec le minimum dont j'avais besoin, un processeur, une barette et une carte graphique.

martin_mtl a écrit :

Que donne un :

# fdisk -l


Si tu ne trouves rien, donne-nous plus d'infos sur le matériel.



Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x28d65159

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1216     9767488+  83  Linux
/dev/sda2            1217        2432     9767520   83  Linux
/dev/sda3            2433        9729    58613152+   5  Extended
/dev/sda5            2433        2554      979933+  82  Linux swap / Solaris
/dev/sda6            2555        2919     2931831   83  Linux
/dev/sda7            2920        3284     2931831   83  Linux
/dev/sda8            3285        9729    51769431    c  W95 FAT32 (LBA)

Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x15ad15ac

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        1275    10241406    7  HPFS/NTFS
/dev/hda2            1276        4865    28836675    c  W95 FAT32 (LBA)


manifestement pas de trace d'un hdb quelconque.

smolski a écrit :

Faire une copie de :

$ lspci


00:00.0 Host bridge: VIA Technologies, Inc. KT880 Host Bridge (rev 80)
00:00.1 Host bridge: VIA Technologies, Inc. KT880 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. KT880 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. KT880 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. KT880 Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. KT880 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:09.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (Secondary) (rev 01)

là je suis infoutu d'en interprer ne serait-ce qu'un 10e !

mani a écrit :

je mettrais même ma main à couper que Windows ne le voit pas non plus, puisqu'il n'est pas reconnu dans le bios.


Bien vu, ta main risque pas grand chose wink Windows en voit pas plus, la dernière fois que j'ai démarré il ne voyait plus que le disque sur lequel il est du reste.

Donc déjà, re-vérifie bien tes branchements. Normalement, tu ne peux pas te planter sur un disque Sata, il n'y a qu'un seul sens et les deux connecteurs ne sont pas de la même taille.


On est bien d'accord, même moi je m'y retrouve c'est dire si la connectique est simple !

Si tu es sûr que tout est bien connecté et que ça ne fonctionne toujours pas, débranche tes autres disques pour ne garder que celui-là (et attention à bien tout reconnecter à la même place plus tard !). Si le bios ne le détecte toujours pas à ce stade, ça se complique vraiment. Donne-nous ces informations si tu les connais :
- marque et modèle de carte mère
- lecteurs (CD, DVD, graveur...), disques durs, leur type (IDE ou Sata) et l'ordre de branchement.


C'est pas dans ce qui s'affiche là plus haut ? Il y a un graveur, (NEC ND 4571 16× IDE OEM) qui est sur la même nappe IDE que hda, et aussi un lecteur de disquettes (eh ouais elle est vintage ma machine,:P en 2004 je trouvais encore ça justifié)
J'ai branché le disque incriminé sur un prise dérivée du cordon alimentant déjà sda.

C'est peut-être une incompatibilité matérielle, si tu as un autre ordinateur sous la main, essaye-le dessus.


Ça va être compliqué mais après tout...

Dans le pire des cas, ton disque est défectueux, ça m'est arrivé en décembre avec un 500Go de chez Seagate, et pourtant c'est le constructeur le plus fiable : le disque n'a jamais voulu démarrer !


C'est un Maxtor, ça me semblait fiable pourtant.

Dernière modification par Einucent (18-03-2009 21:12:40)


Led Zepplin didn't write tunes that everyone liked, they left that to the Bee Gees !
mxl87-br-buton.png

Hors ligne

#6 19-03-2009 00:01:10

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Disque interne non-reconnu

Tu as essayé de démarrer avec juste ton Maxtor de connecté, voir si le bios le reconnaît quand il est tout seul ?

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#7 17-10-2011 22:17:03

knives
Membre
Inscription : 17-10-2011

Re : Disque interne non-reconnu

Bonjour à tous,

je me permets de vous relancer sur le sujet car je me trouve dans un cas similaire à celui de Einucent.
J'ai branché un disque dur interne SATA III (en plus du disque dur déjà installé sur lequel j'ai fait mon install de debian) qui n'est reconnu ni par le BIOS ni par ma debian (je suis sous squeeze avec le noyau version 2.6.32). En tapant:

 lspci


, j'obtiens ces deux lignes qui m'intéressent car elles permettent de connaître les chipset liés à mes disques durs:

00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)


Le VIA VT6420 est lié au disque dur non reconnu (du moins je pense) et j'ai donc essayé d'installer les drivers liés à ce chipset avant de m'apercevoir qu'ils étaient déjà actifs dans mon noyau. Du coup, je suis un peu sans solution et j'ai essayé de débrancher mon autre disque dur comme vous le préconisiez.

J'ajoute que quand je tape la commande

ls -l /dev/disk/by-uuid/


je ne vois pas mon disque dur.

Je me pose enfin la question suivante: les cartes PCI SATA sont-elles (mieux) reconnues?

Merci de me porter assistance.

Dernière modification par knives (17-10-2011 22:23:37)

Hors ligne

#8 18-10-2011 03:38:32

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Disque interne non-reconnu

Salut

Il est d'usage de ne pas s'insérer dans un fil de discussion pour exposer son problème même si ce dernier est similaire comme expliqué sur le wiki. Dans le cas d'un problème similaire à un autre se trouvant déjà sur le forum, on peut toujours faire un lien vers ce dernier dans son propre fil de discussion. Aussi, je t'invite donc à reprendre ton message dans un fil que tu auras créé. Et si on trouve solution à ton problème tu pourras ainsi mettre un résolu.

Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 18-10-2011 11:34:26

knives
Membre
Inscription : 17-10-2011

Re : Disque interne non-reconnu

Ok, pas de problème, je viens d'ouvrir un nouveau fil.

Edit de smolski, ce nouveau fil est là :
http://debian-facile.org/forum/viewtopic.php?id=4455 wink

Dernière modification par smolski (18-10-2011 11:53:37)

Hors ligne

Pied de page des forums