Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-03-2009 13:47:57

timar146
Membre
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 12-03-2009

[Résolu] Clavier numérique inactif

Bonjour,

Il y a problème qui viens d'arriver je ne sais pas comment.
Mon clavier numérique est incative après que je me connecte avec mon user.
Lors de la fenêtre de connexion il fonctionne, quand je me connecte en root il fonctionne.
en mode console dans les TTY il fonctionne aussi.
Mais pas dans ma session utilisateur.

Je pense qu'il y a donc un problème de configuration au niveau du profil du user mais je ne sais vraiment pas où.

La diode reste allumé et la touche de verrouillage n'est plus opérationnel. Les touches ne fonctionnent carrément pas, n'y les fléches n'y les caratères spéciaux n'y le numéros. Seul la touche entrée fonctionne encore.

Qu'est ce que je peux faire??

Merci ++

Dernière modification par timar146 (06-10-2009 12:42:43)

Hors ligne

#2 22-03-2009 14:49:45

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Clavier numérique inactif

Salut timar146

peux-tu renvoyer ce que te donne la commande

cat /etc/X11/xorg.conf


Surtout la partie qui concerne le clavier (Keyboard)

Pour reconfigurer ton clavier tu peux essayer

# apt-get install console-data
# dpkg-reconfigure console-data


Il sera configuré au prochain démarrage de la machine.

Bon courage !


logo_3dminfographie_signature.png

Hors ligne

#3 22-03-2009 16:25:39

timar146
Membre
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 12-03-2009

Re : [Résolu] Clavier numérique inactif

Mon "xorg.conf":

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Thu Feb  5 00:18:17 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    #Option        "CoreKeyboard"
    #Option        "XkbRules"    "xorg"
    #Option        "XkbModel"    "pc104"
    Option        "XkbLayout"    "fr"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Hors ligne

#4 22-03-2009 17:03:59

timar146
Membre
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 12-03-2009

Re : [Résolu] Clavier numérique inactif

Je crois que cela c'est produit quand j'ai activer le contrôle à distance via VNC et que je me suis connecté depuis mon Vista avec UltraVNC client.

Hors ligne

#5 22-03-2009 17:36:22

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : [Résolu] Clavier numérique inactif

Est-ce que tu as essayé

# apt-get install console-data
# dpkg-reconfigure console-data


logo_3dminfographie_signature.png

Hors ligne

#6 22-03-2009 17:58:09

timar146
Membre
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 12-03-2009

Re : [Résolu] Clavier numérique inactif

J'avance un peu (enfin si on veut).
Maintenant avec les flèches du clavier numérique j'arrive à déplacer le curseur de la souris.
Ce n'est pas très utile mais c'est tout ce que j'ai.

Hors ligne

#7 22-03-2009 18:46:48

timar146
Membre
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 12-03-2009

Re : [Résolu] Clavier numérique inactif

damien a écrit :

Est-ce que tu as essayé

# apt-get install console-data
# dpkg-reconfigure console-data


J'ai mis le clavier en "azerty french" mais le clavier numérique est toujours bloqué sad

Hors ligne

#8 22-03-2009 18:54:30

timar146
Membre
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 12-03-2009

Re : [Résolu] Clavier numérique inactif

J'ai créer un nouvel utilisateur, je me suis connecté, la clavier fonctionne correctement.
J'ai donc voulut prendre mon home pour avoir mes fichiers et reglage, depuis le transfert le clavier ne fonctionne plus.

Il semblerait qu'un fichier de conf dans le Home pose problème.
Une idée??

Edit:

Bon après plusieurs tests (j'ai supprimer petit à petit les dossiers et fichiers) j'en suis arrivé à ciblé le fichier qui posait problème: "/home/user/.gconf/desktop/%gconf.xml". c'est un fichier vide et à partir de moment ou je l'ai supprimé et uns reconnexion mon numpad à fonctionné.

Le fichier à été recréé mais est resté vide.

Voila, tout semble être rentré dans l'autre... après une bonne partie de l'après midi à plancher dessus.
Un mystère de plus que je n'explique pas.

a++ sur le forum pour un prochain problème big_smile

Dernière modification par timar146 (22-03-2009 19:18:39)

Hors ligne

#9 22-03-2009 21:05:13

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Clavier numérique inactif

Salut

Dans Gconf, on retrouve les données de configuration de ton bureau. Pour modifier ces données, on passe par gconf-editor.

La prochaine fois que ce problème survient lance gconf-editor et vérifie dans desktop, gnome, peripherals, keyboard, host-debian, 0, si la clé numlock_on est activé.

Si tout fonctionnait bien avant c'est fort probablement le fait d'utiliser VNC qui a modifié dans config.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#10 01-04-2009 18:31:57

gustave
Membre
Distrib. : Debian
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 01-04-2009

Re : [Résolu] Clavier numérique inactif

Je ne me rapellai plus comment faire pour réactiver le clavier numérique aprés une session vnc, donc je cherche sur le net, puis je tombe sur ce post.
En meme temps je me rapel, il suffit donc de faire.
ctrl-shift-verr/num
et c'est reparti, alors si je l'ai ecrit,  je m'en rapellerai plus tard.
Gus

Hors ligne

#11 12-04-2009 12:35:28

KsmoinO
Modérateur
Distrib. : testing/sid
(G)UI : KDE
Inscription : 05-10-2007

Re : [Résolu] Clavier numérique inactif

dans le menu système préférence clavier, sous longlet touches de la souris désactive l'option :
permettre le contrôle du pointeur par le clavier (qui se fait aussi par ctrl + shift + vernum)

(ça m'arrive quand j'essaie de mettre un point avec le pavé numérique dans ultra vnc)

et si c'est résolu marque le post en résolu

merci

Hors ligne

Pied de page des forums