Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-10-2015 12:58:15

yeKcim
Membre
Inscription : 18-10-2015

problème avec mon sources.list ? impossible d’installer krita

Bonjour

Je suis un nouvel utilisateur de debian, je rencontre un problème pour installer krita.

Mon sources.list :

deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free

deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

################################################
## sid
deb http://ftp.fr.debian.org/debian/ unstable main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ unstable main contrib non-free

################################################
## experimental
deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ experimental main contrib non-free
 



Mon fichier preferences :

Package: *
Pin: release a=stable
Pin-Priority: 500

Package: *
Pin: release a=testing
Pin-Priority: 900

Package: *
Pin: release a=unstable
Pin-Priority: 600

Package: *
Pin: release a=experimental
Pin-Priority: 10
 



Lorsque j’essaie d’installer krita je rencontre des conflits :

Les NOUVEAUX paquets suivants vont être installés :    
  calligra-data{a} calligra-libs{a} docbook-xsl{a} icoutils{a} kate-data{a} katepart{a} kde-runtime{a} kde-runtime-data{a} kdelibs-bin{a}
  kdelibs5-data{a} kdelibs5-plugins{a} kdoctools{a} krita krita-data{a} libattica0.4{a} libdbusmenu-qt2{a} libexiv2-13{a} libilmbase6{a}
  libiodbc2{a} libkactivities-bin{a} libkactivities-models1{a} libkactivities6{a} libkatepartinterfaces4{a} libkcmutils4{a} libkdcraw-data{a}
  libkdcraw23{a} libkde3support4{a} libkdeclarative5{a} libkdesu5{a} libkdeui5{a} libkdewebkit5{a} libkdnssd4{a} libkemoticons4{a} libkfile4{a}
  libkhtml5{a} libkio5{a} libkjsapi4{a} libkjsembed4{a} libkmediaplayer4{a} libknewstuff3-4{a} libknotifyconfig4{a} libkntlm4{a} libkparts4{a}
  libkpty4{a} libkrosscore4{a} libkrossui4{a} libktexteditor4{a} libkxmlrpcclient4{a} libnepomuk4{a} libnepomukcore4{a} libnepomukquery4a{a}
  libnepomukutils4{a} libntrack-qt4-1{a} libntrack0{a} libopencolorio1{a} libopenexr6{a} libphonon4{a} libphononexperimental4{a} libplasma3{a}
  libpolkit-qt-1-1{a} libqca2{a} libqca2-plugin-ossl{a} libqca2-plugins{a} libsolid4{a} libsoprano4{a} libstreamanalyzer0v5{a} libstreams0v5{a}
  libthreadweaver4{a} libtinyxml2.6.2{a} libxml2-utils{a} libyaml-cpp0.3{a} nepomuk-core-data{a} ntrack-module-libnl-0{a} oxygen-icon-theme{a}
  phonon{a} phonon-backend-vlc{a} plasma-scriptengine-javascript{a} soprano-daemon{a}
0 paquets mis à jour, 78 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 93,8 Mo d'archives. Après dépaquetage, 255 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libopencolorio1v5 : Est en conflit avec: libopencolorio1 mais 1.0.9~dfsg0-3+b1 doit être installé.
 libopenexr6v5 : Est en conflit avec: libopenexr6 mais 1.6.1-8 doit être installé.
 libilmbase6v5 : Est en conflit avec: libilmbase6 mais 1.0.1-6.1 doit être installé.
 libyaml-cpp0.3v5 : Est en conflit avec: libyaml-cpp0.3 mais 0.3.0-1.1 doit être installé.
 libtinyxml2.6.2v5 : Est en conflit avec: libtinyxml2.6.2 mais 2.6.2-2 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     calligra-libs [Non installé]                            
2)     krita [Non installé]                                    
3)     libilmbase6 [Non installé]                              
4)     libopencolorio1 [Non installé]                          
5)     libopenexr6 [Non installé]                              
6)     libtinyxml2.6.2 [Non installé]                          
7)     libyaml-cpp0.3 [Non installé]

Accepter cette solution ? [Y/n/q/?] n
 



Les solutions suivantes ne sont pas vraiment plus intéressantes :

Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                          
1)      blender                                                  
2)      libopencolorio1v5                                        
3)      libopenimageio1.5v5                                      
4)      libtinyxml2.6.2v5                                        

      Conserver les paquets suivants dans leur version actuelle :
5)      calligra-libs [Non installé]                            
6)      krita [Non installé]                                    
7)      libilmbase6 [Non installé]                              
8)      libopencolorio1 [Non installé]                          
9)      libopenexr6 [Non installé]                              
10)     libyaml-cpp0.3 [Non installé]
 



Les solutions suivantes sont pires et quelque soit la solution proposée, krita n’est de toute façon jamais installé.

Mon but est avant tout de comprendre ce que j’ai mal géré dans ma configuration sources/preferences, l’installation de krita est presque secondaire. Quelqu’un ici voit-il mon erreur / pourrait me guider ?

Merci

Hors ligne

#2 30-10-2015 14:57:04

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : problème avec mon sources.list ? impossible d’installer krita

Si tu veux du sid, commence par ne mettre que les sources recommandées pour sid :
testing - experimental -sid.

Pas besoin de preferences ainsi.

Pourquoi les deb-src ?
Tu compiles ?

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 30-10-2015 15:18:51

yeKcim
Membre
Inscription : 18-10-2015

Re : problème avec mon sources.list ? impossible d’installer krita

je peux supprimer les debs-src en effet. je ne veux pas du sid je veux du testing

Hors ligne

#4 30-10-2015 16:14:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : problème avec mon sources.list ? impossible d’installer krita

Mets unstable en preference 10, et experimental est à 1 par defaut. wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 30-10-2015 17:01:23

yeKcim
Membre
Inscription : 18-10-2015

Re : problème avec mon sources.list ? impossible d’installer krita

cela ne change pas grand chose… du moins de ce que je comprends.
apt-cache policy va retourner les mêmes ordres de priorités… me trompé-je ?

Hors ligne

#6 30-10-2015 17:25:35

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : problème avec mon sources.list ? impossible d’installer krita

Bonjour

Ta testing est elle bien a jour avant cette tentative d'installation ?

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#7 30-10-2015 19:17:26

yeKcim
Membre
Inscription : 18-10-2015

Re : problème avec mon sources.list ? impossible d’installer krita

À jour, avec pas mal de paquets de unstable et les drivers nvidia de experimental

Hors ligne

#8 02-06-2016 11:04:28

yeKcim
Membre
Inscription : 18-10-2015

Re : problème avec mon sources.list ? impossible d’installer krita

Je continue à rencontrer le problème. Pour résumer, voici mon sources.list :


deb http://httpredir.debian.org/debian stable main contrib non-free
deb http://httpredir.debian.org/debian testing main contrib non-free
deb http://httpredir.debian.org/debian unstable main contrib non-free
deb http://httpredir.debian.org/debian experimental main contrib non-free
 



Mon preferences et preferences.d/nvidia :


Package: *
Pin: release a=stable
Pin-Priority: 500

Package: *
Pin: release a=testing
Pin-Priority: 900

Package: *
Pin: release a=unstable
Pin-Priority: 600

Package: *
Pin: release a=experimental
Pin-Priority: 1
 




Explanation: Version expérimentale de Nvidia
Package: nvidia-driver libgl1-nvidia-glx libegl1-nvidia nvidia-driver-bin xserver-xorg-video-nvidia nvidia-vdpau-driver nvidia-alternative nvidia-kernel-dkms libnvidia-eglcore nvidia-kernel-support
Pin: release o=Debian,a=experimental,n=experimental,l=Debian
Pin-Priority: 1001
 



Mon système est à jour :

aptitude update && aptitude full-upgrade && aptitude clean


Ignoré http://debian.univ-lorraine.fr/debian stable InRelease                          
Atteint http://debian.univ-lorraine.fr/debian testing InRelease    
Atteint http://debian.univ-lorraine.fr/debian unstable InRelease
Atteint http://debian.univ-lorraine.fr/debian experimental InRelease
Atteint http://debian.univ-lorraine.fr/debian stable Release
                                   
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.



apt-cache policy blender


blender:
  Installé : 2.77.a+dfsg0-5
  Candidat : 2.77.a+dfsg0-5
 Table de version :
 *** 2.77.a+dfsg0-5 900
        900 http://httpredir.debian.org/debian testing/main amd64 Packages
        600 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2.72.b+dfsg0-3 500
        500 http://httpredir.debian.org/debian stable/main amd64 Packages



apt-cache policy krita


krita:
  Installé : (aucun)
  Candidat : 1:2.8.5+dfsg-1+b2
 Table de version :
     1:2.8.5+dfsg-1+b2 500
        500 http://httpredir.debian.org/debian stable/main amd64 Packages
        100 /var/lib/dpkg/status



Le message d’erreur que j’obtiens lorsque j’essaye d’installer krita alors que blender est installé :

aptitude install krita


Les NOUVEAUX paquets suivants vont être installés :    
  calligra-data{a} calligra-libs{a} krita krita-data{a} libexiv2-13{a} libglew1.10{a} libilmbase6{a} libkrossui4{a} libopencolorio1{a} libopenexr6{a}
  libphononexperimental4{a} libqca2-plugin-ossl{a} libtinyxml2.6.2{a} libyaml-cpp0.3{a}
0 paquets mis à jour, 14 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 33,2 Mo d'archives. Après dépaquetage, 109 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libopencolorio1v5 : Est en conflit avec: libopencolorio1 mais 1.0.9~dfsg0-3 doit être installé.
 libtinyxml2.6.2v5 : Est en conflit avec: libtinyxml2.6.2 mais 2.6.2-2 doit être installé.
 libyaml-cpp0.3v5 : Est en conflit avec: libyaml-cpp0.3 mais 0.3.0-1.1 doit être installé.
ouverts : 17 ; fermés : 687 ; reportés : 8 ; en conflit : 22                                                                                                 .Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :
1)     blender                      
2)     libopencolorio1v5            
3)     libopenimageio1.6            
4)     libtinyxml2.6.2v5            
5)     libyaml-cpp0.3v5              



Accepter cette solution ? [Y/n/q/?]



J’ai beau répondre N, aucune des propositions ne permet d’obtenir les deux softs en même temps.

Je n’arrive pas à résoudre le conflit, quelqu’un voit d’où peut venir le problème ? J’ai fait une erreur grossière dans mon sources.list ou dans mon preferences ?

En attendant j’utilise krita en version appimage…

Hors ligne

#9 02-06-2016 11:16:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : problème avec mon sources.list ? impossible d’installer krita

peut-être passer par aptitude graphique sera plus facile pour résoudre le problème :
https://debian-facile.org/doc:systeme:a … ce-ncurses smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums