Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-11-2015 11:22:00

phil995511
Membre
Inscription : 13-11-2015

Drivers expérimentaux Nvidia 352.x

Bonjour,

Je suis sous Mint LMDE 2 et Debian 8.2 (que je teste) en dual boot.

J'ai changé de carte graphique en adoptant une Nvidia 970 GTX.

Malheureusement le driver inclu dans debian (340.x) ne reconnais pas ma carte.

J'ai rajoutté le dépot

deb http://ftp.de.debian.org/debian experimental main non-free
 

dans /etc/apt/sources.list.

Malheureusement l'install en se fait pas :

root@station:/home/philippe#

apt-get install -t experimental nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Package nvidia-settings is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libxnvctrl-dev

E: Package 'nvidia-settings' has no installation candidate
 



Auriez-vous une solution a me fournir ?

Meilleures salutations.

Dernière modification par phil995511 (13-11-2015 11:35:00)

Hors ligne

#2 13-11-2015 14:41:49

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

Bonjour
ça doit fonctionner , il faut l option "-t" il me semble avec "apt-get install" , tu dois trouver des infos sur le forum D_F a ce sujet , il s agit de priorité , le paquet ne sera jamais installé si tu ne l indique pas.

le plus terrible c est que je l ai fait déja  tongue

sinon tu a le ".run" du site nvidia qui fonctionne bien pour les cartes récentes de la serie "gtx9xx"

ps: regarde ici tongue => https://debian-facile.org/viewtopic.php?id=11132 , tu trouvera surement des infos et il y a aussi un wiki sur le "sources.list" et "apt-get" sur le fofo.

Dernière modification par robert2a (13-11-2015 15:17:11)

En ligne

#3 13-11-2015 14:49:58

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

voila quelques pistes :

pour tester sans installer


apt-get install -t experimental -s xserver-xorg-video-nvidia
 


pour installer (sans l option -s)


apt-get install -t experimental xserver-xorg-video-nvidia
 


preciser plusieurs paquets : (tester)
tu demande le driver + le cuda


apt-get install -t experimental -s xserver-xorg-video-nvidia nvidia-driver nvidia-settings nvidia-cuda-toolkit
 


ps:modification de la ligne ci dessus , ajout de "nvidia-settings" sinon probleme (la version de stretch/sid pas compatible "drivers experimental")

enfin le post qui parle de l installation du .run du site du constructeur "nvidia" touffu aussi mais tu trouvera les infos utiles .

https://debian-facile.org/viewtopic.php?id=12119

Dernière modification par robert2a (19-11-2015 16:29:32)

En ligne

#4 13-11-2015 18:18:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

j'ai lancé la commande avec -t et -s  (pour test une installation du driver experimental) sur une stretch/sid plus apte a mon avis que jessie a recevoir ces paquets (a tester avec jessie)


apt-get install -t experimental -s xserver-xorg-video-nvidia
 


retour de la commande

 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libjansson4 libxnvctrl0 nvidia-settings pkg-config
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libegl1-nvidia libgl1-nvidia-glx libgles1-nvidia libgles2-nvidia libnvidia-eglcore nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-kernel-dkms
  nvidia-kernel-support nvidia-vdpau-driver
Paquets recommandés :
  libgl1-nvidia-glx-i386
Les paquets suivants seront mis à jour :
  libegl1-nvidia libgl1-nvidia-glx libgles1-nvidia libgles2-nvidia libnvidia-eglcore nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-kernel-dkms
  nvidia-kernel-support nvidia-vdpau-driver xserver-xorg-video-nvidia
12 mis à jour, 0 nouvellement installés, 0 à enlever et 288 non mis à jour.
Inst nvidia-kernel-support [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-driver [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-driver-bin [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst xserver-xorg-video-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-alternative [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libgles2-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libgles1-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libegl1-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libnvidia-eglcore [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-vdpau-driver [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-kernel-dkms [340.93-6] (352.55-2 Debian:experimental [amd64]) []
Inst libgl1-nvidia-glx [340.93-7] (352.55-2 Debian:experimental [amd64])
Conf nvidia-alternative (352.55-2 Debian:experimental [amd64])
Conf nvidia-kernel-support (352.55-2 Debian:experimental [amd64])
Conf libgl1-nvidia-glx (352.55-2 Debian:experimental [amd64])
Conf libnvidia-eglcore (352.55-2 Debian:experimental [amd64])
Conf libegl1-nvidia (352.55-2 Debian:experimental [amd64])
Conf nvidia-driver-bin (352.55-2 Debian:experimental [amd64])
Conf xserver-xorg-video-nvidia (352.55-2 Debian:experimental [amd64])
Conf nvidia-vdpau-driver (352.55-2 Debian:experimental [amd64])
Conf nvidia-kernel-dkms (352.55-2 Debian:experimental [amd64])
Conf nvidia-driver (352.55-2 Debian:experimental [amd64])
Conf libgles2-nvidia (352.55-2 Debian:experimental [amd64])
Conf libgles1-nvidia (352.55-2 Debian:experimental [amd64])
 



vu le retour de la commande je vois pas de soucis , mails il n y a pas l'intallation du cuda .

Dernière modification par robert2a (13-11-2015 18:30:07)

En ligne

#5 13-11-2015 18:36:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

la meme chose avec le cuda ,


apt-get install -t experimental -s xserver-xorg-video-nvidia nvidia-driver nvidia-cuda-toolkit
 



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libjansson4 libxnvctrl0 nvidia-settings pkg-config
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libcublas6.5 libcuda1 libcudart6.5 libcufft6.5 libcufftw6.5 libcuinj64-6.5 libcurand6.5 libcusparse6.5 libegl1-nvidia libgl1-nvidia-glx libgles1-nvidia
  libgles2-nvidia libnppc6.5 libnppi6.5 libnpps6.5 libnvblas6.5 libnvcuvid1 libnvidia-compiler libnvidia-eglcore libnvidia-encode1 libnvidia-fbc1
  libnvidia-ifr1 libnvtoolsext1 libnvvm2 nvidia-alternative nvidia-cuda-dev nvidia-cuda-doc nvidia-cuda-gdb nvidia-driver-bin nvidia-kernel-dkms
  nvidia-kernel-support nvidia-opencl-icd nvidia-profiler nvidia-vdpau-driver nvidia-visual-profiler
Paquets recommandés :
  libcuda1-i386 libgl1-nvidia-glx-i386
Les paquets suivants seront mis à jour :
  libcublas6.5 libcuda1 libcudart6.5 libcufft6.5 libcufftw6.5 libcuinj64-6.5 libcurand6.5 libcusparse6.5 libegl1-nvidia libgl1-nvidia-glx libgles1-nvidia
  libgles2-nvidia libnppc6.5 libnppi6.5 libnpps6.5 libnvblas6.5 libnvcuvid1 libnvidia-compiler libnvidia-eglcore libnvidia-encode1 libnvidia-fbc1
  libnvidia-ifr1 libnvtoolsext1 libnvvm2 nvidia-alternative nvidia-cuda-dev nvidia-cuda-doc nvidia-cuda-gdb nvidia-cuda-toolkit nvidia-driver
  nvidia-driver-bin nvidia-kernel-dkms nvidia-kernel-support nvidia-opencl-icd nvidia-profiler nvidia-vdpau-driver nvidia-visual-profiler
  xserver-xorg-video-nvidia
38 mis à jour, 0 nouvellement installés, 0 à enlever et 262 non mis à jour.
Inst nvidia-kernel-support [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-driver [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-driver-bin [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst xserver-xorg-video-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-alternative [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libgles2-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libgles1-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libegl1-nvidia [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libnvidia-eglcore [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-vdpau-driver [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-kernel-dkms [340.93-6] (352.55-2 Debian:experimental [amd64]) []
Inst libgl1-nvidia-glx [340.93-7] (352.55-2 Debian:experimental [amd64])
Inst nvidia-opencl-icd [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libnvidia-compiler [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libnvidia-ifr1 [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libnvidia-fbc1 [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libnvcuvid1 [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst libnvidia-encode1 [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-visual-profiler [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcuda1 [340.93-7] (352.55-2 Debian:experimental [amd64]) []
Inst nvidia-profiler [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) [nvidia-cuda-toolkit:amd64 ]
Inst nvidia-cuda-toolkit [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst nvidia-cuda-dev [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcuinj64-6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libnvvm2 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcudart6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcublas6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libnvblas6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcufft6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcufftw6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcusparse6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libcurand6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libnppc6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libnppi6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libnpps6.5 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64]) []
Inst libnvtoolsext1 [6.5.14-2] (6.5.19-1 Debian:experimental [amd64])
Inst nvidia-cuda-doc [6.5.14-2] (6.5.19-1 Debian:experimental [all])
Inst nvidia-cuda-gdb [6.5.14-2] (6.5.19-1 Debian:experimental [amd64])
Conf nvidia-alternative (352.55-2 Debian:experimental [amd64])
Conf nvidia-kernel-support (352.55-2 Debian:experimental [amd64])
Conf libgl1-nvidia-glx (352.55-2 Debian:experimental [amd64])
Conf libnvidia-eglcore (352.55-2 Debian:experimental [amd64])
Conf libegl1-nvidia (352.55-2 Debian:experimental [amd64])
Conf nvidia-driver-bin (352.55-2 Debian:experimental [amd64])
Conf xserver-xorg-video-nvidia (352.55-2 Debian:experimental [amd64])
Conf nvidia-vdpau-driver (352.55-2 Debian:experimental [amd64])
Conf nvidia-kernel-dkms (352.55-2 Debian:experimental [amd64])
Conf nvidia-driver (352.55-2 Debian:experimental [amd64])
Conf libgles2-nvidia (352.55-2 Debian:experimental [amd64])
Conf libgles1-nvidia (352.55-2 Debian:experimental [amd64])
Conf libcuda1 (352.55-2 Debian:experimental [amd64])
Conf libnvidia-compiler (352.55-2 Debian:experimental [amd64])
Conf nvidia-opencl-icd (352.55-2 Debian:experimental [amd64])
Conf libnvidia-ifr1 (352.55-2 Debian:experimental [amd64])
Conf libnvidia-fbc1 (352.55-2 Debian:experimental [amd64])
Conf libnvcuvid1 (352.55-2 Debian:experimental [amd64])
Conf libnvidia-encode1 (352.55-2 Debian:experimental [amd64])
Conf libcuinj64-6.5 (6.5.19-1 Debian:experimental [amd64])
Conf nvidia-profiler (6.5.19-1 Debian:experimental [amd64])
Conf nvidia-visual-profiler (6.5.19-1 Debian:experimental [amd64])
Conf libcudart6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libcublas6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libnvblas6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libcufft6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libcufftw6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libcusparse6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libcurand6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libnppc6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libnppi6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libnpps6.5 (6.5.19-1 Debian:experimental [amd64])
Conf libnvtoolsext1 (6.5.19-1 Debian:experimental [amd64])
Conf libnvvm2 (6.5.19-1 Debian:experimental [amd64])
Conf nvidia-cuda-dev (6.5.19-1 Debian:experimental [amd64])
Conf nvidia-cuda-toolkit (6.5.19-1 Debian:experimental [amd64])
Conf nvidia-cuda-doc (6.5.19-1 Debian:experimental [all])
Conf nvidia-cuda-gdb (6.5.19-1 Debian:experimental [amd64])
 

En ligne

#6 13-11-2015 20:35:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

suite au lancement de l installation en console



nvidia-graphics-drivers (352.55-1) experimental; urgency=medium

  The NVIDIA driver now automatically integrates with the Xorg configuration.
  Therefore it is no longer necessary to manually create an xorg.conf to
  enable it.

 -- Andreas Beckmann <anbe@debian.org>  Fri, 16 Oct 2015 23:41:50 +0200

nvidia-graphics-drivers (343.22-1) experimental; urgency=medium

  LEGACY GPUs: If you have a GeForce 8xxx, GeForce 9xxx, GeForce 2xx/3xx,
  GeForce 405, GeForce G 1xx/2xx, GeForce GT 1xx/2xx/3xx, GeForce GT 415,
  GeForce GTS 1xx/2xx/3xx, GeForce GTX 2xx, ION/ION 2/ION VGA/ION LE VGA,
  NVS 300/2100/3100/5100, Quadro 400, Quadro CX, Quadro FX (any model),
  Quadro NVS 130/135/140/150/160/290/295/320/420/450, Quadro Plex, Quadro VX,
  Tesla C870/C1060/M1060, nforce 7xx, i.e., any GPU based on the C77/C78/C79,
  G80/G84/G86/G92/G94/G96/G98, GT200/GT215/GT216/GT218, ION VGA, or
  MCP79/MCP7A/MCP89 chips or a variant thereof (that is anything predating
  the Fermi architecture),
  DO NOT INSTALL THIS RELEASE!!!
  Use the nvidia-legacy-340xx-driver, nvidia-legacy-340xx-kernel-dkms
  packages instead.

 -- Andreas Beckmann <anbe@debian.org>  Tue, 14 Oct 2014 15:14:53 +0200

(q to quit)
 



le plus terrible va etre le reboot  tongue tongue tongue

En ligne

#7 13-11-2015 20:52:25

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

voila c'est fait.
si je peut te donner un conseil
avec jessie utilise plutot le .run du site nvidia
si tu utilise la methode ci dessus via le depot débian, il vaut mieux installer plutot stretch/sid comme debian, le noyau est plus récent ainsi que certains paquets
la meme methode peut etre faite a partir de jessie mais il y a certainement des risques smile

dans tout les cas supprimer ou commenter la ligne "experimental" du sources.list pour eviter tout risque de polluer ta debian apres l installation du driver.

ps: si tu te lance pour la mise à jour ne manque pas de nous faire un retour et tes observations smile

un petit extrait du log => /var/log/Xorg.0.log


[    20.573]
X.Org X Server 1.17.3
Release Date: 2015-10-26
[    20.573] X Protocol Version 11, Revision 0
[    20.573] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[    20.573] Current Operating System: Linux debian7 4.2.0-1-amd64 #1 SMP Debian 4.2.6-1 (2015-11-10) x86_64
[    20.573] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.2.0-1-amd64 root=UUID=b0d2b8cf-8ef3-4532-91ee-f06bf56ce56f ro quiet
[    20.573] Build Date: 27 October 2015  11:41:02PM
[    20.573] xorg-server 2:1.17.3-2 (http://www.debian.org/support)
[    20.573] Current version of pixman: 0.33.4
[    20.573]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    20.573] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    20.573] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 13 19:40:36 2015
[    20.935] (==) Using config file: "/etc/X11/xorg.conf"
[    20.935] (==) Using system config directory "/usr/share/X11/xorg.conf.d"



[    26.544] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[    26.545] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 750 (GM107-A) at PCI:1:0:0 (GPU-0)
[    26.545] (--) NVIDIA(0): Memory: 1048576 kBytes
[    26.545] (--) NVIDIA(0): VideoBIOS: 82.07.32.00.f6
[    26.545] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    26.560] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    26.560] (**) NVIDIA(0):     device Maxdata/Belinea Bel101728 (CRT-0) (Using EDID
[    26.560] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
 

Dernière modification par robert2a (13-11-2015 21:07:49)

En ligne

#8 13-11-2015 21:17:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

un petit recapitulatif des gpu maxwell (il manque a mon avis la 980TI dans leur tableau , entre la 980 et 980 TITAN X )
mon gpu de test est un GM107A  (GTX750 1go de ddr5) le premier du tableau tongue lol

=>  https://fr.wikipedia.org/wiki/Maxwell_% … aphique%29

Dernière modification par robert2a (13-11-2015 21:19:33)

En ligne

#9 14-11-2015 08:19:42

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

Bonjour
quelques remarques sur ton premier post:
la ligne supplementaire de ton sources.list doit etre :


deb http://ftp.de.debian.org/debian experimental main contrib non-free
 


si tu ne met pas "contrib" tu passe a coté de ceci =>  https://packages.debian.org/experimenta … a-settings
qui est dans la section "contrib"
pour l instant j'ai gardé mes 2 lignes sid et experimental et j'ai des mises a jour ce matin certains paquets passe de 340.93-7 a 340.93-8 (de sid)
ce qu il vient de "experimental" ne bouge pas
mon sources.list


deb http://ftp.fr.debian.org/debian/ stretch main contrib non-free

deb http://ftp.fr.debian.org/debian/ stretch-updates main contrib non-free


deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free

 



je vais installer le "nvidia-settings" sur le meme principe avec -t et -s (pour vérification) puis -t uniquement


apt-get install -t experimental -s xserver-xorg-video-nvidia nvidia-driver nvidia-settings nvidia-cuda-toolkit
 


tout semble correct :


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
nvidia-cuda-toolkit est déjà la plus récente version disponible.
Les paquets supplémentaires suivants seront installés :
  libegl1-nvidia libgl1-nvidia-glx libgles1-nvidia libgles2-nvidia libjansson4 libnvidia-eglcore libxnvctrl0 nvidia-alternative nvidia-driver-bin
  nvidia-kernel-support nvidia-vdpau-driver pkg-config
Paquets recommandés :
  libgl1-nvidia-glx-i386
Les NOUVEAUX paquets suivants seront installés :
  libjansson4 libxnvctrl0 nvidia-settings pkg-config
Les paquets suivants seront mis à jour :
  libegl1-nvidia libgl1-nvidia-glx libgles1-nvidia libgles2-nvidia libnvidia-eglcore nvidia-alternative nvidia-driver nvidia-driver-bin
  nvidia-kernel-support nvidia-vdpau-driver xserver-xorg-video-nvidia
11 mis à jour, 4 nouvellement installés, 0 à enlever et 120 non mis à jour.
Inst nvidia-kernel-support [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst nvidia-driver-bin [352.55-2] (352.55-3 Debian:experimental [amd64]) [nvidia-driver:amd64 ]
Inst nvidia-driver [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst xserver-xorg-video-nvidia [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst nvidia-alternative [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst libgles2-nvidia [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst libgles1-nvidia [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst libegl1-nvidia [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst libnvidia-eglcore [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst nvidia-vdpau-driver [352.55-2] (352.55-3 Debian:experimental [amd64]) []
Inst libgl1-nvidia-glx [352.55-2] (352.55-3 Debian:experimental [amd64])
Inst pkg-config (0.28-1 Debian:testing [amd64])
Inst libjansson4 (2.7-3 Debian:testing [amd64])
Inst libxnvctrl0 (346.59-1 Debian:experimental [amd64])
Inst nvidia-settings (346.59-1 Debian:experimental [amd64])
Conf nvidia-alternative (352.55-3 Debian:experimental [amd64])
Conf nvidia-kernel-support (352.55-3 Debian:experimental [amd64])
Conf nvidia-driver-bin (352.55-3 Debian:experimental [amd64])
Conf libgl1-nvidia-glx (352.55-3 Debian:experimental [amd64])
Conf libnvidia-eglcore (352.55-3 Debian:experimental [amd64])
Conf libegl1-nvidia (352.55-3 Debian:experimental [amd64])
Conf xserver-xorg-video-nvidia (352.55-3 Debian:experimental [amd64])
Conf nvidia-vdpau-driver (352.55-3 Debian:experimental [amd64])
Conf nvidia-driver (352.55-3 Debian:experimental [amd64])
Conf libgles2-nvidia (352.55-3 Debian:experimental [amd64])
Conf libgles1-nvidia (352.55-3 Debian:experimental [amd64])
Conf pkg-config (0.28-1 Debian:testing [amd64])
Conf libjansson4 (2.7-3 Debian:testing [amd64])
Conf libxnvctrl0 (346.59-1 Debian:experimental [amd64])
Conf nvidia-settings (346.59-1 Debian:experimental [amd64])
 



voila mon utilitaire nvidia est dans mon menu de Mate et fonctionne.
pour la ligne de commande de l installation de ton premier post c est la bonne (celle donné par le tuto de D_F )
avec les options "experimental , -t et -s " ça doit fonctionner de la meme maniere (moi j'ai mes habitudes pas toujours les bonnes neutral wink  )
pour cuda tu peut l installer par la suite ou pas.

Dernière modification par robert2a (14-11-2015 08:49:57)

En ligne

#10 14-11-2015 11:23:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Drivers expérimentaux Nvidia 352.x

Merci artisan robert2a smile

Au passage je t'ai mis les codes apt_sources dans tes balises pour ce qui concerne la lecture du fichier sources. C'est bientôt nowel, les guirlandes, les boules, les couleurs... tout ça quoi ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 14-11-2015 12:12:28

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

merci tu est un amour smile , regarde je viens de poster pour toi pour l utilisation du swap  wink

je vai essayer d etre plus pointu sur la rédaction tongue
par contre j ai du faire peur a  phil995511 , pas de retour roll 

lol

ps: quand on fait quelque chose comme ci dessus (jessie ou stretch ) comment on peu stabliser  sa debian , pour garder la version du driver sans perturber sa stable ou testing.
j accroche pas trop sur les fichiers preferences hmm

ps2: le code apt-sources , je note dans mon petit cerveau , a mon avis c est pas la premiere remarque pour ceci (j y pense pas roll a  l utiliser)

Edit à jojo :
Le code balise est apt_sources et pas apt-sources ! tongue

Dernière modification par smolski (15-11-2015 15:03:05)

En ligne

#12 15-11-2015 10:14:38

phil995511
Membre
Inscription : 13-11-2015

Re : Drivers expérimentaux Nvidia 352.x

Bonjour Robert & Smolski,

J' apporté la correction que vous m'avez suggéré du dépôt :

deb http://ftp.de.debian.org/debian experimental main contrib non-free
 



Malheureusement quand j'essaie d'installer le driver cela se termine par un échec :

station philippe # apt-get install -t experimental -s xserver-xorg-video-nvidia nvidia-driver nvidia-settings nvidia-cuda-toolkit
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 nvidia-cuda-toolkit : Dépend: nvidia-profiler (= 6.0.37-5) mais ne sera pas installé
                       Dépend: nvidia-cuda-dev (= 6.0.37-5) mais ne sera pas installé
 nvidia-driver : Dépend: libgl1-nvidia-glx (= 352.55-3) mais ne sera pas installé
                 Dépend: libegl1-nvidia (= 352.55-3) mais ne sera pas installé
                 Dépend: nvidia-driver-bin (= 352.55-3) mais ne sera pas installé
                 Dépend: nvidia-vdpau-driver (= 352.55-3) mais ne sera pas installé
                 Dépend: nvidia-alternative (= 352.55-3)
                 Dépend: nvidia-kernel-dkms (= 352.55-3) ou
                          nvidia-kernel-352.55
 nvidia-settings : Dépend: nvidia-alternative
 xserver-xorg-video-nvidia : Dépend: libgl1-nvidia-glx (= 352.55-3) mais ne sera pas installé
                             Dépend: nvidia-alternative (= 352.55-3)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».







Je bute sans arrêt sur ce même problème :

E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état »




Si je tente d'installer le .run de Nvidia, il s'installe sans le moindre problème, mais il m'est impossible de faire fonctionner Steam. Il me dit qu'il lui manque les drivers swrast_dri.so et swrast.

J'en perd mon latin... merci par avance pour votre aide.

Dernière modification par phil995511 (15-11-2015 14:16:14)

Hors ligne

#13 15-11-2015 10:57:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Drivers expérimentaux Nvidia 352.x

Il te faut être superutilisateur pour installer des paquets.
Comment qu'on se métamorphose en superutilisateur ? Clique ici pour le savoir !

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#14 15-11-2015 14:17:46

phil995511
Membre
Inscription : 13-11-2015

Re : Drivers expérimentaux Nvidia 352.x

Merci mais je sais déjà qu'il faut se loger en su ou utiliser sudo...

Cela ne fonctionne pas, il n'y a rien à faire...

Si j'utilise le .run de Nvidia qui lui fonctionne (ça sera peut-être plus simple), comment faire réussir à lancer Steam ? Il me dit qu'il lui manque les drivers swrast_dri.so et swrast sont manquants ?

Dernière modification par phil995511 (15-11-2015 14:57:04)

Hors ligne

#15 15-11-2015 15:03:53

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Drivers expérimentaux Nvidia 352.x

Tu as mis à jour après avoir modifier les sources ?

Désolé pour ce qui est dit alors que tu l'as réalisé, mais quand cela n'apparaît pas dans le fil, ça aide aussi les lecteurs éventuels. smile

Dernière modification par smolski (15-11-2015 15:04:47)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#16 15-11-2015 15:59:29

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

Pour le . run de nvidia il te faut purger les paquets nvidia et cuda des depots de debian , faire l installation en console (stoper le serveur X ) et installer les librairies 32.
mettre en service le multiarch comme preciser dans le tuto "installation de steam"
pour ton sources.list tu reste en jessie ?
si tu a basculé ta jessie en stretch c est pas bon non plus (en partie).
c 'est pour ça qu au debut j ai precisé que le .run est le mieux pour une stable. (quand on dispose d une carte tres récentes)
juste a mettre en service le multiarch sur ta debian
puis stoper le serveur X
lancer le .run (avec l indication de l endroit ou tu veut mettre les librairies 32 )
installer steam
et go fragger  tongue

ps: l erreur que tu donne serait connu sur le net , surement un probleme sur le driver

un exemple : pour avoir les librairies 32 avec le .run


./NVIDIA-Linux-86_64-352-41.run --compat32-libdir lib32
 



je te remet les liens utiles :
https://debian-facile.org/doc:jeux:steam

https://debian-facile.org/viewtopic.php?id=12119

ps: dans ton cas (si tu est a l aise en console ) je casse le serveur X , avec une purge des fichiers nvidia du genre :
(un sources.list correct)


apt-get clean
apt-get update
apt-get remove --purge nvidia*
reboot
 



tu te retrouve au prochain demarrage en console pure (serveur X stopé)
tu installe le multiarch


dpkg --add-architecture i386
 



apt-get update && apt-get install multiarch-support
 


tu confirme le nettoyage et tu installe ton .run


apt-get update
apt-get autoremove --purge
./NVIDIA-Linux-86_64-352-41.run --compat32-libdir lib32 #donner les droits a l executable avant
reboot
 


ensuite installation du jeu

ps: si de te retrouver en console (mode serveur) te fait peur ne fait pas cette manipulation , le but est de se retrouver avec une debian propre sans trace des installations ulterieures.
quand je tombe sur une machine qui pose probleme , je fais le grand ménage.
dans tout les cas , tu ne dois pas avoir de messages d erreur ( a l installation du .run et de steam (peut etre steam va te demander au lancement un truc "US" mais n est pas bloquant )).

encore une petite chose smile , ton profil n est pas renseigné , je ne peu pas te donner la commande pour stoper le serveur X . (je sais pas quel lanceur et quel bureau tu utilise wink  )

Dernière modification par robert2a (15-11-2015 16:41:06)

En ligne

#17 15-11-2015 16:44:37

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

robert2a a écrit :



Edit à jojo :
Le code balise est apt_sources et pas apt-sources ! tongue



heureusement que tu est la tongue  wink

En ligne

#18 16-11-2015 11:55:04

phil995511
Membre
Inscription : 13-11-2015

Re : Drivers expérimentaux Nvidia 352.x

Bonjour Robert & Smolsky,

Je reste en Jessie (LMDE2 & Cinnamon).

Voilà j'ai purgé mon système :

apt clean
apt update
apt remove --purge nvidia*
reboot



J'ai installé multiarch :

dpkg --add-architecture i386



apt-get update && apt-get install multiarch-support



Puis j'ai installé le driver Nvidia :


sudo /etc/init.d/mdm stop
apt-get update
apt-get autoremove --purge
./NVIDIA-Linux-86_64-352-41.run --compat32-libdir lib32 #donner les droits a l executable avant
reboot



J'ai configuré le tout avec DKMS, je lui ai demandé de m'installer les librairies 32 bits et de reconfigurer le serveur X automatiquement.

J'ai à nouveau un bel affichage en 1920x1080 j'ai installé Steam mais bien malheureusement il refuse de se lancer...

apt install steam




philippe@station ~ $ steam
Running Steam on linuxmint 2 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1444853545)
*** stack smashing detected ***: /home/philippe/.local/share/Steam/ubuntu12_32/steam terminated
crash_20151116104408_1.dmp[6588]: Uploading dump (out-of-process)
/tmp/dumps/crash_20151116104408_1.dmp
/home/philippe/.local/share/Steam/steam.sh : ligne 756 :  6585 Erreur de segmentation  $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
crash_20151116104408_1.dmp[6588]: Finished uploading minidump (out-of-process): success = yes
crash_20151116104408_1.dmp[6588]: response: CrashID=bp-4bfa3c95-87ba-42aa-bf55-187652151116
crash_20151116104408_1.dmp[6588]: file ''/tmp/dumps/crash_20151116104408_1.dmp'', upload yes: ''CrashID=bp-4bfa3c95-87ba-42aa-bf55-187652151116''



Bien à vous.

Philippe

Dernière modification par phil995511 (16-11-2015 12:08:32)

Hors ligne

#19 16-11-2015 12:26:29

phil995511
Membre
Inscription : 13-11-2015

Re : Drivers expérimentaux Nvidia 352.x

@ Robert

Dans le liens que tu m'as fourni https://debian-facile.org/doc:jeux:steam, ils disent d'installer :

apt-get install libgl1-nvidia-glx:i386



Je peux "mélanger" au driver .run la librairie "libgl1-nvidia-glx:i386" ??

Philippe

Hors ligne

#20 16-11-2015 13:16:31

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

non surtout pas , le tuto steam est pour une carte video nvidia ,normale tongue
toi tu a la derniere sorti du constructeur.
le .run si tu l installe avec les librairie 32 (comme je te l ai indiqué ) , tu n a besoin de rien
donc surtout pas installer un paquet debian relatif aux drivers nvidia
ps: c est pour cela que je t ai indiqué comment purger tout ce qui correspond au driver et cuda des depots debian.
si par exemple tu avais une GTX660 le tuto est parfait , le driver debian (non free ) prend en compte cette carte.
pour l instant jusqu a la carte GTX780TI , jessie et stretch doivent les prendre en compte (sauf la GTX750 (TI) qui a une version en maxwell , qui ne tournera pas sous jessie )

Dernière modification par robert2a (16-11-2015 13:23:09)

En ligne

#21 17-11-2015 12:46:48

phil995511
Membre
Inscription : 13-11-2015

Re : Drivers expérimentaux Nvidia 352.x

Je n'ai tjrs pas de solution pour faire fonctionner steam si ce n'est de changer d'OS...

Vous n'avez pas une idée à me proposer pour réussir à lancer steam ?

Bien à vous.

Dernière modification par phil995511 (17-11-2015 12:47:45)

Hors ligne

#22 17-11-2015 13:07:26

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

je comprend pas ton soucis sad
explique nous bien la ou tu bloque.
ta debian => jessie normalement
l installation du .run , tout se passe bien ?
ensuite installation de steam , il est sur les depots debian normalement => si erreur laquelle ?
ton sources.list complet pour savoir si il est correct.
beaucoup de personnes du forum jouent sur steam je pense.
pour le multiarch tu a reussi ?
et si tu n a pas compris quelque chose n hesite pas a demander , peut etre que j ai mal expliquer , quelqu un d autre peu te répondre.
ça fait un petit moment que je n ai plus installé steam , mais je dois l avoir installé sur une machine avec une GTX960.
tu ne détaille pas beaucoup le probleme que tu a tongue

En ligne

#23 17-11-2015 18:32:45

phil995511
Membre
Inscription : 13-11-2015

Re : Drivers expérimentaux Nvidia 352.x

Bonjour Robert,

Je suis sous LMDE2 (Mint) qui utilise Jessie comme base.

L'installation du .run de Nvidia se fait sans soucis.

Je peux installer Steam mais lorsque j'essaie de le lancer j'ai les erreurs suivantes :

philippe@station ~ $

steam


Running Steam on linuxmint 2 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1444853545)
*** stack smashing detected ***: /home/philippe/.local/share/Steam/ubuntu12_32/steam terminated
crash_20151116104408_1.dmp[6588]: Uploading dump (out-of-process)
/tmp/dumps/crash_20151116104408_1.dmp
/home/philippe/.local/share/Steam/steam.sh : ligne 756 :  6585 Erreur de segmentation  $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
crash_20151116104408_1.dmp[6588]: Finished uploading minidump (out-of-process): success = yes
crash_20151116104408_1.dmp[6588]: response: CrashID=bp-4bfa3c95-87ba-42aa-bf55-187652151116
crash_20151116104408_1.dmp[6588]: file ''/tmp/dumps/crash_20151116104408_1.dmp'', upload yes: ''CrashID=bp-4bfa3c95-87ba-42aa-bf55-187652151116''



Mon source liste est ok :

philippe@station ~ $

inxi -r



Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com betsy main upstream import
           deb http://ftp.us.debian.org/debian/ jessie main contrib non-free
           deb http://ftp.us.debian.org/debian/ jessie-updates main contrib non-free
           deb http://security.debian.org/ jessie/updates main contrib non-free
           deb http://www.deb-multimedia.org jessie main non-free
           deb http://extra.linuxmint.com betsy main
           Active apt sources in file: /etc/apt/sources.list.d/steam.list
           deb [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
           deb-src [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
 



Multiarch c'est installé sans problèmes.

Depuis que j'ai effectué la commande suivante :

apt-get install libgl1-nvidia-glx:i386



J'ai le Nvidia installer cleanup qui essaie de se lancer en boucle.

Voilà tout ce que je puis te dire je n'ai pas d'autres infos disponibles.

Merci beaucoup pour ton aide.

Dernière modification par phil995511 (17-11-2015 18:52:16)

Hors ligne

#24 17-11-2015 22:38:40

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : Drivers expérimentaux Nvidia 352.x

j'ai lancé steam sur ma machine , il tourne sans soucis sur "jessie+ Mate"
pour jessie le paquet s'appelle "steam:i386"  (sur stretch il n existe pas )
un apt-get install steam:i386  va t installer tous les paquets necessaires (comme tu utilise un mirroir debian pas de soucis smile )
pour le nvidia-glx un remove doit reparer le souci


apt-get update
apt-get remove --purge libgl1-nvidia-glx:i386
apt-get autoremove --purge
 


si le noyau n a pas ete modifié , l installation du .run doit etre encore correcte.
il ne faut pas que tu est un paquet (depot debian) des drivers non free nvidia installé avec le .run du site nvidia.
l installation de steam par le depots debian et l utilisation du .run ça doit fonctionner.
ps: avec Mate comme bureau (gnome et xfce idem ) j 'ai un lien "steam"  dans mon menu "jeux" , juste à cliquer dessus.

Dernière modification par robert2a (17-11-2015 22:41:09)

En ligne

#25 17-11-2015 23:48:07

tourbinux
Membre
Distrib. : Debian 8.6 (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE 4.14.2
Inscription : 03-11-2015

Re : Drivers expérimentaux Nvidia 352.x

Bonsoir,

robert2a a écrit :

si par exemple tu avais une GTX660 le tuto est parfait , le driver debian (non free ) prend en compte cette carte.
pour l instant jusqu a la carte GTX780TI , jessie et stretch doivent les prendre en compte (sauf la GTX750 (TI) qui a une version en maxwell , qui ne tournera pas sous jessie )

Pourquoi dis-tu que la Nvidia GeForce GTX 750 Ti n'est pas prise en compte par le pilote non-free dans Jessie ? J'ai installé le pilote propriétaire 340.65 depuis les dépôts et cela fonctionne. D'après le site nvidia http://www.nvidia.fr/Download/driverRes … x/80686/fr cette version du pilote prend bien en charge cette carte graphique. Donc cela voudrait dire si tu ne te trompes pas, que le 340.65 dans les dépôts Debian n'est pas exactement le même que le 340.65 officiel de Nvidia ?
Quoi qui l'en soit, mon affichage fonctionne bien avec cette carte/système/pilote (résolution de 1920 x 1200 pixels, effets de bureaux : cube, etc...) mais je rencontre quand même un problème, si jamais tu as une idée wink :

KDE 4 - Nvidia - Très légère latence lors du déplacement des fenêtres
https://debian-facile.org/viewtopic.php?id=12552

robert2a a écrit :

ensuite installation de steam , il est sur les depots debian normalement => si erreur laquelle ?

Effectivement, ce paquet est bien dispo dans Jessie https://packages.debian.org/jessie/steam
Un truc qui m'étonne par contre yikes c'est que Apper sous KDE ne le trouve pas roll pourtant je n'ai aucun filtre de recherche et je pense que mon /etc/apt/sources.list est correct :

#deb cdrom:[Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 kde-CD Binary-1 20150906-11:10]/ jessie main
#deb cdrom:[Debian GNU/Linux 8.2.0 _Jessie_ - Official amd64 kde-CD Binary-1 20150906-11:10]/ jessie main

# Debian Jessie. Depot principal + paquets non libres
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free

# Debian Jessie. Mises a jour de securite + paquets non libres
deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# Debian Jessie. Mises a jour "volatiles" + paquets non libres
# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

Hors ligne

Pied de page des forums