Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-11-2015 11:03:00

bigdong
Membre
Inscription : 18-11-2015

installer skype sur debian 8 jessie

Bonjour à tous,

Je m'inscris sur ce forum car j'ai essayer toute les manips pour installer skype sur debian 8 jessie.

Comme je vois que le poste date de pas trop longtemps je me permets de le réutiliser.

J'ai donc tenté les instructions fournis sur https://debian-facile.org/doc:reseau:skype sans succès.

J'ai l'impression que ma becan est trop vieille, quelque chose ne vas pas, ces instructions on bien fonctionné sur le x1 carbon.

sudo dpkg -i /tmp/skype-debian.deb
Selecting previously unselected package skype.
(Reading database ... 172105 files and directories currently installed.)
Preparing to unpack /tmp/skype-debian.deb ...
Unpacking skype (4.3.0.37-1) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libc6 (>= 2.3.6-6~); however:
  Package libc6:i386 is not installed.
 skype depends on libc6 (>= 2.7); however:
  Package libc6:i386 is not installed.
 skype depends on libgcc1 (>= 1:4.1.1); however:
  Package libgcc1:i386 is not installed.
 skype depends on libqt4-dbus (>= 4:4.5.3); however:
 skype depends on libqt4-network (>= 4:4.8.0); however:
 skype depends on libqt4-xml (>= 4:4.5.3); however:
 skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
 skype depends on libqtgui4 (>= 4:4.8.0); however:
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
 skype depends on libstdc++6 (>= 4.2.1); however:
 skype depends on libx11-6; however:
  Package libx11-6:i386 is not installed.
 skype depends on libxext6; however:
  Package libxext6:i386 is not installed.
 skype depends on libxss1; however:
  Package libxss1:i386 is not installed.
 skype depends on libxv1; however:
  Package libxv1:i386 is not installed.
 skype depends on l
dpkg: error processing package skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for dbus (1.8.20-0+deb8u1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 skype
 

Dernière modification par bigdong (18-11-2015 11:03:33)

Hors ligne

#2 18-11-2015 11:18:07

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer skype sur debian 8 jessie

Bonjour et bienvenue,

J'ai déplacé ton post dans une nouvelle discussion pour que tu aies des chances d'obtenir des réponses.
Tu peux toujours ajouter des liens vers des discussions analogues en référence.  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 18-11-2015 12:12:31

Kusajika
Membre
Inscription : 08-04-2015

Re : installer skype sur debian 8 jessie

Bonjour , et pour la deuxième solution proposée ça te donne quoi comme erreur ?

En ligne

#4 18-11-2015 12:16:48

zorzi
Membre
Distrib. : Debian Jessie + Backports
Noyau : Linux 3.16.0-4-amd64
Inscription : 30-09-2015

Re : installer skype sur debian 8 jessie

Hello.

Pour ma part, j'avais téléchargé skype (version debian) directement sur leur site.

Je l'ai installé ensuite avec gdebi (clic droit sur le paquet .deb puis "installer avec gdebi").

Et tout roule.

Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon X1650 Pro, Ram 4 Go, DD 500 Go) / Debian Jessie (Gnome)
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Jessie (Mate)

Hors ligne

#5 18-11-2015 12:45:33

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : installer skype sur debian 8 jessie

Salut!
Il manque des dépendances. Essaie de résoudre ça avec

apt-get install -f


Sinon, il faudra les installer à la main.


YA3HGA-H

Hors ligne

#6 18-11-2015 14:45:06

bigdong
Membre
Inscription : 18-11-2015

Re : installer skype sur debian 8 jessie

J'avais déjà essayé avec gdebi, c'est le même résultat il ne résous pas toutes les dépendances, comme ci je n'avais pas accès à certaine source contrairement à d'autre ?
Peut-être un problème de compatibilité avec la carte mère ?

sudo apt-get install -f
[sudo] password for me:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  ca-certificates-java i965-va-driver:i386 java-common libasound2:i386 libasyncns0:i386 libatk-wrapper-java libatk-wrapper-java-jni libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libavresample2:i386 libavutil54:i386 libbsd0:i386 libcap2:i386 libcdparanoia0:i386 libcomerr2:i386 libcups2:i386 libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
  libdrm-radeon1:i386 libdrm2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcrypt20:i386 libgif4 libgl1-mesa-glx:i386 libglapi-mesa:i386
  libgmp10:i386 libgnutls-deb0-28:i386 libgpg-error0:i386 libgsm1:i386 libgssapi-krb5-2:i386 libhogweed2:i386 libice-dev libice6:i386 libjbig0:i386 libjpeg62-turbo:i386 libjson-c2:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libmng1:i386 libmp3lame0:i386 libnettle4:i386 libogg0:i386 libopenjpeg5:i386 libopus0:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpciaccess0:i386 libpcre3:i386 libpng12-0:i386 libpthread-stubs0-dev libpulse0:i386 libsamplerate0:i386 libselinux1:i386 libsm-dev libsm6:i386 libsndfile1:i386 libspeex1:i386 libspeexdsp1:i386
  libsqlite3-0:i386 libssl1.0.0:i386 libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386 libudev1:i386 libva1:i386 libvdpau1:i386 libvisual-0.4-0:i386 libvorbis0a:i386 libvorbisenc2:i386
  libvpx1:i386 libwrap0:i386 libx11-6:i386 libx11-dev libx11-doc libx11-xcb1:i386 libx264-142:i386 libxau-dev libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-sync1:i386 libxcb1:i386 libxcb1-dev libxdamage1:i386 libxdmcp-dev libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxrender1:i386 libxshmfence1:i386 libxss1:i386 libxt-dev libxt6:i386
  libxtst6:i386 libxv1:i386 libxvidcore4:i386 libxxf86vm1:i386 openjdk-8-jre-headless va-driver-all:i386 vdpau-va-driver:i386 x11proto-core-dev x11proto-input-dev x11proto-kb-dev xorg-sgml-doctools
  xtrans-dev zlib1g:i386
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  skype:i386
0 upgraded, 0 newly installed, 1 to remove and 17 not upgraded.
1 not fully installed or removed.
After this operation, 44.3 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 172419 files and directories currently installed.)
Removing skype (4.3.0.37-1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
 


sudo dpkg -i /tmp/skype-debian.deb
Selecting previously unselected package skype.
(Reading database ... 172272 files and directories currently installed.)
Preparing to unpack /tmp/skype-debian.deb ...
Unpacking skype (4.3.0.37-1) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libqt4-dbus (>= 4:4.5.3).
 skype depends on libqt4-network (>= 4:4.8.0).
 skype depends on libqt4-xml (>= 4:4.5.3).
 skype depends on libqtcore4 (>= 4:4.7.0~beta1).
 skype depends on libqtgui4 (>= 4:4.8.0).
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13).
 skype depends on libstdc++6 (>= 4.2.1).
 skype depends on libasound2-plugins.

dpkg: error processing package skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for dbus (1.8.20-0+deb8u1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 skype
 

Dernière modification par bigdong (18-11-2015 14:48:01)

Hors ligne

#7 18-11-2015 14:50:06

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : installer skype sur debian 8 jessie

Il ne te reste plus qu'à installer à la main les paquets suivants :
skype depends on libqt4-dbus (>= 4:4.5.3).
skype depends on libqt4-network (>= 4:4.8.0).
skype depends on libqt4-xml (>= 4:4.5.3).
skype depends on libqtcore4 (>= 4:4.7.0~beta1).
skype depends on libqtgui4 (>= 4:4.8.0).
skype depends on libqtwebkit4 (>= 2.1.0~2011week13).
skype depends on libstdc++6 (>= 4.2.1).
skype depends on libasound2-plugins.

YA3HGA-H

Hors ligne

#8 18-11-2015 14:51:04

bigdong
Membre
Inscription : 18-11-2015

Re : installer skype sur debian 8 jessie

sudo apt-get install libqt4-dbus



Reading package lists... Done
Building dependency tree      
Reading state information... Done
libqt4-dbus is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 skype:i386 : Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
              Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
              Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
              Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
              Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
              Depends: libqtwebkit4:i386 (>= 2.1.0~2011week13) but it is not going to be installed
              Depends: libstdc++6:i386 (>= 4.2.1) but it is not going to be installed
              Depends: libasound2-plugins:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
 



sudo apt-get -f install



Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  ca-certificates-java i965-va-driver:i386 java-common libasound2:i386 libasyncns0:i386 libatk-wrapper-java libatk-wrapper-java-jni libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libavresample2:i386 libavutil54:i386 libbsd0:i386 libcap2:i386 libcdparanoia0:i386 libcomerr2:i386 libcups2:i386 libdbus-1-3:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
  libdrm-radeon1:i386 libdrm2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcrypt20:i386 libgif4 libgl1-mesa-glx:i386 libglapi-mesa:i386
  libgmp10:i386 libgnutls-deb0-28:i386 libgpg-error0:i386 libgsm1:i386 libgssapi-krb5-2:i386 libhogweed2:i386 libice-dev libice6:i386 libjbig0:i386 libjpeg62-turbo:i386 libjson-c2:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libmng1:i386 libmp3lame0:i386 libnettle4:i386 libogg0:i386 libopenjpeg5:i386 libopus0:i386 liborc-0.4-0:i386 libp11-kit0:i386
  libpciaccess0:i386 libpcre3:i386 libpng12-0:i386 libpthread-stubs0-dev libpulse0:i386 libsamplerate0:i386 libselinux1:i386 libsm-dev libsm6:i386 libsndfile1:i386 libspeex1:i386 libspeexdsp1:i386
  libsqlite3-0:i386 libssl1.0.0:i386 libsystemd0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386 libudev1:i386 libva1:i386 libvdpau1:i386 libvisual-0.4-0:i386 libvorbis0a:i386 libvorbisenc2:i386
  libvpx1:i386 libwrap0:i386 libx11-6:i386 libx11-dev libx11-doc libx11-xcb1:i386 libx264-142:i386 libxau-dev libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-sync1:i386 libxcb1:i386 libxcb1-dev libxdamage1:i386 libxdmcp-dev libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxrender1:i386 libxshmfence1:i386 libxss1:i386 libxt-dev libxt6:i386
  libxtst6:i386 libxv1:i386 libxvidcore4:i386 libxxf86vm1:i386 openjdk-8-jre-headless va-driver-all:i386 vdpau-va-driver:i386 x11proto-core-dev x11proto-input-dev x11proto-kb-dev xorg-sgml-doctools
  xtrans-dev zlib1g:i386
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  skype:i386
0 upgraded, 0 newly installed, 1 to remove and 17 not upgraded.
1 not fully installed or removed.
After this operation, 44.3 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 172419 files and directories currently installed.)
Removing skype (4.3.0.37-1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
 




Je tourne en rond comme je disais hmm

Dernière modification par bigdong (18-11-2015 14:58:17)

Hors ligne

#9 18-11-2015 16:55:21

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : installer skype sur debian 8 jessie

ça donne quoi ?

dpkg --print-architecture


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#10 18-11-2015 17:54:58

bigdong
Membre
Inscription : 18-11-2015

Re : installer skype sur debian 8 jessie

dpkg --print-architecture
amd64

Hors ligne

#11 18-11-2015 18:12:19

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer skype sur debian 8 jessie

Il te faut l'archtecturei i386 : https://debian-facile.org/doc:reseau:skype

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#12 18-11-2015 18:31:46

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : installer skype sur debian 8 jessie

dpkg --add-architecture i386


apt-get install multiarch-support



(la commande d'installation de multiarch-support n'est pas indiqué sur le wiki de skype)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#13 18-11-2015 18:36:39

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer skype sur debian 8 jessie

Je ne pense pas qu'elle est indispensable ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#14 18-11-2015 18:42:52

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : installer skype sur debian 8 jessie

(aucune idée, je n'utilise pas skype tongue)
par contre c'est indiqué comme ça sur le wiki steam (qui tourne aussi en 32 comme skype)
donc je me dis que ça doit fonctionner pareil smile
wiki steam

Prérequis
Architecture

Le paquet Steam ne fonctionne pour le moment que sur des architectures de type i386 (32bits). Pour les systèmes 64 bits il faut activer le support multiarch avant de pouvoir lancer l'installation :

dpkg --add-architecture i386
apt-get update && apt-get install multiarch-support


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#15 18-11-2015 18:47:27

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer skype sur debian 8 jessie

Bon ...  big_smile

Pourtant, quand je vois le contenu du paquet ...  tongue

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#16 18-11-2015 19:19:41

bigdong
Membre
Inscription : 18-11-2015

Re : installer skype sur debian 8 jessie

Severian a écrit :

dpkg --add-architecture i386


apt-get install multiarch-support



(la commande d'installation de multiarch-support n'est pas indiqué sur le wiki de skype)



sudo dpkg --add-architecture i386



[sudo] password for me:
me@dev-02:[~]: sudo apt-get install multiarch-support
Reading package lists... Done
Building dependency tree      
Reading state information... Done
multiarch-support is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 skype:i386 : Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
              Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
              Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
              Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
              Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
              Depends: libqtwebkit4:i386 (>= 2.1.0~2011week13) but it is not going to be installed
              Depends: libstdc++6:i386 (>= 4.2.1) but it is not going to be installed
              Depends: libasound2-plugins:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
 

Hors ligne

#17 18-11-2015 19:21:56

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer skype sur debian 8 jessie

sudo apt-get -f install


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#18 21-11-2015 19:16:51

bigdong
Membre
Inscription : 18-11-2015

Re : installer skype sur debian 8 jessie

Paskal, déjà fait... on tourne en rond lol

Regarde le poste que j'ai fais du 18-11-2015 13:51:04

Hors ligne

#19 21-11-2015 19:42:56

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer skype sur debian 8 jessie

Pas du tout : à ce moment-là, tu n'avais pas l'architecture te permettant d'installer les paquets en i386  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 21-11-2015 19:46:43

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : installer skype sur debian 8 jessie

j'ai une question ...

quand tu est en terminal, tu es sur ta session utilisateur ? ou en root (su)

parce que quand tu passe tes commandes sur le forum c'est en root (donc en su) et tu utilise en même temps sudo, je ne sais pas si c'est compatible smile

sinon comme suggéré par Thuban

Thuban a écrit :

Il ne te reste plus qu'à installer à la main les paquets suivants :
skype depends on libqt4-dbus (>= 4:4.5.3).
skype depends on libqt4-network (>= 4:4.8.0).
skype depends on libqt4-xml (>= 4:4.5.3).
skype depends on libqtcore4 (>= 4:4.7.0~beta1).
skype depends on libqtgui4 (>= 4:4.8.0).
skype depends on libqtwebkit4 (>= 2.1.0~2011week13).
skype depends on libstdc++6 (>= 4.2.1).
skype depends on libasound2-plugins.


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#21 21-11-2015 20:10:59

bigdong
Membre
Inscription : 18-11-2015

Re : installer skype sur debian 8 jessie

J'execute avec sudo, ce qui est pareil que root car j'ai rajoute mon user dans les sudoers, je n'ai jamais eu de problème mis à par skype.

J'utilise debian sur nombreux depuis quelques années déjà.

La suggestion de Thuban est pas possible (voir plus haut)

Hors ligne

#22 21-11-2015 20:14:43

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer skype sur debian 8 jessie

Après ton #16, que renvoi désormais :

apt-get -f install


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums