Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-11-2015 20:16:57

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

erreur à l'installation de PostgreSQL pour python3[résolu]

Bonjour,

pour installer PostgreSQL et l'utiliser avec Django

j'ai lancé la commande suivante

apt-get install python-pip python-dev libpq-dev postgresql postgresql-contrib



et j'ai eu le retour

Des erreurs ont été rencontrées pendant l'exécution :
 python-colorama
 python-distlib
 python-html5lib
 python-ndg-httpsclient
 python-urllib3
 python-requests
 python-setuptools
 python-pip
 python-wheel
E: Sub-process /usr/bin/dpkg returned an error code (1)



Comment je peux arranger cela ?

Merci

Dernière modification par Hypathie (29-11-2015 22:34:39)

Hors ligne

#2 29-11-2015 20:54:16

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : erreur à l'installation de PostgreSQL pour python3[résolu]

Bonsoir Hypathie,

Quelles sont les erreurs retournées par :

dpkg --configure -a


Puis que se passe-t-il quand tu fais :

apt-get install -f


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 29-11-2015 21:07:23

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : erreur à l'installation de PostgreSQL pour python3[résolu]

Coucou paskal  :)


dpkg --configure -a





Paramétrage de python-setuptools (5.5.1-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-setuptools (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 python-setuptools




apt-get install -f



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
7 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 29, in <module>
    import anydbm
ImportError: No module named 'anydbm'
Paramétrage de python-colorama (0.3.2-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-colorama (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-distlib (0.1.9-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-distlib (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-html5lib (0.999-3) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-html5lib (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-ndg-httpsclient (0.3.2-1) ...
  File "/usr/sbin/update-python-modules", line 52
    print x
          ^
SyntaxError: Missing parentheses in call to 'print'
dpkg: erreur de traitement du paquet python-ndg-httpsclient (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-setuptools (5.5.1-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-setuptools (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-urllib3 (1.9.1-3) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-urllib3 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de python-wheel (0.24.0-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-wheel (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 python-colorama
 python-distlib
 python-html5lib
 python-ndg-httpsclient
 python-setuptools
 python-urllib3
 python-wheel
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Hors ligne

#4 29-11-2015 21:20:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : erreur à l'installation de PostgreSQL pour python3[résolu]

Je manque de temps aujourd'hui pour approfondir mais, si tu es en Python 3, tu peux voir :
http://stackoverflow.com/questions/1408 … nfigparser
https://github.com/clinton-hall/nzbToMedia/issues/266
https://github.com/farcepest/MySQLdb1/issues/14
Le module a été renommé en configparsersad

Pour "No module named 'anydbm'", je ne vois pas.  hmm

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 29-11-2015 21:24:41

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : erreur à l'installation de PostgreSQL pour python3[résolu]

merci smile

Hors ligne

#6 29-11-2015 21:55:01

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : erreur à l'installation de PostgreSQL pour python3[résolu]

J'ai fait

rm /var/lib/dpkg/info/python*



puis

apt-get --purge autoremove le_paquet_qui_bloque



ça a amélioré le retour mais le problème est circonscrit  à l'installation de python-pip :


apt-get install python-pip



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
python-pip est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 29, in <module>
    import anydbm
ImportError: No module named 'anydbm'
Paramétrage de python-pip (1.5.6-5) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-pip (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 python-pip
E: Sub-process /usr/bin/dpkg returned an error code (1)




et

apt-get install -f



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 29, in <module>
    import anydbm
ImportError: No module named 'anydbm'
Paramétrage de python-pip (1.5.6-5) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erreur de traitement du paquet python-pip (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 python-pip
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Hors ligne

#7 29-11-2015 22:33:50

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : erreur à l'installation de PostgreSQL pour python3[résolu]

C'est bon !

j'aurai dû penser à ma version courante de python big_smile

python --version



Python 3.4.2



Donc il fallait faire :

apt-get install python3-pip libpq-dev postgresql postgresql-contrib



Avec python3 pas besoin d'installer les python3-dev python3-setuptools, ils s'installent avec python3-pip

Hors ligne

#8 29-11-2015 22:35:13

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : erreur à l'installation de PostgreSQL pour python3[résolu]

Bien vu !  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums