Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-12-2015 19:46:29

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

[Résolu] Installation des derniers driver nvidia depuis repo steamos

Bonjour,

J'aimerai savoir si quelqu'un a déjà testé d'installer les derniers drivers nvidia depuis les dépots steamos ?
https://wiki.debian.org/NvidiaGraphicsD … ository.29

Dernière modification par nIQnutn (19-12-2015 20:20:24)

Hors ligne

#2 11-12-2015 03:44:28

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

Bonsoir
non jamais ,testé
je reste dans les dépots debian , a part le .run éventuellement (pour GTX 950 , 960 , 970 et 980 ti/x )
je ne pense pas que steam installe cuda avec le driver (les jeux doivent tourner en OpenGL sous linux)

pourquoi pas tester roll sur une machine qui a pas trop d importance .

Hors ligne

#3 11-12-2015 09:41:51

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

[terroriste-libriste-du-vendredi]C'est pas libre, donc non, j'ai pas testé. Trop dangereux pour ma machine big_smile [/terroriste-libriste-du-vendredi]

YA3HGA-H

Hors ligne

#4 11-12-2015 11:11:03

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

si on avait des pilotes libres aussi performant que les proprios ça irait bien.

J'étais motivé hier mais je pense que je vais installer un truc à coté pour éviter de faire un truc bâtard.

Hors ligne

#5 11-12-2015 12:30:52

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

C'est justement avec les à-côtés qu'on fait des bâtards lol

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 11-12-2015 13:55:46

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

On a du libre performant , "nouveau" et "Mesa"  avec du materiel recent mais pas trop ça tourne super bien.
entre les technologies propiétaires et le reste pas évident de rester 100% libre hmm
pour Ati/Amd , tant qu il y aura le firmware non free a mettre je considere qu ils seront jamais libre (mode / tete de mule ).
Ce qui est sur , ils travaillent sur le non free pour notre plus grand plaisir , le noyau reçoit des améliorations , idem pour les drivers. 
le fglrx d Ati a pris quelques versions de plus il faudra que je teste de nouveau.
Prendre des paquets un peu n importe ou, pour une machine en production ça me tente pas trop.
Sur un bureau Mate j ai une GTX980 avec "nouveau" et "Mesa" le bureau est nickel , pas testé un jeux , Quake III  doit tourner wink
juste quelques messages au démarrage du noyau pour nouveau qui n a pas encore toutes les fonctions de ces dernieres cartes.
Je pense que le travail qu ils font sur les drivers propriétaires leur permet d'améliorer par la suite les drivers libres.
Ce qui est inquiétant c'est que pour  le materiel , on va avoir de moins en moins de choix , si Amd disparait (il a vendu déja pas mal de choses ) , il restera Intel et Microsoft roll

Hors ligne

#7 11-12-2015 17:53:56

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

je cherche à installer le dernier driver pour jouer.
déjà que la plupart des jeux ne sont pas natifs et souffrent de performance, utiliser les drivers libres me semblent impossible.
J'ai déjà le driver propriétaire nvidia mais il faut le dernier pour lancer le jeu.

il y aurait peut être possibilité de faire du pinning avec la branche buggy mais j'ai pas trop confiance. Je préfère attendre et tester sur une autre branche.
En attendant, j'ai redémarré windows pour jouer mais l'OS ne sait pas gérer les mises à jour (entre 3 et 4 heures pour 150 mises à jour qui ont plantés 2 fois).

Hors ligne

#8 11-12-2015 19:31:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

Lorsque l'on tarde trop pour faire les mises à jour w celui-ci peut avoir des mises à jour à installer qui précèdent celles à venir, d'où plantage.
Il te faut selectionner les mises à jour manuellement (10 par 10) et quand ça plante sauter la mise à jour qui fait planter et passer aux suivantes.

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 11-12-2015 20:01:16

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

smolski a écrit :

Lorsque l'on tarde trop pour faire les mises à jour w celui-ci peut avoir des mises à jour à installer qui précèdent celles à venir, d'où plantage.
Il te faut selectionner les mises à jour manuellement (10 par 10) et quand ça plante sauter la mise à jour qui fait planter et passer aux suivantes.


il faut être tolérant envers cette startup qui débute avec son OS lol
j'avais pas envie de faire ça 15 fois avec les redémarrage qui vont avec sachant que ça allait rebooter automatiquement sur Debian. Et c'est pas tout, le temps de récupérer les mises à jour disponibles de très longues minutes, télécharger 500Mo pendant une éternité et installer les mises à jour (tu cliques sur redémarrer > ça relance une étape de mise à jour, au redémarrage > encore une étape qui t'annonce que t'as tout planté).
Quand tu vois que pendant cette mise à jour le système utilise plus de 5Go de RAM, ça fait peur.

Hors ligne

#10 11-12-2015 20:03:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

J'viens de mettre à jour un vista que j'utilise pour le pilote canon de mon imprimante pro. 5h en tout. cool

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 11-12-2015 20:14:32

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

visiblement y'a du progrès parce que j'ai mis moins de temps avec 7 lol

Hors ligne

#12 11-12-2015 20:29:31

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

105 mises à jour...
Et j'ai un second portable à faire aussi... smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 12-12-2015 01:55:34

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

nIQnutn a écrit :

je cherche à installer le dernier driver pour jouer.
déjà que la plupart des jeux ne sont pas natifs et souffrent de performance, utiliser les drivers libres me semblent impossible.
J'ai déjà le driver propriétaire nvidia mais il faut le dernier pour lancer le jeu.

il y aurait peut être possibilité de faire du pinning avec la branche buggy mais j'ai pas trop confiance. Je préfère attendre et tester sur une autre branche.
En attendant, j'ai redémarré windows pour jouer mais l'OS ne sait pas gérer les mises à jour (entre 3 et 4 heures pour 150 mises à jour qui ont plantés 2 fois).



si tu a déja le drivers propiétaire nvidia , --uninstall puis tu installe le dernier ça va trés vite , avec jessie il n y a pas de soucis.

pour l experimental faut geler les mises a jour apres son installation sinon chaque fois je plante stretch tongue

pour windows depuis la sortie de win10 plus de mise a jour du 7 et 8.1 , tant qu il fonctionne ça roule , deja avec directx12 il rend tous les anciens OS obsolètes .
ils vont bien trouver autre chose pour forcer la main pour passer au 10 (avec leur ami Intel )

Hors ligne

#14 12-12-2015 02:12:12

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

robert2a a écrit :

ils vont bien trouver autre chose pour forcer la main pour passer au 10 (avec leur ami Intel )


Ouaip, en ce moment ils offrent dix albums aux utilisateurs de Windows 10 :
http://www.pcworld.com/article/3014435/ … idays.html

Hey, avant je plaisantais avec ça, mais en fait c’est désormais vraiment le cas : Microsoft a commencé à *payer* les gens pour utiliser son système roll

-----

Désolé nIQnutn, je ne déraillerai pas plus la discussion, mais je trouvais cette anecdote trop amusante pour ne pas la partager wink


Jouer sous Debian ? Facile !

Hors ligne

#15 12-12-2015 02:16:50

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

c'est pire que ce que j imaginais , et vous faites les mises a jour , il est capable d injecter une saleté pour forcer le passage a 10 tongue  => []

Hors ligne

#16 12-12-2015 10:50:13

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

robert2a a écrit :

pour l experimental faut geler les mises a jour apres son installation sinon chaque fois je plante stretch tongue


avec du pinning, c'est facile mais je vais pas m'embeter pour le moment. je ferai ça sur une autre partition si besoin.


Pour W, il parait que c'est un bug qui forçait la mise à jour (c'est pas de chance big_smile). Si M continuait à faire du logiciel propriétaire, ça passerait encore mais là ça devient pire que les autres.
Si M peut offrir des Albums, il pourrait également donner des distribs à installer en cas de mécontentement smile

Hors ligne

#17 13-12-2015 12:15:37

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

j'ai regardé par curiosité avec les dépôts steamos

 aptitude install -s -t brewmaster libegl1-nvidia:amd64 libgl1-nvidia-glx:amd64 libgl1-nvidia-glx:i386 libgl1-nvidia-glx-i386 libgles1-nvidia:amd64 libgles2-nvidia:amd64 libnvidia-eglcore:amd64 libnvidia-ml1:amd64 libxnvctrl0 nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-kernel-dkms nvidia-modprobe nvidia-settings nvidia-vdpau-driver:amd64 xserver-xorg-video-nvidia
 


aptitude install -s -t brewmaster libegl1-nvidia:amd64 libgl1-nvidia-glx:amd64 libgl1-nvidia-glx:i386 libgl1-nvidia-glx-i386 libgles1-nvidia:amd64 libgles2-nvidia:amd64 libnvidia-eglcore:amd64 libnvidia-ml1:amd64 libxnvctrl0 nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-kernel-dkms nvidia-modprobe nvidia-settings nvidia-vdpau-driver:amd64 xserver-xorg-video-nvidia
Note : sélection de « libgl1-nvidia-glx-i386:i386 » à la place du
       paquet virtuel « libgl1-nvidia-glx-i386 »
Les NOUVEAUX paquets suivants vont être installés :
  libgl1-nvidia-glx-i386:i386 nvidia-kernel-support{a} nvidia-persistenced{a}
Les paquets suivants seront ENLEVÉS :
  libjansson4{u} nvidia-settings{u}
Les paquets suivants seront mis à jour :
  glx-alternative-nvidia glx-diversions libegl1-nvidia libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgles1-nvidia libgles2-nvidia
  libnvidia-eglcore libnvidia-ml1 libvdpau1 libvdpau1:i386 libxnvctrl0 nvidia-alternative nvidia-driver nvidia-driver-bin
  nvidia-kernel-common nvidia-kernel-dkms nvidia-modprobe nvidia-vdpau-driver xserver-xorg-video-nvidia
20 paquets mis à jour, 3 nouvellement installés, 2 à enlever et 1142 non mis à jour.
Il est nécessaire de télécharger 31,2 Mo d'archives. Après dépaquetage, 10,8 Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 glx-alternative-mesa : Dépend: glx-diversions (= 0.5.1) mais 0.6.93+bsos1 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                          
1)      glx-alternative-mesa                                    
2)      glx-alternative-nvidia                                  
3)      libegl1-nvidia                                          
4)      libgl1-nvidia-glx                                        
5)      libgl1-nvidia-glx:i386                                  
6)      libgles1-nvidia                                          
7)      libgles2-nvidia                                          
8)      libnvidia-ml1                                            
9)      nvidia-alternative                                      
10)     nvidia-driver                                            
11)     nvidia-driver-bin                                        
12)     nvidia-kernel-common                                    
13)     nvidia-kernel-dkms                                      
14)     nvidia-vdpau-driver                                      
15)     xserver-xorg-video-nvidia                                

      Conserver les paquets suivants dans leur version actuelle :
16)     libgl1-nvidia-glx-i386:i386 [Non installé]              
17)     nvidia-kernel-support [Non installé]                    

      Laisser les dépendances suivantes non satisfaites :        
18)     glx-diversions recommande glx-alternative-mesa          
19)     nvidia-driver-bin recommande nvidia-driver              


Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

     Mettre à jour les paquets suivants :                                  
1)     glx-alternative-mesa [0.5.1 (now, stable) -> 0.6.93+bsos1 (testing)]



Accepter cette solution ? [Y/n/q/?] y
Les NOUVEAUX paquets suivants vont être installés :
  libgl1-nvidia-glx-i386:i386 nvidia-kernel-support{a} nvidia-persistenced{a}
Les paquets suivants seront ENLEVÉS :
  libjansson4{u} nvidia-settings{u}
Les paquets suivants seront mis à jour :
  glx-alternative-mesa glx-alternative-nvidia glx-diversions libegl1-nvidia libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgles1-nvidia
  libgles2-nvidia libnvidia-eglcore libnvidia-ml1 libvdpau1 libvdpau1:i386 libxnvctrl0 nvidia-alternative nvidia-driver
  nvidia-driver-bin nvidia-kernel-common nvidia-kernel-dkms nvidia-modprobe nvidia-vdpau-driver xserver-xorg-video-nvidia
21 paquets mis à jour, 3 nouvellement installés, 2 à enlever et 1141 non mis à jour.
Il est nécessaire de télécharger 31,2 Mo d'archives. Après dépaquetage, 10,8 Mo seront libérés.
Voulez-vous continuer ? [Y/n/?] y
ATTENTION : des versions non certifiées des paquets suivants vont
être installées.

Des paquets non certifiés peuvent compromettre la sécurité de votre
système. Vous ne devriez les installer que si vous êtes certain
que c'est bien votre intention.

  nvidia-alternative libegl1-nvidia libgles2-nvidia nvidia-driver xserver-xorg-video-nvidia libgl1-nvidia-glx-i386:i386
  glx-alternative-mesa nvidia-modprobe nvidia-kernel-support glx-diversions libgl1-nvidia-glx libgl1-nvidia-glx:i386
  nvidia-kernel-dkms libgles1-nvidia libnvidia-ml1 glx-alternative-nvidia nvidia-vdpau-driver nvidia-driver-bin nvidia-kernel-common
  libvdpau1 libvdpau1:i386 libnvidia-eglcore libxnvctrl0

Voulez-vous ignorer cet avertissement et continuer quand même ?
Pour continuer, entrer « Oui ». Pour interrompre l'installation, entrer « Non » : oui
Charger/installer/enlever des paquets.
 

Hors ligne

#18 13-12-2015 13:51:16

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

pour faire propre , j enleverai le driver debian avant et retour a "nouveau" (ou pas )
desactivation du xorg.conf
purge des paquets nvidia relatif au driver debian
mise a jour du driver depuis steam
d'apres ton post ça a l air correct.

Hors ligne

#19 13-12-2015 14:07:31

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

je vais pas aller plus loin mais j'ai espoir que ça arrive dans les backports big_smile

je reste uniquement sur les dépôts debian par fainéantise.

Hors ligne

#20 14-12-2015 15:42:37

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

passage des driver à la version 352.55 OK


1. les commandes pour intaller
2. mes pb pour des paquets en attentes de mises à jour et gestion des préférences des dépots.

apt update
...
apt-get install valve-archive-keyring
...
aptitude install -t brewmaster libegl1-nvidia:amd64 libgl1-nvidia-glx:amd64 libgl1-nvidia-glx:i386 libgl1-nvidia-glx-i386 libgles1-nvidia:amd64 libgles2-nvidia:amd64 libnvidia-eglcore:amd64 libnvidia-ml1:amd64 libxnvctrl0 nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-kernel-dkms nvidia-modprobe nvidia-settings nvidia-vdpau-driver:amd64 xserver-xorg-video-nvidia
 




  Note : sélection de « libgl1-nvidia-glx-i386:i386 » à la place du
       paquet virtuel « libgl1-nvidia-glx-i386 »
  Les NOUVEAUX paquets suivants vont être installés :
    libgl1-nvidia-glx-i386:i386 nvidia-kernel-support{a} nvidia-persistenced{a}
  Les paquets suivants seront ENLEVÉS :
    libjansson4{u} nvidia-settings{u}
  Les paquets suivants seront mis à jour :
    glx-alternative-nvidia glx-diversions libegl1-nvidia libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgles1-nvidia libgles2-nvidia
    libnvidia-eglcore libnvidia-ml1 libvdpau1 libvdpau1:i386 libxnvctrl0 nvidia-alternative nvidia-driver nvidia-driver-bin
    nvidia-kernel-common nvidia-kernel-dkms nvidia-modprobe nvidia-vdpau-driver xserver-xorg-video-nvidia
  20 paquets mis à jour, 3 nouvellement installés, 2 à enlever et 1142 non mis à jour.
  Il est nécessaire de télécharger 31,2 Mo d'archives. Après dépaquetage, 10,8 Mo seront libérés.
  Les paquets suivants ont des dépendances non satisfaites :
   glx-alternative-mesa : Dépend: glx-diversions (= 0.5.1) mais 0.6.93+bsos1 doit être installé.
  Internal error: found 2 (choice -> promotion) mappings for a single choice.
  Internal error: found 2 (choice -> promotion) mappings for a single choice.
  Internal error: found 2 (choice -> promotion) mappings for a single choice.
  Internal error: found 2 (choice -> promotion) mappings for a single choice.
  Internal error: found 2 (choice -> promotion) mappings for a single choice.
  Internal error: found 2 (choice -> promotion) mappings for a single choice.
  Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                          
  1)      glx-alternative-mesa                                    
  2)      glx-alternative-nvidia                                  
  3)      libegl1-nvidia                                          
  4)      libgl1-nvidia-glx                                        
  5)      libgl1-nvidia-glx:i386                                  
  6)      libgles1-nvidia                                          
  7)      libgles2-nvidia                                          
  8)      libnvidia-ml1                                            
  9)      nvidia-alternative                                      
  10)     nvidia-driver                                            
  11)     nvidia-driver-bin                                        
  12)     nvidia-kernel-common                                    
  13)     nvidia-kernel-dkms                                      
  14)     nvidia-vdpau-driver                                      
  15)     xserver-xorg-video-nvidia                                

      Conserver les paquets suivants dans leur version actuelle :
  16)     libgl1-nvidia-glx-i386:i386 [Non installé]              
  17)     nvidia-kernel-support [Non installé]                    

      Laisser les dépendances suivantes non satisfaites :        
  18)     glx-diversions recommande glx-alternative-mesa          
  19)     nvidia-driver-bin recommande nvidia-driver              


  Accepter cette solution ? [Y/n/q/?] n
  Les actions suivantes permettront de résoudre ces dépendances :

     Mettre à jour les paquets suivants :                                  
  1)     glx-alternative-mesa [0.5.1 (now, stable) -> 0.6.93+bsos1 (testing)]



  Accepter cette solution ? [Y/n/q/?] y
  Les NOUVEAUX paquets suivants vont être installés :
    libgl1-nvidia-glx-i386:i386 nvidia-kernel-support{a} nvidia-persistenced{a}
  Les paquets suivants seront ENLEVÉS :
    libjansson4{u} nvidia-settings{u}
  Les paquets suivants seront mis à jour :
    glx-alternative-mesa glx-alternative-nvidia glx-diversions libegl1-nvidia libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgles1-nvidia
    libgles2-nvidia libnvidia-eglcore libnvidia-ml1 libvdpau1 libvdpau1:i386 libxnvctrl0 nvidia-alternative nvidia-driver
    nvidia-driver-bin nvidia-kernel-common nvidia-kernel-dkms nvidia-modprobe nvidia-vdpau-driver xserver-xorg-video-nvidia
  21 paquets mis à jour, 3 nouvellement installés, 2 à enlever et 1141 non mis à jour.
  Il est nécessaire de télécharger 31,2 Mo d'archives. Après dépaquetage, 10,8 Mo seront libérés.
  Voulez-vous continuer ? [Y/n/?] y
  Prendre :  1 http://ftp.fr.debian.org/debian/ jessie-backports/contrib nvidia-persistenced amd64 358.09-1~bpo8+1 [19,9 kB]
  Prendre :  2 http://repo.steampowered.com/steamos/ brewmaster/non-free nvidia-driver amd64 352.55-2+steamos1+bsos1 [432 kB]
  Prendre :  3 http://repo.steampowered.com/steamos/ brewmaster/non-free nvidia-driver-bin amd64 352.55-2+steamos1+bsos1 [226 kB]
  Prendre :  4 http://repo.steampowered.com/steamos/ brewmaster/non-free nvidia-alternative amd64 352.55-2+steamos1+bsos1 [148 kB]
  Prendre :  5 http://repo.steampowered.com/steamos/ brewmaster/contrib glx-alternative-nvidia amd64 0.6.93+bsos1 [4 560 B]
  Prendre :  6 http://repo.steampowered.com/steamos/ brewmaster/non-free xserver-xorg-video-nvidia amd64 352.55-2+steamos1+bsos1 [3 139 kB]
  Prendre :  7 http://repo.steampowered.com/steamos/ brewmaster/non-free libnvidia-ml1 amd64 352.55-2+steamos1+bsos1 [450 kB]              
  Prendre :  8 http://repo.steampowered.com/steamos/ brewmaster/contrib glx-alternative-mesa amd64 0.6.93+bsos1 [3 492 B]                  
  Prendre :  9 http://repo.steampowered.com/steamos/ brewmaster/contrib glx-diversions amd64 0.6.93+bsos1 [10,0 kB]                        
  Prendre :  10 http://repo.steampowered.com/steamos/ brewmaster/non-free libgl1-nvidia-glx i386 352.55-2+steamos1+bsos1 [6 992 kB]        
  Prendre :  11 http://repo.steampowered.com/steamos/ brewmaster/non-free libgl1-nvidia-glx amd64 352.55-2+steamos1+bsos1 [7 287 kB]        
  Prendre :  12 http://repo.steampowered.com/steamos/ brewmaster/non-free libgles2-nvidia amd64 352.55-2+steamos1+bsos1 [167 kB]            
  Prendre :  13 http://repo.steampowered.com/steamos/ brewmaster/non-free libgles1-nvidia amd64 352.55-2+steamos1+bsos1 [162 kB]            
  Prendre :  14 http://repo.steampowered.com/steamos/ brewmaster/non-free libegl1-nvidia amd64 352.55-2+steamos1+bsos1 [288 kB]            
  Prendre :  15 http://repo.steampowered.com/steamos/ brewmaster/non-free libnvidia-eglcore amd64 352.55-2+steamos1+bsos1 [6 765 kB]        
  Prendre :  16 http://repo.steampowered.com/steamos/ brewmaster/non-free nvidia-vdpau-driver amd64 352.55-2+steamos1+bsos1 [616 kB]        
  Prendre :  17 http://repo.steampowered.com/steamos/ brewmaster/main libvdpau1 i386 1.1-1+bsos1 [37,8 kB]                                  
  Prendre :  18 http://repo.steampowered.com/steamos/ brewmaster/main libvdpau1 amd64 1.1-1+bsos1 [39,1 kB]                                
  Prendre :  19 http://repo.steampowered.com/steamos/ brewmaster/contrib nvidia-kernel-common amd64 20151021+1+bsos1 [10,7 kB]              
  Prendre :  20 http://repo.steampowered.com/steamos/ brewmaster/contrib nvidia-modprobe amd64 340.46-1+bsos2 [14,7 kB]                    
  Prendre :  21 http://repo.steampowered.com/steamos/ brewmaster/non-free nvidia-kernel-support amd64 352.55-2+steamos1+bsos1 [147 kB]      
  Prendre :  22 http://repo.steampowered.com/steamos/ brewmaster/non-free nvidia-kernel-dkms amd64 352.55-2+steamos1+bsos1 [4 071 kB]      
  Prendre :  23 http://repo.steampowered.com/steamos/ brewmaster/non-free libgl1-nvidia-glx-i386 i386 352.55-2+steamos1+bsos1 [146 kB]      
  Prendre :  24 http://repo.steampowered.com/steamos/ brewmaster/contrib libxnvctrl0 amd64 340.46-2+bsos2 [20,9 kB]                        
   31,2 Mo téléchargés en 48s (640 ko/s)                                                                                                    
  Lecture des fichiers de modifications (« changelog »)... Terminé
  apt-listchanges: Envoi des modifications par courriel à root : apt-listchanges : nouveautés pour jessie
  Préconfiguration des paquets...
  (Lecture de la base de données... 163594 fichiers et répertoires déjà installés.)
  Suppression de nvidia-settings (340.46-2) ...
  Suppression de libjansson4:amd64 (2.7-1) ...
  Traitement des actions différées (« triggers ») pour nvidia-alternative (340.65-2) ...
  update-alternatives: avertissement: forçage de la réinstallation de l'alternative /usr/lib/nvidia/current car le groupe de liens nvidia est cassé
  Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
  Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u1) ...
  Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.5.1) ...
  update-initramfs: deferring update (trigger activated)
  Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u1) ...
  Traitement des actions différées (« triggers ») pour initramfs-tools (0.120) ...
  update-initramfs: Generating /boot/initrd.img-3.16.0-4-amd64
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
  (Lecture de la base de données... 163576 fichiers et répertoires déjà installés.)
  Préparation du dépaquetage de .../nvidia-driver_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de nvidia-driver (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../nvidia-driver-bin_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de nvidia-driver-bin (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../nvidia-alternative_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de nvidia-alternative (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../glx-alternative-nvidia_0.6.93+bsos1_amd64.deb ...
  Dépaquetage de glx-alternative-nvidia (0.6.93+bsos1) sur (0.5.1) ...
  Préparation du dépaquetage de .../xserver-xorg-video-nvidia_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de xserver-xorg-video-nvidia (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../libnvidia-ml1_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de libnvidia-ml1:amd64 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../glx-alternative-mesa_0.6.93+bsos1_amd64.deb ...
  Dépaquetage de glx-alternative-mesa (0.6.93+bsos1) sur (0.5.1) ...
  Préparation du dépaquetage de .../glx-diversions_0.6.93+bsos1_amd64.deb ...
  Dépaquetage de glx-diversions (0.6.93+bsos1) sur (0.5.1) ...
  Préparation du dépaquetage de .../libgl1-nvidia-glx_352.55-2+steamos1+bsos1_amd64.deb ...
  Déconfiguration de libgl1-nvidia-glx:i386 (340.65-2) ...
  Dépaquetage de libgl1-nvidia-glx:amd64 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../libgl1-nvidia-glx_352.55-2+steamos1+bsos1_i386.deb ...
  Dépaquetage de libgl1-nvidia-glx:i386 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../libgles2-nvidia_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de libgles2-nvidia:amd64 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../libgles1-nvidia_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de libgles1-nvidia:amd64 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../libegl1-nvidia_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de libegl1-nvidia:amd64 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../libnvidia-eglcore_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de libnvidia-eglcore:amd64 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../nvidia-vdpau-driver_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de nvidia-vdpau-driver:amd64 (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Préparation du dépaquetage de .../libvdpau1_1.1-1+bsos1_amd64.deb ...
  Déconfiguration de libvdpau1:i386 (0.8-3+deb8u2) ...
  Dépaquetage de libvdpau1:amd64 (1.1-1+bsos1) sur (0.8-3+deb8u2) ...
  Préparation du dépaquetage de .../libvdpau1_1.1-1+bsos1_i386.deb ...
  Dépaquetage de libvdpau1:i386 (1.1-1+bsos1) sur (0.8-3+deb8u2) ...
  Préparation du dépaquetage de .../nvidia-kernel-common_20151021+1+bsos1_amd64.deb ...
  Dépaquetage de nvidia-kernel-common (20151021+1+bsos1) sur (20141201+1) ...
  Préparation du dépaquetage de .../nvidia-modprobe_340.46-1+bsos2_amd64.deb ...
  Dépaquetage de nvidia-modprobe (340.46-1+bsos2) sur (340.46-1) ...
  Sélection du paquet nvidia-kernel-support précédemment désélectionné.
  Préparation du dépaquetage de .../nvidia-kernel-support_352.55-2+steamos1+bsos1_amd64.deb ...
  Dépaquetage de nvidia-kernel-support (352.55-2+steamos1+bsos1) ...
  Préparation du dépaquetage de .../nvidia-kernel-dkms_352.55-2+steamos1+bsos1_amd64.deb ...

  -------- Uninstall Beginning --------
  Module:  nvidia-current
  Version: 340.65
  Kernel:  3.16.0-4-amd64 (x86_64)
  -------------------------------------

  Status: Before uninstall, this module version was ACTIVE on this kernel.

  nvidia-current.ko:
   - Uninstallation
     - Deleting from: /lib/modules/3.16.0-4-amd64/updates/dkms/
   - Original module
     - No original module was found for this module on this kernel.
     - Use the dkms install command to reinstall any previous module version.


  nvidia-uvm.ko:
   - Uninstallation
     - Deleting from: /lib/modules/3.16.0-4-amd64/updates/dkms/
   - Original module
     - No original module was found for this module on this kernel.
     - Use the dkms install command to reinstall any previous module version.

  depmod....

  DKMS: uninstall completed.

  ------------------------------
  Deleting module version: 340.65
  completely from the DKMS tree.
  ------------------------------
  Done.
  Dépaquetage de nvidia-kernel-dkms (352.55-2+steamos1+bsos1) sur (340.65-2) ...
  Sélection du paquet libgl1-nvidia-glx-i386 précédemment désélectionné.
  Préparation du dépaquetage de .../libgl1-nvidia-glx-i386_352.55-2+steamos1+bsos1_i386.deb ...
  Dépaquetage de libgl1-nvidia-glx-i386 (352.55-2+steamos1+bsos1) ...
  Préparation du dépaquetage de .../libxnvctrl0_340.46-2+bsos2_amd64.deb ...
  Dépaquetage de libxnvctrl0 (340.46-2+bsos2) sur (340.46-2) ...
  Sélection du paquet nvidia-persistenced précédemment désélectionné.
  Préparation du dépaquetage de .../nvidia-persistenced_358.09-1~bpo8+1_amd64.deb ...
  Dépaquetage de nvidia-persistenced (358.09-1~bpo8+1) ...
  Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
  Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
  Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
  Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
  Paramétrage de glx-diversions (0.6.93+bsos1) ...
  Conservation de « détournement de /usr/lib/libGL.so en /usr/lib/mesa-diverted/libGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGL.so en /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGL.so en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGL.so en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/libGL.so.1 en /usr/lib/mesa-diverted/libGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGL.so.1 en /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGL.so.1 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGL.so.1 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/libGL.so.1.2 en /usr/lib/mesa-diverted/libGL.so.1.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGL.so.1.2 en /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGL.so.1.2 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGL.so.1.2 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so.1.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/libGL.so.1.2.0 en /usr/lib/mesa-diverted/libGL.so.1.2.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGL.so.1.2.0 en /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1.2.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGL.so.1.2.0 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1.2.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGL.so.1.2.0 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so.1.2.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/libEGL.so en /usr/lib/mesa-diverted/libEGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libEGL.so en /usr/lib/mesa-diverted/i386-linux-gnu/libEGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libEGL.so en /usr/lib/mesa-diverted/x86_64-linux-gnu/libEGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libEGL.so en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libEGL.so par glx-diversions »
  Conservation de « détournement de /usr/lib/libEGL.so.1 en /usr/lib/mesa-diverted/libEGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libEGL.so.1 en /usr/lib/mesa-diverted/i386-linux-gnu/libEGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libEGL.so.1 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libEGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libEGL.so.1 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libEGL.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/libEGL.so.1.0.0 en /usr/lib/mesa-diverted/libEGL.so.1.0.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libEGL.so.1.0.0 en /usr/lib/mesa-diverted/i386-linux-gnu/libEGL.so.1.0.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libEGL.so.1.0.0 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libEGL.so.1.0.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libEGL.so.1.0.0 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libEGL.so.1.0.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/libGLESv1_CM.so en /usr/lib/mesa-diverted/libGLESv1_CM.so par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGLESv1_CM.so en /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv1_CM.so par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv1_CM.so par glx-diversions »
  Conservation de « détournement de /usr/lib/libGLESv1_CM.so.1 en /usr/lib/mesa-diverted/libGLESv1_CM.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGLESv1_CM.so.1 en /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv1_CM.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so.1 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv1_CM.so.1 par glx-diversions »
  Conservation de « détournement de /usr/lib/libGLESv1_CM.so.1.1.0 en /usr/lib/mesa-diverted/libGLESv1_CM.so.1.1.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGLESv1_CM.so.1.1.0 en /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv1_CM.so.1.1.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1.1.0 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so.1.1.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so.1.1.0 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv1_CM.so.1.1.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/libGLESv2.so en /usr/lib/mesa-diverted/libGLESv2.so par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGLESv2.so en /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv2.so par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGLESv2.so en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv2.so par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGLESv2.so en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv2.so par glx-diversions »
  Conservation de « détournement de /usr/lib/libGLESv2.so.2 en /usr/lib/mesa-diverted/libGLESv2.so.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGLESv2.so.2 en /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv2.so.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGLESv2.so.2 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv2.so.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv2.so.2 par glx-diversions »
  Conservation de « détournement de /usr/lib/libGLESv2.so.2.0.0 en /usr/lib/mesa-diverted/libGLESv2.so.2.0.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/i386-linux-gnu/libGLESv2.so.2.0.0 en /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv2.so.2.0.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/x86_64-linux-gnu/libGLESv2.so.2.0.0 en /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv2.so.2.0.0 par glx-diversions »
  Conservation de « détournement de /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2.0.0 en /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv2.so.2.0.0 par glx-diversions »
  Paramétrage de glx-alternative-mesa (0.6.93+bsos1) ...
  update-alternatives: avertissement: forçage de la réinstallation de l'alternative /usr/lib/nvidia car le groupe de liens glx est cassé
  update-alternatives: avertissement: création de /usr/lib/x86_64-linux-gnu/libEGL.so.1 abandonnée car le fichier associé /usr/lib/x86_64-linux-gnu/nvidia/libEGL.so.1 (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/i386-linux-gnu/libGL.so.1 abandonnée car le fichier associé /usr/lib/i386-linux-gnu/nvidia/libGL.so.1 (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/x86_64-linux-gnu/libGL.so.1 abandonnée car le fichier associé /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1 (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1 abandonnée car le fichier associé /usr/lib/x86_64-linux-gnu/nvidia/libGLESv1_CM.so.1 (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/x86_64-linux-gnu/libGLESv2.so.2 abandonnée car le fichier associé /usr/lib/x86_64-linux-gnu/nvidia/libGLESv2.so.2 (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/i386-linux-gnu/libnvidia-cfg.so.1 abandonnée car le fichier associé /usr/lib/i386-linux-gnu/nvidia/libnvidia-cfg.so.1 (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/x86_64-linux-gnu/libnvidia-cfg.so.1 abandonnée car le fichier associé /usr/lib/x86_64-linux-gnu/nvidia/libnvidia-cfg.so.1 (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/xorg/modules/linux/libglx.so abandonnée car le fichier associé /usr/lib/nvidia/libglx.so (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /etc/modprobe.d/nvidia-blacklists-nouveau.conf abandonnée car le fichier associé /etc/nvidia/nvidia-blacklists-nouveau.conf (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/bin/nvidia-bug-report.sh abandonnée car le fichier associé /usr/lib/nvidia/nvidia-bug-report.sh (du groupe de liens glx) n'existe pas
  update-alternatives: avertissement: création de /usr/lib/xorg/modules/drivers/nvidia_drv.so abandonnée car le fichier associé /usr/lib/nvidia/nvidia_drv.so (du groupe de liens glx) n'existe pas
  Paramétrage de glx-alternative-nvidia (0.6.93+bsos1) ...
  update-alternatives: utilisation de « /usr/lib/mesa-diverted » pour fournir « /usr/lib/glx » (glx) en mode automatique
  update-initramfs: deferring update (trigger activated)
  Removing obsolete conffile /etc/nvidia/nvidia-blacklists-nouveau.conf ...
  Paramétrage de nvidia-alternative (352.55-2+steamos1+bsos1) ...
  Removing obsolete conffile /etc/nvidia/nvidia-modprobe.conf ...
  Paramétrage de libnvidia-eglcore:amd64 (352.55-2+steamos1+bsos1) ...
  Paramétrage de libvdpau1:amd64 (1.1-1+bsos1) ...
  Paramétrage de libvdpau1:i386 (1.1-1+bsos1) ...
  Paramétrage de nvidia-kernel-common (20151021+1+bsos1) ...
  Installation de la nouvelle version du fichier de configuration /etc/modprobe.d/nvidia-kernel-common.conf ...
  Removing obsolete conffile /etc/init.d/nvidia-kernel ...
  Removing obsolete conffile /etc/default/nvidia-kernel ...
  Paramétrage de nvidia-modprobe (340.46-1+bsos2) ...
  Paramétrage de libxnvctrl0 (340.46-2+bsos2) ...
  Paramétrage de nvidia-persistenced (358.09-1~bpo8+1) ...
  Traitement des actions différées (« triggers ») pour nvidia-alternative (352.55-2+steamos1+bsos1) ...
  update-alternatives: utilisation de « /usr/lib/nvidia/current » pour fournir « /usr/lib/nvidia/nvidia » (nvidia) en mode automatique
  Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.6.93+bsos1) ...
  update-alternatives: utilisation de « /usr/lib/nvidia » pour fournir « /usr/lib/glx » (glx) en mode automatique
  update-initramfs: deferring update (trigger activated)
  Paramétrage de libegl1-nvidia:amd64 (352.55-2+steamos1+bsos1) ...
  Paramétrage de libnvidia-ml1:amd64 (352.55-2+steamos1+bsos1) ...
  Paramétrage de nvidia-driver-bin (352.55-2+steamos1+bsos1) ...
  Paramétrage de nvidia-vdpau-driver:amd64 (352.55-2+steamos1+bsos1) ...
  Paramétrage de nvidia-kernel-support (352.55-2+steamos1+bsos1) ...
  Paramétrage de libgles2-nvidia:amd64 (352.55-2+steamos1+bsos1) ...
  Paramétrage de libgles1-nvidia:amd64 (352.55-2+steamos1+bsos1) ...
  Paramétrage de libgl1-nvidia-glx:amd64 (352.55-2+steamos1+bsos1) ...
  Paramétrage de libgl1-nvidia-glx:i386 (352.55-2+steamos1+bsos1) ...
  Paramétrage de xserver-xorg-video-nvidia (352.55-2+steamos1+bsos1) ...
  Paramétrage de libgl1-nvidia-glx-i386 (352.55-2+steamos1+bsos1) ...
  Traitement des actions différées (« triggers ») pour nvidia-alternative (352.55-2+steamos1+bsos1) ...
  update-alternatives: mise à jour de l'alternative /usr/lib/nvidia/current car le groupe de liens nvidia contient des liens esclaves modifiés
  Paramétrage de nvidia-kernel-dkms (352.55-2+steamos1+bsos1) ...
  Loading new nvidia-current-352.55 DKMS files...
  Building only for 3.16.0-4-amd64
  Building initial module for 3.16.0-4-amd64
  Done.

  nvidia-current:
  Running module version sanity check.
   - Original module
     - No original module exists within this kernel
   - Installation
     - Installing to /lib/modules/3.16.0-4-amd64/updates/dkms/

  nvidia-current-uvm.ko:
  Running module version sanity check.
   - Original module
     - No original module exists within this kernel
   - Installation
     - Installing to /lib/modules/3.16.0-4-amd64/updates/dkms/

  depmod....

  DKMS: install completed.
  Traitement des actions différées (« triggers ») pour glx-alternative-nvidia (0.6.93+bsos1) ...
  update-alternatives: mise à jour de l'alternative /usr/lib/nvidia car le groupe de liens glx contient des liens esclaves modifiés
  update-initramfs: deferring update (trigger activated)
  Paramétrage de nvidia-driver (352.55-2+steamos1+bsos1) ...
  Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u1) ...
  Traitement des actions différées (« triggers ») pour initramfs-tools (0.120) ...
  update-initramfs: Generating /boot/initrd.img-3.16.0-4-amd64
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
  W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
                             
  État actuel : 1141 mises à jour restantes [-23].



reboot et je vérifie que c'est bien installé

apt show nvidia-driver


Package: nvidia-driver
Source: nvidia-graphics-drivers
Version: 352.55-2+steamos1+bsos1
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Installed-Size: 1 104 kB
Pre-Depends: nvidia-installer-cleanup
Depends: libgl1-nvidia-glx (= 352.55-2+steamos1+bsos1), libegl1-nvidia (= 352.55-2+steamos1+bsos1), nvidia-driver-bin (= 352.55-2+steamos1+bsos1), xserver-xorg-video-nvidia (= 352.55-2+steamos1+bsos1), nvidia-vdpau-driver (= 352.55-2+steamos1+bsos1), nvidia-alternative (= 352.55-2+steamos1+bsos1), nvidia-kernel-dkms (= 352.55-2+steamos1+bsos1) | nvidia-kernel-352.55, nvidia-support
Recommends: nvidia-settings (>= 352), libgl1-nvidia-glx-i386, libgles1-nvidia (= 352.55-2+steamos1+bsos1), libgles2-nvidia (= 352.55-2+steamos1+bsos1), nvidia-persistenced
Suggests: nvidia-kernel-dkms (>= 352.55) | nvidia-kernel-source (>= 352.55)
Breaks: nvidia-glx
Replaces: nvidia-glx
Provides: nvidia-glx-any
Homepage: http://www.nvidia.com
Priority: optional
Section: non-free/x11
Download-Size: 432 kB
APT-Manual-Installed: no
APT-Sources: http://repo.steampowered.com/steamos/ brewmaster/non-free amd64 Packages
Description: NVIDIA metapackage
 This metapackage depends on the NVIDIA binary driver and libraries
 that provide optimized hardware acceleration of
 OpenGL applications via a direct-rendering X Server.
 AGP, PCIe, SLI, TV-out and flat panel displays are also supported.
 .
 Please see the nvidia-kernel-dkms or
 nvidia-kernel-source packages
 for building the kernel module required by this package.
 This will provide nvidia-kernel-352.55.
 .
 This version only supports GeForce, Quadro, NVS, Tesla, ... GPUs based on the
 Fermi, Kepler, Maxwell, or newer architectures.  Look at the legacy packages
 for older cards.
 .
 See /usr/share/doc/nvidia-driver/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.
 .
 Building the kernel module has been tested up to Linux 4.3.

N: There are 2 additional records. Please use the '-a' switch to see them.
 



par contre j'ai

 apt list --upgradable


En train de lister... Fait
glx-alternative-mesa/jessie-backports 0.7.1~bpo8+1 amd64 [upgradable from: 0.6.93+bsos1]
glx-alternative-nvidia/jessie-backports 0.7.1~bpo8+1 amd64 [upgradable from: 0.6.93+bsos1]
glx-diversions/jessie-backports 0.7.1~bpo8+1 amd64 [upgradable from: 0.6.93+bsos1]
libvdpau1/jessie-backports 1.1.1-1~bpo8+1 amd64 [upgradable from: 1.1-1+bsos1]
libxnvctrl0/jessie-backports 340.93-1~bpo8+1 amd64 [upgradable from: 340.46-2+bsos2]
nvidia-modprobe/jessie-backports 358.09-1~bpo8+1 amd64 [upgradable from: 340.46-1+bsos2]



j'en ai profité pour remettre correctement les préférences parce que 1141 mises à jour ça me fait un peu peur

cat /etc/apt/sources.list



#

#
# deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20150323-08:15]/ jessie main
#
# deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20150323-08:15]/ jessie main
#
# deb http://ftp.fr.debian.org/debian/ jessie main non-free contrib
# deb-src http://ftp.fr.debian.org/debian/ jessie main non-free contrib
#
# deb http://security.debian.org/ jessie/updates main contrib non-free
# deb-src http://security.debian.org/ jessie/updates main contrib non-free

#deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20150323-08:15]/ jessie main

deb http://ftp.fr.debian.org/debian/ jessie main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ jessie main non-free contrib

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

# jessie-backports, previously on backports.debian.org
deb http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-backports main contrib non-free


# ownCloud:desktop / owncloud-client   as official
# deb http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Debian_8.0/ /
 



cat /etc/apt/preferences
 


Package: *
Pin: release n=jessie
Pin-Priority: 900
 
Package: *
Pin: release n=jessie-updates
Pin-Priority: 900
 
Package: *
Pin: release n=jessie/updates
Pin-Priority: 900

Package: *
Pin: release n=jessie-backports
Pin-Priority: 100

 



cat /etc/apt/sources.list.d/steamos.list



 deb http://repo.steampowered.com/steamos brewmaster main contrib non-free



cat /etc/apt/preferences.d/steamos



Package: *
Pin: release n=brewmaster
Pin-Priority: 1
 



apt-cache policy



Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
   1 http://repo.steampowered.com/steamos/ brewmaster/non-free i386 Packages
     release o=Valve Software LLC,a=testing,n=brewmaster,l=SteamOS,c=non-free
     origin repo.steampowered.com
   1 http://repo.steampowered.com/steamos/ brewmaster/contrib i386 Packages
     release o=Valve Software LLC,a=testing,n=brewmaster,l=SteamOS,c=contrib
     origin repo.steampowered.com
   1 http://repo.steampowered.com/steamos/ brewmaster/main i386 Packages
     release o=Valve Software LLC,a=testing,n=brewmaster,l=SteamOS,c=main
     origin repo.steampowered.com
   1 http://repo.steampowered.com/steamos/ brewmaster/non-free amd64 Packages
     release o=Valve Software LLC,a=testing,n=brewmaster,l=SteamOS,c=non-free
     origin repo.steampowered.com
   1 http://repo.steampowered.com/steamos/ brewmaster/contrib amd64 Packages
     release o=Valve Software LLC,a=testing,n=brewmaster,l=SteamOS,c=contrib
     origin repo.steampowered.com
   1 http://repo.steampowered.com/steamos/ brewmaster/main amd64 Packages
     release o=Valve Software LLC,a=testing,n=brewmaster,l=SteamOS,c=main
     origin repo.steampowered.com
 500 http://ftp.fr.debian.org/debian/ jessie-backports/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie-backports/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie-backports/contrib Translation-en
 100 http://ftp.fr.debian.org/debian/ jessie-backports/non-free i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ jessie-backports/contrib i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ jessie-backports/non-free amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ jessie-backports/contrib amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin ftp.fr.debian.org
 100 http://ftp.fr.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie-updates/contrib Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/contrib i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/contrib amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://security.debian.org/ jessie/updates/non-free Translation-en
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/contrib Translation-en
 500 http://security.debian.org/ jessie/updates/non-free i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/contrib i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/non-free amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/contrib amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/contrib Translation-en
 500 http://ftp.fr.debian.org/debian/ jessie/contrib i386 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/non-free i386 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/main i386 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/contrib amd64 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/non-free amd64 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.fr.debian.org
Paquets épinglés :
 



du coup, je sais pas ce comment gérer les paquets en attente de mises à jour, sachant que ça vient de backports, je vais m'abstenir si j'en ai pas besoin.
c'est un peu le bazar dans les priorités et je sais pas comment actualiser tout ça ou si j'ai des erreurs.

Hors ligne

#21 14-12-2015 21:24:22

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

Bonsoir

aprés avoir eu un soucis ce matin avec les mises a jour , je suis revenu au driver nvidia 340.96 de stretch.
Mon soucis est le cuda (il ne fonctionne plus)
voici quelques paquets qui ont posé probleme :
libc-bin (2.21-0 experimental2)
g44-4.9 (ne peut etre installé)
gcc-4.9-base (ne peut etre installé)
gcc-4.9 (ne peut etre installé )
libstdc++-4.9-dev (ne peut etre installé)

a l'aide d une console root et de Synatic j'ai put remettre de l ordre et revenir a une stretch propre
la console avec l option -s pour la description du souci
Synaptic avec l option force sur un paquet (revenir a une version anterieure) qui fonctionne tres bien.
j'ai put remettre le paquet nvidia-cuda-toolkit et les autres paquet a la version de stretch.
le rendement sur un calcul est de 50% inferieur par rapport au 352 (surtout sur la durée qui est bien plus longue )
sur les machines qui bossent j attendrai le 343 sur stretch (pour cuda la version 6.5 est acquise pour stretch et sid)
des que j ai une machine disponnible je teste Steam smile quitte a refaire une installation ensuite wink  (le pinnig pas mon truc)
je suis ton post avec interet
ps: sur le 352 j'ai eu des bugs sur certains calcul , je sais pas ce que ça peut donner en jeu .

Hors ligne

#22 14-12-2015 22:18:06

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

pour les bugs, je ne pourrais pas te dire pour le moment mais je pense que c'est bien testé sur steam (c'est un peu leur fond de commerce) et c'est pas exactement la même version.
le pinning c'est un truc pour ceux qui veulent s’embêter mais c'est un compromis.

après, il y avait aussi la possibilité de tester l'installateur provenant du site officiel de Nvidia

Hors ligne

#23 15-12-2015 10:04:38

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

Pour le site officiel de nvidia c'est fait (en plus j ai le dernier cuda) et ça fonctionne tres bien.
Pour testing le probleme c est qu une mise a jour peu casser le driver. (pour jessie c est peu probable).
Pour Steam le seul jeux que j ai testé c est HL et HL2 qui fonctionne super bien.

Hors ligne

#24 15-12-2015 10:25:25

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

je comprends pas comment les backports puissent avoir 2 priorités différentes pour le pinning.
avec ou sans le/les/sans fichiers de préférence, je me retrouve toujours avec le même résultat.

apt-cache policy



Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://httpredir.debian.org/debian/ jessie-backports/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/contrib Translation-en
 100 http://httpredir.debian.org/debian/ jessie-backports/non-free i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/contrib i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/non-free amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/contrib amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin httpredir.debian.org
 500 http://security.debian.org/ jessie/updates/non-free Translation-en
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/contrib Translation-en
 500 http://security.debian.org/ jessie/updates/non-free i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/contrib i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/non-free amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/contrib amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://httpredir.debian.org/debian/ jessie/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie/main Translation-fr
 500 http://httpredir.debian.org/debian/ jessie/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie/contrib Translation-en
 500 http://httpredir.debian.org/debian/ jessie/non-free i386 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/contrib i386 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/main i386 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/non-free amd64 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/contrib amd64 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
     release v=8.2,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin httpredir.debian.org
Paquets épinglés :
 

Hors ligne

#25 15-12-2015 11:24:30

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Installation des derniers driver nvidia depuis repo steamos

La priorité de 100 des backports est celle par défaut, comme celle d'experimental est à 1. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums