Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#76 01-01-2016 15:16:13

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

À pésent, je pense que le problème est réglé… tu nous diras si c'est le
cas wink



Je suis navrée car le problème persite...


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#77 01-01-2016 17:27:49

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

il faut que tu sois plus précis. Tu peux faire un « ps -C mpd -O user », pour voir quel est l'identité
du mpd qui t'empêche éventuellement de démarrer un mpd utilisateur.
Tu peux aussi arrêter le mpd qui est démarré par systemd en faisant :


systemctl stop mpd
 


Car le fait de l'avoir désactivé ne l'arrête pas…
Il faut aussi rétablir les droits sur le script /etc/init.d/mpd :


chmod +x /etc/init.d/mpd
 


Et tu peux refaire :


systemctl disable mpd
 


Comme cela il ne sera pas lancer à l'initialisation du système.

Enfin tu pourras réessayer de démarrer mpd :


mpd
 

Dernière modification par enicar (01-01-2016 17:29:01)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#78 01-01-2016 17:49:24

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Alors dans l'ordre...

enicar a écrit :

il faut que tu sois plus précis. Tu peux faire un « ps -C mpd -O user », pour voir quel est l'identité
du mpd qui t'empêche éventuellement de démarrer un mpd utilisateur.


 PID USER     S TTY          TIME COMMAND
 1854 mpd      S ?        00:00:07 /usr/bin/mpd --no-daemon




Tu peux aussi arrêter le mpd qui est démarré par systemd en faisant :


systemctl stop mpd
 


Warning: Stopping mpd.service, but it can still be activated by:
  mpd.socket
 




Car le fait de l'avoir désactivé ne l'arrête pas…
Il faut aussi rétablir les droits sur le script /etc/init.d/mpd :


chmod +x /etc/init.d/mpd
 


Il n'y a pas eu aucun commentaire.

Et tu peux refaire :


systemctl disable mpd
 


Comme cela il ne sera pas lancer à l'initialisation du système.

ynchronizing state for mpd.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d mpd defaults
insserv: warning: current start runlevel(s) (empty) of script `mpd' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mpd' overrides LSB defaults (0 1 6).
Executing /usr/sbin/update-rc.d mpd disable
insserv: warning: current start runlevel(s) (empty) of script `mpd' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mpd' overrides LSB defaults (0 1 6).



Enfin tu pourras réessayer de démarrer mpd :


mpd
 


Jan 01 16:34 : fatal_error: Failed to set group 29: Operation not permitted



J'ai testé gmpc, mpd "failed to decode"

Est-ce que je devrais remettre l'ancien port 6600 ?? au lieu de 6601 ?


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#79 01-01-2016 18:00:38

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

D'abord, il faut t'assurer que le mpd système ne tourne plus, que
raconte à présent :


ps -C mpd -O user
 


tiare a écrit :


Est-ce que je devrais remettre l'ancien port 6600 ?? au lieu de 6601 ?


Oui, pourquoi pas. Mais le message d'erreur n'a rien à voir avec cela.
Le groupe 29 devrait être le groupe audio. Quel est le résultat de la
commande :


grep 29 /etc/group
 


Il devrait avoir une ligne qui ressemble à :


audio:x:29:tiare,pulse
 




Il faut que tu utilises le bon fichier de configuration de mpd.
C'est à dire celui qui est dans ~/.mpd/. Que donne la commande :


ls -l ~/.mpd/
 


Et quel est le résultat de :


ls -l ~/.config/mpd
 


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#80 01-01-2016 18:20:33

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

ça me dit ceci maintenant :

  PID USER     S TTY          TIME COMMAND
 4898 mpd      S ?        00:00:03 /usr/bin/mpd --no-daemon
 



Puis j'ai remis le port à 6600.

Ensuite, ça à donner pour le groups :

audio:x:29:tiare



ls -l ~/.mpd/


total 32
-rw-r----- 1 tiare tiare 14224 janv.  1 17:09 mpd.conf
-rw-r--r-- 1 tiare tiare     0 déc.  30 22:23 mpd.log
 



ls -l ~/.config/mpd


ls: impossible d'accéder à /home/tiare/.config/mpd: Aucun fichier ou dossier de ce type



Les fichiers mpd.conf et mpd.log, je les ai trouvé dans home/tiare/.mpd et non dans tiare/.config
Il doit être normalement dans .config le répertoire mpd ?


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#81 01-01-2016 18:26:38

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Fais dans cet ordre :


systemctl disable mpd
systemctl stop mpd
/etc/init.d/mpd stop
 



Ensuite en tant qu'utilisateur :


mpd
 



J'espère que tu as bien laissé les valeurs que j'avais donné dans mon post #40
pour les options de configurations de mpd dans ton fichier ~/.mpd/mpd.conf.

Le fichier /etc/mpd.conf, on s'en fiche. On ne va plus y toucher.

Dernière modification par enicar (01-01-2016 18:27:07)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#82 01-01-2016 18:36:40

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Oui j'ai bien laissé les valeurs, je n'y ai pas touché.
Dans l'ordre, les résultats :

Synchronizing state for mpd.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d mpd defaults
insserv: warning: current start runlevel(s) (empty) of script `mpd' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mpd' overrides LSB defaults (0 1 6).
Executing /usr/sbin/update-rc.d mpd disable
insserv: warning: current start runlevel(s) (empty) of script `mpd' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mpd' overrides LSB defaults (0 1 6).
 



Warning: Stopping mpd.service, but it can still be activated by:
  mpd.socket



....] Stopping mpd (via systemctl): mpd.serviceWarning: Stopping mpd.service, but it can still be activated by:
  mpd.socket
. ok



Jan 01 17:34 : socket: Failed to bind to '[::1]:6600': Address already in use
 


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#83 01-01-2016 18:39:04

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Le message d'erreur :


Jan 01 16:34 : fatal_error: Failed to set group 29: Operation not permitted
 


indique que tu as démarré mpd avec une configuration qui utilise alsa depuis un
utilisateur qui n'est pas dans le groupe audio…

D'ailleurs qu'elle est la configuration de mpd en ce qui concerne la sortie audio.
Dans ton ~/.mpd/mpd.conf tu chercheras une option :


audio_output {
  type    "alsa"
  name    "ALSA Device"
  device    "default" # optional
  #format   "48000:16:2"  # optional
  #mixer_device "default" # optional
  #mixer_control  "PCM"   # optional
  #mixer_index  "0"   # optional
}
 


Tu peux aussi avoir :


audio_output {
  type    "pulse"
  name    "My Pulse Output"
}
 


Normalement il y a plusieurs configuration donnée en exemple.
Seule la configuration pour alsa n'est pas mise en commentaire,
c'est à dire ne commence pas par un #.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#84 01-01-2016 18:42:08

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Bon, il y en a assez, aux grands maux les grands moyens, tu feras en root :


pkill mpd
 


la plaisanterie a assez duré…

Puis ensuite tu regraderas si tu peux démarré mpd avec ton utilisateur :


mpd
 


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#85 01-01-2016 18:45:02

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Oui je vois :

audio_output {
  type      "alsa"
  name      "Mulan"
  device      "default"
  mixer_type      "hardware"      # optional
  mixer_device  "default"
  mixer_control "Master"    # optional
  auto_resample "no"
  format      "44100:16:2"
# mixer_index "0"   # optional
}
 



Ici j'ai des #

#audio_output {
  #type   "pulse"
  #name   "Mulan"
  #server     "localhost"
### server    "remote_server"   # optional
### sink    "remote_server_sink"  # optional
#}
 


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#86 01-01-2016 18:47:06

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Bon, on s'occupera de la sortie audio, quand on aura réussi à se débarrasser du mpd système…

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#87 01-01-2016 18:47:21

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

enicar a écrit :

Bon, il y en a assez, aux grands maux les grands moyens, tu feras en root :


pkill mpd
 


la plaisanterie a assez duré…

Puis ensuite tu regraderas si tu peux démarré mpd avec ton utilisateur :


mpd
 



Ok j'ai fait pkill mpd.

Et toujours :

Jan 01 17:47 : socket: Failed to bind to '[::1]:6600': Address already in use
 


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#88 01-01-2016 18:49:00

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Redémarre ta machine.

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#89 01-01-2016 18:55:08

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Cela a été fait et me voilà smile

Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#90 01-01-2016 18:57:12

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Ben, la question est-ce que tu peux démarré mpd à présent ?

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#91 01-01-2016 18:57:58

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

non toujours pas sad

Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#92 01-01-2016 19:09:12

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

D'abord tu vas regarder si mpd tourne toujours :


ps -C mpd -O user
 



Ensuite pour savoir quel programme utilise cette socket :


netstat -naut |grep '::1:6600'
 


Je crains que ce soit cette saloperie de systemd qui utilise cette
socket et donc empêche le démarrage de mpd en tant que user…

On peut aussi contourner le problème en mettant dans le ~/.mpd/mpd.conf :


bind_to_address /home/tiare/.mpd/socket
 


En supposant que ton utilisateur est tiare.
Il faudra mettre la même valeur dans gmpc (le champ Hôte des
préférences de connexion…) Et là, je te garanti que le problème
ne peut plus venir de là.


D'ailleurs, ce n'est pas normal que ce problème persiste si tu as
bien exécuté les commandes qui permettent de désactivé le lancement de
mpd… mais on verra cela plus tard ou pas…


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#93 01-01-2016 19:23:11

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

  PID USER     S TTY          TIME COMMAND
 1666 mpd      S ?        00:00:02 /usr/bin/mpd --no-daemon



tcp6       0      0 ::1:6600                ::1:50629               ESTABLISHED
tcp6       0      0 ::1:50629               ::1:6600                ESTABLISHED



J'ai bien mis bind_to_address /home/tiare/.mpd/socket à la place de

bind_to_address "localhost"


Dans hôte je mets bien : bind_to_address /home/tiare/.mpd/socket ou /home/tiare/.mpd/socket
Dans tous les cas cela ne marche pas...
Cela suppose qu'il y ait un répertoire socket dans .mpd ??


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#94 01-01-2016 19:29:43

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Dans le champ hôte de gmpc il faut mettre « /home/tiare/.mpd/socket  » /me soupire…
mpd va créer le fichier au démarrage… Donc il faut que mpd soit démarré pour que ça fonctionne.
C'est un fichier spécial de type socket…

Bon, il faut aussi mettre un peu du tien. Moi, je ne comprend absolument pas
pourquoi mpd est toujours démarré sur ton système. Il ne devrait pas !
Dans tout ce que je t'ai fait faire, tu as fait un truc de travers. Ce n'est
pas possible autrement !

Dernière modification par enicar (01-01-2016 19:30:42)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#95 01-01-2016 19:37:01

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Ok, vais revoir depuis tout le début smile

Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#96 01-01-2016 19:37:20

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

est-ce que tu as bien fait la commande  en ROOT


update-rc.d mpd disable
systemctl stop mpd
systemctl disable mpd
 


Après ça, mpd ne devrait plus démarré à l'initialisation du système. Ce qui veut dire
que quand tu redémarres ta machine il n'y a plus de mpd lancé avec l'identité de mpd.
Redémarrer la machine, ça veut dire faire un reboot complet de ton pc
portable (le serveur on s'en fiche).


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#97 01-01-2016 19:43:46

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Pour être absoument certain que systemd ignore complétement mpd, tu feras
en root :


ln -s /dev/null /etc/systemd/system/mpd.service
 


Et ensuite tu redémarres ta machine. Ceci fait, tu vérifieras que mpd ne tourne plus avec
l'identité de mpd (tu sais comment…) et tu pourras toujours me montrer le résultat de la commande


netstat -naut
 

Dernière modification par enicar (01-01-2016 19:44:45)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#98 03-01-2016 13:51:40

tiare
Adhérent(e)
Distrib. : GNU/Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 23-12-2015

Re : [Résolu] Comment faire fonctionner mon gmpc ?

Une question, j'ai deux fichiers mpd.conf :

etc/mpd.conf = ici il m'est impossible d'éditer les valeurs car cela m'ouvre une fenêtre

"erreur lors de l'ouverture du fichier "/etc/mpd.conf" : Permission non accordée. Le fichier sur le disque est peut-être tronqué !


home/.mpd/mpd.conf = c'est ici que j'ai pu changer les valeurs

Est-ce que le fait que l'autre fichier dans etc/mpd.conf dont les valeurs sont fausses peut perturber la configuration ??


J'ai fait en root

ln -s /dev/null /etc/systemd/system/mpd.service



Puis identité du mpd :

PID USER     S TTY          TIME COMMAND



Ensuite après avoir redémarré mon pc, en root :

netstat -naut


Connexions Internet actives (serveurs et établies)
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat      
tcp        0      0 127.0.0.1:7634          0.0.0.0:*               LISTEN    
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN    
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN    
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN    
tcp        0      0 127.0.0.1:8953          0.0.0.0:*               LISTEN    
tcp        0      0 127.0.0.1:7634          127.0.0.1:56670         TIME_WAIT  
tcp        0      0 127.0.0.1:7634          127.0.0.1:56664         TIME_WAIT  
tcp        0      0 127.0.0.1:7634          127.0.0.1:56672         TIME_WAIT  
tcp        0      0 127.0.0.1:7634          127.0.0.1:56668         TIME_WAIT  
tcp        0      1 192.168.0.250:58877     188.125.69.6:993        LAST_ACK  
tcp        1      0 192.168.0.250:40403     173.203.187.10:993      CLOSE_WAIT
tcp        0      0 192.168.0.250:57806     188.125.68.240:993      ESTABLISHED
tcp        0      1 192.168.0.250:58882     188.125.69.6:993        LAST_ACK  
tcp        0      0 192.168.0.250:57803     188.125.68.240:993      ESTABLISHED
tcp        0      0 192.168.0.250:40406     173.203.187.10:993      ESTABLISHED
tcp        0      0 127.0.0.1:7634          127.0.0.1:56665         TIME_WAIT  
tcp        0      0 192.168.0.250:57783     188.125.68.240:993      ESTABLISHED
tcp        0      0 192.168.0.250:40354     173.203.187.10:993      ESTABLISHED
tcp        0      0 127.0.0.1:7634          127.0.0.1:56669         TIME_WAIT  
tcp        0      0 127.0.0.1:7634          127.0.0.1:56678         TIME_WAIT  
tcp        0      0 192.168.0.250:40409     173.203.187.10:993      ESTABLISHED
tcp        0      1 192.168.0.250:58867     188.125.69.6:993        LAST_ACK  
tcp        1      0 192.168.0.250:35995     157.249.32.164:80       CLOSE_WAIT
tcp        0      0 127.0.0.1:7634          127.0.0.1:56677         TIME_WAIT  
tcp        0      1 192.168.0.250:58879     188.125.69.6:993        LAST_ACK  
tcp        0      0 127.0.0.1:7634          127.0.0.1:56671         TIME_WAIT  
tcp        0      0 127.0.0.1:7634          127.0.0.1:56674         TIME_WAIT  
tcp        0      0 127.0.0.1:7634          127.0.0.1:56673         TIME_WAIT  
tcp        0      0 192.168.0.250:40416     173.203.187.10:993      ESTABLISHED
tcp6       0      0 ::1:53                  :::*                    LISTEN    
tcp6       0      0 ::1:631                 :::*                    LISTEN    
tcp6       0      0 ::1:25                  :::*                    LISTEN    
tcp6       0      0 ::1:8953                :::*                    LISTEN    
tcp6       0      0 2a01:e35:3994:905:59099 2a02:26f0:108:19f::2:80 TIME_WAIT  
tcp6       0      0 2a01:e35:3994:905:46197 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46288 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46292 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46296 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46297 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46298 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46291 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46294 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:59081 2a02:26f0:108:19f::2:80 TIME_WAIT  
tcp6       1      0 ::1:40090               ::1:631                 CLOSE_WAIT
tcp6       0      0 2a01:e35:3994:905:46196 2a00:1450:400c:c07::993 ESTABLISHED
tcp6       0      0 2a01:e35:3994:905:46301 2a00:1450:400c:c07::993 ESTABLISHED
udp        0      0 0.0.0.0:631             0.0.0.0:*                          
udp        0      0 0.0.0.0:1900            0.0.0.0:*                          
udp        0      0 127.0.0.1:53            0.0.0.0:*                          
udp6       0      0 ::1:53                  :::*  


Réf ordi portable : GNU/LINUX 3.16.0-4-686-pae, Xcfe

**** "Un pour tous, Tous pour un"

Hors ligne

#99 03-01-2016 14:15:27

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : [Résolu] Comment faire fonctionner mon gmpc ?

En ligne

#100 03-01-2016 14:20:19

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Comment faire fonctionner mon gmpc ?

tiare a écrit :

Une question, j'ai deux fichiers mpd.conf :



Et bien, on ne s'occupe pas de /etc/mpd.conf car c'est le fichier de
configuration utilisé par le mpd système… et c'est justement ce que
l'on ne veut pas utiliser.

Donc il faut modifier les valeurs dans ~/.mpd/mpd.conf, oui.  Je
suppose que ton home est /home/tiare.  Si tu as gardé la valeur de la
socket unix (/home/tiare/.mpd/socket) pour l'option bind_to_address
dans ~/.mpd/mpd.conf, il faudra mettre la même valeur dans la
configuration de connexion de gmpc (champ hôte).  C'est à dire bien
mettre la valeur /home/tiare/.mpd/socket dans ce champ.  Remarque, tu
n'as besoin que d'une seule option bind_to_address dans le mpd.conf.
On peut en mettre plusieurs, mais ça sera inutile dans ton cas.

La sortie de netstat -naut indique que le daemon mpd n'occupe plus le
port 6600 sur le localhost (ce sont les adresses (en ipv4) 127.0.0.1
et (en ipv6) ::1.

Normalement tu devrais pouvoir démarrer mpd avec ton utilisateur. Et
en fait, tu ne devrais même pas avoir besoin de le démarrer car il est
démarré automatiquement avec ta session Xorg.

Toutefois, il est possible que tu aies besoin de changer la
configuration du mpd.conf et de gmpc pour que ça marche correctement.
Pour cela, après avoir modifié ta configuration, il faudra tuer mpd et
le redémarrer comme suit :


pkill mpd
mpd
 



Fais attention à la correspondance des valeurs suivantes :

  • Valeur du champ Hôte de gmpc et valeur de l'option bind_to_address dans mpd.conf.

  • Valeur du champ Port de gmpc et valeur de l'option port dans mpd.conf



Si tu uitlises une socket unix la valeur du port n'est pas utilisée.

Tu voudras peut être remettre un configuration plus classique que
l'utilisation d'une socket unix, en remettant le champ Hôte à la
valeur localhost ainsi que celle de l'option bind_to_address du
mpd.conf, ainsi que le port sur 6600 dans les deux cas.

Ah ! Et aussi, j'ai rédigé ce  post pour que tu sois obligé de lire, et donc tu ne pourras pas
copier/coller des commandes en espérant que ça marche, car c'est bien mieux ainsi smile

Dernière modification par enicar (03-01-2016 18:30:50)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

Pied de page des forums