Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-01-2016 23:47:09

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

[Resolu]Installer une version récente de l'environnement Arduino

Je suis en train de développer deux trois trucs avec mes cartes "Arduino" et mes puces Atmega (surtout un système de relevés météo de l'extérieur (T° air, Humidité rel., UV-B, T° sol, éclairement, orages, précipitations, et bien plus), et vu que mes capteurs seront reliés à une base en communication sans fil, j'avais besoin de la librairie VirtualWire qui ne fonctionnant pas, m'a fait prendre conscience que la version que j'ai de l'IDE arduino est trèèèèèèèèèès obselète: 1.0.5 alors que la version actuelle est la 1.6.7, j'aimerais donc un coup de main pour installer une version plus récente car je recherche depuis quelques jours mais je n'arrive pas à trouver un moyen pour arriver à mes fins.

Ca sera aussi une découverte/un TP pour moi qui ne comprends pas vraiment comment installer les progs sous Linux (je sais copier/coller des commandes  mais rien de plus pour l'instant) en dehors d'avec la merveilleuse roll APT bien sur. Et peut être que je réussirai enfin d'installer tous les programmes que je ne réussis pas à installer (parser pour une de mes imprimantes, obs-studio, UPSmonitor, ...).

Pour situer mon niveau actuel de connaissances en installation/lancement de progs sous Debian:

- dossiers avec un .exe comme SubtitleEdit par le biais de MONO

- fichiers .i386 ou .amd64 comme UrbanTerror

- .jar avec

java -jar machin.jar



- .deb pour installer avec dpkg ou apt

- sources avec .tar.xz + make + make install (je ne maitrise pas trop cette partie

pour en revenir à mon problème actuel, j'ai essayer de réinstaller Arduino par apt  mais il ne veut pas la mettre à jour puisque j'ai déjà la version la plus récente dispo., j'ai lu le site débian, qu'il y a la version 1.5.6 dispo dans expérimental (mais j'ai un doute si je dois installer ce genre de choses sur mon beau système), les Site officiel Arduino propose apparemment un fichier de sources de la dernière version mais je n'ai pas réussi à trouver de documentation suffisante pour l'installer.

Aussi, que faire du Arduino que j'ai déjà d'installé ? Car j'ai plein de libraries dedans, dois-je sauvegarder et

apt-get remove Arduino

?

J'ai cherché sur le wiki au sujet d'Arduino et vu que je n'ai rien trouvé, j'ai commencé un petit article sur les relations entre les cartes type Arduino et Debian tongue

Quelques pages que j'ai parcouru:
https://www.arduino.cc/en/Main/Software
https://packages.debian.org/experimental/arduino-core
https://packages.debian.org/jessie/arduino


Merci d'avance pour votre aide.

Dernière modification par nazmi (12-01-2016 20:18:57)

Hors ligne

#2 12-01-2016 20:18:17

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Resolu]Installer une version récente de l'environnement Arduino

Je dois être bète, l'archive .tar.xz fournie par le site arduino contenait tout le nécessaire, il a suffit de cliquer sur le fichier exécutable Arduino et tout s'est lancé neutral
bon, je retourne au développement de ma station météo, faudra que j'ouvre un sujet pour les progs que je n'arrive pas à installer,

pourquoi le Arduino fourni par les dépots debian est il si vieux ?

Cordialement

Dernière modification par nazmi (12-01-2016 20:18:43)

Hors ligne

#3 12-01-2016 20:32:15

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Resolu]Installer une version récente de l'environnement Arduino

nazmi a écrit :

bon, je retourne au développement de ma station météo,

Bah ! D'tt' façon, va faire un temps pourri ...  tongue  lol


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 12-01-2016 20:52:29

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : [Resolu]Installer une version récente de l'environnement Arduino

lol lol

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#5 12-01-2016 22:21:48

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Resolu]Installer une version récente de l'environnement Arduino

nazmi a écrit :

pourquoi le Arduino fourni par les dépôts debian est il si vieux ?

C'est du au cycle de développement de Debian. Les paquets de Jessie n'ont plus changé de version depuis Novembre 2014, sauf pour corriger des bugs graves smile

Ceci-dit, j'ai fait une petite simulation et il semblerait que l'ajout des sources de Experimental et l'installation depuis ces dépôts ne pose pas de problèmes.

aptitude install -s -t experimental arduino -v
 


Les NOUVEAUX paquets suivants vont être installés :    
  astyle{a} bossa-cli{a} libapache-pom-java{a} libastylej-jni{a}
  libcommons-codec-java{a} libcommons-exec-java{a}
  libcommons-httpclient-java{a} libcommons-logging-java{a}
  libcommons-parent-java{a} libjmdns-java{a} libjsch-java{a}
  libjssc-java{a} libjzlib-java{a}
Les paquets suivants seront ENLEVÉS :
  librxtx-java{u}
Les paquets suivants seront mis à jour :
  arduino arduino-core
Les paquets suivants sont SUGGÉRÉS mais ne seront pas installés :
  libavalon-framework-java libcommons-httpclient-java-doc
  libcommons-logging-java-doc libexcalibur-logkit-java liblog4j1.2-java
2 paquets mis à jour, 13 nouvellement installés, 1 à enlever et 179 non mis à jour.
Il est nécessaire de télécharger 11,3 Mo d'archives. Après dépaquetage, 56,6 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Inst libcommons-exec-java (1.2-1 Debian:8.2/stable [all])
Inst libapache-pom-java (10-2 Debian:8.2/stable [all])
Inst libcommons-parent-java (22-2 Debian:8.2/stable [all])
Inst libcommons-logging-java (1.2-1 Debian:8.2/stable [all])
Inst libcommons-codec-java (1.9-1 Debian:8.2/stable [all])
Inst libcommons-httpclient-java (3.1-11 Debian:8.2/stable [all])
Inst libjmdns-java (3.4.1-2 Debian:8.2/stable [all])
Inst libjzlib-java (1.1.3-1 Debian:8.2/stable [all])
Inst libjsch-java (0.1.51-1 Debian:8.2/stable [all])
Inst libjssc-java (2.6.0-5 Debian:8.2/stable [amd64])
Inst arduino [2:1.0.5+dfsg2-4] (2:1.5.6.2+sdfsg2-3 Debian:experimental [all]) []
Inst arduino-core [2:1.0.5+dfsg2-4] (2:1.5.6.2+sdfsg2-3 Debian:experimental [all]) []
Inst libastylej-jni (2.04-1 Debian:8.2/stable [amd64])
Remv librxtx-java [2.2pre2-13]
Inst astyle (2.04-1 Debian:8.2/stable [amd64])
Inst bossa-cli (1.3~20120408-5 Debian:8.2/stable [amd64])
Conf libcommons-exec-java (1.2-1 Debian:8.2/stable [all])
Conf libapache-pom-java (10-2 Debian:8.2/stable [all])
Conf libcommons-parent-java (22-2 Debian:8.2/stable [all])
Conf libcommons-logging-java (1.2-1 Debian:8.2/stable [all])
Conf libcommons-codec-java (1.9-1 Debian:8.2/stable [all])
Conf libcommons-httpclient-java (3.1-11 Debian:8.2/stable [all])
Conf libjmdns-java (3.4.1-2 Debian:8.2/stable [all])
Conf libjzlib-java (1.1.3-1 Debian:8.2/stable [all])
Conf libjsch-java (0.1.51-1 Debian:8.2/stable [all])
Conf libjssc-java (2.6.0-5 Debian:8.2/stable [amd64])
Conf arduino-core (2:1.5.6.2+sdfsg2-3 Debian:experimental [all])
Conf libastylej-jni (2.04-1 Debian:8.2/stable [amd64])
Conf arduino (2:1.5.6.2+sdfsg2-3 Debian:experimental [all])
Conf astyle (2.04-1 Debian:8.2/stable [amd64])
Conf bossa-cli (1.3~20120408-5 Debian:8.2/stable [amd64])
 



Seul un paquet librxtx-java est supprimé. Si je m'interroge pour savoir pourquoi, il semble que cela soit une dépendance de la version du paquet arduino 1.0.5+dfsg2-4 de Jessie, mais plus pour la version 1.5.6.2+sdfsg2-3 de Experimental

aptitude why librxtx-java


i   arduino Dépend librxtx-java (>= 2.2pre2-3)



/|\ Attention, ce n'est qu'une simulation et pas un essai en réel. Je n'affirme donc pas que cela fonctionne sans aucun problème

Pour plus d'info sur les avancées sur ce paquet, tu peux regarder ce bug là, classé souhaits, qui date de Mars 2015 smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#6 12-01-2016 22:43:14

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Resolu]Installer une version récente de l'environnement Arduino

Merci, je comprends mieux mais c'est assez dommage que ça traîne comme ça, enfin après il y a le site officiel Arduino et son archive sans Readme ou il faut deviner que faire hmm

J'ai réussi en utilisant le logiciel "portable" fourni par Arduino, je vais m'en contenter, de plus c'est une version encore plus récente: la 1.6.7 qui fonctionne bien avec mes librairies jusqu'à maintenant smile

Bien cordialement

PS: est-ce que ça veut dire que la prochaine version de Debian s'appellera Stretch ?

Dernière modification par nazmi (12-01-2016 22:44:49)

Hors ligne

#7 12-01-2016 22:56:59

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Resolu]Installer une version récente de l'environnement Arduino

nazmi a écrit :

mais c'est assez dommage que ça traîne comme ça

C'est un prix à payer pour la robustesse légendaire de Debian wink Il y a également un problème de licence si je comprend bien. Cette nouvelle version d'Arduino n'est pas complètement libre, ce qui est contraire au contrat social de Debian hmm


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#8 13-01-2016 23:32:52

nazmi
Membre
Lieu : Normandie
Distrib. : GNU/LINUX Debian Jessie
Noyau : Linux 4.3.0-0.bpo.1-amd64
(G)UI : KDE/XFCE
Inscription : 17-07-2015

Re : [Resolu]Installer une version récente de l'environnement Arduino

Pas libre, à quel point ??? neutral j'ai lu ton lien, pas trop compris (en même temps je suis pas de leur équipe et tout, donc vu de l’extérieur ça semble trouble), mais ça aurait donc à voir avec des compilateurs pour l'architecture ARM neutral n'importe quoi, comment se fait-il qu'un tel projet comme Arduino qui est connu et reconnu pour sa liberté dérive ainsi ?

Hors ligne

Pied de page des forums