Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-01-2016 17:10:58

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

test reseau filaire via systemd

on va essayer de mettre en place ce tuto
https://debian-facile.org/atelier:chant … ia-systemd

ceci peut etre fait a la fin de la configuration ?
pour éviter de perdre le réseau  en cour de configuration
a la fin il faut activer systemd networkd (donc jusque la on peut mettre les scripts en place sans soucis ? )


systemctl disable network
systemctl disable NetworkManager
 

Hors ligne

#2 12-01-2016 17:47:00

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : test reseau filaire via systemd

voui et voui

tu peux mettre en place tes fichiers

et une fois fait stopper les autres config réseau

systemctl stop network


systemctl stop NetworkManager



fait un stop dans un premier temps, si la connexion via systemd ne fonctionne pas (pour une réaison ou une autre) tu auras juste à redémarrer les autres connexions


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#3 12-01-2016 18:33:33

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Bon j'attaque (aprés mise a jour et mise en place du driver 340.96 des dépots  sinon affichage trés mauvais sad   )
voila le premier


nano /etc/systemd/network/50-enp1s0.network
 




[Match]
Name=enp1s0

[Network]
DHCP=yes
 



udevadm info -q all -p /sys/class/net/enp1s0
 



retour


P: /devices/pci0000:00/0000:00:1c.1/0000:01:00.0/net/enp1s0
E: DEVPATH=/devices/pci0000:00/0000:00:1c.1/0000:01:00.0/net/enp1s0
E: ID_BUS=pci
E: ID_MM_CANDIDATE=1
E: ID_MODEL_FROM_DATABASE=AR8152 v2.0 Fast Ethernet
E: ID_MODEL_ID=0x2062
E: ID_NET_DRIVER=atl1c
E: ID_NET_LINK_FILE=/lib/systemd/network/99-default.link
E: ID_NET_NAME_MAC=enxd050992caab4
E: ID_NET_NAME_PATH=enp1s0
E: ID_OUI_FROM_DATABASE=ASRock Incorporation
E: ID_PATH=pci-0000:01:00.0
E: ID_PATH_TAG=pci-0000_01_00_0
E: ID_PCI_CLASS_FROM_DATABASE=Network controller
E: ID_PCI_SUBCLASS_FROM_DATABASE=Ethernet controller
E: ID_VENDOR_FROM_DATABASE=Qualcomm Atheros
E: ID_VENDOR_ID=0x1969
E: IFINDEX=2
E: INTERFACE=enp1s0
E: SUBSYSTEM=net
E: SYSTEMD_ALIAS=/sys/subsystem/net/devices/enp1s0
E: TAGS=:systemd:
E: USEC_INITIALIZED=580221
 



la j'ai un souci => commande:


cat /etc/udev/rules.d/70-persistent-net.rules
 


retour


cat: /etc/udev/rules.d/70-persistent-net.rules: Aucun fichier ou dossier de ce type
 


donc je vai chercher le mac adress , je pense que celui de la carte (physique) doit convenir.
avec ceci : (ifconfig a été entrer sur une autre machine , pour exemple avec 2 cartes réseau )


ifconfig
 


retour commande


eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.10.26  netmask 255.255.255.0  broadcast 192.168.10.255
        inet6 fe80::21d:60ff:fe01:f010  prefixlen 64  scopeid 0x20<link>
        ether 00:1d:60:01:f0:10  txqueuelen 1000  (Ethernet)  => adresse mac :   00:1d:60:01:f0:10
        RX packets 75037  bytes 74486833 (71.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 47843  bytes 44406291 (42.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  

eth1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 30:b5:c2:05:2b:32  txqueuelen 1000  (Ethernet) => adresse mac :  30:b5:c2:05:2b:32
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Boucle locale)
        RX packets 190181  bytes 31927454 (30.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 190181  bytes 31927454 (30.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 


bon le mac adresse vérifié par le boot pxe wink  est "d0.50.99.2c.aa.b4"
le fichier  .link


nano /etc/systemd/network/50-enp1s0.link
 


retour


[Match]
MACAddress=d0.50.99.2c.aa.b4
Path=pci-0000:01:00.0
Virtualization=no

[Link]
Name=enp1s0
MTUBytes=1464
MACAddressPolicy=persistent
WakeOnLan=off
 



pour la résolution DNS c'est obligatoire ?
voici mon resolv.conf actuel (généré par network-manager) , le dhcp local donne toutes les infos dont a besoin le client (dns,ntp,passerelle,pxe,etc....)
je peu activer systemd maintenant ou je dois effectuer la modification du resolv.conf ?


# Generated by NetworkManager
search mondomain.com
nameserver 192.168.10.1
 



voici le resultat
avant activation


 systemctl status systemd-networkd
 


retour


● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:systemd-networkd.service(8)
 


desactivation network


 systemctl disable network
 


retour


Failed to execute operation: No such file or directory
 


desactivation network-manager


systemctl disable NetworkManager
 


retour


Removed symlink /etc/systemd/system/dbus-org.freedesktop.nm-dispatcher.service.
Removed symlink /etc/systemd/system/multi-user.target.wants/NetworkManager.service.
 


activation systemd-networkd


systemctl enable systemd-networkd
 


retour


Created symlink from /etc/systemd/system/multi-user.target.wants/systemd-networkd.service to /lib/systemd/system/systemd-networkd.service.
Created symlink from /etc/systemd/system/sockets.target.wants/systemd-networkd.socket to /lib/systemd/system/systemd-networkd.socket.
 


demarrer le systemed-networkd


systemctl start systemd-networkd
 


verifier si pas d erreur


systemctl status systemd-networkd
 


retour


● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: active (running) since mar. 2016-01-12 18:48:46 CET; 23s ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 1516 (systemd-network)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-networkd.service
           └─1516 /lib/systemd/systemd-networkd

janv. 12 18:48:46 debiang41m systemd[1]: Starting Network Service...
janv. 12 18:48:46 debiang41m systemd-networkd[1516]: enp1s0: Gained IPv6LL
janv. 12 18:48:46 debiang41m systemd-networkd[1516]: Enumeration completed
janv. 12 18:48:46 debiang41m systemd[1]: Started Network Service.
janv. 12 18:48:50 debiang41m systemd-networkd[1516]: enp1s0: DHCPv4 address 192.168.10.34/24 via 192.168.10.1
janv. 12 18:48:50 debiang41m systemd-networkd[1516]: enp1s0: Configured
 


le resolv.conf n'est pas obligatoire dans mon cas , je reboot et je reviens
me revoilou , j attaque le resolv.conf
activer systemd-resolved service


systemctl enable systemd-resolved.service
 


retour


Created symlink from /etc/systemd/system/multi-user.target.wants/systemd-resolved.service to /lib/systemd/system/systemd-resolved.service.
 


effacer l ancien resolv.conf


rm /etc/resolv.conf
 


créer le lien symbolique


ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf
 


demarrer le service


systemctl start systemd-resolved.service
 


renseigner le dns

 
nano /etc/systemd/resolved.conf
 


retour


#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See resolved.conf(5) for details

[Resolve]
#DNS=
#FallbackDNS=8.8.8.8 8.8.4.4 2001:4860:4860::8888 2001:4860:4860::8844
#LLMNR=yes

DNS=192.168.10.1
 


ps: correction 192.168.10.1 et pas 192,168,10,1
redemarrer le service


systemctl restart systemd-resolved.service
 



informations ethtool


ethtool -i enp1s0
 


retour


driver: atl1c
version: 1.0.1.1-NAPI
firmware-version:
expansion-rom-version:
bus-info: 0000:01:00.0
supports-statistics: no
supports-test: no
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no
 



et fin
ps: pour ma passerelle ça va etre plus hard , 2 cartes reseau , limitation du debit , services serveur , faut bien que je reflechisse avant
pour mon autre serveur en jessie pas necessaire pour l instant (celui ou il y a le bonding en service )
toutes les options ici => 
http://www.freedesktop.org/software/sys … twork.html
http://www.freedesktop.org/software/sys … .link.html

pour tous les clients en stretch ils risquent de passer a la casserole tongue
je vais vérifier la suppression du paquet "ifupdown" et "network-manager" je sais pas si gnome l autorise (niveau dépendance )

ps2:  pour network-manager , il veut enlever gnome  (pour ifupdown c est fait il est enlevé)


apt-get -s remove --purge network-manager
 


retour


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  gnome* network-manager* network-manager-gnome*
0 mis à jour, 0 nouvellement installés, 3 à enlever et 0 non mis à jour.
Purg gnome [1:3.14+3]
Purg network-manager-gnome [1.0.10-1]
Purg network-manager [1.0.10-1]
 


il est désactivé pas bien grave

Dernière modification par robert2a (17-01-2016 14:47:25)

Hors ligne

#4 12-01-2016 21:17:41

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

j'ai fait une erreur dans le resolv.conf  192,168,10,1 au lieu de 192.168.10.1 (en console le "." du pavé numérique me met une virgule a la place sad


Jan 12 19:20:43 debiang41m systemd-resolved[1325]: Using system hostname 'debiang41m'.
Jan 12 19:20:43 debiang41m systemd-resolved[1325]: Ignoring invalid DNS address '192,168,10,1'
Jan 12 19:20:43 debiang41m systemd[1]: Started Network Name Resolution.
 


je n ai pas modifié ni installé ntp mais la machine se met a l heure sur le serveur wink


jan 12 19:56:08 debiang41m systemd-timesyncd[358]: Network configuration changed, trying to establish connection.
Jan 12 19:56:08 debiang41m systemd-timesyncd[358]: Synchronized to time server 192.168.10.1:123 (192.168.10.1).
 



tout m a l air correct  smile

cette ligne

cat /etc/udev/rules.d/70-persistent-net.rules


ne renvoie rien , tu sais pourquoi ? (le dossier /etc/udev/rules.d   est vide )

Dernière modification par robert2a (12-01-2016 23:08:45)

Hors ligne

#5 13-01-2016 15:01:25

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

J'ai mit a jour quelques infos au dessus.
la machine qui a servi aux tests a encore laché (disque dur)
je vais tenter la meme chose sur une machine avec 2 cartes réseau (serveur pxe qui m a servi a travailler sur les clients pxe)
eth0 en dhcp (coté réseau local )
eth1 en ip fixe (coté client pxe)
serveur dhcp sur eth1
partage tftp sur eth1

je suis sur la machine , je vais enlever network-manager des paquets installés .
status de systemd-network


systemctl status systemd-networkd
 


retour


● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: active (running) since mer. 2016-01-13 14:25:09 CET; 14s ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 1535 (systemd-network)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-networkd.service
           └─1535 /lib/systemd/systemd-networkd

janv. 13 14:25:08 debian5 systemd[1]: Starting Network Service...
janv. 13 14:25:09 debian5 systemd-networkd[1535]: eth0: Gained IPv6LL
janv. 13 14:25:09 debian5 systemd-networkd[1535]: Enumeration completed
janv. 13 14:25:09 debian5 systemd[1]: Started Network Service.
janv. 13 14:25:09 debian5 systemd-networkd[1535]: eth1: Could not set route: Network is unreachable
janv. 13 14:25:13 debian5 systemd-networkd[1535]: eth0: DHCPv4 address 192.168.10.37/24 via 192.168.10.1
janv. 13 14:25:13 debian5 systemd-networkd[1535]: eth0: Configured
 


on voit une erreur sur eth1 , volontaire j'ai donné un passerelle en 192.168.10.1
donc maintenant il faut voir comment je gere le forward entre eth0 et eth1
voici les fichiers .network et .link


le network eth0


[Match]
Name=eth0

[Network]
DHCP=yes
 


le network eth1


Match]
Name=eth1

[Network]
DHCP=no
Address=192.168.0.5/24
Gateway=192.168.10.1 => supprimé incorrect
 



le .link eth1


[Match]
MACAddress=30:b5:c2:05:2b:32
Path=pci-0000:04:00.0
Virtualization=no

[Link]
Name=eth1
MTUBytes=1464
MACAddressPolicy=persistent
WakeOnLan=off
 



le .link eth0


[Match]
MACAddress=00:1d:60:01:f0:10
Path=pci-0000:02:00.0
Virtualization=no

[Link]
Name=eth0
MTUBytes=1464
MACAddressPolicy=persistent
WakeOnLan=off
 



un petit status


● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: active (running) since mer. 2016-01-13 14:32:11 CET; 21min ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 513 (systemd-network)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-networkd.service
           └─513 /lib/systemd/systemd-networkd

janv. 13 14:32:10 debian5 systemd[1]: Starting Network Service...
janv. 13 14:32:11 debian5 systemd-networkd[513]: Enumeration completed
janv. 13 14:32:11 debian5 systemd[1]: Started Network Service.
janv. 13 14:32:14 debian5 systemd-networkd[513]: eth0: Gained carrier
janv. 13 14:32:16 debian5 systemd-networkd[513]: eth0: Gained IPv6LL
janv. 13 14:32:17 debian5 systemd-networkd[513]: eth0: DHCPv4 address 192.168.10.37/24 via 192.168.10.1
janv. 13 14:32:17 debian5 systemd-networkd[513]: eth0: Configured
 



eth1 a disparut tongue

Dernière modification par robert2a (13-01-2016 17:56:44)

Hors ligne

#6 13-01-2016 19:00:13

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Bon apres réflexion voici ce qu il me faut pour faire fonctionner la machine. roll

le fichier /etc/sysctl.conf a été modifié : la ligne net.ipv4.ip_forward=0 est devenue net.ipv4.ip_forward=1


# /etc/sysctl.conf - Configuration file for setting system variables
# See /etc/sysctl.d/ for additional system variables.
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com

# Uncomment the following to stop low-level messages on console
#kernel.printk = 3 4 1 3

##############################################################3
# Functions previously found in netbase
#

# Uncomment the next two lines to enable Spoof protection (reverse-path filter)
# Turn on Source Address Verification in all interfaces to
# prevent some spoofing attacks
#net.ipv4.conf.default.rp_filter=1
#net.ipv4.conf.all.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
# See http://lwn.net/Articles/277146/
# Note: This may impact IPv6 TCP sessions too
#net.ipv4.tcp_syncookies=1

# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
#  Enabling this option disables Stateless Address Autoconfiguration
#  based on Router Advertisements for this host
#net.ipv6.conf.all.forwarding=1
 


la commande "route -n" me donne


route -n
 


retour


Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
0.0.0.0         192.168.10.1    0.0.0.0         UG    1024   0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.10.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.10.1    0.0.0.0         255.255.255.255 UH    1024   0        0 eth0
 



la regle de forward


iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
 



l iptable actuel qui etait chargé avec le fichier network (n'existe plus)


# Generated by iptables-save v1.4.21 on Sun Oct  4 15:11:19 2015
*filter
:INPUT ACCEPT [567:226140]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [585:77111]
-A FORWARD -s 192.168.0.0/24 -i eth1 -o eth0 -p tcp -m state --state NEW,ESTABLISHED -j ACCEPT
-A FORWARD -d 192.168.0.0/24 -i eth0 -o eth1 -p tcp -m state --state ESTABLISHED -j ACCEPT
COMMIT
# Completed on Sun Oct  4 15:11:19 2015
# Generated by iptables-save v1.4.21 on Sun Oct  4 15:11:19 2015
*nat
:PREROUTING ACCEPT [4:304]
:INPUT ACCEPT [4:304]
:OUTPUT ACCEPT [23:1590]
:POSTROUTING ACCEPT [0:0]
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT
# Completed on Sun Oct  4 15:11:19 2015
 



il faut faire l equivalent avec systemd-network  tongue
actuellement mes 2 cartes fonctionnent , un client pxe  sur eth1 reçoit bien une ip , sur eth0 j'ai bien le réseau et le net.
une autre question il me reste un fichier "interfaces" avec la boucle locale , normalement je peut l effacer ?
ps: pour rappel , network-manager n 'est plus installé , plus de configuration eth0 et eth1 dans le fichier "interfaces" , ifupdown supprimé , pas d erreur sur le status de systemd-network

une piste => http://cgit.freedesktop.org/systemd/sys … 56638378ce

voila ce que devient  .network de eth0


[Match]
Name=eth0

[Network]
DHCP=yes

IPForward=ipv4                    

IPMasquerade=yes =>  retiré ne fonctionne pas
 



etat du service



● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: active (running) since mer. 2016-01-13 18:29:49 CET; 5s ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 1746 (systemd-network)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-networkd.service
           └─1746 /lib/systemd/systemd-networkd

janv. 13 18:29:49 debian5 systemd[1]: Starting Network Service...
janv. 13 18:29:49 debian5 systemd-networkd[1746]: eth0: Gained IPv6LL
janv. 13 18:29:49 debian5 systemd-networkd[1746]: eth1: Gained IPv6LL
janv. 13 18:29:49 debian5 systemd-networkd[1746]: Enumeration completed
janv. 13 18:29:49 debian5 systemd[1]: Started Network Service.
janv. 13 18:29:49 debian5 systemd-networkd[1746]: eth1: Configured
janv. 13 18:29:53 debian5 systemd-networkd[1746]: eth0: DHCPv4 address 192.168.10.30/24 via 192.168.10.1
janv. 13 18:29:53 debian5 systemd-networkd[1746]: eth0: Configured
 



http://man7.org/linux/man-pages/man5/sy … ork.5.html

Dernière modification par robert2a (13-01-2016 19:54:36)

Hors ligne

#7 16-01-2016 21:43:33

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Bonsoir

j'ai testé ceci => firewall.service


[Unit]
Description=Packet Filtering Framework
After=network.target local-fs.target

[Service]
RemainAfterExit=true
ExecStart=/etc/parefeu start
ExecStop=/etc/parefeu stop

[Install]
WantedBy=multi-user.target
 



ça me répond dans le syslog , pas de fichier ou dossier , ce n est pas encore ça  roll
le fichier "/etc/parefeu"


# Generated by iptables-save v1.4.21 on Sun Oct  4 15:11:19 2015
*filter
:INPUT ACCEPT [567:226140]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [585:77111]
-A FORWARD -s 192.168.0.0/24 -i eth1 -o eth0 -p tcp -m state --state NEW,ESTABLISHED -j ACCEPT
-A FORWARD -d 192.168.0.0/24 -i eth0 -o eth1 -p tcp -m state --state ESTABLISHED -j ACCEPT
COMMIT
# Completed on Sun Oct  4 15:11:19 2015
# Generated by iptables-save v1.4.21 on Sun Oct  4 15:11:19 2015
*nat
:PREROUTING ACCEPT [4:304]
:INPUT ACCEPT [4:304]
:OUTPUT ACCEPT [23:1590]
:POSTROUTING ACCEPT [0:0]
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT
# Completed on Sun Oct  4 15:11:19 2015
 


c'est juste pour autoriser le passage entre eth0 et eth1 , tout est autorisé , le noyau est configuré pour autoriser le forward
ps avec cette configuration dans "interfaces" ceci fonctionnait

le message a changé dans syslog


Jan 16 20:29:46 debian5 systemd[477]: firewall.service: Failed at step EXEC spawning /etc/parefeu: Permission denied
 



relancer le service  sad


systemctl restart systemd-firewall.service
 


retour


Failed to restart systemd-firewall.service: Unit systemd-firewall.service failed to load: No such file or directory.
 



l etat du service

]
systemctl status firewall.service
 


retour


● firewall.service - Packet Filtering Framework
   Loaded: loaded (/etc/systemd/system/firewall.service; enabled; vendor preset: enabled)
   Active: active (exited) (Result: exit-code) since sam. 2016-01-16 20:29:46 CET; 44min ago
 Main PID: 477 (code=exited, status=203/EXEC)
   CGroup: /system.slice/firewall.service

janv. 16 20:29:46 debian5 systemd[1]: Started Packet Filtering Framework.
janv. 16 20:29:46 debian5 systemd[477]: firewall.service: Failed at step EXEC spawning /etc/parefeu: Permission denied
janv. 16 20:29:46 debian5 systemd[1]: firewall.service: Main process exited, code=exited, status=203/EXEC
 



liens systemd

https://wiki.archlinux.org/index.php/iptables
https://forums.archlinux.fr/viewtopic.php?t=16796
http://doc.fedora-fr.org/wiki/Systemd

Dernière modification par robert2a (16-01-2016 22:17:04)

Hors ligne

#8 17-01-2016 15:59:38

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Bonjour
j'ai modifié ma configuration , après plusieurs lectures , il m a semblé que le fichier ".link" n était pas obligatoire (pour l 'instant)
j'ai 2 fichiers ".network"  , le 50-eth0.network et 51-eth1.network (les .link ont été supprimés )
l'état du réseau


systemctl status -l systemd-networkd
 


retour


● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: active (running) since dim. 2016-01-17 14:47:25 CET; 1min 10s ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 535 (systemd-network)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-networkd.service
           └─535 /lib/systemd/systemd-networkd

janv. 17 14:47:25 debian5 systemd-networkd[535]: Enumeration completed
janv. 17 14:47:25 debian5 systemd[1]: Started Network Service.
janv. 17 14:47:27 debian5 systemd-networkd[535]: eth1: Gained carrier
janv. 17 14:47:28 debian5 systemd-networkd[535]: eth0: Gained carrier
janv. 17 14:47:29 debian5 systemd-networkd[535]: eth1: Gained IPv6LL
janv. 17 14:47:29 debian5 systemd-networkd[535]: eth1: Configured
janv. 17 14:47:30 debian5 systemd-networkd[535]: eth0: Gained IPv6LL
janv. 17 14:47:32 debian5 systemd-networkd[535]: eth0: DHCPv4 address 192.168.10.32/24 via 192.168.10.1
janv. 17 14:47:32 debian5 systemd-networkd[535]: eth0: Configured
janv. 17 14:47:41 debian5 systemd-networkd[535]: eth1: Starting DHCPv6 client after NDisc timeout failed: Invalid argument
 


ps: pour le message eth1 , le dhcp est en ipv4 (serveur) et eth1 est en ipfixe  "192.168.0.1" , il faudra que je cherche le pourquoi de ce message , mais le réseau est fonctionnel.

le fichier 50-eth0.network (dans /etc/systemd/network/50-eth0.network )


[Match]
Path=pci-0000:02:00.0
Driver=sky2
Name=eth0
Host=debian5
Virtualization=no

[Link]
MACAddress=00:1d:60:01:f0:10
MTUBytes=1500

[Network]
DHCP=yes
 


ps: ajout d une section [Link]

le fichier 51-eth1.network (dans /etc/systemd/network/51-eth1.network )


[Match]
Path=pci-0000:04:00.0
Driver=r8169
Name=eth1
Host=debian5
Virtualization=no

[Link]
MACAddress=30:b5:c2:05:2b:32
MTUBytes=1500

[Network]
DHCP=no
Address=192.168.0.1/24
 



pour iptables , je n ai pas trouvé la bonne méthode pour le lancer proprement.
j'ai crée un dossier /etc/iptables/  avec un fichier iptables.rules
il serait peut etre mieux de faire cela avec un fichier ".sh"  (script) pour mettre en places les regles proprement)
Faut il encore savoir lancer ce script correctement avec systemd  hmm

@Severian
c'est une alternative a ce que tu présente dans le tuto , ça me semble correct et le réseau fonctionne .
Quand faut t'il utiliser un .link je ne sais pas tongue

Dernière modification par robert2a (17-01-2016 16:19:22)

Hors ligne

#9 17-01-2016 18:46:23

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : test reseau filaire via systemd

robert2a a écrit :

@Severian
c'est une alternative a ce que tu présente dans le tuto , ça me semble correct et le réseau fonctionne .
Quand faut t'il utiliser un .link je ne sais pas tongue



j'avais eu des erreurs avec la section [Link] inseré dans le .network (sans compter que ça ne prenait pas la configuration), pour ça que j'ai mis le .link, mais effectivement, visiblement tu peux configurer tes connexions sans .link

de ce que je comprend (encore une fois je ne suis pas informaticien, si un spécialiste du réseau passe par là il pourra sans doute mieux expliquer) le .network sert à configurer ta connexion, le .link sert à certaines options (mtu, débit (si ont veut limiter), wake of lan, masquage adresse mac...).

j'ai essayé de faire un tuto le plus complet, mais si on va au plus simple pour configurer une connexion via systemd ça peut se résumer par

nano /etc/systemd/network/20-eth0.network


[Match]
Name=eth0

[Network]
DHCP=yes


systemctl enable systemd-networkd


systemctl start systemd-networkd


normalement ça doit fonctionner ...

d'autre liens
https://wiki.archlinux.fr/Systemd-networkd
https://wiki.archlinux.org/index.php/systemd-networkd (version anglaise plus complète)
http://www.freedesktop.org/software/sys … rvice.html


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#10 17-01-2016 18:48:00

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Pour supprimer l erreur dhcpv6 j ai ajouté a la section network de la configuration de eth1 => LinkLocalAddressing=no et  IPForward=yes


[Match]
Path=pci-0000:04:00.0
Driver=r8169
Name=eth1
Host=debian5
Virtualization=no

[Link]
MACAddress=30:b5:c2:05:2b:32
MTUBytes=1500

[Network]
DHCP=no
Address=192.168.0.1/24
LinkLocalAddressing=no
IPForward=yes
 



@Severian

citer:


de ce que je comprend (encore une fois je ne suis pas informaticien, si un spécialiste du réseau passe par là il pourra sans doute mieux expliquer)
 le .network sert à configurer ta connexion, le .link sert à certaines options (mtu, débit (si ont veut limiter), wake of lan, masquage adresse mac...).
 


je pense aussi , moi non plus c est souvent du "petit chinois" , mais je trouve intéressant , donc je persiste smile
il faut faire attention au redondance ou conflit entre ".network" et ".link"
sinon ce que j ai mit ci dessus fonctionne , pas testé mais si je charge mon iptables manuellement je suis sur que ça fonctionne.
comme tu dis une personne qui gère  bien serait le bienvenue , mais je pense que systemd-networkd reste encore au stade de nouveauté , sur fedora (et archilinux) ça bouge , mais sur debian c est calme smile

ps: le souci est revenu hmm


eth1: Starting DHCPv6 client after NDisc timeout failed: Invalid argument
 


c'est le clientdhcp qui fait ça , qui ne devrait pas solliciter eth1  sad
ps: j'ai remit => IPForward=yes qui a priori supprime le message , mais sans comprendre .. sad

Dernière modification par robert2a (17-01-2016 19:49:30)

Hors ligne

#11 26-01-2016 17:00:33

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Bonjour
suite a la discution ici => https://debian-facile.org/viewtopic.php … 00#p160000

la mise en place de iptables-persistent (et des regles ) sur une passerelle avec systemd_networkd

ce que donne la modification (création de /etc/iptables/rules.v4 )


# Generated by iptables-save v1.4.21 on Tue Jan 26 15:40:06 2016
*filter
:INPUT ACCEPT [18:3018]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [18:3018]
-A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A FORWARD -i eth1 -o eth0 -j ACCEPT
COMMIT
# Completed on Tue Jan 26 15:40:06 2016
# Generated by iptables-save v1.4.21 on Tue Jan 26 15:40:06 2016
*nat
:PREROUTING ACCEPT [1:76]
:INPUT ACCEPT [1:76]
:OUTPUT ACCEPT [1:80]
:POSTROUTING ACCEPT [1:80]
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT
# Completed on Tue Jan 26 15:40:06 2016
 



suite aux mises a jour (sid)  un fichier /etc/network/interfaces a été créer (par ifupdown je suppose)


# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
 

Dernière modification par robert2a (26-01-2016 17:06:29)

Hors ligne

#12 03-02-2016 01:36:50

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Bonsoir
j'ai monté une carte pci wifig et un modem routeur wifi , je suis connecté (avec network manager) debian stretch et mate
que faut il faire pour tester systemd-networkd en wifi , un début de tuto ou il faut chercher ?

ps: c est une machine CM A8V Deluxe + carte wifig Asus (chipset realtek)  connecté sur un modem routeur dlink en wifi , une carte reseau filaire (deconnecté apres la config du wifi)
le reseau est configuré par defaut (premiere installation) , il y a tout a faire .

Hors ligne

#13 03-02-2016 08:19:10

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : test reseau filaire via systemd

robert2a a écrit :

Bonsoir
j'ai monté une carte pci wifig et un modem routeur wifi , je suis connecté (avec network manager) debian stretch et mate
que faut il faire pour tester systemd-networkd en wifi , un début de tuto ou il faut chercher ?

ps: c est une machine CM A8V Deluxe + carte wifig Asus (chipset realtek)  connecté sur un modem routeur dlink en wifi , une carte reseau filaire (deconnecté apres la config du wifi)
le reseau est configuré par defaut (premiere installation) , il y a tout a faire .



regarde https://wiki.archlinux.fr/Systemd-networkd#WiFi


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#14 03-02-2016 16:24:28

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : test reseau filaire via systemd

Merci je testerai avec des retours ici , mais comme il est dit c est plus compliqué qu une carte filaire .
je pense qu il faut commencer par la carte cablé puis ensuite le wifi.
ps: avec mate j ai un petit icone en haut a droite qui me donne la qualité de la réception (network manager) et l état de la connection . roll

Hors ligne

#15 03-02-2016 16:26:27

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : test reseau filaire via systemd

network-manager ou un applet du genre
par contre je pense qu'avec le wifi systemd il y en aura pas (du moins pas encore)

"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

Pied de page des forums