Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-01-2016 05:25:14

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[Résolu] Le PHP7 refuse de fonctionner avec Apache2

Bonjour,

Je tente de faire le saut vers PHP7 avant qu'il ne soit officiellement soutenu par Debian stable.

J'ai suivi les instructions de https://angristan.fr/installer-php-7-so … ot-dotdeb/
J'ai désinstallé et installé apache2 à l'aide de Synaptic
J'ai aussi lu https://debian-facile.org/viewtopic.php?id=13141 et bien d'autres discussions ailleurs, une entre autres qui suggérait de totalement désinstaller apache2.  Je me suis arrêté en voyant le nombre impressionnant de dépendances - d'où l'usage de Synaptic

Au bout du compte:  ça ne fonctionne pas.

Les commandes

php -v
apache2 -v



Me donnent des réponses cohérentes, les deux fonctionnent bien, mais individuellement.
Comment faire d'Apache2 le serveur PHP de mes rêves ?

Mon /etc/log/apache2/error.log ne me donne que ceci

[:error] [pid 18112] avahi_entry_group_add_service_strlst("localhost") failed: Invalid host name


Bref, il redit ce que je vous ai écrit ci-haut  localhost est introuvable.
Je n'ai pas de meilleur résultat avec 127.0.0.1

Merci encore.

Dernière modification par Patriboom (29-01-2016 07:50:52)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 29-01-2016 07:50:34

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Le PHP7 refuse de fonctionner avec Apache2

Dans mon installation, j'avais oublié le paquet libapache2-mod
Oups!

Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums