Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-02-2016 19:58:07

crousti
Membre
Distrib. : debian testing/sid
Noyau : Linux 4.3.0-1-686-pae
(G)UI : dwm, fluxbox ou lxde
Inscription : 20-11-2015

[résolu] Plus de wifi!

Bonsoir suite à petit nettoyage à coup d'aptitude purge et autoclean, je n'ai plus de wifi.
Après vérification mon firmeware-b43 est toujours là
Ma carte wifi apparait bien avec lspci
Par contre pas de wlan0 avec ifconfig
Quand je fais ifconfig wlan0 up j'ai une erreur:
sylvain@debian:~$

sudo ifconfig wlan0 up



wlan0: ERROR while getting interface flags: Aucun périphérique de ce type
 


Une idée?
Merci
Sylvain

Edit à toto :
Tilt ! Mis sous balises Commande user la commande user indiquée et séparée de son retour.
Voir le tuto qui le fait : Voir le tuto : Le code, ça pique moins les yeux en couleur smile

Dernière modification par crousti (05-02-2016 00:02:05)

Hors ligne

#2 04-02-2016 21:26:20

dh
Membre
Lieu : Rhône
Distrib. : SID
Noyau : 4.2.0-1-amd64
(G)UI : Gnome3
Inscription : 23-03-2010

Re : [résolu] Plus de wifi!

Que donne :

lsmod | grep b43


Libertaire, libéral, libre.

Hors ligne

#3 04-02-2016 21:52:03

crousti
Membre
Distrib. : debian testing/sid
Noyau : Linux 4.3.0-1-686-pae
(G)UI : dwm, fluxbox ou lxde
Inscription : 20-11-2015

Re : [résolu] Plus de wifi!

Bonsoir et merci.
9a donne ça:
sylvain@debian:~$

lsmod | grep b43



b43                   393216  0
bcma                   45056  1 b43
mac80211              516096  1 b43
cfg80211              413696  2 b43,mac80211
rng_core               16384  1 b43
ssb                    57344  1 b43
mmc_core              102400  2 b43,ssb
pcmcia                 49152  2 b43,ssb
 



Edit à toto :
Juste la commande et rien d'autre dans les balises commande user et le retour dans les balises retour de comande séparé lui aussi. cool

Dernière modification par crousti (04-02-2016 21:52:28)

Hors ligne

#4 04-02-2016 23:19:30

Vernom
Membre
Distrib. : Sid
Noyau : 4.4.0-1-amd64
(G)UI : Openbox
Inscription : 10-11-2015

Re : [résolu] Plus de wifi!

Salut.

Question bête : tu as redémarré la machine ?

Dernière modification par Vernom (04-02-2016 23:19:44)

Hors ligne

#5 04-02-2016 23:31:50

crousti
Membre
Distrib. : debian testing/sid
Noyau : Linux 4.3.0-1-686-pae
(G)UI : dwm, fluxbox ou lxde
Inscription : 20-11-2015

Re : [résolu] Plus de wifi!

Salut.
J'ai redémarré oui, et je viens de le refaire, du coup je me suis aperçu que j'avais un message d'erreur avec le  firmware-b43-lpphy-installer.
En cherchant j 'ai vu que c'était un paquet qui provenait de debian wheezy, ce qui doit expliquer, peu être,  sa purge.
j'essaye d'installer le firmware officiel de chez broadcom pour voir.

Pas mieux!
je met ce que j'ai trouvé dans les log:

Feb  4 22:33:47 debian kernel: [   16.473085] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
Feb  4 22:33:47 debian kernel: [   16.504762] b43-phy0: Found PHY: Analog 6, Type 5 (LP), Revision 1
Feb  4 22:33:47 debian kernel: [   16.504779] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2062, Revision 2, Version 0
Feb  4 22:33:47 debian kernel: [   16.517191] Broadcom 43xx driver loaded [ Features: PMNLS ]
Feb  4 22:33:47 debian kernel: [   16.537464] b43 ssb0:0: firmware: failed to load b43/ucode15.fw (-2)
Feb  4 22:33:47 debian kernel: [   16.537533] b43 ssb0:0: Direct firmware load for b43/ucode15.fw failed with error -2
Feb  4 22:33:47 debian kernel: [   16.537552] b43 ssb0:0: firmware: failed to load b43/ucode15.fw (-2)
Feb  4 22:33:47 debian kernel: [   16.537611] b43 ssb0:0: Direct firmware load for b43/ucode15.fw failed with error -2
Feb  4 22:33:47 debian kernel: [   16.537630] b43 ssb0:0: firmware: failed to load b43-open/ucode15.fw (-2)
Feb  4 22:33:47 debian kernel: [   16.537693] b43 ssb0:0: Direct firmware load for b43-open/ucode15.fw failed with error -2
Feb  4 22:33:47 debian kernel: [   16.537706] b43 ssb0:0: firmware: failed to load b43-open/ucode15.fw (-2)
Feb  4 22:33:47 debian kernel: [   16.537767] b43 ssb0:0: Direct firmware load for b43-open/ucode15.fw failed with error -2
Feb  4 22:33:47 debian kernel: [   16.537771] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version.$

Dernière modification par crousti (04-02-2016 23:47:45)

Hors ligne

#6 05-02-2016 00:01:39

crousti
Membre
Distrib. : debian testing/sid
Noyau : Linux 4.3.0-1-686-pae
(G)UI : dwm, fluxbox ou lxde
Inscription : 20-11-2015

Re : [résolu] Plus de wifi!

C'est bon j'y suis arrivé!
Si quelqu'un a le même problème il faut suivre cette méthode:
https://wiki.debian.org/fr/wl
Merci et bonne nuit

Hors ligne

Pied de page des forums