Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-02-2016 10:53:52

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Bonjour a tous , après une mise a jour habituelle aptitude update && aptitude full-upgrade (sans problème d'habitude ) neutral je me suis retrouver avec ce code erreur dans dpkg :

dpkg: parse error, in file '/var/lib/dpkg/status' near line 717 package 'python-idna':
`Depends' field, invalid package name `python:any': character `:' not allowed (only letters, digits and characters `-+._')
E: Sub-process /usr/bin/dpkg returned an error code (2)

J'ai farfouiller un peu sur le net mais a mon grand déséspoire je n'ai pas encore trouver de solution sad

pourriez-vous m'aider svp

Hors ligne

#2 09-02-2016 11:10:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Salut leratdu60 et bienvenue sur df !

Sur ce forum, nous avons choisi que chacun indique son système et autre VM dans son Profil ainsi :
Voir le tuto : Trop cool d'indiquer son installation dans son profil ! smile

Pour ton problème, apparemment tu es en sid et si tu choisis d'utiliser full-upgrade c'est que tu ne lis pas suffisamment ce que te renvoie cette commande avant de l'executer.
Ni peut-être que tu n'as pas l'usage de l'application list-bug pourtant faite pour ça.

Peux-tu indiquer ici ce à quoi ta commande full-upgrade t'a proposé d'opérer et que tu as validé ?

Pour le reste, étant en stable, je ne pourrai t'aider davantage. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 09-02-2016 11:12:51

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Bonjour et bienvenue smile

leratdu60 a écrit :

pourriez-vous m'aider svp

Moi non, mais toi, je pense que oui.

J'aurais tendance à penser que tu as trouver un bug, chose plus ou moins normale dans sid (Still In Developpement), la version de développement de Debian.

Il faut donc remonter ce bug afin qu'il soit corrigé.

Comme je n'utilise pas Sid, je ne serais pas affirmatif, mais si un utilisateur de Sid plus expérimenté passe par là, il pourra peut-être confirmer smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#4 09-02-2016 11:27:30

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Bonjour

tu a une reference a stretch dans ton sources.list  ?
tu peu aussi attendre un peu et faire :
nettoyer ton cache


apt-get clean
 


recupérer les paquets disponnibles


apt-get update
 


mettre a jour (voir si le probleme persiste ) tu simule dans un premier temps


apt-get -s upgrade
 


si pas de soucis tu met a jour


apt-get upgrade
 


ps:pour les mises a jour j'utilise plutot  upgrade que full-upgrade
je vai me connecter sur ma sid (en général je suis le roi du bug tongue  )

En ligne

#5 09-02-2016 11:29:20

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Bonjour smolski d 'abord merci pour la rapidité de votre réponse
J ai mit a jour mon profil merci (je suis nouveau tongue)

C'est arriver il y a quelques jours d'habitude je regarde bien la liste des paquets qui se mettent a jours et ceux qui s'enlevent avant de valider mais la honétement je m'en rappelle pas ( a l'aide de synaptic je viens de verifier si 'python-idna' est manquant mais il est bien installer et je n'ai aucuns paquet manquant) hmm


Bonjour bendia, Oui surement ça peut arriver pourtant jusque la ça roulait bien lol

Hors ligne

#6 09-02-2016 11:36:18

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Bonjour robert2a
Non voilà mon source.list :


# Debian sid, dépôt principal + paquets non libres
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid non-free contrib main

# Debian sid, mises-à-jour de sécurité + paquets non libres
# deb http://security.debian.org/ sid/updates main contrib non-free
# deb-src http://security.debian.org/ sid/updates main contrib non-free

# Debian sid, mises-à-jour "volatiles" + paquets non libres
# deb http://ftp.fr.debian.org/debian/ sid-updates main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ sid-updates main contrib non-free





deb http://www.deb-multimedia.org/ sid main non-free

# deb http://downloads.sourceforge.net/project/xenlism-wildfire/repo/ deb/



Edit à toto :
Mis les balises apt_sources pour faire joli et faciliter la lecture des sources citées.

Hors ligne

#7 09-02-2016 11:41:14

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

voici le retour des 2 premieres commandes :

root@debian:/home/lerat#

apt-get update



Atteint:1 [url]http://www.deb-multimedia.org[/url] sid InRelease
Atteint:2 [url]http://ftp.fr.debian.org/debian[/url] sid InRelease      
Atteint:3 [url]https://pkg.tox.chat/debian[/url] nightly InRelease
Lecture des listes de paquets... Fait


root@debian:/home/lerat#

apt-get -s upgrade



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libavcodec56 libavresample2 libavutil54 libswresample1 libtheora0 libvlccore8 libvorbis0a libvorbisenc2 libvorbisfile3 lximage-qt
  pcmanfm-qt vlc vlc-nox vlc-plugin-notify vlc-plugin-samba
Les paquets suivants seront mis à jour:
  acl diffstat ffmpeg findutils icedtea-8-plugin icedtea-netx icedtea-netx-common libacl1 libavdevice56 libavfilter5 libavformat56
  libdc1394-22 libgnutls-openssl27 libgnutls30 libhogweed4 libio-socket-ssl-perl libltdl7 libnettle6 libopencv-calib3d2.4v5
  libopencv-contrib2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4v5
  libopencv-imgproc2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 libperl5.22
  libpostproc53 libswscale3 libtokyocabinet9 libvlc5 libwcs5 linux-compiler-gcc-5-x86 linux-headers-4.3.0-1-amd64
  linux-headers-4.3.0-1-common linux-image-4.3.0-1-amd64 linux-libc-dev manpages manpages-dev perl perl-base perl-modules-5.22
  python-cryptography vlc-data
47 mis à jour, 0 nouvellement installés, 0 à enlever et 15 non mis à jour.
3 partiellement installés ou enlevés.
Inst icedtea-netx-common [1.6.2-1] (1.6.2-2 Debian:unstable [all])
Inst icedtea-8-plugin [1.6.2-1] (1.6.2-2 Debian:unstable [amd64]) []
Inst icedtea-netx [1.6.2-1] (1.6.2-2 Debian:unstable [amd64])
Inst findutils [4.6.0-2] (4.6.0+git+20160126-2 Debian:unstable [amd64])
Conf findutils (4.6.0+git+20160126-2 Debian:unstable [amd64])
Inst libperl5.22 [5.22.1-5] (5.22.1-7 Debian:unstable [amd64]) [perl:amd64 ]
Inst perl [5.22.1-5] (5.22.1-7 Debian:unstable [amd64]) []
Inst perl-base [5.22.1-5] (5.22.1-7 Debian:unstable [amd64]) []
Conf perl-base (5.22.1-7 Debian:unstable [amd64]) []
Inst perl-modules-5.22 [5.22.1-5] (5.22.1-7 Debian:unstable [all])
Inst libvlc5 [1:2.2.1-dmo14] (1:2.2.2-dmo1 Unofficial Multimedia Packages:unstable [amd64])
Inst linux-image-4.3.0-1-amd64 [4.3.3-7] (4.3.5-1 Debian:unstable [amd64])
Inst acl [2.2.52-2] (2.2.52-3 Debian:unstable [amd64]) []
Inst libacl1 [2.2.52-2] (2.2.52-3 Debian:unstable [amd64])
Conf libacl1 (2.2.52-3 Debian:unstable [amd64])
Inst libhogweed4 [3.1.1-4] (3.2-1 Debian:unstable [amd64]) []
Inst libnettle6 [3.1.1-4] (3.2-1 Debian:unstable [amd64])
Inst libgnutls-openssl27 [3.4.8-3] (3.4.9-2 Debian:unstable [amd64]) []
Inst libgnutls30 [3.4.8-3] (3.4.9-2 Debian:unstable [amd64])
Inst libtokyocabinet9 [1.4.48-6] (1.4.48-7 Debian:unstable [amd64])
Inst manpages [4.04-0.1] (4.04-1 Debian:unstable [all])
Inst diffstat [1.60-1] (1.61-1 Debian:unstable [amd64])
Inst libavformat56 [10:2.8.6-dmo1] (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Inst libpostproc53 [10:2.8.6-dmo1] (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Inst libswscale3 [10:2.8.6-dmo1] (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Inst libavfilter5 [10:2.8.6-dmo1] (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Inst libdc1394-22 [2.2.3-1] (2.2.4-1 Debian:unstable [amd64])
Inst libavdevice56 [10:2.8.6-dmo1] (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Inst ffmpeg [10:2.8.6-dmo1] (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Inst libio-socket-ssl-perl [2.023-1] (2.024-1 Debian:unstable [all])
Inst libltdl7 [2.4.2-1.11] (2.4.6-0.1 Debian:unstable [amd64])
Inst libopencv-legacy2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-contrib2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-calib3d2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-features2d2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-flann2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-video2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-objdetect2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-highgui2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-imgproc2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-ml2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64]) []
Inst libopencv-core2.4v5 [2.4.9.1+dfsg-1.2+b1] (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Inst libwcs5 [5.13-1] (5.14-1 Debian:unstable [amd64])
Inst linux-compiler-gcc-5-x86 [4.3.3-7] (4.3.5-1 Debian:unstable [amd64])
Inst linux-headers-4.3.0-1-amd64 [4.3.3-7] (4.3.5-1 Debian:unstable [amd64]) []
Inst linux-headers-4.3.0-1-common [4.3.3-7] (4.3.5-1 Debian:unstable [amd64])
Inst linux-libc-dev [4.3.3-7] (4.3.5-1 Debian:unstable [amd64])
Inst manpages-dev [4.04-0.1] (4.04-1 Debian:unstable [all])
Inst python-cryptography [1.2.2-1] (1.2.2-2 Debian:unstable [amd64])
Inst vlc-data [1:2.2.1-dmo14] (1:2.2.2-dmo1 Unofficial Multimedia Packages:unstable [all])
Conf icedtea-netx-common (1.6.2-2 Debian:unstable [all])
Conf icedtea-netx (1.6.2-2 Debian:unstable [amd64])
Conf icedtea-8-plugin (1.6.2-2 Debian:unstable [amd64])
Conf default-java-plugin (2:1.8-55 Debian:unstable [amd64])
Conf perl-modules-5.22 (5.22.1-7 Debian:unstable [all])
Conf libperl5.22 (5.22.1-7 Debian:unstable [amd64])
Conf perl (5.22.1-7 Debian:unstable [amd64])
Conf libvlc5 (1:2.2.2-dmo1 Unofficial Multimedia Packages:unstable [amd64])
Conf linux-image-4.3.0-1-amd64 (4.3.5-1 Debian:unstable [amd64])
Conf acl (2.2.52-3 Debian:unstable [amd64])
Conf libnettle6 (3.2-1 Debian:unstable [amd64])
Conf libhogweed4 (3.2-1 Debian:unstable [amd64])
Conf libgnutls30 (3.4.9-2 Debian:unstable [amd64])
Conf libgnutls-openssl27 (3.4.9-2 Debian:unstable [amd64])
Conf libtokyocabinet9 (1.4.48-7 Debian:unstable [amd64])
Conf manpages (4.04-1 Debian:unstable [all])
Conf diffstat (1.61-1 Debian:unstable [amd64])
Conf libavformat56 (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Conf libpostproc53 (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Conf libswscale3 (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Conf libavfilter5 (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Conf libdc1394-22 (2.2.4-1 Debian:unstable [amd64])
Conf libavdevice56 (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Conf ffmpeg (10:2.8.6-dmo2 Unofficial Multimedia Packages:unstable [amd64])
Conf libio-socket-ssl-perl (2.024-1 Debian:unstable [all])
Conf libltdl7 (2.4.6-0.1 Debian:unstable [amd64])
Conf libopencv-core2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-flann2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-imgproc2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-highgui2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-features2d2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-calib3d2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-ml2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-video2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-legacy2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-objdetect2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libopencv-contrib2.4v5 (2.4.9.1+dfsg-1.3 Debian:unstable [amd64])
Conf libwcs5 (5.14-1 Debian:unstable [amd64])
Conf linux-compiler-gcc-5-x86 (4.3.5-1 Debian:unstable [amd64])
Conf linux-headers-4.3.0-1-common (4.3.5-1 Debian:unstable [amd64])
Conf linux-headers-4.3.0-1-amd64 (4.3.5-1 Debian:unstable [amd64])
Conf linux-libc-dev (4.3.5-1 Debian:unstable [amd64])
Conf manpages-dev (4.04-1 Debian:unstable [all])
Conf python-cryptography (1.2.2-2 Debian:unstable [amd64])
Conf vlc-data (1:2.2.2-dmo1 Unofficial Multimedia Packages:unstable [all])
 


root@debian:/home/lerat#

Edit à toto :
Mis les commandes root sous balises root séparées de ce qui les précède et leur retours séparés dans des balises code simple.
Voir le tuto : Le code, ça pique moins les yeux en couleur smile

Hors ligne

#8 09-02-2016 11:45:33

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

voici le mien


deb http://ftp.fr.debian.org/debian sid main contrib non-free

deb http://ftp.fr.debian.org/debian stretch main contrib non-free
deb http://ftp.fr.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
 



j'ai fait une simulation a l'instant pas de problemes .
je met a jour

@++

ps:


Les paquets suivants ont été conservés :
  libtesseract3 libzmq3 tesseract-ocr
Les paquets suivants seront mis à jour :
  acl alsa-utils apt apt-utils busybox cpp-5 default-jre default-jre-headless diffstat dmsetup findutils gcc-5 gcc-5-base gir1.2-packagekitglib-1.0 gnupg
  gpgv grub-common grub-pc grub-pc-bin grub2-common init init-system-helpers installation-report java-common libacl1 libapt-inst2.0 libapt-pkg5.0 libasan2
  libatomic1 libbs2b0 libcc1-0 libcilkrts5 libdevmapper1.02.1 libgcc-5-dev libgcc1 libgfortran3 libgnutls-openssl27 libgnutls30 libgomp1 libhogweed4
  libio-socket-ssl-perl libitm1 libllvm3.7 liblsan0 libltdl7 libmpx0 libnettle6 libnm-glib4 libnm-util2 libnss-mdns libopencv-core2.4v5
  libopencv-imgproc2.4v5 libpackagekit-glib2-18 libpam-systemd libperl5.22 libquadmath0 libsmbclient libstdc++6 libsystemd0 libtheora0 libtsan0 libubsan0
  libudev1 libvorbis0a libvorbisenc2 libvorbisfile3 libwbclient0 linux-compiler-gcc-5-x86 linux-headers-4.3.0-1-amd64 linux-headers-4.3.0-1-common
  linux-image-4.3.0-1-amd64 linux-libc-dev manpages manpages-dev openjdk-8-jre openjdk-8-jre-headless packagekit packagekit-tools perl perl-base
  perl-modules-5.22 pinentry-gnome3 publicsuffix python-samba samba-common samba-common-bin samba-libs systemd systemd-sysv udev
90 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
 

Dernière modification par robert2a (09-02-2016 12:03:31)

En ligne

#9 09-02-2016 11:47:11

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

leratdu60 a écrit :

Oui surement ça peut arriver pourtant jusque la ça roulait bien lol

Louis Aragon a écrit :

Rien n'est jamais acquis à l'homme Ni sa force
Ni sa faiblesse ni son coeur Et quand il croit
Ouvrir ses bras son ombre est celle d'une croix
Et quand il croit serrer son bonheur il le broie
Sa vie est un étrange et douloureux divorce
          Il n'y a pas d'amour heureux

C'est une bonne définition de Sid wink
Sinon, pour ma collection de points-choco Voir le tuto : Le code, ça pique moins les yeux en couleur


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#10 09-02-2016 11:52:40

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

met une référence a stretch ça coute rien wink et je sais pas si (demander au modo ) tes référence a security et update pour sid servent a quelque chose ?

mise a jour effectué sans probleme pour moi.

tu est allez jusqu au bout de la mise a jour ?
d'apres ton post en #7 tu n'a pas de souci pour la mise a jour , pas d erreurs

Dernière modification par robert2a (09-02-2016 12:01:38)

En ligne

#11 09-02-2016 13:40:27

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Salut,

@ leratdu60, au vu de ton apt-get -s upgrade du post #7, il y a ceci que tu peux corriger :

3 partiellement installés ou enlevés

.
avec la commande :

dpkg --configure -a


       --configure package...|-a|--pending
              Configure a package which has been unpacked but not yet configured.  If -a or --pending is given instead of package, all unpacked but unconfigured packages are configured.

              To reconfigure a package which has already been configured, try the dpkg-reconfigure(8) command instead.

              Configuring consists of the following steps:

              1. Unpack the conffiles, and at the same time back up the old conffiles, so that they can be restored if something goes wrong.

              2. Run postinst script, if provided by the package.



Sinon pour le paquet python-idna, je n'ai pas eu d'erreur, mais j'ai plus d'une centaine de mises à jour en attente, sans doute une dépendance qui coince .

Ma version de python-idna installé :

apt-cache policy python-idna


python-idna:
  Installé : 2.0-3
  Candidat : 2.0-3
 Table de version :
 *** 2.0-3 500
        500 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
 

Dernière modification par nono47 (09-02-2016 13:42:41)

Hors ligne

#12 09-02-2016 22:12:28

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

dpkg --configure -a
 


Toujours cette même érreur

  dpkg: parse error, in file '/var/lib/dpkg/status' near line 717 package 'python-idna':
 `Depends' field, invalid package name `python:any': character `:' not allowed (only letters, digits and characters `-+._')  

Hors ligne

#13 09-02-2016 22:14:53

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Ce que me donne

  apt-cache policy python-idna



  python-idna:
  Install: 2.0-3
  Candidat: 2.0-3
 Table de version:
 *** 2.0-3 500
        500 http://ftp.fr.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status  

Hors ligne

#14 10-02-2016 11:06:05

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Pour information, ce message d'erreur indique bien un bug dans le fichier control de l'archive deb d'un certain paquet. Il y a maintenant deux possibilités. Attendre que le bug soit corrigé, ou trouver le paquet incriminé et remonter le bug voire le corriger.
Puis-je voir le retour complet de la commande

apt-get upgrade


(sans le -s, pour voir les messages d'erreur)

Ou la sortie complète de

dpkg --configure -a

Dernière modification par Dunatotatos (10-02-2016 11:07:09)


Never trust Windows output.

Hors ligne

#15 10-02-2016 11:25:09

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

apt-get update



 Réception de:1 http://ftp.fr.debian.org/debian sid InRelease [287 kB]
Réception de:2 http://www.deb-multimedia.org sid InRelease [24,4 kB]
Réception de:3 http://www.deb-multimedia.org sid/main amd64 Packages [169 kB]
Réception de:4 http://ftp.fr.debian.org/debian sid/non-free Sources.diff/Index [27,8 kB]  
Réception de:5 http://www.deb-multimedia.org sid/non-free amd64 Packages [2 688 B]        
Réception de:6 http://ftp.fr.debian.org/debian sid/main Sources.diff/Index [27,9 kB]      
Réception de:7 http://ftp.fr.debian.org/debian sid/main amd64 Packages.diff/Index [27,9 kB]
Réception de:8 http://ftp.fr.debian.org/debian sid/main Translation-en.diff/Index [27,9 kB]
Réception de:9 http://ftp.fr.debian.org/debian sid/main amd64 DEP-11 Metadata [2 284 kB]
Réception de:10 http://ftp.fr.debian.org/debian sid/main DEP-11 64x64 Icons [7 496 kB]
Atteint:11 https://pkg.tox.chat/debian nightly InRelease                        
Réception de:12 http://ftp.fr.debian.org/debian sid/contrib amd64 DEP-11 Metadata [3 626 B]                                          
Réception de:13 http://ftp.fr.debian.org/debian sid/contrib DEP-11 64x64 Icons [133 kB]                                              
Réception de:14 http://ftp.fr.debian.org/debian sid/non-free amd64 Packages.diff/Index [27,8 kB]                                    
Réception de:15 http://ftp.fr.debian.org/debian sid/non-free Translation-en.diff/Index [19,3 kB]                                    
Réception de:16 http://ftp.fr.debian.org/debian sid/non-free amd64 DEP-11 Metadata [6 328 B]                                        
Réception de:17 http://ftp.fr.debian.org/debian sid/non-free DEP-11 64x64 Icons [33,5 kB]                                            
Réception de:18 http://ftp.fr.debian.org/debian sid/non-free Sources 2016-02-09-1453.04.pdiff [1 117 B]                              
Réception de:18 http://ftp.fr.debian.org/debian sid/non-free Sources 2016-02-09-1453.04.pdiff [1 117 B]                              
Réception de:19 http://ftp.fr.debian.org/debian sid/main Sources 2016-02-09-1453.04.pdiff [12,2 kB]                                  
Réception de:20 http://ftp.fr.debian.org/debian sid/main Sources 2016-02-09-2055.06.pdiff [16,2 kB]                                  
Réception de:21 http://ftp.fr.debian.org/debian sid/main Sources 2016-02-10-0253.53.pdiff [9 043 B]                                  
Réception de:21 http://ftp.fr.debian.org/debian sid/main Sources 2016-02-10-0253.53.pdiff [9 043 B]                                  
Réception de:22 http://ftp.fr.debian.org/debian sid/main amd64 Packages 2016-02-09-1453.04.pdiff [16,4 kB]                          
Réception de:23 http://ftp.fr.debian.org/debian sid/main amd64 Packages 2016-02-09-2055.06.pdiff [21,2 kB]                          
Réception de:24 http://ftp.fr.debian.org/debian sid/main amd64 Packages 2016-02-10-0253.53.pdiff [16,4 kB]                          
Réception de:24 http://ftp.fr.debian.org/debian sid/main amd64 Packages 2016-02-10-0253.53.pdiff [16,4 kB]                          
Réception de:25 http://ftp.fr.debian.org/debian sid/main Translation-en 2016-02-09-1453.04.pdiff [2 154 B]                          
Réception de:26 http://ftp.fr.debian.org/debian sid/main Translation-en 2016-02-09-2055.06.pdiff [1 455 B]                          
Réception de:27 http://ftp.fr.debian.org/debian sid/main Translation-en 2016-02-10-0253.53.pdiff [910 B]                            
Réception de:27 http://ftp.fr.debian.org/debian sid/main Translation-en 2016-02-10-0253.53.pdiff [910 B]                            
Réception de:28 http://ftp.fr.debian.org/debian sid/non-free amd64 Packages 2016-02-09-1453.04.pdiff [782 B]                        
Réception de:29 http://ftp.fr.debian.org/debian sid/non-free amd64 Packages 2016-02-10-0253.53.pdiff [233 B]                        
Réception de:30 http://ftp.fr.debian.org/debian sid/non-free Translation-en 2016-02-09-1453.04.pdiff [430 B]                        
Réception de:30 http://ftp.fr.debian.org/debian sid/non-free Translation-en 2016-02-09-1453.04.pdiff [430 B]                        
Réception de:29 http://ftp.fr.debian.org/debian sid/non-free amd64 Packages 2016-02-10-0253.53.pdiff [233 B]                        
10,7 Mo réceptionnés en 16s (643 ko/s)                                                                                              
Lecture des listes de paquets... Fait



puis

apt-get upgrade



 Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés:
  libavcodec56 libavresample2 libavutil54 libswresample1 libtheora0 libvlccore8 libvorbis0a libvorbisenc2 libvorbisfile3 lximage-qt
  pcmanfm-qt vlc vlc-nox vlc-plugin-notify vlc-plugin-samba
Les paquets suivants seront mis à jour:
  acl acpid diffstat ffmpeg findutils icedtea-8-plugin icedtea-netx icedtea-netx-common libacl1 libavdevice56 libavfilter5
  libavformat56 libboost-date-time1.58.0 libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-program-options1.58.0
  libboost-python1.58.0 libboost-system1.58.0 libboost-thread1.58.0 libdc1394-22 libgnutls-openssl27 libgnutls30 libhogweed4
  libio-socket-ssl-perl libltdl7 libnettle6 libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-core2.4v5
  libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4v5 libopencv-imgproc2.4v5 libopencv-legacy2.4v5
  libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 libperl5.22 libpostproc53 libswscale3 libtokyocabinet9
  libutempter0 libvlc5 libwcs5 linux-compiler-gcc-5-x86 linux-headers-4.3.0-1-amd64 linux-headers-4.3.0-1-common
  linux-image-4.3.0-1-amd64 linux-libc-dev manpages manpages-dev perl perl-base perl-modules-5.22 python-cryptography
  python-html5lib python-six python3-six vlc-data xserver-common xserver-xorg-core xserver-xorg-legacy
62 mis à jour, 0 nouvellement installés, 0 à enlever et 15 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 78,1 Mo dans les archives.
Après cette opération, 5 819 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://www.deb-multimedia.org sid/main amd64 libvlc5 amd64 1:2.2.2-dmo1 [145 kB]
Réception de:2 http://ftp.fr.debian.org/debian sid/main amd64 icedtea-netx-common all 1.6.2-2 [1 387 kB]
Réception de:3 http://www.deb-multimedia.org sid/main amd64 libavformat56 amd64 10:2.8.6-dmo2 [824 kB]
Réception de:4 http://www.deb-multimedia.org sid/main amd64 libpostproc53 amd64 10:2.8.6-dmo2 [82,4 kB]
Réception de:5 http://www.deb-multimedia.org sid/main amd64 libswscale3 amd64 10:2.8.6-dmo2 [173 kB]
Réception de:6 http://www.deb-multimedia.org sid/main amd64 libavfilter5 amd64 10:2.8.6-dmo2 [559 kB]
Réception de:7 http://www.deb-multimedia.org sid/main amd64 libavdevice56 amd64 10:2.8.6-dmo2 [93,8 kB]
Réception de:8 http://www.deb-multimedia.org sid/main amd64 ffmpeg amd64 10:2.8.6-dmo2 [1 352 kB]
Réception de:9 http://www.deb-multimedia.org sid/main amd64 vlc-data all 1:2.2.2-dmo1 [6 079 kB]
Réception de:10 http://ftp.fr.debian.org/debian sid/main amd64 icedtea-8-plugin amd64 1.6.2-2 [201 kB]
Réception de:11 http://ftp.fr.debian.org/debian sid/main amd64 icedtea-netx amd64 1.6.2-2 [34,6 kB]
Réception de:12 http://ftp.fr.debian.org/debian sid/main amd64 findutils amd64 4.6.0+git+20160126-2 [498 kB]                        
Réception de:13 http://ftp.fr.debian.org/debian sid/main amd64 libperl5.22 amd64 5.22.1-7 [3 451 kB]                                
Réception de:14 http://ftp.fr.debian.org/debian sid/main amd64 perl amd64 5.22.1-7 [237 kB]                                          
Réception de:15 http://ftp.fr.debian.org/debian sid/main amd64 perl-base amd64 5.22.1-7 [1 283 kB]                                  
Réception de:16 http://ftp.fr.debian.org/debian sid/main amd64 perl-modules-5.22 all 5.22.1-7 [2 697 kB]                            
Réception de:17 http://ftp.fr.debian.org/debian sid/main amd64 linux-image-4.3.0-1-amd64 amd64 4.3.5-1 [35,4 MB]                    
Réception de:18 http://ftp.fr.debian.org/debian sid/main amd64 acl amd64 2.2.52-3 [58,7 kB]                                          
Réception de:19 http://ftp.fr.debian.org/debian sid/main amd64 libacl1 amd64 2.2.52-3 [27,8 kB]                                      
Réception de:20 http://ftp.fr.debian.org/debian sid/main amd64 libboost-iostreams1.58.0 amd64 1.58.0+dfsg-5 [51,0 kB]                
Réception de:21 http://ftp.fr.debian.org/debian sid/main amd64 libhogweed4 amd64 3.2-1 [136 kB]                                      
Réception de:22 http://ftp.fr.debian.org/debian sid/main amd64 libnettle6 amd64 3.2-1 [191 kB]                                      
Réception de:23 http://ftp.fr.debian.org/debian sid/main amd64 libgnutls-openssl27 amd64 3.4.9-2 [204 kB]                            
Réception de:24 http://ftp.fr.debian.org/debian sid/main amd64 libgnutls30 amd64 3.4.9-2 [786 kB]                                    
Réception de:25 http://ftp.fr.debian.org/debian sid/main amd64 libtokyocabinet9 amd64 1.4.48-7 [365 kB]                              
Réception de:26 http://ftp.fr.debian.org/debian sid/main amd64 manpages all 4.04-1 [1 112 kB]                                        
Réception de:27 http://ftp.fr.debian.org/debian sid/main amd64 acpid amd64 1:2.0.26-1 [55,5 kB]                                      
Réception de:28 http://ftp.fr.debian.org/debian sid/main amd64 diffstat amd64 1.61-1 [31,9 kB]                                      
Réception de:29 http://ftp.fr.debian.org/debian sid/main amd64 libdc1394-22 amd64 2.2.4-1 [107 kB]                                  
Réception de:30 http://ftp.fr.debian.org/debian sid/main amd64 libboost-date-time1.58.0 amd64 1.58.0+dfsg-5 [42,4 kB]                
Réception de:31 http://ftp.fr.debian.org/debian sid/main amd64 libboost-system1.58.0 amd64 1.58.0+dfsg-5 [30,8 kB]                  
Réception de:32 http://ftp.fr.debian.org/debian sid/main amd64 libboost-filesystem1.58.0 amd64 1.58.0+dfsg-5 [60,9 kB]              
Réception de:33 http://ftp.fr.debian.org/debian sid/main amd64 libboost-program-options1.58.0 amd64 1.58.0+dfsg-5 [161 kB]          
Réception de:34 http://ftp.fr.debian.org/debian sid/main amd64 libboost-python1.58.0 amd64 1.58.0+dfsg-5 [144 kB]                    
Réception de:35 http://ftp.fr.debian.org/debian sid/main amd64 libboost-thread1.58.0 amd64 1.58.0+dfsg-5 [70,1 kB]                  
Réception de:36 http://ftp.fr.debian.org/debian sid/main amd64 libio-socket-ssl-perl all 2.024-1 [189 kB]                            
Réception de:37 http://ftp.fr.debian.org/debian sid/main amd64 libltdl7 amd64 2.4.6-0.1 [45,7 kB]                                    
Réception de:38 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-legacy2.4v5 amd64 2.4.9.1+dfsg-1.3 [415 kB]                
Réception de:39 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-contrib2.4v5 amd64 2.4.9.1+dfsg-1.3 [310 kB]                
Réception de:40 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-calib3d2.4v5 amd64 2.4.9.1+dfsg-1.3 [228 kB]                
Réception de:41 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-features2d2.4v5 amd64 2.4.9.1+dfsg-1.3 [225 kB]            
Réception de:42 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-flann2.4v5 amd64 2.4.9.1+dfsg-1.3 [117 kB]                  
Réception de:43 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-video2.4v5 amd64 2.4.9.1+dfsg-1.3 [129 kB]                  
Réception de:44 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-objdetect2.4v5 amd64 2.4.9.1+dfsg-1.3 [200 kB]              
Réception de:45 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-highgui2.4v5 amd64 2.4.9.1+dfsg-1.3 [112 kB]                
Réception de:46 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-imgproc2.4v5 amd64 2.4.9.1+dfsg-1.3 [643 kB]                
Réception de:47 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-ml2.4v5 amd64 2.4.9.1+dfsg-1.3 [199 kB]                    
Réception de:48 http://ftp.fr.debian.org/debian sid/main amd64 libopencv-core2.4v5 amd64 2.4.9.1+dfsg-1.3 [683 kB]                  
Réception de:49 http://ftp.fr.debian.org/debian sid/main amd64 libutempter0 amd64 1.1.6-2 [7 872 B]                                  
Réception de:50 http://ftp.fr.debian.org/debian sid/main amd64 libwcs5 amd64 5.14-1 [263 kB]                                        
Réception de:51 http://ftp.fr.debian.org/debian sid/main amd64 linux-compiler-gcc-5-x86 amd64 4.3.5-1 [333 kB]                      
Réception de:52 http://ftp.fr.debian.org/debian sid/main amd64 linux-headers-4.3.0-1-amd64 amd64 4.3.5-1 [480 kB]                    
Réception de:53 http://ftp.fr.debian.org/debian sid/main amd64 linux-headers-4.3.0-1-common amd64 4.3.5-1 [4 935 kB]                
Réception de:54 http://ftp.fr.debian.org/debian sid/main amd64 linux-libc-dev amd64 4.3.5-1 [1 076 kB]                              
Réception de:55 http://ftp.fr.debian.org/debian sid/main amd64 manpages-dev all 4.04-1 [2 047 kB]                                    
Réception de:56 http://ftp.fr.debian.org/debian sid/main amd64 python-six all 1.10.0-3 [14,4 kB]                                    
Réception de:57 http://ftp.fr.debian.org/debian sid/main amd64 python-cryptography amd64 1.2.2-2 [201 kB]                            
Réception de:58 http://ftp.fr.debian.org/debian sid/main amd64 python-html5lib all 0.999-4 [84,0 kB]                                
Réception de:59 http://ftp.fr.debian.org/debian sid/main amd64 python3-six all 1.10.0-3 [14,4 kB]                                    
Réception de:60 http://ftp.fr.debian.org/debian sid/main amd64 xserver-common all 2:1.18.1-1 [1 911 kB]                              
Réception de:61 http://ftp.fr.debian.org/debian sid/main amd64 xserver-xorg-legacy amd64 2:1.18.1-1 [1 920 kB]                      
Réception de:62 http://ftp.fr.debian.org/debian sid/main amd64 xserver-xorg-core amd64 2:1.18.1-1 [3 222 kB]                        
78,1 Mo réceptionnés en 1min 19s (984 ko/s)                                                                                          
Lecture des fichiers de modifications (changelog)... Terminé
Extraction des modèles depuis les paquets: 100%
Préconfiguration des paquets...
setting xserver-xorg-legacy/xwrapper/allowed_users from configuration file
dpkg: parse error, in file '/var/lib/dpkg/status' near line 717 package 'python-idna':
 `Depends' field, invalid package name `python:any': character `:' not allowed (only letters, digits and characters `-+._')
E: Sub-process /usr/bin/dpkg returned an error code (2)  



Je sais pas comment je pourrai y remédier sad

Hors ligne

#16 10-02-2016 11:36:57

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Et si je remplace var/lib/dpkg/status par /var/lib/dpkg/status-old ?

Hors ligne

#17 10-02-2016 12:49:13

Dunatotatos
Membre
Lieu : Arabie Saoudite
Distrib. : Sid
Noyau : linux-image-amd64
(G)UI : tty
Inscription : 24-04-2012

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Ne touche pas au contenu de /var sans savoir ce que tu fais, ou tu vas casser ton système !

C'était le message urgent. Attends un peu, je reviens éditer mon message avec une probable solution.

EDIT : Un début de solution, il est possible qu'il reste d'autres erreurs.
Commence par faire une sauvegarde de ton fichier /var/lib/dpkg/status, au cas où.

cp /var/lib/dpkg/status /var/lib/dpkg/status.bak



Ensuite, ouvre ton fichier /var/lib/dpkg/status, puis va à la ligne 717. Remplace python:any par python.
Puis

apt-get update


apt-get reinstall python-idna



Si ça bloque a un endroit, remets ta sauvegarde en place, et viens poster l'erreur.

Edit à toto :
Séparation des deux commandes root.

Dernière modification par Dunatotatos (10-02-2016 13:06:49)


Never trust Windows output.

Hors ligne

#18 10-02-2016 13:06:06

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Bonjour,
Comme j'utilise sid également, j'ai vérifié que le paquet
python-idna était installé sur mon système.  C'est le cas. Donc je
suis allé voir dans le fichier /var/lib/dpkg/status. Je trouve cela :


Package: python-idna
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 314
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Architecture: all
Version: 2.0-3
Depends: python:any (<< 2.8), python:any (>= 2.7.5-5~)
Description: Python IDNA2008 (RFC 5891) handling (Python 2)
 A library to support the Internationalised Domain Names in Applications (IDNA)
 protocol as specified in RFC 5891. This version of the protocol is often
 referred to as “IDNA2008” and can produce different results from the earlier
 standard from 2003.
 .
 The library is also intended to act as a suitable drop-in replacement for the
 “encodings.idna” module that comes with the Python standard library but
 currently only supports the older 2003 specification.
 .
 This package contains the module for Python 2.
Homepage: https://github.com/kjd/idna
 


On voit bien dans le champ depends :


Depends: python:any (<< 2.8), python:any (>= 2.7.5-5~)
 


et dpkg ne me retourne aucune erreur lorsque je mets à jour
quotidiennement mon système. Donc le problème ne vient pas de cette
ligne. Cela vient probablement d'une ligne précédente, voire de la
« section control » d'un autre paquet…
Il faudrait regarder dans l'historique d'aptitude, les paquets qui ont
étaient mis à jour récemment. Ça se trouve dans


/var/log/aptitude
 


Évidemment, ce fichier est un peu long, il vaut mieux aller voir
directement à la fin, pour regarder les deux dernières mises à jour.
Elles sont faciles à indentifier dans ce fichier wink

Dernière modification par enicar (10-02-2016 13:06:40)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#19 10-02-2016 22:46:28

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Apparement les coupables seraientt

 [NON CONFIGURÉ] default-java-plugin:amd64 2:1.8-55
[NON CONFIGURÉ] icedtea-8-plugin:amd64 1.6.2-1
[NON CONFIGURÉ] icedtea-netx:amd64 1.6.2-1  

Hors ligne

#20 10-02-2016 23:04:53

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Je ne peux pas les reconfigurer

dpkg --configure default-java-plugin


 dpkg: parse error, in file '/var/lib/dpkg/status' near line 717 package 'python-idna':
 `Depends' field, invalid package name `python:any': character `:' not allowed (only letters, digits and characters `-+._')  

Hors ligne

#21 10-02-2016 23:19:52

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

leratdu60 a écrit :

Je ne peux pas les reconfigurer

Regarde comme l'a fait enicar le fichier /var/lib/dpkg/status près de la ligne 117. Essaye de trouver toute la section qui correspond au paquet python-idna et colle là ici.

Le message d'erreur parle d'une erreur dans la ligne depends ?


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#22 10-02-2016 23:25:11

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

leratdu60 a écrit :

Apparement les coupables seraientt

 [NON CONFIGURÉ] default-java-plugin:amd64 2:1.8-55
[NON CONFIGURÉ] icedtea-8-plugin:amd64 1.6.2-1
[NON CONFIGURÉ] icedtea-netx:amd64 1.6.2-1  



Pas sûr. La configuration de ces paquets peut être bloquée par le fait
que dpkg n'arrive pas à lire le fichier /var/lib/dpkg/status
d'où un arrêt de la procédure.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#23 10-02-2016 23:32:37

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Dans mon /var/lib/dpkg/status

 Package: python-idna
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 314
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Architecture: all
Version: 2.0-3
Depends: python:any (<< 2.8), python:any (>= 2.7.5-5~)
Description: Python IDNA2008 (RFC 5891) handling (Python 2)
 A library to support the Internationalised Domain Names in Applications (IDNA)
 protocol as specified in RFC 5891. This version of the protocol is often
 referred to as “IDNA2008” and can produce different results from the earlier
 standard from 2003.
 .
 The library is also intended to act as a suitable drop-in replacement for the
 “encodings.idna” module that comes with the Python standard library but
 currently only supports the older 2003 specification.
 .
 This package contains the module for Python 2.
Homepage: https://github.com/kjd/idna

Hors ligne

#24 11-02-2016 00:10:29

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

Il n'y a que 2 espace d'écart entre ton fichier et celui d'Enicar, mais c'est peut-être une histoire de copié/collé sur le fofo.

Tout ce que je trouve sur le net ne sent pas très bon. On y parle d'un fichier d'état corrompu, j'ai pas vu d'endroit où ça se réparait. Ceci-dit, dans la page man de «dpkg»], on lit ça

man dpkg a écrit :

var/lib/dpkg/status

États des paquets disponibles. Ce fichier contient des informations qui permettent de savoir si un paquet est marqué comme devant être supprimé ou pas, devant être installé ou pas, etc. Voyez la section RENSEIGNEMENTS SUR LES PAQUETS pour des informations supplémentaires.

Le fichier d’état est sauvegardé quotidiennement dans /var/backups. Cela peut être utile en cas de perte ou de corruption dûe à des problèmes de système de fichiers.



Tu peux peut-être vérifier la différence entre la sauvegarde et celui corrompu avec

diff /var/backups/dpkg.status.0 /var/lib/dpkg/status


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#25 11-02-2016 10:48:44

leratdu60
Membre
Distrib. : Debian Sid
Noyau : 4.3.0-1-amd64
(G)UI : Lxqt
Inscription : 09-02-2016

Re : sid dpkg E: Sub-process /usr/bin/dpkg returned an error code (2)

voici /var/backups/dpkg.status.0 :

Package: python-idna
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 314
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Architecture: all
Version: 2.0-3
Depends: python:any (<< 2.8), python:any (>= 2.7.5-5~)
Description: Python IDNA2008 (RFC 5891) handling (Python 2)
 A library to support the Internationalised Domain Names in Applications (IDNA)
 protocol as specified in RFC 5891. This version of the protocol is often
 referred to as “IDNA2008” and can produce different results from the earlier
 standard from 2003.  
.
 The library is also intended to act as a suitable drop-in replacement for the
 “encodings.idna” module that comes with the Python standard library but
 currently only supports the older 2003 specification.
 .
 This package contains the module for Python 2.
Homepage: https://github.com/kjd/idna




Et voilà /var/lib/dpkg/status:

Package: python-idna
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 314
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Architecture: all
Version: 2.0-3
Depends: python:any (<< 2.8), python:any (>= 2.7.5-5~)
Description: Python IDNA2008 (RFC 5891) handling (Python 2)
 A library to support the Internationalised Domain Names in Applications (IDNA)
 protocol as specified in RFC 5891. This version of the protocol is often
 referred to as “IDNA2008” and can produce different results from the earlier
 standard from 2003.
 .
 The library is also intended to act as a suitable drop-in replacement for the
 “encodings.idna” module that comes with the Python standard library but
 currently only supports the older 2003 specification.
 .
 This package contains the module for Python 2.
Homepage: https://github.com/kjd/idna

Hors ligne

Pied de page des forums