Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-02-2016 14:30:39

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

[Resolu] Se connecter à un serveur ssh en graphique et sur root.

Bonjour.

J'aimerais me connecter à un serveur ssh (c'est mon raspberrypi avec raspbian dessus) en graphique sous le compte root directement.
Je peux le faire en user sans problème mais en root l'accès m'est refusé. En ligne de commande j'ai cette réponse si je veux me connecter avec ssh root@op_du_raspberry


ssh root@192.168.77.1
 




root@192.168.77.1's password:
Permission denied, please try again.
root@192.168.77.1's password:
Permission denied, please try again.
root@192.168.77.1's password:
Permission denied (publickey,password).
 



Je ne sais pas ce qu'il faut que je modifie pour ce me soit autorisé et quels risques ça peut présenter.

A+

Dernière modification par laguespa (10-02-2016 19:53:03)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 10-02-2016 15:08:57

raleur
Membre
Inscription : 03-10-2014

Re : [Resolu] Se connecter à un serveur ssh en graphique et sur root.

Regarde dans la configuration de sshd (/etc/ssh/sshd_config), si le login root et l'authentification de root par mot de passe sont autorisés.
Par contre je ne comprends pas ce que signifie "SSH en graphique".

Hors ligne

#3 10-02-2016 16:13:27

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Se connecter à un serveur ssh en graphique et sur root.

En graphique signifie, pour moi, que j'utilise le navigateur de fichier (caja sous Mate) pour me connecter à un serveur.
Je peux chosir ssh ou ftp ou nfs.

Dans le fichier /etc/ssh/sshd_config j'ai ça qui concerne root :


cat /etc/ssh/sshd_config
 



# Authentication:
LoginGraceTime 120
PermitRootLogin without-password
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys
 

Dernière modification par laguespa (10-02-2016 16:21:54)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 10-02-2016 16:56:42

avram
Membre
Distrib. : dual boot jessie/testing en 64 bits+xp virtualbox
Noyau : 3.16 et 4.3
(G)UI : xfce
Inscription : 28-01-2016

Re : [Resolu] Se connecter à un serveur ssh en graphique et sur root.

bonjour.

Autoriser la connexion ssh pour root c'est ouvrir un boulevard pour les malfaisants qui essayent toujours de s'inviter chez vous sans y être conviés; encore pire,  autoriser la connexion root sans mot de passe, là c'est franchement suicidaire.

Hors ligne

#5 10-02-2016 17:02:46

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Se connecter à un serveur ssh en graphique et sur root.

Je me doute bien que c'est courir un risque. D'un autre côté sur une piratebox c'est pas trop grave vu que c'est quelque chose de très temporaire.
En attendant j'ai trouvé une autre solution en rendant l'utilisateur avec lequel je me connecte à certains répertoires propriétaire de ces répertoires qui ne doivent contenir que de la musique.

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 10-02-2016 18:06:34

raleur
Membre
Inscription : 03-10-2014

Re : [Resolu] Se connecter à un serveur ssh en graphique et sur root.

C'est la bonne solution, la gestion des permissions des utilisateurs plutôt que faire les choses en root alors que ce n'est pas justifié.

Pour l'explication de l'accès refusé, l'option "PermitRootLogin" a la valeur "without-password" donc l'authentification de root ne peut pas se faire par mot de passe, il faut utiliser une authentification par clé publique/privée. Si tu veux autoriser le mot de passe pour root, il faut changer la valeur à "yes" et relancer sshd (service ssh restart).

Hors ligne

#7 10-02-2016 19:52:25

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Resolu] Se connecter à un serveur ssh en graphique et sur root.

Ok, merci. J'aurais appris quelque chose.

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

Pied de page des forums