Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-03-2016 14:39:18

meikodubriska
Membre
Inscription : 07-03-2016

Besoin d'installer une ancienne version de Mysql et php

Bonjour à tous,

J'ai installé DEBIAN 8 sur un PC pour en faire un serveur "intranet".

Malheureusement, pour un problème de compatibilité avec le "site", j'ai besoin d'installé mysql 5.0.51b et php5.2.6 en lieu et place des dernières versions de mysql et php.

J'ai fait des essais avec LAMP, mais effectivement les pages s'affichent mal et m'indiquent des erreurs, alors que sous WAMP version mysql 5.0.51b / php5.2.6 pas de soucis.

Quelqu'un pourrait-il m'aider !

D'avance merci !

Hors ligne

#2 07-03-2016 14:49:40

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Besoin d'installer une ancienne version de Mysql et php

Bjr,
Je vais encore me faire engueuler mais tant pis.
Mon conseil perso : tu mets le dépot wheezy ou autre (inférieur à ta version actuelle) dans ton sources.list. Update. Et tu installes. Tu peux aussi faire une simul avant

aptitude -s mon_paquet


De toute façon apt (ou aptitude) râlera si ça coince.


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 07-03-2016 20:20:23

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Besoin d'installer une ancienne version de Mysql et php

Salut smile

Avec les sources wheezy+jessie, on obtient ça  :

apt-cache policy libapache2-mod-php5 mysql-server


libapache2-mod-php5:
  Installé : 5.6.17+dfsg-0+deb8u1
  Candidat : 5.6.17+dfsg-0+deb8u1
 Table de version :
 *** 5.6.17+dfsg-0+deb8u1 0
        500 http://http.debian.net/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
     5.4.44-0+deb7u1 0
        500 http://http.debian.net/debian/ wheezy/main amd64 Packages
mysql-server:
  Installé : 5.5.46-0+deb8u1
  Candidat : 5.5.46-0+deb8u1
 Table de version :
 *** 5.5.46-0+deb8u1 0
        500 http://http.debian.net/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
     5.5.44-0+deb7u1 0
        500 http://http.debian.net/debian/ wheezy/main amd64 Packages
 



Donc, php5.4 et mysql 5.5. Du coup, ça ne sert à rien avec wheezy hmm Même sous squeeze, on obtient ça pour mysql-server.

Il faudrait donc remonter dans lenny pour avoir la version que tu souhaites hmm Ca me semble compliqué et probablement assez dangereux en terme de sécurité (ceci dit, je ne suis pas un pro big_smile)

De plus, même en essayant de rétrograder les paquet qui t'intéresses sur les version dispo dans wheezy de cette façon

aptitude install libapache2-mod-php5=5.4.44-0+deb7u1 mysql-server=5.5.44-0+deb7u1 -s

On obtient ça vers la 3 ou 4ème solutions proposées

Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                                
1)      apache2-bin                                                                    
2)      apache2-data                                                                  
3)      init-system-helpers                                                            
4)      libterm-readkey-perl                                                          
5)      openssh-server                                                                
6)      php5-json                                                                      
7)      php5-readline                                                                  

      Installer les paquets suivants :                                                
8)      apache2-mpm-prefork [2.2.22-13+deb7u6 (oldstable)]                            
9)      apache2.2-bin [2.2.22-13+deb7u6 (oldstable)]                                  
10)     apache2.2-common [2.2.22-13+deb7u6 (oldstable)]                                
11)     dropbear [2014.65-1 (stable)]                                                  
12)     heirloom-mailx [12.5-4 (stable)]                                              
13)     libclass-isa-perl [0.36-5 (stable)]                                            
14)     libswitch-perl [2.17-2 (stable)]                                              

      Réinstaller à une version antérieure les paquets suivants :                      
15)     apache2 [2.4.10-10+deb8u4 (now, stable) -> 2.2.22-13+deb7u6 (oldstable)]      
16)     dpkg [1.17.26 (now, stable) -> 1.16.16 (oldstable)]                            
17)     libdbd-mysql-perl [4.028-2+b1 (now, stable) -> 4.021-1+b1 (oldstable)]        
18)     libdbi-perl [1.631-3+b1 (now, stable) -> 1.622-1+deb7u1 (oldstable)]          
19)     liblocale-gettext-perl [1.05-8+b1 (now, stable) -> 1.05-7+b1 (oldstable)]      
20)     libsub-name-perl [0.12-1 (now, stable) -> 0.05-1+b2 (oldstable)]              
21)     libtext-charwidth-perl [0.04-7+b3 (now, stable) -> 0.04-7+b1 (oldstable)]      
22)     libtext-iconv-perl [1.7-5+b2 (now, stable) -> 1.7-5 (oldstable)]              
23)     mysql-client-5.5 [5.5.46-0+deb8u1 (now, stable) -> 5.5.44-0+deb7u1 (oldstable)]
24)     mysql-server-5.5 [5.5.46-0+deb8u1 (now, stable) -> 5.5.44-0+deb7u1 (oldstable)]
25)     perl [5.20.2-3+deb8u3 (now, stable) -> 5.14.2-21+deb7u2 (oldstable)]          
26)     perl-base [5.20.2-3+deb8u3 (now, stable) -> 5.14.2-21+deb7u2 (oldstable)]      
27)     perl-modules [5.20.2-3+deb8u3 (now, stable) -> 5.14.2-21+deb7u2 (oldstable)]  
28)     php5-cli [5.6.17+dfsg-0+deb8u1 (now, stable) -> 5.4.44-0+deb7u1 (oldstable)]  
29)     php5-common [5.6.17+dfsg-0+deb8u1 (now, stable) -> 5.4.44-0+deb7u1 (oldstable)]
30)     php5-mysql [5.6.17+dfsg-0+deb8u1 (now, stable) -> 5.4.44-0+deb7u1 (oldstable)]

      Laisser les dépendances suivantes non satisfaites :                              
31)     perl-modules recommande perl (>= 5.20.2-1)                                    
32)     php5-cli recommande php5-readline  



Donc, je pense sincèrement que ça n'est pas une bonne solution de vouloir ça sur Debian 8, en tout cas, pas via les dépôts hmm


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#4 07-03-2016 23:12:31

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Besoin d'installer une ancienne version de Mysql et php

Bon là je suis d'accord ça va trop loin. Soit mettre le "site" à jour ou faire un chroot dans une version qui lui est compatible ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#5 07-03-2016 23:33:32

meikodubriska
Membre
Inscription : 07-03-2016

Re : Besoin d'installer une ancienne version de Mysql et php

Merci pour vos réponses ...

Je vais essayer de forcer en passant par lenny ..

Je sens que ce n'est pas gagné !

Hors ligne

#6 07-03-2016 23:43:36

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Besoin d'installer une ancienne version de Mysql et php

Installer une ancienne version de MySQL via les paquets sur une Debian à jour ne fonctionnera pas. Ça va tout casser.
Je ne vois pas 36 possibilités.
Créer un LXC ou un Chroot simple avec une Lenny (ou la Debian dont tu as besoin) dedans.
Créer une VM avec une Lenny
Récupérer les paquets sources de MySQL pour Lenny et tenter de les re-compiler pour la Debian stable (mais bon, casse-gueule.)

Dans tous les cas, utiliser cette vieille version de MySQL me semble être purement une mauvaise idée smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 08-03-2016 14:31:15

meikodubriska
Membre
Inscription : 07-03-2016

Re : Besoin d'installer une ancienne version de Mysql et php

Et si je refait une installation propre sous Lenny en mode serveur + ssh ??

Pourrais-je installer les versions mysql et php qu'il me faut ??

Un grand merci pour vos réponses !

Hors ligne

#8 08-03-2016 14:53:55

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Besoin d'installer une ancienne version de Mysql et php

Voilà ce que j'ai trouvé sur les versions sous lenny des logiciels que tu souhaites installer https://www.howtoforge.com/perfect-serv … ispconfig2

Ça semble donc presque bon.

@captnfab propose un container LXC, ça me semble une bonne idée avec une lenny dedans, mais cette distrib ne fait pas partie des templates de base. Il te faudra donc écrire ton propre template pour l'installer.

Il faudra probablement utiliser les dépôts snapshot et piocher dededans pour récupérer la bonne version. Tu peux déjà y fouiller pour voir ce qui s'y trouve wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#9 08-03-2016 18:16:40

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Besoin d'installer une ancienne version de Mysql et php

Si tu expliques comment utiliser debootstrap avec LXC faut-il un template spécifique ?

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#10 08-03-2016 19:08:49

Zer00CooL
Membre
Inscription : 08-03-2016

Re : Besoin d'installer une ancienne version de Mysql et php

Pareil que toi, je souffre sur du PHP 5.3.3
Pour le moment j'ai un ENV à jour en VM sur Jessie 8.3 mais je ne vois pas comment installer mon vieux site, pour alors seulement upp php et upper le cms.

Voilà le sujet : http://www.visionduweb.fr/forum/apache/ … debian-8-3

Hors ligne

#11 08-03-2016 20:09:27

leonlemouton
Adhérent(e)
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate 1.8.1
Inscription : 14-08-2012

Re : Besoin d'installer une ancienne version de Mysql et php

Pour php il y a ça : http://phpbrew.github.io/phpbrew/
Mais je n'ai jamais testé... smile

Leonlemouton
°(")°

Hors ligne

#12 09-03-2016 13:05:48

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Besoin d'installer une ancienne version de Mysql et php

phlinux a écrit :

Si tu expliques comment utiliser debootstrap avec LXC faut-il un template spécifique ?

Oui, le template de base ne prend pas en charge lenny smile Pour le fun, j'ai essayé. J'ai modifié le template de base pour d'une part, utiliser un mirroir snapshot, et d'autre part pour demander l'installation du paquet dhcp-client à la place de isc-dhcp-client non présent sous lenny

J'ai mis ce template dans un paste là.

J'ai configuré le réseau avec ce tuto.

Ceci dit, les versions que tu souhaites ne sont pas les bonnes, au moins pour mysql. Il faudrait peut-être continué avec les snapshots et faire du pinning lenny/squeeze lorsque cette dernière était à ses débuts.

Bon courage pour la suite wink


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#13 09-03-2016 14:23:06

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Besoin d'installer une ancienne version de Mysql et php

Ok, merci. Je vais essayer dans mon nouveau bac à sable (j'en ai fait exploser un hier)

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#14 26-03-2016 07:14:31

Zer00CooL
Membre
Inscription : 08-03-2016

Re : Besoin d'installer une ancienne version de Mysql et php

Phlinux, tu peux m'aider par hasard, avec quelques pistes, pour moi stp, je vois que tu es un ancien.

Pour ma part, j'ai monté une debian 6 avec les paquets en local; Maintenant que j'ai copié tous les paquets de Debian 6 en local, j'aimerais pouvoir installer :

php 5.3.3 et mysql.

Hors ligne

Pied de page des forums