Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-03-2016 19:02:12

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Le wake on lan ne fonctionne pas

Bonjour à tous,

J'ai un vieil ordinateur portable que je veux transformer en petit serveur perso avec Jessie. Il est placé juste à côté de la livebox (qui me sert également pour le réseau local) à un endroit difficile d'accès (ie, juste derrière une grosse armoire). Comme je ne l'utilise pas 24/24H, je voudrais pouvoir l'éteindre et l'allumer à distance via le wake on lan. J'ai suivi diverses indications pour installer ce système, mais ça ne fonctionne pas. A priori, la carte est compatible et activée, puisque la commande

 ethtool eth0  | egrep "^[[:blank:]]*Wake-on: (g|d)"

renvoie :

Wake-on: g



J'ai modifié le fichier /etc/rc.local pour l'empêcher d'éteindre l'interface réseau. J'ai aussi modifié le fichier /etc/default/halt pour interdire l'extinction du réseau. Néanmoins, lorsque le pc est éteint, la LED indiquant si l'interface réseau fonctionne est éteinte, alors que, en toute logique, elle devrait être allumée. Il me semble donc que le problème vient de là : comment conserver l'interface réseau allumée ?

A priori, ce n'est pas l'émetteur qui pose problème : j'ai testé avec etherwake sur fedora, avec un logiciel sur android, et avec un serveur sur internet : aucun n'y parvient. En revanche, lorsque l'ordinateur est allumé, le paquet magique est bien reçu, au moins des deux derniers (etherwake ne donne rien). Voici un exemple :

tcpdump -i eth0 port 9
 


tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
17:27:06.948700 IP android-df68294371c06ae5.home.48012 > palantire.home.discard: UDP, length 102
17:27:06.949490 IP android-df68294371c06ae5.home.37582 > palantire.home.discard: UDP, length 102
17:27:06.950136 IP android-df68294371c06ae5.home.39242 > palantire.home.discard: UDP, length 102
17:27:06.950230 IP android-df68294371c06ae5.home.50587 > palantire.home.discard: UDP, length 102
17:27:06.952213 IP android-df68294371c06ae5.home.44098 > palantire.home.discard: UDP, length 102
17:27:06.952285 IP android-df68294371c06ae5.home.54934 > palantire.home.discard: UDP, length 102
17:27:10.985041 IP android-df68294371c06ae5.home.56928 > palantire.home.discard: UDP, length 102
17:27:10.985727 IP android-df68294371c06ae5.home.38537 > palantire.home.discard: UDP, length 102
17:27:10.987238 IP android-df68294371c06ae5.home.60157 > palantire.home.discard: UDP, length 102
17:27:10.987305 IP android-df68294371c06ae5.home.57885 > palantire.home.discard: UDP, length 102
17:27:10.988740 IP android-df68294371c06ae5.home.60397 > palantire.home.discard: UDP, length 102
17:27:10.988782 IP android-df68294371c06ae5.home.35652 > palantire.home.discard: UDP, length 102
17:27:12.062836 IP android-df68294371c06ae5.home.47015 > palantire.home.discard: UDP, length 102
17:27:12.063425 IP android-df68294371c06ae5.home.58907 > palantire.home.discard: UDP, length 102
17:27:12.064707 IP android-df68294371c06ae5.home.34946 > palantire.home.discard: UDP, length 102
17:27:12.064750 IP android-df68294371c06ae5.home.51442 > palantire.home.discard: UDP, length 102
17:27:12.064764 IP android-df68294371c06ae5.home.37494 > palantire.home.discard: UDP, length 102
17:27:12.065972 IP android-df68294371c06ae5.home.60625 > palantire.home.discard: UDP, length 102
17:29:51.921593 IP nemorius.com.42993 > palantire.home.discard: UDP, length 102
17:30:47.417467 IP nemorius.com.38649 > palantire.home.discard: UDP, length 102


J'ai même essayé en inversant l'adresse MAC : ça marche dans les deux cas.

Quelques informations :
Carte mère :

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
    Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
    Product Name: 300E4A/300E5A/300E7A/3430EA/3530EA
    Version: FAB1
    Serial Number: 123490EN400015
    Asset Tag: Base Board Asset Tag
    Features:
        Board is a hosting board
        Board is replaceable
    Location In Chassis: Part Component
    Chassis Handle: 0x0000
    Type: Motherboard
    Contained Object Handles: 0



Carte réseau :

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
        Subsystem: Samsung Electronics Co Ltd Device c606
        Flags: bus master, fast devsel, latency 0, IRQ 41
        I/O ports at 2000 [size=256]
        Memory at e1404000 (64-bit, prefetchable) [size=4K]
        Memory at e1400000 (64-bit, prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
        Capabilities: [d0] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
        Kernel driver in use: r8169
 



Si l'un de vous a une idée, je suis preneur ! :-)
Merci d'avance.


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#2 12-03-2016 19:10:08

sinozis
Membre
Lieu : Moselle
Distrib. : Debian stable
Inscription : 12-03-2016

Re : Le wake on lan ne fonctionne pas

il faut parfois activer le WOL dans le bios
si les led ne sont pas allumées, je ne pense pas que la carte soit active, il y a peut être une option dans le bios pour empêcher ça.

Dernière modification par sinozis (12-03-2016 19:19:32)


Je résiste à tout sauf à la tentation.......

Hors ligne

#3 12-03-2016 19:44:54

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : Le wake on lan ne fonctionne pas

sinozis a écrit :

il faut parfois activer le WOL dans le bios


Oui, c'est ce que j'ai lu, mais est-ce qu'on peut avoir Wake-on : g si ce n'est pas activé dans le bios hmm ? J'ai regardé dans le mien, mais je n'ai rien d'autre que

USB S3 wake-up

. J'ai mis en Enabled, mais je suis connecté en réseau par ethernet, pas par usb. Est-ce qu'une mise à jour du bios pourrait régler le problème ? Je n'ose pas m'attaquer à ça pour ne pas tout casser...


Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#4 12-03-2016 20:16:48

sinozis
Membre
Lieu : Moselle
Distrib. : Debian stable
Inscription : 12-03-2016

Re : Le wake on lan ne fonctionne pas

Perso je n'ai jamais fait du WOL sur un portable
les bios de PC portable sont souvent minimalistes (par exemple j'ai des PC portable tosh avec port COM on peut rien regler juste activer/desactiver)

Je résiste à tout sauf à la tentation.......

Hors ligne

#5 13-03-2016 20:35:14

Lancelot du Lac
Membre
Lieu : France
Distrib. : Jessie | Stretch
Noyau : Linux 3.16.0-4-amd64 | 4.5.0-1-amd64
(G)UI : ZSH / LXDE, Openbox | KDE
Inscription : 22-02-2016

Re : Le wake on lan ne fonctionne pas

Je me posais une question : est-ce que c'est possible de laisser un composant allumé si tout le reste de la machine est éteint ?

Dell Inspiron 7500 series - Debian Stretch - KDE/openbox - ZSH
Samsung - Debian Jessie - LXDE/pas de graphique - ZSH

Hors ligne

#6 13-03-2016 23:07:58

REL@tif
Membre
Lieu : Ici, Maintenant...
Distrib. : DEBIAN Jessie
Noyau : 3.16.0-4-amd64
(G)UI : KDE plasma
Inscription : 08-02-2016
Site Web

Re : Le wake on lan ne fonctionne pas

Lancelot du Lac a écrit :

Je me posais une question : est-ce que c'est possible de laisser un composant allumé si tout le reste de la machine est éteint ?



Éteint ou en veille (la machine) ?

Parce qu'éteint, j'en doute neutral


Tout est relatif !

Hors ligne

Pied de page des forums