Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-03-2016 20:24:34

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

upload max dans serveur avec owncloud auto-hébergé

salut les Doux Folding lol

je me suis installé yunohost sur une Jessie
jusqu'a là tout va bien

dans le cloud je ne peux pas télécharger (voir uploader) un fichier plus grand que 10 G.
j'ai donc modifier 4 fichiers de conf

les deux premiers avec 22528M

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 22528M


/etc/php5/cli/php.ini  et /etc/php5/fpm/php.ini

et relancé les services

RIEN,  puisque c'est pas apache mais nginx

puis j'ai trouvé

/etc/php5/fpm/pool.d/owncloud.conf

a la fin du fichier on peut voir :

hp_value[upload_max_filesize] = 10G
php_value[post_max_size] = 10G
php_value[session.save_path] = /var/www/owncloud/lib/private/session/
php_value[default_charset] = UTF-8
php_value[always_populate_raw_post_data] = -1
clear_env = no

j'ai mis 22G à la place de 10G

puis  comme ça ne fait rien je suis allé dans

/etc/nginx/conf.d/chezlagrenouille.nohost.me.d/owncloud.conf


et changé 10 par 22G là aussi

client_max_body_size 10G;
    index index.php;
    try_files $uri $uri/ /index.php;

j'ai relançé les services nginx et /etc/php5/fpm/php.ini

dans l'owncloud en tant qu.admin, j'ai ouvert administration
on y trouve l,upload fixé à 10 G
j'ai mis à 22 G et sauvegarder
ça revient à 10 G

hmm
rien n'y fait

j'ai beau rebooter le serveur ...:(

bah koikifofaire les amis:)

Dernière modification par lagrenouille (25-06-2016 08:40:55)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#2 25-06-2016 08:38:15

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : upload max dans serveur avec owncloud auto-hébergé

j'ai laissé tomber yunohost
le problème est le même
j'ai un peut tout essayer
upload_max_filesize et pst_max_size dans php.ini à 20000M
réglage dans les confs apache et owncloud a 20 GB
reste des histoires de droit quelque part
ou

reste les systèmes de fichier
ça m'a pas l'air simple à paramétrer

Ce qui est curieux c'est que les premiers jours j'etais limité à 1,5 gb et maintenant à 500 Megas et des poussières,
je nage un peu avec ce cloud
si vous avez une idée

Dernière modification par lagrenouille (25-06-2016 08:46:08)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#3 26-06-2016 13:01:35

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : upload max dans serveur avec owncloud auto-hébergé

Salut!
Au cas où, ce n'est pas "pst_max_size" mais "post_max_size".
Tu as bien sûr relancé php?

YA3HGA-H

Hors ligne

#4 26-06-2016 13:33:51

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : upload max dans serveur avec owncloud auto-hébergé

cat /etc/php5/apache2/php.ini | grep max_size


post_max_size = 20000M



cat /etc/php5/apache2/php.ini | grep upload_max


upload_max_filesize = 20000M


cat /etc/owncloud/htaccess



<IfModule mod_fcgid.c>
<IfModule mod_setenvif.c>
<IfModule mod_headers.c>
SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1
RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION
</IfModule>
</IfModule>
</IfModule>
<IfModule mod_php5.c>
php_value upload_max_filesize 20G
php_value post_max_size 20G
php_value memory_limit 512M
php_value mbstring.func_overload 0
<IfModule env_module>
 SetEnv htaccessWorking true
</IfModule>
</IfModule>
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^/owncloud/\.well-known/host-meta /owncloud/public.php?service=host-meta [QSA,L]
RewriteRule ^/owncloud/\.well-known/host-meta\.json /owncloud/public.php?service=host-meta-json [QSA,L]
RewriteRule ^/owncloud/\.well-known/carddav /owncloud/remote.php/carddav/ [R]
RewriteRule ^/owncloud/\.well-known/caldav /owncloud/remote.php/caldav/ [R]
RewriteRule ^/owncloud/apps/calendar/caldav\.php /owncloud/remote.php/caldav/ [QSA,L]
RewriteRule ^/owncloud/apps/contacts/carddav\.php /owncloud/remote.php/carddav/ [QSA,L]
RewriteRule ^/owncloud/remote/(.*) /owncloud/remote.php [QSA,L]
</IfModule>
<IfModule mod_mime.c>
AddType image/svg+xml svg svgz
AddEncoding gzip svgz
</IfModule>
<IfModule dir_module>
DirectoryIndex index.php index.html
</IfModule>
AddDefaultCharset utf-8
Options -Indexes
<IfModule pagespeed_module>
        ModPagespeed Off
</IfModule>

ErrorDocument 403 /owncloud/core/templates/403.php
ErrorDocument 404 /owncloud/core/templates/404.php
 



owncloud auto-hebérgé

http://monnuage.chezlagrenouille.fr

Edit à bendia : un peu de couleur dans ce monde de brutes winkVoir le tuto : Le code, ça pique moins les yeux en couleur

Dernière modification par lagrenouille (26-06-2016 13:38:55)


Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

Pied de page des forums