Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-04-2016 16:09:52

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

[Résolu] Pas de lecture de fichier PHP

Bonjour à tous,

J'installe un nouveau serveur, en Debian 8 cette fois, et j'ai un petit problème.

Les pages PHP ne sont pas interprétés. Pourtant je pense avoir installé tout ce qu'il fallait.

apt-get install build-essential apache2 libapache2-mod-php5 mysql-server


apt-get install php5-mysql phpmyadmin


apt-get install apache2 apache2-utils php5 php5-common php5-mcrypt php5-dev php5-gd curl libapache2-mod-proxy-html modsecurity-crs libapache2-mod-fcgid libapache2-mod-authnz-external


apt-get install php5-mysql mysql-server mysql-client mysql-common



Pour les mods :


a2enmod rewrite
a2enmod ssl
a2enmod include
a2enmod info
a2enmod filter auth_digest authn_default headers expires proxy actions authnz_external proxy_connect authz_unixgroup
 



Je ne vois pas ce que j'ai oublié, c'est pourtant la même installe que pour mon serveur LAMP actuel (Debian 7)

A votre avis ?

Merci par avance pour votre aide.

Orsam

Dernière modification par Orsam999 (17-04-2016 07:15:03)


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#2 16-04-2016 01:53:22

clonador
Membre
Distrib. : Proxmox VE 4.1 sur Debian 8.4
Noyau : Linux 4.2.8-1-pve
(G)UI : il n'y a pas
Inscription : 13-04-2016

Re : [Résolu] Pas de lecture de fichier PHP

Le probleme:

libapache2-mod-fcgid



Le solution:

aptitude remove libapache2-mod-fcgid



Edit à toto :
Mis la commande aptitude en balise root.

Hors ligne

#3 16-04-2016 07:38:41

Orsam999
Membre
Distrib. : Debian GNU/Linux 7.9 (wheezy)
Noyau : Linux 3.2.0-4-486
Inscription : 16-01-2015

Re : [Résolu] Pas de lecture de fichier PHP

Bonjour clonador,

Désolé, en faite, c'est une erreur PHP sur la page, mais manifestement les messages d'erreur sont désactivés donc je ne voyais qu'une page blanche.


Peux-tu quand même me dire pourquoi est-ce que tu me préconisais cette commande ?

aptitude remove libapache2-mod-fcgid



Merci

Orsam

Dernière modification par Orsam999 (16-04-2016 07:47:05)


Celui qui ne progresse pas chaque jour, recule chaque jour.
Confucius

Hors ligne

#4 16-04-2016 11:22:34

clonador
Membre
Distrib. : Proxmox VE 4.1 sur Debian 8.4
Noyau : Linux 4.2.8-1-pve
(G)UI : il n'y a pas
Inscription : 13-04-2016

Re : [Résolu] Pas de lecture de fichier PHP

car le module fcgid remplace le module libapache2-mod-php5 en MPM Prefork (Lorsque l'installation est plus tard)

Il faut une configuration spécial pour le module fcgid. Peut-être ils peuvent coexister, je crois que oui, mais sans le module libapache2-mod-php5 et le MPM Prefork chargé, il faut una configuration spécial pour la interprétation des script php.

https://x10hosting.com/community/thread … ay.148894/

Pour savoir quel module est chargé:

sudo apache2 -V


Server MPM:     Prefork



Prefork = mod-php5 (default)
worker = mod-fcgid

d'autre part, le archive php.ini en MPM Prefork Il est situé dans /etc/php5/apache2/
le php.ini en MPM Worker Il est situé dans /etc/php5/cgi/

la directive du php.ini qui empêche l'interruption d' un script php s'il trouve un error, c'est:

display_errors = Off



Salut.

Dernière modification par clonador (16-04-2016 11:30:01)

Hors ligne

Pied de page des forums