Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-04-2016 13:27:27

rvH
Membre
Noyau : Linux 3.16.0-4-amd64
Inscription : 12-04-2016

apt-get update

Bonjour à tous,

lorsque je fais un apt-get update et que mon système réceptionne ceci par exemple :

Réception de : 1 http://ftp.belnet.be jessie-updates/main amd64 Packages/DiffIndex [1.996 B]
Réception de : 2 http://ftp.belnet.be jessie-updates/main Translation-en/DiffIndex [1.228 B]

est-ce que je dois faire une installation après ?

merci d'avance pour vos réponse.
rvH

Hors ligne

#2 19-04-2016 16:41:57

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : apt-get update

Tu peux utiliser la commande suivante pour savoir si tu as des mises-à-jour en attente après un 'apt-get update' :

apt list --upgradable


Jouer sous Debian ? Facile !

Hors ligne

#3 19-04-2016 16:51:58

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : apt-get update

Bonjour,

Ça dépend de ce que ça te dis après : en principe ça doit te rajouter :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait


Et ensuite si tu as une ligne avec All packages are up to date, c'est que tout est à jour.

Si ça te dit qu'il y a des paquets à mettre à jour et que tu souhaites le faire, il faut faire la commande

apt-get upgrade


Voir le tuto Apt-get

Sur Jessie on peut aussi utiliser Apt tout court : le tuto Apt

Et pour qu'on puisse t'aider plus facilement tu peux indiquer les infos de ta distribution dans ton profil :
Voir le tuto : Trop cool d'indiquer son installation dans son profil !


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#4 19-04-2016 17:26:51

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : apt-get update

je te conseille d'utiliser apt

pour récupérer la liste des mises à jour disponibles:

apt update


Atteint http://security.debian.org jessie/updates InRelease
Atteint http://security.debian.org jessie/updates/main amd64 Packages                                  
Ign http://httpredir.debian.org jessie InRelease                                                                      
Atteint http://security.debian.org jessie/updates/contrib amd64 Packages                                              
Réception de : 1 http://httpredir.debian.org jessie-updates InRelease [142 kB]                                          
Atteint http://security.debian.org jessie/updates/non-free amd64 Packages                                
Atteint http://security.debian.org jessie/updates/main i386 Packages                                                  
Atteint http://security.debian.org jessie/updates/contrib i386 Packages                                              
Atteint http://security.debian.org jessie/updates/non-free i386 Packages                                              
Atteint http://security.debian.org jessie/updates/contrib Translation-en                                              
Atteint http://security.debian.org jessie/updates/main Translation-en                                                        
Atteint http://security.debian.org jessie/updates/non-free Translation-en                                                                
Atteint http://httpredir.debian.org jessie-backports InRelease                                                                          
Réception de : 2 http://httpredir.debian.org jessie Release.gpg [2 373 B]                      
Réception de : 3 http://httpredir.debian.org jessie-updates/main amd64 Packages/DiffIndex [1 996 B]
Atteint http://httpredir.debian.org jessie-updates/contrib amd64 Packages
Réception de : 4 http://httpredir.debian.org jessie-updates/non-free amd64 Packages/DiffIndex [736 B]
Réception de : 5 http://httpredir.debian.org jessie-updates/main i386 Packages/DiffIndex [1 996 B]
Atteint http://httpredir.debian.org jessie-updates/contrib i386 Packages
Réception de : 6 http://httpredir.debian.org jessie-updates/non-free i386 Packages/DiffIndex [736 B]
Réception de : 7 http://httpredir.debian.org jessie-updates/contrib Translation-en [14 B]
Réception de : 8 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [1 228 B]
Réception de : 9 http://httpredir.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Réception de : 10 http://httpredir.debian.org jessie Release [148 kB]    
Réception de : 11 http://httpredir.debian.org jessie-backports/main amd64 Packages/DiffIndex [27,8 kB]
Réception de : 12 http://httpredir.debian.org jessie-backports/contrib amd64 Packages/DiffIndex [6 544 B]
Réception de : 13 http://httpredir.debian.org jessie-backports/non-free amd64 Packages/DiffIndex [6 622 B]
Réception de : 14 http://httpredir.debian.org jessie-backports/main i386 Packages/DiffIndex [27,8 kB]
Réception de : 15 http://httpredir.debian.org jessie-backports/contrib i386 Packages/DiffIndex [7 036 B]
Réception de : 16 http://httpredir.debian.org jessie-backports/non-free i386 Packages/DiffIndex [5 992 B]
Réception de : 17 http://httpredir.debian.org jessie-backports/contrib Translation-en/DiffIndex [3 532 B]
Réception de : 18 http://httpredir.debian.org jessie-backports/main Translation-en/DiffIndex [27,8 kB]
Réception de : 19 http://httpredir.debian.org jessie-backports/non-free Translation-en/DiffIndex [6 346 B]
Atteint http://httpredir.debian.org jessie/main amd64 Packages          
Atteint http://httpredir.debian.org jessie/contrib amd64 Packages
Atteint http://httpredir.debian.org jessie/non-free amd64 Packages
Atteint http://httpredir.debian.org jessie/main i386 Packages
Atteint http://httpredir.debian.org jessie/contrib i386 Packages
Atteint http://httpredir.debian.org jessie/non-free i386 Packages
Réception de : 20 http://httpredir.debian.org jessie/contrib Translation-en [38,5 kB]
Réception de : 21 http://httpredir.debian.org jessie/main Translation-fr [846 kB]              
Atteint http://httpredir.debian.org jessie/non-free Translation-en                            
Réception de : 22 http://httpredir.debian.org jessie/main Translation-en [4 581 kB]
5 886 ko réceptionnés en 5s (1 094 ko/s)                                                    
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
19 packages can be upgraded. Run 'apt list --upgradable' to see them.



à la fin tu noteras le 'apt list --upgradable', ce qui signifie que des mises à jours sont disponibles.


pour les afficher, tu lances la commande:

apt list --upgradable


En train de lister... Fait
libreoffice/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-base/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-base-core/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-base-drivers/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-calc/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-common/jessie-backports 1:5.1.2-3~bpo8+1 all [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-core/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-draw/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-gtk/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-impress/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-java-common/jessie-backports 1:5.1.2-3~bpo8+1 all [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-l10n-fr/jessie-backports 1:5.1.2-3~bpo8+1 all [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-math/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-style-galaxy/jessie-backports 1:5.1.2-3~bpo8+1 all [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-style-tango/jessie-backports 1:5.1.2-3~bpo8+1 all [upgradable from: 1:5.1.1-1~bpo8+1]
libreoffice-writer/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
python3-uno/jessie-backports 1:5.1.2-3~bpo8+1 amd64 [upgradable from: 1:5.1.1-1~bpo8+1]
uno-libs3/jessie-backports 5.1.2-3~bpo8+1 amd64 [upgradable from: 5.1.1-1~bpo8+1]
ure/jessie-backports 5.1.2-3~bpo8+1 amd64 [upgradable from: 5.1.1-1~bpo8+1]



il ne reste plus qu'a les installer avec la commande

apt upgrade




Pour info, tu pourras trouver des commandes dont la syntaxe diffère mais qui effectueront la même chose.

Hors ligne

#5 19-04-2016 17:27:02

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : apt-get update

Mercredi a écrit :

Bonjour,

Ça dépend de ce que ça te dis après : en principe ça doit te rajouter :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait


Et ensuite si tu as une ligne avec All packages are up to date, c'est que tout est à jour.

Si ça te dit qu'il y a des paquets à mettre à jour et que tu souhaites le faire, il faut faire la commande

apt-get upgrade


Voir le tuto Apt-get

Sur Jessie on peut aussi utiliser Apt tout court : le tuto Apt

Et pour qu'on puisse t'aider plus facilement tu peux indiquer les infos de ta distribution dans ton profil :
Voir le tuto : Trop cool d'indiquer son installation dans son profil !



petite correction / précision
apt-get update ne te dira pas s'il y a des paquets à mettre à jour, c'est apt update qui te le dira automatiquement
le plus simple à utiliser / faire
mettre la liste des paquets à jours

apt update


si des paquets sont à mettre à jour

apt list --upgradable


pour mettre à jour

apt-get upgrade


j'ai l'impression que apt upgrade est l'équivalent de aptitude upgrade, donc un peu plus "intrusif" que apt-get upgrade
donc personnellement je préfère l'éviter pour l'instant tongue


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#6 19-04-2016 17:57:04

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : apt-get update

Salut,

Le cahier de l'administrateur Debian - https://debian-handbook.info/browse/fr- … t-get.html

6.2.3. Mise à jour
Des mises à jour régulières sont recommandées, car elles mettront en place les derniers correctifs de sécurité. Pour cela,
on invoquera apt upgrade, apt-get upgrade ou aptitude safe-upgrade (évidemment précédé par apt update). Cette commande
cherche les mises à jour des paquets installés, réalisables sans supprimer de paquets. Autrement dit, l'objectif est d'assurer
une mise à jour la moins intrusive possible. Pour cette action, apt-get est un peu plus exigeant que aptitude ou apt parce qu'il refusera d'installer
des paquets qui ne l'étaient pas préalablement.

... plein d'infos intéressantes ...



C'est une subtilité pour une mise à jour
! smile

Dernière modification par nono47 (19-04-2016 18:00:24)

Hors ligne

#7 19-04-2016 19:16:35

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : apt-get update

rvH a écrit :

lorsque je fais un apt-get update et que mon système réceptionne ceci par exemple :

Réception de : 1 http://ftp.belnet.be jessie-updates/main amd64 Packages/DiffIndex [1.996 B]
Réception de : 2 http://ftp.belnet.be jessie-updates/main Translation-en/DiffIndex [1.228 B]

est-ce que je dois faire une installation après ?



Salut !

Ce qui est réceptionné, ce sont des listes de paquets, pas des paquets.
apt-get upgrade se charge de lire ces listes et de comparer avec ce qui est installé sur ton système pour voir s'il y a des paquets à mettre à jour, si c'est le cas il va te le demander smile


Schokolade ist keine Lüge.

Hors ligne

#8 19-04-2016 19:47:50

rvH
Membre
Noyau : Linux 3.16.0-4-amd64
Inscription : 12-04-2016

Re : apt-get update

bonjour,

voici ce que donne un apt-get upgrade :

apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'
état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



merci

Hors ligne

#9 19-04-2016 19:56:20

rodrigue7000
Membre
Lieu : beloeil
Distrib. : debian jessie (stable) v8.4
Noyau : Linux 4.5.0-0.bpo.2-amd64
(G)UI : kde et cinnamon Fixe pc + xfce et cinnamon laptop
Inscription : 01-03-2016

Re : apt-get update

j'ai fait mise à jours kernel 4.0 smile big_smile
libreoffice 5.1.2.2.0 ^^
tout seule intel remplacer par ati au graphique  ????

je suis malentendant car une problème du Dyslexique en français smile merci vos respect
http://debian-art.org/CONTENT/content-pre1/80977-1.png
la groupe de debiannistes sur ce facebook : https://www.facebook.com/groups/1533439706960929/
le serveur irc de linuxfriends : irc.freemind.ovh #linuxfriends

Hors ligne

#10 19-04-2016 20:10:50

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : apt-get update

apt a écrit :

0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.


Ben il est clair l'ami APT, il te dit bien qu'y a rien à faire smile


Schokolade ist keine Lüge.

Hors ligne

#11 19-04-2016 20:27:50

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : apt-get update

bonjour smile

Il serait intéressant de voir ton sources.list, parce-que la simple chose que nous indique le retour de apt, c'est qu'aucune mise à jour n'est disponible à partir des sources actuelles.

C'est faisable avec

cat /etc/apt/sources.list


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#12 19-04-2016 21:06:29

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : apt-get update

Severian a écrit :


petite correction / précision
apt-get update ne te dira pas s'il y a des paquets à mettre à jour, c'est apt update qui te le dira automatiquement


Ah bah oui tu as raison roll j'aurais du vérifier car j'ai assez peu utilisé apt-get, je suis passée à apt quand nlQnutn a commencé à écrire la doc et je l'ai adopté en oubliant les petites différences des deux.


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#13 21-04-2016 07:47:57

rvH
Membre
Noyau : Linux 3.16.0-4-amd64
Inscription : 12-04-2016

Re : apt-get update

bendia a écrit :

bonjour smile

Il serait intéressant de voir ton sources.list, parce-que la simple chose que nous indique le retour de apt, c'est qu'aucune mise à jour n'est disponible à partir des sources actuelles.

C'est faisable avec

cat /etc/apt/sources.list



bonjour voici :

#

# deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 NETINST Binary-1 20160402-14:42]/ jessie main

#deb cdrom:[Debian GNU/Linux 8.4.0 _Jessie_ - Official amd64 NETINST Binary-1 20160402-14:42]/ jessie main

deb http://ftp.belnet.be/debian/ jessie main
deb-src http://ftp.belnet.be/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.belnet.be/debian/ jessie-updates main
deb-src http://ftp.belnet.be/debian/ jessie-updates main
 



merci

Hors ligne

#14 21-04-2016 10:24:34

rodrigue7000
Membre
Lieu : beloeil
Distrib. : debian jessie (stable) v8.4
Noyau : Linux 4.5.0-0.bpo.2-amd64
(G)UI : kde et cinnamon Fixe pc + xfce et cinnamon laptop
Inscription : 01-03-2016

Re : apt-get update

salut rvh

tu ajoutes une ligne


# Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
 



bien à toi
Rodrigue7000


je suis malentendant car une problème du Dyslexique en français smile merci vos respect
http://debian-art.org/CONTENT/content-pre1/80977-1.png
la groupe de debiannistes sur ce facebook : https://www.facebook.com/groups/1533439706960929/
le serveur irc de linuxfriends : irc.freemind.ovh #linuxfriends

Hors ligne

#15 21-04-2016 10:43:19

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : apt-get update

rodrigue7000 a écrit :

salut rvh

tu ajoutes une ligne


# Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
 



bien à toi
Rodrigue7000



pourquoi lui faire rajouter les backports ???
le sources.list est bien, s'il n'a pas besoin de logiciels particuliers, pas besoin des backports.

la question à la base était

rvH a écrit :

Bonjour à tous,

lorsque je fais un apt-get update et que mon système réceptionne ceci par exemple :

Réception de : 1 http://ftp.belnet.be jessie-updates/main amd64 Packages/DiffIndex [1.996 B]
Réception de : 2 http://ftp.belnet.be jessie-updates/main Translation-en/DiffIndex [1.228 B]

est-ce que je dois faire une installation après ?

merci d'avance pour vos réponse.
rvH


donc oui il est possible qu'il y ai des mises à jours, pour vérifier (réponse donné post #2 par vv222)

apt list --upgradable


visiblement pas de mises à jours (post #8)
donc tout va bien, sujet résolu (ou j'ai raté un épisode tongue)

Dernière modification par Severian (21-04-2016 10:44:05)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#16 21-04-2016 11:54:38

rodrigue7000
Membre
Lieu : beloeil
Distrib. : debian jessie (stable) v8.4
Noyau : Linux 4.5.0-0.bpo.2-amd64
(G)UI : kde et cinnamon Fixe pc + xfce et cinnamon laptop
Inscription : 01-03-2016

Re : apt-get update

Severian a écrit :

rodrigue7000 a écrit :

salut rvh

tu ajoutes une ligne


# Debian Jessie, dépôt de rétroportages ("backports")
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
 



bien à toi
Rodrigue7000



pourquoi lui faire rajouter les backports ???
le sources.list est bien, s'il n'a pas besoin de logiciels particuliers, pas besoin des backports.

la question à la base était

rvH a écrit :

Bonjour à tous,

lorsque je fais un apt-get update et que mon système réceptionne ceci par exemple :

Réception de : 1 http://ftp.belnet.be jessie-updates/main amd64 Packages/DiffIndex [1.996 B]
Réception de : 2 http://ftp.belnet.be jessie-updates/main Translation-en/DiffIndex [1.228 B]

est-ce que je dois faire une installation après ?

merci d'avance pour vos réponse.
rvH


donc oui il est possible qu'il y ai des mises à jours, pour vérifier (réponse donné post #2 par vv222)

apt list --upgradable


visiblement pas de mises à jours (post #8)
donc tout va bien, sujet résolu (ou j'ai raté un épisode tongue)



bah il parle backports ?


je suis malentendant car une problème du Dyslexique en français smile merci vos respect
http://debian-art.org/CONTENT/content-pre1/80977-1.png
la groupe de debiannistes sur ce facebook : https://www.facebook.com/groups/1533439706960929/
le serveur irc de linuxfriends : irc.freemind.ovh #linuxfriends

Hors ligne

#17 21-04-2016 12:37:24

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : apt-get update

rodrigue7000 a écrit :


bah il parle backports ?



à aucun moment.
les backports sont mentionné dans les exemples de nIQnutn (ce qui ne reste qu'un exemple d'utilisation des commandes apt update et apt list --upgradable, les commandes sont ici pour montrer un résultat possible)
et dans tes post smile


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#18 21-04-2016 12:40:42

rodrigue7000
Membre
Lieu : beloeil
Distrib. : debian jessie (stable) v8.4
Noyau : Linux 4.5.0-0.bpo.2-amd64
(G)UI : kde et cinnamon Fixe pc + xfce et cinnamon laptop
Inscription : 01-03-2016

Re : apt-get update

Severian a écrit :

rodrigue7000 a écrit :


bah il parle backports ?



à aucun moment.
les backports sont mentionné dans les exemples de nIQnutn (ce qui ne reste qu'un exemple d'utilisation des commandes apt update et apt list --upgradable, les commandes sont ici pour montrer un résultat possible)
et dans tes post smile



ok


je suis malentendant car une problème du Dyslexique en français smile merci vos respect
http://debian-art.org/CONTENT/content-pre1/80977-1.png
la groupe de debiannistes sur ce facebook : https://www.facebook.com/groups/1533439706960929/
le serveur irc de linuxfriends : irc.freemind.ovh #linuxfriends

Hors ligne

#19 22-04-2016 12:42:55

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : apt-get update

Un peu trop HS ces jours-ci pour le finir, mais c'est déjà ça : Fichier de completion pour la commande “apt”

Hors ligne

Pied de page des forums