Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-04-2016 16:55:13

moumoula
Membre
Inscription : 19-04-2016

Ouverture de port 5900

Bonjour à tous;


Quelqun peut me dire comment ouvrir le port 5900 , sachant que quand je tape la commande:

nmap -PN -p5900 @IP  , J'obtient le résultat :

Starting Nmap 6.40 ( http://nmap.org ) at 2016-04-19 14:51 UTC
Nmap scan report for xxx.xxx.xxx.xxx
Host is up (0.0025s latency).
PORT     STATE  SERVICE
5900/tcp closed vnc





Merci d'avance.

Hors ligne

#2 19-04-2016 17:18:13

abecido
Membre
Lieu : Var
Distrib. : Debian GNU/Linux testing (stretch)
Noyau : Linux 4.4.0-1-amd64
(G)UI : KDE
Inscription : 19-09-2015

Re : Ouverture de port 5900

Il semble que ce soit le port du service vnc, as tu lancé vnc ? si c'est bien vnc que tu veux utiliser.

"Appréciez votre liberté, ou vous la perdrez, nous apprend l’Histoire. « Ne nous ennuyez pas avec la politique », répondent ceux qui ne veulent pas apprendre." Richard Stallman

Hors ligne

#3 19-04-2016 17:46:48

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : Ouverture de port 5900

iptables -A INPUT -p tcp --dport 5900 -j ACCEPT



Pour que se soit définitif, regarde ici.

Edit : N'oublie pas également d'ouvrir le port sur la box.

Dernière modification par kawer (19-04-2016 17:48:55)


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#4 20-04-2016 09:32:26

moumoula
Membre
Inscription : 19-04-2016

Re : Ouverture de port 5900

Bonjour;
Merci pour votre réponse abecido ,Oui, je veux lancer vnc  afin d'accéder au bureau à distance d'une machine se trouvant sur un autre réseau.

Hors ligne

#5 20-04-2016 09:36:28

moumoula
Membre
Inscription : 19-04-2016

Re : Ouverture de port 5900

Merci Kawar , j'ai éxécuté votre commande, mais le problème persiste, quand je lance l'interface graphique x11vnc via la commande:

x11vnc -many -rfbauth ~/.vnc_passwd




j'obtient le résultat suivant:

20/04/2016 07:38:58 passing arg to libvncserver: -rfbauth
20/04/2016 07:38:58 passing arg to libvncserver: /root/.vnc_passwd
20/04/2016 07:38:58 x11vnc version: 0.9.13 lastmod: 2011-08-10  pid: 2849
20/04/2016 07:38:58 XOpenDisplay("") failed.
20/04/2016 07:38:58 Trying again with XAUTHLOCALHOSTNAME=localhost ...
20/04/2016 07:38:58
20/04/2016 07:38:58 *** XOpenDisplay failed. No -display or DISPLAY.
20/04/2016 07:38:58 *** Trying ":0" in 4 seconds.  Press Ctrl-C to abort.
20/04/2016 07:38:58 *** 1 2 3 4
No protocol specified
20/04/2016 07:39:02 XOpenDisplay(":0") failed.
20/04/2016 07:39:02 Trying again with XAUTHLOCALHOSTNAME=localhost ...
No protocol specified
20/04/2016 07:39:02 XOpenDisplay(":0") failed.
20/04/2016 07:39:02 Trying again with unset XAUTHLOCALHOSTNAME ...
No protocol specified
20/04/2016 07:39:02

20/04/2016 07:39:02 ***************************************
20/04/2016 07:39:02 *** XOpenDisplay failed (:0)

*** x11vnc was unable to open the X DISPLAY: ":0", it cannot continue.
*** There may be "Xlib:" error messages above with details about the failure.

Some tips and guidelines:

** An X server (the one you wish to view) must be running before x11vnc is
   started: x11vnc does not start the X server.  (however, see the -create
   option if that is what you really want).

** You must use -display <disp>, -OR- set and export your $DISPLAY
   environment variable to refer to the display of the desired X server.
 - Usually the display is simply ":0" (in fact x11vnc uses this if you forget
   to specify it), but in some multi-user situations it could be ":1", ":2",
   or even ":137".  Ask your administrator or a guru if you are having
   difficulty determining what your X DISPLAY is.

** Next, you need to have sufficient permissions (Xauthority)
   to connect to the X DISPLAY.   Here are some Tips:

 - Often, you just need to run x11vnc as the user logged into the X session.
   So make sure to be that user when you type x11vnc.
 - Being root is usually not enough because the incorrect MIT-MAGIC-COOKIE
   file may be accessed.  The cookie file contains the secret key that
   allows x11vnc to connect to the desired X DISPLAY.
 - You can explicitly indicate which MIT-MAGIC-COOKIE file should be used
   by the -auth option, e.g.:
       x11vnc -auth /home/someuser/.Xauthority -display :0
       x11vnc -auth /tmp/.gdmzndVlR -display :0
   you must have read permission for the auth file.
   See also '-auth guess' and '-findauth' discussed below.

** If NO ONE is logged into an X session yet, but there is a greeter login
   program like "gdm", "kdm", "xdm", or "dtlogin" running, you will need
   to find and use the raw display manager MIT-MAGIC-COOKIE file.
   Some examples for various display managers:

     gdm:     -auth /var/gdm/:0.Xauth
              -auth /var/lib/gdm/:0.Xauth
     kdm:     -auth /var/lib/kdm/A:0-crWk72
              -auth /var/run/xauth/A:0-crWk72
     xdm:     -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
     dtlogin: -auth /var/dt/A:0-UgaaXa

   Sometimes the command "ps wwwwaux | grep auth" can reveal the file location.

   Starting with x11vnc 0.9.9 you can have it try to guess by using:

              -auth guess

   (see also the x11vnc -findauth option.)

   Only root will have read permission for the file, and so x11vnc must be run
   as root (or copy it).  The random characters in the filenames will of course
   change and the directory the cookie file resides in is system dependent.

See also: [url]http://www.karlrunge.com/x11vnc/faq.html[/url]
 

Dernière modification par moumoula (20-04-2016 09:53:56)

Hors ligne

#6 20-04-2016 10:00:50

Kusajika
Membre
Inscription : 08-04-2015

Re : Ouverture de port 5900

Bonjour , je pense que ça n'a rien à voir avec le problème de départ , dans le log du problème on peu lire que c'est l'affichage qui est en cause.

XOpenDisplay failed (:0)


*** x11vnc was unable to open the X DISPLAY: ":0", it cannot continue.
*** There may be "Xlib:" error messages above with details about the failure.

Hors ligne

#7 20-04-2016 10:17:23

abecido
Membre
Lieu : Var
Distrib. : Debian GNU/Linux testing (stretch)
Noyau : Linux 4.4.0-1-amd64
(G)UI : KDE
Inscription : 19-09-2015

Re : Ouverture de port 5900

lance la même commande mais pas en root, il devrait trouver le display

"Appréciez votre liberté, ou vous la perdrez, nous apprend l’Histoire. « Ne nous ennuyez pas avec la politique », répondent ceux qui ne veulent pas apprendre." Richard Stallman

Hors ligne

#8 20-04-2016 12:24:03

moumoula
Membre
Inscription : 19-04-2016

Re : Ouverture de port 5900

j'ai lancé la  même commabe en mode user, mais j'avais le même problème

Hors ligne

#9 20-04-2016 13:10:11

abecido
Membre
Lieu : Var
Distrib. : Debian GNU/Linux testing (stretch)
Noyau : Linux 4.4.0-1-amd64
(G)UI : KDE
Inscription : 19-09-2015

Re : Ouverture de port 5900

Si on reprend la sortie de x11vnc :

Some tips and guidelines:

** An X server (the one you wish to view) must be running before x11vnc is
   started: x11vnc does not start the X server.  (however, see the -create
   option if that is what you really want).

Un serveur X doit tourner. Sinont tu peux essayer l'option "-create"

** You must use -display <disp>, -OR- set and export your $DISPLAY
   environment variable to refer to the display of the desired X server.
- Usually the display is simply ":0" (in fact x11vnc uses this if you forget
   to specify it), but in some multi-user situations it could be ":1", ":2",
   or even ":137".  Ask your administrator or a guru if you are having
   difficulty determining what your X DISPLAY is.

Tu peux trouver le $DISPLAY avec un "ps" pour trouver le serveur X (chez moi c'est Xorg) :

ps -ef | grep Xorg


root      1055  1029  6 avril18 tty7   03:06:49 /usr/lib/xorg/Xorg :0 vt7 -br -nolisten tcp -auth /var/run/xauth/A:0-vHtzQb

C'est le ":0" juste après "Xorg".

** Next, you need to have sufficient permissions (Xauthority)
   to connect to the X DISPLAY.   Here are some Tips:

- Often, you just need to run x11vnc as the user logged into the X session.
   So make sure to be that user when you type x11vnc.
- Being root is usually not enough because the incorrect MIT-MAGIC-COOKIE
   file may be accessed.  The cookie file contains the secret key that
   allows x11vnc to connect to the desired X DISPLAY.
- You can explicitly indicate which MIT-MAGIC-COOKIE file should be used
   by the -auth option, e.g.:
       x11vnc -auth /home/someuser/.Xauthority -display :0
       x11vnc -auth /tmp/.gdmzndVlR -display :0
   you must have read permission for the auth file.
   See also '-auth guess' and '-findauth' discussed below.

La même commande "ps" que ci dessus te donne le MIT-MAGIC-COOKIE, c'est le parametre après "-auth", dans mon cas c'est /var/run/xauth/A:0vHtzQb.

** If NO ONE is logged into an X session yet, but there is a greeter login
   program like "gdm", "kdm", "xdm", or "dtlogin" running, you will need
   to find and use the raw display manager MIT-MAGIC-COOKIE file.
   Some examples for various display managers:

     gdm:     -auth /var/gdm/:0.Xauth
              -auth /var/lib/gdm/:0.Xauth
     kdm:     -auth /var/lib/kdm/A:0-crWk72
              -auth /var/run/xauth/A:0-crWk72
     xdm:     -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
     dtlogin: -auth /var/dt/A:0-UgaaXa

   Sometimes the command "ps wwwwaux | grep auth" can reveal the file location.

Une autre façon de trouver le MIT-MAGIC-COOKIE

Starting with x11vnc 0.9.9 you can have it try to guess by using:

              -auth guess

Voir quelle version tu utilise.

(see also the x11vnc -findauth option.)

Encore une autre façon de trouver MIT-MAGIC-COOKIE

Only root will have read permission for the file, and so x11vnc must be run
   as root (or copy it).  The random characters in the filenames will of course
   change and the directory the cookie file resides in is system dependent.


Si tu précise le "-auth" ou "-findauth" il faut être en root


Chez moi, la commande suivant fonctionne :

x11vnc -display :0 -auth /var/run/xauth/nom_du_fichier



Si avec ça x11vnc n'arrive toujours pas à ouvrir le display :

Dernière modification par abecido (20-04-2016 15:03:37)


"Appréciez votre liberté, ou vous la perdrez, nous apprend l’Histoire. « Ne nous ennuyez pas avec la politique », répondent ceux qui ne veulent pas apprendre." Richard Stallman

Hors ligne

#10 20-04-2016 17:14:29

moumoula
Membre
Inscription : 19-04-2016

Re : Ouverture de port 5900

Merci beaucoup abecido , vous m'avez vraiment aidé pour l'ouverture du port 5900,j'ai seulement ajouté l'option:
" -create"

J'ai peu accédé à la machine distante, mais l'interface graphique ne s'affiche  pas correctement, c'est une page grise.

J'ai réinstallé Gnome , mais le problème persiste encore et l'exécution de la commande:  x11vnc -many -rfbauth ~/.vnc_passwd
me donne toujours le même résultat.

Dernière modification par moumoula (20-04-2016 17:16:47)

Hors ligne

Pied de page des forums