Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-04-2016 22:37:51

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Subtitleeditor et gstreamermm

Bonjour à vous,

j'ai un petit soucis de compilation avec les sources de Subtitle editor (la version 0.33.0-3 dans les dépôts bugue sad )

http://home.gna.org/subtitleeditor/

J'ai résolu pas mal de dépendances mais celle là, je sèche hmm



./autogen.sh
etc ...
etc ...
checking for GSTREAMERMM... no
configure: error: Package requirements (gstreamermm-1.0 >= 1.0) were not met:

No package 'gstreamermm-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GSTREAMERMM_CFLAGS
and GSTREAMERMM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.



merci d'avance pour le coup de pouce qui m'aidera à aller plus loin cool

Totophe56

Dernière modification par totophe56 (23-04-2016 22:38:49)

Hors ligne

#2 23-04-2016 22:57:15

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Subtitleeditor et gstreamermm

Bonsoir,


apt-get install libgstreamermm-1.0-dev
 



EDIT: désolé, n'est pas sous Jessie hmm

Dernière modification par golgot200 (23-04-2016 23:04:31)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#3 23-04-2016 23:41:22

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : Subtitleeditor et gstreamermm

effectivement wink

pt-get install libgstreamermm-1.0-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
E: Impossible de trouver le paquet libgstreamermm-1.0-dev
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libgstreamermm-1.0-dev »



j'ai essayé de tourner ..., multimedia est activé...

Hors ligne

#4 26-04-2016 22:27:59

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : Subtitleeditor et gstreamermm

Bonsoir,

vous pensez que je peux aller faire un tour du côté des backports ou de sid ?

merci pour votre aide

Totophe56

Hors ligne

#5 26-04-2016 22:40:17

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : Subtitleeditor et gstreamermm

Bonsoir,

Je n'ai pas l'impression que ça y soit : https://packages.debian.org/search?keyw … ection=all

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#6 26-04-2016 23:07:35

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Subtitleeditor et gstreamermm

tu peux tenter le pinning avec le dépôt stretch ou sid.
dans ce cas autant installer le paquet subtitleeditor plutot que la dépendance seule.

Hors ligne

#7 01-05-2016 20:17:08

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : Subtitleeditor et gstreamermm

Bonjour et merci pour votre aide

subtitleeditor est la même version sur les dépôt stable et les backports, malheureusement, elle plante, et la dernière version est la version 0.52.1
http://home.gna.org/subtitleeditor/

apt-cache policy subtitleeditor
subtitleeditor:
  Installé : (aucun)
  Candidat : 0.33.0-3
 Table de version :
     0.33.0-3 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages

 



apt-cache -t jessie-backports policy subtitleeditor
subtitleeditor:
  Installé : (aucun)
  Candidat : 0.33.0-3
 Table de version :
     0.33.0-3 0
        500 http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages
 



et pas de libgstreamermm-1.0-dev dans les backports non plus sad

 apt-cache -t jessie-backports policy libgstreamermm-1.0-dev
N: Impossible de trouver le paquet libgstreamermm-1.0-dev
N: Impossible de trouver de paquet correspondant à l'expression rationnelle « libgstreamermm-1.0-dev »
 



une petite idée ?

merci d'avance ;-)

Totophe56

Hors ligne

#8 01-05-2016 20:40:53

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Subtitleeditor et gstreamermm

pour info, la version subtitleeditor 0.52.1-2 est disponible avec stretch (testing), par contre l'installer sur debian stable risque de casser beaucoup de choses

 apt-cache depends subtitleeditor/stretch


subtitleeditor
  Dépend: libatkmm-1.6-1v5
  Dépend: libc6
  Dépend: libcairomm-1.0-1v5
  Dépend: libgcc1
  Dépend: libglib2.0-0
  Dépend: libglibmm-2.4-1v5
  Dépend: libgstreamer-plugins-base1.0-0
  Dépend: libgstreamer1.0-0
  Dépend: libgstreamermm-1.0-0v5
  Dépend: libgtk-3-0
  Dépend: libgtkmm-3.0-1v5
  Dépend: libpangomm-1.4-1v5
  Dépend: libsigc++-2.0-0v5
  Dépend: libstdc++6
  Dépend: libsubtitleeditor0
  Dépend: gstreamer1.0-x
  Dépend: gstreamer1.0-plugins-good
  Dépend: gstreamer1.0-plugins-base
  Suggère: gstreamer1.0-libav
 



apt-get -s install subtitleeditor/stretch


NOTE: Ceci n'est qu'une simulation !
      apt-get a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Version choisie « 0.52.1-2 » (Debian:testing [amd64]) pour « subtitleeditor »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 subtitleeditor : Dépend: libatkmm-1.6-1v5 (>= 2.24.0) mais ne sera pas installé
                  Dépend: libcairomm-1.0-1v5 (>= 1.12.0) mais ne sera pas installé
                  Dépend: libglibmm-2.4-1v5 (>= 2.46.0) mais ne sera pas installé
                  Dépend: libgstreamermm-1.0-0v5 mais ne sera pas installé
                  Dépend: libgtkmm-3.0-1v5 (>= 3.18.0) mais ne sera pas installé
                  Dépend: libpangomm-1.4-1v5 (>= 2.38.0) mais ne sera pas installé
                  Dépend: libsigc++-2.0-0v5 (>= 2.6.1) mais ne sera pas installé
                  Dépend: libsubtitleeditor0 (= 0.52.1-2) mais 0.33.0-3 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


autre simulation

apt-get -s install -t dtretch subtitleeditor


NOTE: Ceci n'est qu'une simulation !
      apt-get a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  imagemagick-common libgnomevfs2-0 libgtkspell0 liblqr-1-0 libmagick++-6.q16-5
  libmagickcore-6.q16-2 libmagickwand-6.q16-2
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  adwaita-icon-theme apt apt-utils aptitude-common coinor-libcoinmp1v5 dbus gcc-5-base
  gnome-themes-standard gnome-themes-standard-data libapparmor1 libapt-inst2.0
  libapt-pkg5.0 libatk1.0-0 libatk1.0-data libatkmm-1.6-1v5 libboost-date-time1.58.0
  libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-system1.58.0
  libcairomm-1.0-1v5 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libdbus-1-3
  libetonyek-0.1-1 libglew1.13 libglib2.0-0 libglibmm-2.4-1v5 libgltf-0.0-0v5
  libgstreamermm-1.0-0v5 libgtk-3-0 libgtk-3-common libgtkmm-3.0-1v5 libicu55 liblz4-1
  libmpdec2 libncurses5 libncursesw5 liborcus-0.11-0 libpango-1.0-0 libpango1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpangomm-1.4-1v5 libpangoxft-1.0-0 libpng16-16
  libpython3-stdlib libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-l10n-fr libreoffice-style-galaxy libreoffice-style-oxygen
  libreoffice-style-tango libreoffice-writer libsigc++-2.0-0v5 libssl1.0.2 libstdc++6
  libsubtitleeditor0 libthai0 libtinfo5 libwps-0.4-4 libxkbcommon-x11-0 libxkbcommon0
  libxml++2.6-2v5 libxrandr2 python3 python3-minimal python3-uno python3.5
  python3.5-minimal uno-libs3 ure
Paquets suggérés :
  dpkg-dev apt-doc glew-utils gvfs libreoffice-base ocl-icd-libopencl1
  libreoffice-style-breeze libreoffice-style-hicontrast libreoffice-style-sifr hyphen-fr
  libreoffice-grammarcheck-fr libreoffice-help-fr mythes-fr kde-icons-oxygen oxygencursors
  fonts-crosextra-caladea fonts-crosextra-carlito libreoffice-gcj libreoffice-java-common
  default-jre openjdk-8-jre openjdk-7-jre openjdk-6-jre gcj-jre sun-java5-jre
  sun-java6-jre java5-runtime jre python3-doc python3-tk python3-venv python3.5-venv
  python3.5-doc binutils binfmt-support
Paquets recommandés :
  gnome-accessibility-themes libglib2.0-data libreoffice-math
Les paquets suivants seront ENLEVÉS :
  aptitude* coinor-libcoinmp1* gparted* inkscape* libatkmm-1.6-1*
  libboost-date-time1.55.0* libcairomm-1.0-1* libclucene-contribs1* libclucene-core1*
  libcmis-0.4-4* libcwidget3* libglibmm-2.4-1c2a* libgltf-0.0-0* libgtkmm-2.4-1c2a*
  libpangomm-1.4-1* libsigc++-2.0-0c2a*
Les NOUVEAUX paquets suivants seront installés :
  coinor-libcoinmp1v5 gcc-5-base libapparmor1 libapt-inst2.0 libapt-pkg5.0
  libatkmm-1.6-1v5 libboost-date-time1.58.0 libboost-filesystem1.58.0
  libboost-iostreams1.58.0 libboost-system1.58.0 libcairomm-1.0-1v5 libclucene-contribs1v5
  libclucene-core1v5 libcmis-0.5-5v5 libetonyek-0.1-1 libglew1.13 libglibmm-2.4-1v5
  libgltf-0.0-0v5 libgstreamermm-1.0-0v5 libgtkmm-3.0-1v5 libicu55 liblz4-1
  liborcus-0.11-0 libpangomm-1.4-1v5 libpng16-16 libpython3.5 libpython3.5-minimal
  libpython3.5-stdlib libsigc++-2.0-0v5 libssl1.0.2 libsubtitleeditor0 libwps-0.4-4
  libxml++2.6-2v5 python3.5 python3.5-minimal subtitleeditor
Les paquets suivants seront mis à jour :
  adwaita-icon-theme apt apt-utils aptitude-common dbus gnome-themes-standard
  gnome-themes-standard-data libatk1.0-0 libatk1.0-data libdbus-1-3 libglib2.0-0
  libgtk-3-0 libgtk-3-common libmpdec2 libncurses5 libncursesw5 libpango-1.0-0
  libpango1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libpython3-stdlib
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-l10n-fr libreoffice-style-galaxy libreoffice-style-oxygen
  libreoffice-style-tango libreoffice-writer libstdc++6 libthai0 libtinfo5
  libxkbcommon-x11-0 libxkbcommon0 libxrandr2 python3 python3-minimal python3-uno
  uno-libs3 ure
42 mis à jour, 36 nouvellement installés, 16 à enlever et 674 non mis à jour.
Inst liblz4-1 (0.0~r131-2 Debian:testing [amd64])
Conf liblz4-1 (0.0~r131-2 Debian:testing [amd64])
Inst gcc-5-base (5.3.1-14 Debian:testing [amd64])
Conf gcc-5-base (5.3.1-14 Debian:testing [amd64])
Inst libreoffice-l10n-fr [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [all]) []
Inst libreoffice-calc [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [amd64]) []
Inst libreoffice-writer [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [amd64]) []
Inst libreoffice-style-oxygen [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [all]) [libreoffice-common:amd64 on libreoffice-style-oxygen:amd64] [libreoffice-common:amd64 ]
Inst libreoffice-style-tango [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [all]) [libreoffice-common:amd64 on libreoffice-style-oxygen:amd64] [libreoffice-common:amd64 on libreoffice-style-tango:amd64] [libreoffice-common:amd64 ]
Inst libreoffice-core [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [amd64]) [libreoffice-common:amd64 on libreoffice-core:amd64] [libreoffice-common:amd64 on libreoffice-style-oxygen:amd64] [libreoffice-common:amd64 on libreoffice-style-tango:amd64] [libreoffice-base-core:amd64 python3-uno:amd64 libreoffice-common:amd64 ]
Inst libreoffice-style-galaxy [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [all]) [libreoffice-common:amd64 on libreoffice-core:amd64] [libreoffice-common:amd64 on libreoffice-style-galaxy:amd64] [libreoffice-common:amd64 on libreoffice-style-oxygen:amd64] [libreoffice-common:amd64 on libreoffice-style-tango:amd64] [libreoffice-base-core:amd64 python3-uno:amd64 libreoffice-common:amd64 ]
Inst libreoffice-common [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [all]) [libreoffice-base-core:amd64 python3-uno:amd64 ]
Inst uno-libs3 [4.3.3-2+deb8u3] (5.1.2-3 Debian:testing [amd64]) [libreoffice-base-core:amd64 ure:amd64 python3-uno:amd64 ]
Inst ure [4.3.3-2+deb8u3] (5.1.2-3 Debian:testing [amd64]) [libreoffice-base-core:amd64 python3-uno:amd64 ]
Inst python3-uno [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [amd64]) [libreoffice-base-core:amd64 ]
Inst libreoffice-base-core [1:4.3.3-2+deb8u3] (1:5.1.2-3 Debian:testing [amd64]) []
Inst libboost-date-time1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64]) []
Purg libclucene-contribs1 [2.3.3.4-4] []
Purg libclucene-core1 [2.3.3.4-4] []
Inst libclucene-core1v5 (2.3.3.4-4.1 Debian:testing [amd64]) []
Inst libclucene-contribs1v5 (2.3.3.4-4.1 Debian:testing [amd64]) []
Inst libcmis-0.5-5v5 (0.5.1-2 Debian:testing [amd64]) []
Inst libapparmor1 (2.10-4 Debian:testing [amd64]) []
Inst dbus [1.8.20-0+deb8u1] (1.10.8-1 Debian:testing [amd64]) []
Inst libdbus-1-3 [1.8.20-0+deb8u1] (1.10.8-1 Debian:testing [amd64]) []
Conf libdbus-1-3 (1.10.8-1 Debian:testing [amd64]) []
Inst libglew1.13 (1.13.0-2 Debian:testing [amd64]) []
Purg libgltf-0.0-0 [0.0.2-2] []
Inst libgltf-0.0-0v5 (0.0.2-4+b1 Debian:testing [amd64]) []
Inst libicu55 (55.1-7 Debian:testing [amd64]) []
Inst libpng16-16 (1.6.21-4 Debian:testing [amd64]) []
Inst libssl1.0.2 (1.0.2g-2 Debian:testing [amd64]) []
Inst libglib2.0-0 [2.42.1-1+b1] (2.48.0-1 Debian:testing [amd64]) []
Conf libglib2.0-0 (2.48.0-1 Debian:testing [amd64]) []
Inst libetonyek-0.1-1 (0.1.6-1 Debian:testing [amd64]) []
Inst libwps-0.4-4 (0.4.3-1 Debian:testing [amd64]) []
Purg coinor-libcoinmp1 [1.7.6+dfsg1-1] []
Inst coinor-libcoinmp1v5 (1.7.6+dfsg1-2 Debian:testing [amd64]) []
Inst libboost-system1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64]) []
Inst libboost-filesystem1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64]) []
Inst libboost-iostreams1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64]) []
Inst liborcus-0.11-0 (0.11.1+dfsg-1 Debian:testing [amd64]) []
Inst libpython3.5-minimal (3.5.1-11 Debian:testing [amd64]) []
Inst python3.5-minimal (3.5.1-11 Debian:testing [amd64]) []
Inst libtinfo5 [5.9+20140913-1+b1] (6.0+20160319-1 Debian:testing [amd64]) [libncurses5:amd64 libncursesw5:amd64 ]
Conf libtinfo5 (6.0+20160319-1 Debian:testing [amd64]) [libncurses5:amd64 libncursesw5:amd64 ]
Inst libncursesw5 [5.9+20140913-1+b1] (6.0+20160319-1 Debian:testing [amd64]) [libncurses5:amd64 ]
Conf libncursesw5 (6.0+20160319-1 Debian:testing [amd64]) [libncurses5:amd64 ]
Inst libncurses5 [5.9+20140913-1+b1] (6.0+20160319-1 Debian:testing [amd64]) []
Conf libncurses5 (6.0+20160319-1 Debian:testing [amd64]) []
Inst libmpdec2 [2.4.1-1] (2.4.2-1 Debian:testing [amd64]) []
Inst libpython3.5-stdlib (3.5.1-11 Debian:testing [amd64]) []
Inst python3.5 (3.5.1-11 Debian:testing [amd64]) []
Inst python3-minimal [3.4.2-2] (3.5.1-3 Debian:testing [amd64]) [python3:amd64 ]
Conf libssl1.0.2 (1.0.2g-2 Debian:testing [amd64]) [python3:amd64 ]
Conf libpython3.5-minimal (3.5.1-11 Debian:testing [amd64]) [python3:amd64 ]
Conf python3.5-minimal (3.5.1-11 Debian:testing [amd64]) [python3:amd64 ]
Conf python3-minimal (3.5.1-3 Debian:testing [amd64]) [python3:amd64 ]
Inst python3 [3.4.2-2] (3.5.1-3 Debian:testing [amd64]) []
Inst libpython3-stdlib [3.4.2-2] (3.5.1-3 Debian:testing [amd64]) []
Inst libpython3.5 (3.5.1-11 Debian:testing [amd64]) []
Inst libxrandr2 [2:1.4.2-1+b1] (2:1.5.0-1 Debian:testing [amd64]) []
Conf libxrandr2 (2:1.5.0-1 Debian:testing [amd64]) []
Purg libcmis-0.4-4 [0.4.1-7] []
Purg libboost-date-time1.55.0 [1.55.0+dfsg-3] []
Inst libstdc++6 [4.9.2-10] (5.3.1-14 Debian:testing [amd64])
Conf libstdc++6 (5.3.1-14 Debian:testing [amd64])
Inst libapt-inst2.0 (1.2.11 Debian:testing [amd64]) []
Inst apt-utils [1.0.9.8.3] (1.2.11 Debian:testing [amd64]) []
Inst apt [1.0.9.8.3] (1.2.11 Debian:testing [amd64]) []
Inst libapt-pkg5.0 (1.2.11 Debian:testing [amd64])
Conf libapt-pkg5.0 (1.2.11 Debian:testing [amd64])
Purg aptitude [0.6.11-1+b1]
Purg gparted [0.19.0-2]
Purg inkscape [0.48.5-3]
Purg libgtkmm-2.4-1c2a [1:2.24.4-1.1]
Purg libatkmm-1.6-1 [2.22.7-2.1]
Purg libpangomm-1.4-1 [2.34.0-1.1]
Purg libcairomm-1.0-1 [1.10.0-1.1]
Purg libcwidget3 [0.5.17-2]
Purg libglibmm-2.4-1c2a [2.42.0-1]
Purg libsigc++-2.0-0c2a [2.4.0-1]
Inst libatk1.0-data [2.14.0-1] (2.20.0-1 Debian:testing [all]) [libatk1.0-0:amd64 ]
Conf libatk1.0-data (2.20.0-1 Debian:testing [all]) [libatk1.0-0:amd64 ]
Inst libatk1.0-0 [2.14.0-1] (2.20.0-1 Debian:testing [amd64])
Conf libatk1.0-0 (2.20.0-1 Debian:testing [amd64])
Inst libthai0 [0.1.21-1] (0.1.24-2 Debian:testing [amd64])
Conf libthai0 (0.1.24-2 Debian:testing [amd64])
Inst libpango-1.0-0 [1.36.8-3] (1.40.1-1 Debian:testing [amd64]) [libpango1.0-0:amd64 ]
Conf libpango-1.0-0 (1.40.1-1 Debian:testing [amd64]) [libpango1.0-0:amd64 ]
Inst libpangocairo-1.0-0 [1.36.8-3] (1.40.1-1 Debian:testing [amd64]) [libpango1.0-0:amd64 ]
Conf libpangocairo-1.0-0 (1.40.1-1 Debian:testing [amd64]) [libpango1.0-0:amd64 ]
Inst libpangoxft-1.0-0 [1.36.8-3] (1.40.1-1 Debian:testing [amd64]) [libpango1.0-0:amd64 ]
Inst libpango1.0-0 [1.36.8-3] (1.40.1-1 Debian:testing [amd64]) []
Inst libpangoft2-1.0-0 [1.36.8-3] (1.40.1-1 Debian:testing [amd64])
Conf libpangoft2-1.0-0 (1.40.1-1 Debian:testing [amd64])
Inst libgtk-3-common [3.14.5-1+deb8u1] (3.18.9-1 Debian:testing [all]) []
Inst libxkbcommon-x11-0 [0.4.3-2] (0.5.0-1 Debian:testing [amd64]) []
Inst libxkbcommon0 [0.4.3-2] (0.5.0-1 Debian:testing [amd64]) []
Inst gnome-themes-standard [3.14.2.2-1] (3.20-1 Debian:testing [amd64]) []
Inst gnome-themes-standard-data [3.14.2.2-1] (3.20-1 Debian:testing [all]) []
Inst adwaita-icon-theme [3.14.0-2] (3.20-2 Debian:testing [all])
Inst libgtk-3-0 [3.14.5-1+deb8u1] (3.18.9-1 Debian:testing [amd64])
Inst aptitude-common [0.6.11-1] (0.7.5-3 Debian:testing [all])
Inst libsigc++-2.0-0v5 (2.8.0-1 Debian:testing [amd64])
Inst libglibmm-2.4-1v5 (2.48.1-1 Debian:testing [amd64])
Inst libatkmm-1.6-1v5 (2.24.2-1 Debian:testing [amd64])
Inst libcairomm-1.0-1v5 (1.12.0-1+b1 Debian:testing [amd64])
Inst libgstreamermm-1.0-0v5 (1.4.3+dfsg-5 Debian:testing [amd64])
Inst libpangomm-1.4-1v5 (2.40.0-1 Debian:testing [amd64])
Inst libgtkmm-3.0-1v5 (3.18.0-1 Debian:testing [amd64])
Inst libxml++2.6-2v5 (2.40.1-1 Debian:testing [amd64])
Inst libsubtitleeditor0 (0.52.1-2 Debian:testing [amd64])
Inst subtitleeditor (0.52.1-2 Debian:testing [amd64])
Conf uno-libs3 (5.1.2-3 Debian:testing [amd64])
Conf ure (5.1.2-3 Debian:testing [amd64])
Conf libreoffice-common (1:5.1.2-3 Debian:testing [all])
Conf libreoffice-style-galaxy (1:5.1.2-3 Debian:testing [all])
Conf libreoffice-style-tango (1:5.1.2-3 Debian:testing [all])
Conf libreoffice-style-oxygen (1:5.1.2-3 Debian:testing [all])
Conf libreoffice-l10n-fr (1:5.1.2-3 Debian:testing [all])
Conf libboost-date-time1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64])
Conf libclucene-core1v5 (2.3.3.4-4.1 Debian:testing [amd64])
Conf libclucene-contribs1v5 (2.3.3.4-4.1 Debian:testing [amd64])
Conf libcmis-0.5-5v5 (0.5.1-2 Debian:testing [amd64])
Conf libglew1.13 (1.13.0-2 Debian:testing [amd64])
Conf libgltf-0.0-0v5 (0.0.2-4+b1 Debian:testing [amd64])
Conf libicu55 (55.1-7 Debian:testing [amd64])
Conf libpng16-16 (1.6.21-4 Debian:testing [amd64])
Conf libreoffice-core (1:5.1.2-3 Debian:testing [amd64])
Conf libreoffice-base-core (1:5.1.2-3 Debian:testing [amd64])
Conf coinor-libcoinmp1v5 (1.7.6+dfsg1-2 Debian:testing [amd64])
Conf libboost-system1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64])
Conf libboost-filesystem1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64])
Conf libboost-iostreams1.58.0 (1.58.0+dfsg-5+b1 Debian:testing [amd64])
Conf libetonyek-0.1-1 (0.1.6-1 Debian:testing [amd64])
Conf liborcus-0.11-0 (0.11.1+dfsg-1 Debian:testing [amd64])
Conf libwps-0.4-4 (0.4.3-1 Debian:testing [amd64])
Conf libreoffice-calc (1:5.1.2-3 Debian:testing [amd64])
Conf libreoffice-writer (1:5.1.2-3 Debian:testing [amd64])
Conf libmpdec2 (2.4.2-1 Debian:testing [amd64])
Conf libpython3.5-stdlib (3.5.1-11 Debian:testing [amd64])
Conf python3.5 (3.5.1-11 Debian:testing [amd64])
Conf libpython3-stdlib (3.5.1-3 Debian:testing [amd64])
Conf python3 (3.5.1-3 Debian:testing [amd64])
Conf libpython3.5 (3.5.1-11 Debian:testing [amd64])
Conf python3-uno (1:5.1.2-3 Debian:testing [amd64])
Conf libapparmor1 (2.10-4 Debian:testing [amd64])
Conf dbus (1.10.8-1 Debian:testing [amd64])
Conf libapt-inst2.0 (1.2.11 Debian:testing [amd64])
Conf apt (1.2.11 Debian:testing [amd64])
Conf apt-utils (1.2.11 Debian:testing [amd64])
Conf libpangoxft-1.0-0 (1.40.1-1 Debian:testing [amd64])
Conf libpango1.0-0 (1.40.1-1 Debian:testing [amd64])
Conf adwaita-icon-theme (3.20-2 Debian:testing [all])
Conf libgtk-3-common (3.18.9-1 Debian:testing [all])
Conf libxkbcommon0 (0.5.0-1 Debian:testing [amd64])
Conf libxkbcommon-x11-0 (0.5.0-1 Debian:testing [amd64])
Conf gnome-themes-standard-data (3.20-1 Debian:testing [all])
Conf gnome-themes-standard (3.20-1 Debian:testing [amd64])
Conf libgtk-3-0 (3.18.9-1 Debian:testing [amd64])
Conf aptitude-common (0.7.5-3 Debian:testing [all])
Conf libsigc++-2.0-0v5 (2.8.0-1 Debian:testing [amd64])
Conf libglibmm-2.4-1v5 (2.48.1-1 Debian:testing [amd64])
Conf libatkmm-1.6-1v5 (2.24.2-1 Debian:testing [amd64])
Conf libcairomm-1.0-1v5 (1.12.0-1+b1 Debian:testing [amd64])
Conf libgstreamermm-1.0-0v5 (1.4.3+dfsg-5 Debian:testing [amd64])
Conf libpangomm-1.4-1v5 (2.40.0-1 Debian:testing [amd64])
Conf libgtkmm-3.0-1v5 (3.18.0-1 Debian:testing [amd64])
Conf libxml++2.6-2v5 (2.40.1-1 Debian:testing [amd64])
Conf libsubtitleeditor0 (0.52.1-2 Debian:testing [amd64])
Conf subtitleeditor (0.52.1-2 Debian:testing [amd64])
 

Dernière modification par Severian (01-05-2016 20:44:06)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#9 01-05-2016 20:41:41

Severian
Membre
Distrib. : Debian GNU/Linux 8.6 (jessie)
Noyau : Linux 4.6.0-0.bpo.1-amd64
(G)UI : Openbox 3.6.1-2
Inscription : 13-12-2014

Re : Subtitleeditor et gstreamermm

message en double à supprimer

Dernière modification par Severian (01-05-2016 20:42:21)


"il est urgent d'attendre" (bendia)
ob3-debian2-150x50.png

Hors ligne

#10 04-05-2016 21:58:51

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : Subtitleeditor et gstreamermm

Bonjour,

je viens vous donner les dernières avancées

J'ai téléchargé les sources pour les compiler moi-même :
http://ftp.gnome.org/pub/GNOME/sources/gstreamermm/1.0/

compilation faite, et subtitleeditor installé lui aussi à partir des sources, apparemment la librairie n'est pas trouvée alors que bien présente sad

subtitleeditor
subtitleeditor: error while loading shared libraries: libgstreamermm-1.0.so.0: cannot open shared object file: No such file or directory
 




find /usr -name "libgstreamermm-1.0.so.0"
/usr/local/lib/libgstreamermm-1.0.so.0




je ne suis pas loin je pense smile

merci pour vos conseils big_smile

Totophe56

Dernière modification par totophe56 (04-05-2016 21:59:35)

Hors ligne

#11 04-05-2016 22:12:38

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Subtitleeditor et gstreamermm

Bonjour smile
Je vais peut être dire une bêtise mais j'ai l'impression que ce fichier  est cherché dans le dossier partagé Share ?

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#12 04-05-2016 23:27:35

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Subtitleeditor et gstreamermm

Bonsoir,

en fait quand tu as compilé libgstreamermm tu a laissé par défaut ./configure qui dans le fichier install te dis que ça sera : /usr/local/lib/
subtitleeditor, je pense, cherche la libgstreamermm-1.0.so.0 ailleurs .

Dernière modification par golgot200 (04-05-2016 23:30:00)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#13 05-05-2016 12:24:53

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : Subtitleeditor et gstreamermm

Bonjour et merci pour vos conseils big_smile

Je suis d'accord avec vous, il me faut faire un lien pour que Subtitleeditor trouve ses petits ... mais où mettre le lien symbolique ?

locate libgstreamermm-1.0.so.0
/usr/local/lib/libgstreamermm-1.0.so.0
/usr/local/lib/libgstreamermm-1.0.so.0.0.0



en tout cas, ce n'est pas dans le /usr/local/share/

ln -s /usr/local/lib/libgstreamermm-1.0.so.0 /usr/local/share/libgstreamermm-1.0.so.0




comment pourrais-je savoir quelle cible il appelle ?

merci d'avance

Totophe56

Hors ligne

#14 05-05-2016 14:53:10

chalu
Adhérent(e)
Lieu : Anjou
Distrib. : Debian Jessie (saveur Handylinux 2.5) à jour
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE xfwm4
Inscription : 11-03-2016

Re : Subtitleeditor et gstreamermm

Et si tu faisais une installation en virtualbox en activant le dépôt stretch pour voir où elle est ?
Il y a sûrement mieux mais ça dépasse mes compétences roll

Bien débuter sur Debian :
->Les cahiers du débutant
->Le projet DFlinux (DebianFacileLinux) deux images ISOs (i386 et amd64) basées sur Debian stable et agrémentées d'outils facilitants pour les débutants

Hors ligne

#15 11-05-2016 21:05:36

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : Subtitleeditor et gstreamermm

Bonjour et merci pour votre aide,

Je n'ai pas eu trop le temps de m'en occuper depuis

J'ai juste lancé une mise à jour du système et il se lance sans soucis maintenant

il y a encore des erreurs quand je le lance depuis la console mais il faut que le prenne en main pour pouvoir vous en dire plus

Merci déjà pour les avancées wink je vous tiens au courant de la suite quand j'aurai un peu de temps pour m'y remettre

Hors ligne

Pied de page des forums