Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-05-2016 12:04:48

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

[Résolu] Molette de souris inversée

Bonjour à tous,

Ce matin, en allumant mon ordinateur, j'ai eu la mauvaise surprise que le molette de ma souris soit inversée.
J'ai cherché à savoir d'où venait le problème. Ainsi, en démarrant avec une autre session que celle que j'utilise habituellement (cette autre session étant aussi sous Gnome), la souris n'était pas inversée. J'en ai donc déduit que c'était un paramètre de ma session perso Gnome.

J'ai cherché comment modifier les boutons de la molette de la souris et j'ai trouvé xmodmap. J'ai testé la ligne ci-dessous qui correspond à la configuration par défaut :

xmodmap -e "pointer = 1 2 3 4 5"


Aucun changement. J'ai donc tenté de permuter le 4 et le 5 qui correspondent à la molette :

xmodmap -e "pointer = 1 2 3 5 4"


Dans ce cas-là, la rotation de la molette était bonne sous firefox et sous nautilus mais pas dans le gnome-terminal où elle était encore inversée. Je ne comprends donc pas d'où vient le problème...

Pouvez-vous m'aider ?

Dernière modification par 005flyof (01-05-2016 14:33:54)

Hors ligne

#2 01-05-2016 13:03:52

Frosch
Adhérent(e)
Lieu : Sion (CH)
Distrib. : Chakra
Noyau : Linux 4.5.7
(G)UI : Plasma 5.8
Inscription : 09-12-2015
Site Web

Re : [Résolu] Molette de souris inversée

Question stupide peut-être, mais avant de bidouiller en ligne de commande as-tu tout bêtement regardé dans les paramètres souris de Gnome ?
Il devrait y avoir une option «défilement inversé» ou quelque chose du genre (j'ai ça sous Xfce).

Schokolade ist keine Lüge.

Hors ligne

#3 01-05-2016 13:46:13

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [Résolu] Molette de souris inversée

avec le bureau Mate , je n'ai que droitier ou gaucher et la sensibilité  , pas d'options "défilement inversé"

ps: tu a aussi un probleme de tty (sur un autre post ), peut aussi lié a une mise a jour .

peut etre regarder comment est détecté ta souris dans le serveurX  => /var/log/Xorg.0.log
bien que pour toi hors du bureau gnome , le défilement est correct.
je donne un exemple (j utilise un kvm 2 ports Aten en ps2/vga pour 2 machines )


[    34.780] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event1)
[    34.780] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "evdev pointer catchall"
[    34.781] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "libinput pointer catchall"
[    34.781] (II) Using input driver 'libinput' for 'ImExPS/2 Generic Explorer Mouse'
[    34.781] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
[    34.781] (**) Option "Device" "/dev/input/event1"
[    34.781] (**) Option "_source" "server/udev"
[    34.781] (II) input device 'ImExPS/2 Generic Explorer Mouse', /dev/input/event1 is tagged by udev as: Mouse
[    34.781] (II) input device 'ImExPS/2 Generic Explorer Mouse', /dev/input/event1 is a pointer caps
[    34.808] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input2/event1"
[    34.808] (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE, id 10)
[    34.808] (**) Option "AccelerationScheme" "none"
[    34.808] (**) ImExPS/2 Generic Explorer Mouse: (accel) selected scheme none/0
[    34.808] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
[    34.808] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
[    34.808] (II) input device 'ImExPS/2 Generic Explorer Mouse', /dev/input/event1 is tagged by udev as: Mouse
[    34.808] (II) input device 'ImExPS/2 Generic Explorer Mouse', /dev/input/event1 is a pointer caps
[    34.808] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
[    34.808] (II) No input driver specified, ignoring this device.
[    34.808] (II) This device may have been added with another device file.
 


depuis trés longtemps j'ai le curseur qui se fige par moment
la souris d'origine etait une HP en ps2 , je l ai remplacé par une Microsoft en usb avec adaptateur ps2
elle est toujours mal détecté (généric alors que en usb elle est bien reconnu ) pour l 'instant elle fonctionne bien  smile
tout ceci pour te montrer que selon le model il peut y avoir des comportements étrange (dans mon cas c'est le kvm en ps2 , mes kvm usb ne posent pas de probleme )
je sais pas quel model de souris tu a , peut etre une configuration ou un bouton de la souris
de plus je suppose que la session de gnome ou tu a le probleme c'est celle a partir de laquelle  tu a fait la mise a jour de débian sid
une autre piste , les fichiers cachés de ta session /home/user  (mais la ça dépasse mes compétences hmm  )

Dernière modification par robert2a (01-05-2016 14:28:36)

Hors ligne

#4 01-05-2016 14:33:35

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

Re : [Résolu] Molette de souris inversée

Oh oh --'

Je suis désolé d'avoir fait un post pour aussi peu de choses...

J'avais vérifié les paramètres de souris dans Gnome, mais je n'avais pas vu de paramètre "Inversion" ou du style. Par conséquent, j'ai cherché ailleurs. C'était là mon erreur. En effet, un paramètre nommé "Défilement naturel" permet d'inverser le défilement en se rapprochant du fait de faire glisser une feuille de papier, ce qui inverse le défilement par la souris.

Merci beaucoup smile

Hors ligne

Pied de page des forums