Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-05-2016 10:55:18

Nico
Membre
Inscription : 23-05-2016

[You don't have permission to access / on this server]

Bonjour,

Actuellement en période de stage j'ai un petit projet à réalisé mais je suis actuellement dans une impasse depuis vendredi.

J'ai deux machine :  [Debian GNU/Linux Sans interface graphique] et [Windows Serveur 2012]

Je dois installé un site web WordPress sur la Debian et le faire fonctionner sur le Windows.
J'ai donc installé Apache2,PHP5,MySQL,PHPMYADMIN et un serveur FTP.

Apache2 fonctionne car j'ai bien le petit message It works big_smile
PHPMYADMIN fonctionne aussi.

Mais quand je change les liens de cette page par default par le site WordPress que j'ai transférer sur la Debian via Filezilla et bien j'ai le message [You don't have permission to access / on this server] qui s'affiche (Quand je tape de nouveau l'adresse IP de la Debian sur Windows)

J'ai cherché, cherché et encore cherché mais tout ce qui est proposé sur la toile ne fonctionne pas donc soit je suis incapable soit c'est un problème autre.

Merci d'avance pour votre aide et je reste à disposition pour vous envoyer les réponses à certaines commandes.

Hors ligne

#2 23-05-2016 11:48:13

Nico
Membre
Inscription : 23-05-2016

Re : [You don't have permission to access / on this server]

Voici mon fichier security.conf ça viens peut être de là ou il faut mettre un Allow from all je sais pas. Je débute.

#
# Disable access to the entire file system except for the directories that
# are explicitly allowed later.
#
# This currently breaks the configurations that come with some web application
# Debian packages.
#
#<Directory />
#   AllowOverride None
#   Order Deny,Allow
#   Deny from all
#
#</Directory>


# Changing the following options will not really affect the security of the
# server, but might make attacks slightly more difficult in some cases.

#
# ServerTokens
# This directive configures what you return as the Server HTTP response
# Header. The default is 'Full' which sends information about the OS-Type
# and compiled in modules.
# Set to one of:  Full | OS | Minimal | Minor | Major | Prod
# where Full conveys the most information, and Prod the least.
#ServerTokens Minimal
ServerTokens OS
#ServerTokens Full

#
# Optionally add a line containing the server version and virtual host
# name to server-generated pages (internal error documents, FTP directory
# listings, mod_status and mod_info output etc., but not CGI generated
# documents or custom error documents).
# Set to "EMail" to also include a mailto: link to the ServerAdmin.
# Set to one of:  On | Off | EMail
#ServerSignature Off
ServerSignature On

Hors ligne

#3 23-05-2016 15:21:47

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [You don't have permission to access / on this server]

Pour que les experts soit en mesure de t'aider, donne nous le log de apache lorsque tu essaie de te connecter dessus :

tail -f /var/log/apache2/error.log



Donne nous également le fichier conf de ton site qui se trouve dans /etc/apache2/site-available

Et as-tu pensé à changer les droits wordpress en www-data ?

Dernière modification par kawer (23-05-2016 15:23:05)


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#4 23-05-2016 15:33:22

Nico
Membre
Inscription : 23-05-2016

Re : [You don't have permission to access / on this server]

root@WORDPRESS:/etc/apache2/sites-available# tail -f /var/log/apache2/error.log
[Mon May 23 15:14:30.065281 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:30.227573 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:30.382864 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:30.539182 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:30.694956 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:30.839844 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:32.287611 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:32.429702 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:32.591496 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php
[Mon May 23 15:14:32.748751 2016] [authz_core:error] [pid 1792] [client 192.ccc.0.zz:xxxxx] AH01630: client denied by server configuration: /var/www/site_test/index.php


Oui j'ai fait un www-data

Dernière modification par Nico (23-05-2016 15:45:04)

Hors ligne

#5 23-05-2016 15:35:14

Nico
Membre
Inscription : 23-05-2016

Re : [You don't have permission to access / on this server]

000-default.conf

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/site_test/index.php

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

<Directory /var/www/site_test>
   AllowOverride All
</Directory>

Hors ligne

#6 23-05-2016 16:54:34

Nico
Membre
Inscription : 23-05-2016

Re : [You don't have permission to access / on this server]

Dans le dossier Apache2.conf

<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied
</Directory>

<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

<Directory /var/www/site_test/index.php>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

Hors ligne

#7 23-05-2016 22:26:57

kawer
Adhérent(e)
Lieu : Académie de la Croix-Vraie
Distrib. : Debian stable / ArchLinux
Noyau : Current
(G)UI : xfwm4
Inscription : 08-10-2013
Site Web

Re : [You don't have permission to access / on this server]

Try de changer la directive Require all denied en Require all granted et redémarre apache2

Edit, ps :

à savoir que j'ai jamais réussit à faire fonctionner un site avec une version supérieur à la 2.2.22 de apache en dehors de son dossier prévue /var/www/html/ et non /var/www/

Et au passage : Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Dernière modification par kawer (23-05-2016 22:39:13)


Rendez à César ce qui est à César et à Dieu ce qui est à Dieu -Cit. J.C.
La persévérance, c'est ce qui rend l'impossible possible, le possible probable et le probable réalisé. -Cit. Robert Half.
Dans toutes les situations, le piège c'était avant, car tu ne voyais pas les murs -Cit. Crevette

Hors ligne

#8 24-05-2016 16:25:33

Nico
Membre
Inscription : 23-05-2016

Re : [You don't have permission to access / on this server]

Je viens de résoudre tout mes problèmes, en effet c'est plus simple de faire fonctionner un site WordPress en INSTALLANT WordPress et pas en téléchargent un thème et essayer de le faire fonctionner comme ça XD Merci quand même pour l'aide apporté à un débutant comme moi big_smile

Hors ligne

Pied de page des forums