Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-06-2016 14:43:48

oxyz
Membre
Inscription : 11-05-2016

[Problème] Message d'erreur Update

Bonjour,

Depuis quelques jours maintenant, j'obtiens des messages d'erreur avec un update par apt-get. Je suis sous debian jessie.

 90,0 ko téléchargés en 6s (13,5 ko/s)                                          
W: impossible de récupérer http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/dists/jessie/main/binary-i386/Packages : 404  Not Found
E: Échec du téléchargement pour certains fichiers d'index. Soit ils ont été ignorés, soit les anciens fichiers ont été utilisés à la place.
E: Impossible de reconstruire le cache des paquets



Voici mon sources.list :

# Les dépôts officiels Debian Jessie :
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie main

# Debian Jessie, mises-à-jour de sécurité :
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free

# Debian Jessie, mises-à-jour "volatiles" :
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie-updates main contrib non-free

# Debian Jessie, dépôt de rétroportages ("backports") :
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
#deb-src http://httpredir.debian.org/debian jessie-backports main

# Dépôt pour un firefox à jour :
deb http://mozilla.debian.net/ jessie-backports firefox-release



J'ai trouvé ce sujet en résolu : https://debian-facile.org/topic-8492-re … age-1.html seulement il y a quelques points où j'aimerais avoir plus d'informations.

Concernant mon probleme, cela doit certainement venir des miroirs, et je voudrais savoir si sur une distrib stable cela reste la même procédure ?
Faut-il que je modifie mon sources.list et remplacer httpredir.debian.org/debian par un serveur ftp ou ftp2 ?

Merci pour vos futurs réponses ! smile

Hors ligne

#2 01-06-2016 14:44:59

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Problème] Message d'erreur Update

Salut smile
Vu l'erreur, c'est un dépôt ppa qui a été ajouté (pas bien!) qui met le bazar.
Tu n'as pas d'autres fichiers de sources dans /etc/apt/sources.list.d/ ?

YA3HGA-H

Hors ligne

#3 01-06-2016 15:38:03

oxyz
Membre
Inscription : 11-05-2016

Re : [Problème] Message d'erreur Update

Aïe aïe ... l'erreur du débutant ... roll

Pour /etc/apt/sources.list.d/ :

/etc/apt/sources.list.d$ ls


mozilla.list  mozilla.list.save  nilarimogard-webupd8-jessie.list  nilarimogard-webupd8-jessie.list.save

Hors ligne

#4 01-06-2016 15:57:22

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Problème] Message d'erreur Update

On dirait bien que la source indiquée dans ce fichier n'existe plus smile
/etc/apt/sources.list.d/nilarimogard-webupd8-jessie.list

YA3HGA-H

Hors ligne

#5 01-06-2016 16:03:28

oxyz
Membre
Inscription : 11-05-2016

Re : [Problème] Message d'erreur Update

Donc si ce fichier n'existe plus, autant le supprimé du dossier /etc/apt/sources.list.d/ non ? neutral

Hors ligne

#6 01-06-2016 17:06:19

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Problème] Message d'erreur Update

Le dépôt ne semble plus exister. tu peux donc supprimer ce fichier de sources oui smile
Mais tu voudras peut-être contacter l'auteur pour connaitre la nouvelle adresse du dépôt s'il existe toujours ailleurs .

YA3HGA-H

Hors ligne

#7 01-06-2016 19:44:37

oxyz
Membre
Inscription : 11-05-2016

Re : [Problème] Message d'erreur Update

Bonne idée oui smile
En cherchant un peu je suis tombé sur ça : https://launchpad.net/~nilarimogard/+ar … tu/webupd8, on peut prendre directement contact avec un auteur de dépôt ?

Hors ligne

#8 01-06-2016 20:42:55

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Problème] Message d'erreur Update

Ben, si y a une adresse mail quelque part, oui.
Pis là, c'est du ubuntu, donc tu peux bien les embêter avec leurs ppa... big_smile

YA3HGA-H

Hors ligne

#9 01-06-2016 21:29:01

oxyz
Membre
Inscription : 11-05-2016

Re : [Problème] Message d'erreur Update

Ok je prends note ! big_smile
Va falloir que j'fasse gaffe lors des prochaines installations concernant les ppa ubuntu ...
Merci en tout cas !

Hors ligne

#10 01-06-2016 21:33:18

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Problème] Message d'erreur Update

Et c'est quoi ce programme en fait?
T'as pas de paquet debian propre? Les ppa, c'est quand même casse gueule sur une debian, et niveau sécurité bof bof.
Si t'as accès aux sources, il vaut mieux faire :

./configure
make
... (ou n'importe quelle autre commande pour compiler)
# finir par :
sudo checkinstall make install
 


Ça créée un paquet et l'installe. C'est plus propre pour désintaller plus tard smile


YA3HGA-H

Hors ligne

#11 01-06-2016 22:35:12

oxyz
Membre
Inscription : 11-05-2016

Re : [Problème] Message d'erreur Update

Et bien c'est un programme flash pour firefox, j'avais trouvé le dépôt en farfouillant sur le web. Et comme je galère depuis un moment pour installé le plugin flash ( certaines plateformes de streaming m'indiquent une erreur "Failed to load libpepflashplayer.so" ) j'ai pas fait attention lorsque j'ai installé le ppa sur ma debian; j'débute sur ce système & j'ai encore pas mal de choses à voir ...

Hors ligne

#12 02-06-2016 07:48:49

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Problème] Message d'erreur Update

Tu es sûr d'avoir besoin de flash ? hmm
C'est quel genre de streaming? Il existe des alternatives tu sais, à base de torrent wink

YA3HGA-H

Hors ligne

#13 02-06-2016 09:54:57

oxyz
Membre
Inscription : 11-05-2016

Re : [Problème] Message d'erreur Update

Je pourrais pas vraiment te dire le genre de streaming ... hmm
En revanche, j'ai ceci en message d'erreur.

Failed to load « libpepflashplayer.so ».
Freshwrapper is a translation layer which needs
PPAPI plugin backend. Ensure your system have
« libpepflashplayer.so » available,
Paths tried :
/opt/google/chrome/PepperFlash/libpepflashplayer.so
/opt/google/chrome-beta/PepperFlash/libpepflashplayer.so
/opt/google/chrome-unstable/PepperFlash/libpepflashplayer.so
/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so
/usr/lib/PepperFlash/libpepflashplayer.so
/usr/lib64/PepperFlash/libpepflashplayer.so
/usr/lib/chromium-browser/PepperFlash/lilpepflashplayer.so
/usr/lib64/chromium-browser/PepperFlash/lilpepflashplayer.so
/usr/lib/adobe-flashplugin/libpepflashplayer.so
/usr/lib/chromium/PepperFlash/libpepflashplayer.so
/usr/lib64/chromium/PepperFlash/libpepflashplayer.so
/opt/chromium/PepperFlash/libpepflashplayer.so
/usr/lib/pepflashplugin-installer/libpepflashplayer.so



Je pense que flash n'ai pas primordial, mais une alternative à celui-ci serait bienvenue smile

Hors ligne

#14 02-06-2016 20:10:03

oxyz
Membre
Inscription : 11-05-2016

Re : [Problème] Message d'erreur Update

Petit up tardif !

J'ai supprimé les fichiers nilarimogard-webupd8-jessie.list.save & nilarimogard-webupd8-jessie.list du répertoire /etc/apt/sources.list.d/, par contre en retapant le apt-get update :

90,1 ko réceptionnés en 12s (7 126 o/s)                                                                                              
W: Impossible de récupérer http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt/dists/all/main/binary-i386/Packages  Somme de contrôle de hachage incohérente

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.



Tu pense que cela vient toujours des fichiers présent dans le répertoire ?

Hors ligne

#15 02-06-2016 20:33:54

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Problème] Message d'erreur Update

Ah mais oui, c'est quoi cette source ubuntuzilla??? Vire-moi le fichier mozilla.list et utilise ceux prévus pour debian : http://mozilla.debian.net/

YA3HGA-H

Hors ligne

Pied de page des forums