Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-06-2016 22:33:56

bat.gu
Membre
Inscription : 02-06-2016

[RESOLU] Carte ethernet non détectée

Bonjour,

M'étant enfin motivé à installer debian en parallèle de windows 10 sur mon portable (ASUS TP300L), je suis le très bon tuto de ce site.
Cependant, n'ayant jamais de chance pour ce genre de chose, ma carte ethernet n'est pas détectée et n'apparait pas dans la liste proposée lors de l'installation. C'est une Médiatek MT7630E.
J'ai trouvé ce driver (il n'est plus disponible sur le site officiel de Mediatek dans sa version linux) et l'ai mis sur une autre clé usb que celle utilisée pour l'installation.
De retour dans l'installeur, je choisis dans les options de récupérer le driver sur un périphérique amovible.
Cependant, après un petit chargement je tombe sur ce message d'erreur : "Lecture impossible du support ou pilotes non trouvées".
J'imagine que c'est le format du driver qui ne va pas, à priori il est fait pour être installé directement depuis la distribution. J'ai testé sur les différents ports usb, y compris en inversant avec la clé contenant l'ISO, donc le problème ne doit pas venir de la lecture du support (la clé contenant le driver est en FAT32, je ne sais pas si ça a une incidence).
Avez-vous des solutions ? Car si je ne me trompe pas, il est obligatoire d'avoir une connexion internet pour finaliser l'installation.

Merci d'avance

Dernière modification par bat.gu (03-06-2016 22:57:09)

Hors ligne

#2 03-06-2016 05:34:26

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [RESOLU] Carte ethernet non détectée

Salut,

Il existe des iso d'installation qui inclus des pilotes non libre - drivers -> http://cdimage.debian.org/cdimage/unoff … are/8.4.0/

smile

et bienvenu big_smile

Hors ligne

#3 03-06-2016 09:52:36

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Carte ethernet non détectée

salut bat.gu et bienvenue smile

J'ai un très fort doute sur le modèle de ta carte. Que ce soit sur le lien vers ton pilote ou via une recherche directe sur son nom, je comprends qu'il s'agit d'une carte Wifi et non Ethernet hmm

Pourrait tu renvoyer le retour de

lspci -nn


Si tu n'as pas accès à Intenet depuis Debian mais depuis Windows, tu peux copier le retour de la commande dans un fichier comme cela

lspci -nn > retour_lspci.txt


Tu pourra ensuite copier ce fichier sur une clé USB pour nous le montrer.

Concernant l'installation du pilote via clé USB par l'installateur, il faut une archive de paquet Debian (un fichier en .deb) pour que cela soit faisable. C'est donc normal que cela ne fonctionne pas avec ce que tu as trouvé.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#4 03-06-2016 11:54:43

bat.gu
Membre
Inscription : 02-06-2016

Re : [RESOLU] Carte ethernet non détectée

Salut et merci pour votre accueil !

nono47 a écrit :


Il existe des iso d'installation qui inclus des pilotes non libre - drivers -> http://cdimage.debian.org/cdimage/unoff … are/8.4.0/



Je pourrais essayer une ISO avec des pilotes non-libres, avec un peu de chance ça passera !

bendia a écrit :


J'ai un très fort doute sur le modèle de ta carte. Que ce soit sur le lien vers ton pilote ou via une recherche directe sur son nom, je comprends qu'il s'agit d'une carte Wifi et non Ethernet hmm



En effet, c'est le modèle de la carte Wi-Fi, mais je pensais qu'il n'y avait qu'une seule carte qui contenait Ethernet + Wi-Fi !
Bloquant sur cette étape lors de l'installation, Debian n'est pas encore installé, c'est possible de lancer ces commandes depuis l'installateur ? Ou sinon on peut avoir les informations directement depuis Windows ?
Je pourrais regarder ça uniquement à partir de ce soir (ordinateur perso).

Hors ligne

#5 03-06-2016 12:13:02

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Carte ethernet non détectée

bat.gu a écrit :

c'est possible de lancer ces commandes depuis l'installateur

Je viens de faire un petit essai en machine virtuelle, et la réponse est oui, au moins pour avoir le retour de l'affichage. Il faut pour cela chosir l'option Advanced au boot, puis, Expert Install ou Graphical Expert install. Là, tu as accès à un Shell (avant dernière option je crois).

Ce que je ne sais pas faire, c'est monter une clé USB pour copier le fichier contenant le retour de la commande depuis ce Shell. Si quelqu'un sait ne serait pas de refus hmm

Une autre option peut consister à télécharger un système Live, et passer cette commande de là smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#6 03-06-2016 13:47:03

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Carte ethernet non détectée

bendia a écrit :

Il faut pour cela chosir l'option Advanced au boot, puis, Expert Install ou Graphical Expert install. Là, tu as accès à un Shell (avant dernière option je crois).


Ou bien : n'importe quand après la configuration du clavier, appuyer sur Ctrl+Alt+F2 pour basculer sur la console n° 2 qui contient un shell.
Et pour la sortie, deux lignes (Ethernet et network/wifi) à recopier à la main ce n'est pas la mer à boire.

nono47 a écrit :

Il existe des iso d'installation qui inclus des pilotes non libre - drivers -> http://cdimage.debian.org/cdimage/unoff … are/8.4.0/


A ma connaissance cette image ne contient pas de pilote non libre mais seulement des firmwares non libres. Si c'est le pilote qui manque, elle n'apportera rien.

Hors ligne

#7 03-06-2016 13:51:13

raleur
Membre
Inscription : 03-10-2014

Re : [RESOLU] Carte ethernet non détectée

bendia a écrit :

Ce que je ne sais pas faire, c'est monter une clé USB pour copier le fichier contenant le retour de la commande depuis ce Shell. Si quelqu'un sait ne serait pas de refus


Avec mount, comme d'habitude. Il faut juste spécifier le type de système de fichiers car la commande mount de l'installateur ne le détecte pas forcément automatiquement.
Exemple en supposant que la clé est /dev/sdc avec une partition FAT :

mount -t vfat /dev/sdc1 /mnt
lspci -nn > /mnt/lspci.txt
umount /mnt

Dernière modification par raleur (04-06-2016 11:47:04)

Hors ligne

#8 03-06-2016 14:21:16

bat.gu
Membre
Inscription : 02-06-2016

Re : [RESOLU] Carte ethernet non détectée

Merci pour ces retours,
Si c'est effectivement deux lignes, je les recopierais à la main !
Sinon j'utiliserais la solution de @raleur pour copier les informations dans une clé.
Je vous tient au courant dès que c'est fait, en fin d'après-midi normalement.

Hors ligne

#9 03-06-2016 15:08:01

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Carte ethernet non détectée

Merci raleur smile (au passage, je suis très flatté que tu t’appropries mes citations wink )

Mon problème était que je ne savais pas comment connaître le nom de la partition, la commande fdisk semblant absente de ce shell. Mais, après avoir Chargé des composants d'installation à partir du CD, cette commande est disponible.

@bat.gu : il faut donc aller à cette étape de l'installation, puis passer au Shell : Exécuter un Shell (ligne de commande). Là, tu peux détecter le nom de ta clé avec la commande

fdisk -l


raleur prend l'exemple de /dev/sdc1, mais ça pourrait être un autre nom sous la forme de /dev/sdxn avec x une lettre, et n un nombre. Tu pourras la repérer grâce à la taille, et au système de fichier (les clé sont habituellement formaté en FAT, mais ça n'est pas forcé).

Ensuite, tu la monte comme indique raleur. Si tu souhaites l'enlever avant de quitter l'installateur, n'oublie pas de faire

umount /mnt

Si tu quitte proprement l'installateur, je pense que le système va automatiquement démonter la clé.

Attention lors de la recopie à la main, tous les détails comptes. A la rigueur, concentre toi sur l'identifiant PCI qui se compose de 2 bloc de 4 caractères séparés par : (des nombres hexadécimaux en fait).

Exemple

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)

Le code PCI est entre crochets

[10ec:8168]


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#10 03-06-2016 18:03:08

bat.gu
Membre
Inscription : 02-06-2016

Re : [RESOLU] Carte ethernet non détectée

Re,

fdisk -l ne marche pas (même après avoir fait "Chargé des composants d'installation à partir du CD"), donc impossible de mettre le résultat sur la clé.
J'ai donc pris une photo du retour de lspci -nn, mais la réponse à mon problème est très simple, en fait je n'ai tout simplement pas de carte ethernet (aucune ligne la concernant n'apparait après la commande, pas de port sur le PC et après vérification sous Windows : aucune dans le gestionnaire de périphérique)...
Je vous retransmet quand même la seule ligne concernent un périphérique réseau (du coup la carte Wi-Fi) :

02:00 0 Network controller [0280] :  MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter [14c3:7630]


Du coup ça ce passe comment pour l'installation, d'après ce que j'ai compris, l'installateur a besoin d'une connexion pour récupérer le contenu des DVD 2 et 3.
C'est possible de mettre les 3 ISO sur la même clé USB ? Et après j'installerai le driver Wi-Fi toruvé précédemment.

PS : J'ai honte de moi sur le coups cool

Dernière modification par bat.gu (03-06-2016 18:04:55)

Hors ligne

#11 03-06-2016 19:06:48

robert2a
Membre
Lieu : France
Distrib. : Stretch
Noyau : Linux 4.8.0-1-amd64
(G)UI : Mate 1.16.1
Inscription : 15-11-2014

Re : [RESOLU] Carte ethernet non détectée

j'ai trouvé ceci :

https://doc.ubuntu-fr.org/wifi_bt_mt7630e

si cela peut t'aider

Hors ligne

#12 03-06-2016 19:15:56

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Carte ethernet non détectée

bat.gu a écrit :

mais la réponse à mon problème est très simple, en fait je n'ai tout simplement pas de carte ethernet (aucune ligne la concernant n'apparait après la commande, pas de port sur le PC et après vérification sous Windows : aucune dans le gestionnaire de périphérique)...

C'est bien ce que je me disait en regardant les specs de ta machines wink

Pour l'installation, ça dépend de l'image que tu as téléchargée. Normalement, avec le DVD1, tu dois avoir tout ce qu'il faut pour faire une installation assez complète. Tu peux passer l'étape de la config réseau. Il restera effectivement à installer par la suite ton pilote tel que c'est expliqué dans ton lien.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#13 03-06-2016 22:38:36

bat.gu
Membre
Inscription : 02-06-2016

Re : [RESOLU] Carte ethernet non détectée

Bonsoir,

L'installation s'est bien passée, le partitionnement et l'installation du GRUB aussi.
Cependant, l'ordinateur reboot sur windows, du coup je fais la commande conseillée dans le tuto, qui me renvoie : "modification réussie".
Malheureusement, ça n'a pas marché, je reboot toujours sur windows sans passer par le GRUB, et d'ailleurs que ce soit dans le BIOS ou dans le menu de sélection de la partition sur laquelle booter, la parition Debian n'apparaît pas.
Le SecureBoot est bien désactiver et le mode CSM activé (j'ai essayé de le désactiver et le résultat est le même).
Vous avez une idée du problème ?

Merci

Hors ligne

#14 03-06-2016 22:42:15

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [RESOLU] Carte ethernet non détectée

Ouvre  un autre fil pour ce problème spécifique. Sinon, le titre ne correspondra plus au problème wink Pour celui-là, je laisse la main, je n'ai jamais fait installation en Dual-Boot W8/Debian hmm

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#15 03-06-2016 22:56:16

bat.gu
Membre
Inscription : 02-06-2016

Re : [RESOLU] Carte ethernet non détectée

Ok pas de soucis, et encore merci pour ton aide smile

Dernière modification par bat.gu (03-06-2016 22:58:13)

Hors ligne

Pied de page des forums